Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.72/18: Рейтинг темы: голосов - 18, средняя оценка - 4.72
saiman88
1 / 1 / 0
Регистрация: 30.01.2015
Сообщений: 20
1

Настройка маршрутизатора CISCO1921/K9

13.02.2015, 13:10. Просмотров 3489. Ответов 6
Метки нет (Все метки)

Добрый день уважаемые форумчане.
Недавно принесли маршрутизатор CISCO1921/K9. Новенький, но без документов. Решили использовать его в нашей сети.
Так - как специальной подготовки у меня нет, пришлось изучать все с самого начала. Было прочитано сотни статей и способов конфигурации. К сожалению пока не удалось заставить работать сей девайс.
IOS обновить и задействовать вспомогательные приложения с графикой не удалось, так как нет документов подтверждающих покупку устройства.
Первоначальная задача не хитрая. Подключить на один из портов линию провайдера и раздавать его по внутренней сети. Ну и вести, хоть какой-то учет трафика.
После небольшой настройки маршрутизатор определил провайдера и получил доступ в интернет. А на локальных компьютерах доступа в интернет нет. Получается, что маршрутизация не работает или работает, но не верно.

Может подскажите чего умного .
Заранее благодарен.

Вот простенькая схема сети и конфиг маршрутизатора:

Кликните здесь для просмотра всего текста
License UDI:

-------------------------------------------------
Device# PID SN
-------------------------------------------------
*0 CISCO1921/K9 FCZ1545C2WU



Technology Package License Information for Module:'c1900'

-----------------------------------------------------------------
Technology Technology-package Technology-package
Current Type Next reboot
------------------------------------------------------------------
ipbase ipbasek9 Permanent ipbasek9
security None None None
data None None None

Configuration register is 0x2102


------------------ show running-config ------------------


Building configuration...

Current configuration : 1790 bytes
!
! Last configuration change at 16:33:35 Russia Thu Feb 12 2015 by admin
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname gateway
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
clock timezone Russia 4 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name is
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FCZ1545C2WU
!
!
username admin privilege 15 secret 5 <removed>
username admin2 privilege 15 secret 5 <removed>
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
interface GigabitEthernet0/0
description LOCAL
ip address 192.168.10.1 255.255.255.0
ip accounting output-packets
ip nat inside
ip nat enable
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description PREMIER
ip address dhcp
ip access-group FIREWALL in
no ip redirects
no ip proxy-arp
ip nat outside
ip nat enable
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface Vlan1
description LAN
no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
!
ip dns server
ip nat inside source list NAT interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 213.108.182.1
!
ip access-list extended NAT
permit ip host 192.168.10.0 any
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
end
0
Миниатюры
Настройка маршрутизатора CISCO1921/K9  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.02.2015, 13:10
Ответы с готовыми решениями:

Настройка маршрутизатора
Доброго времени суток! возникла проблема по настройке сети состоящей из трех...

CPT: настройка маршрутизатора
Здравствуйте. Помогите пожалуйста, как можно в программе Cisco Packet Tracer...

Настройка маршрутизатора 2621XM
не получается настроить сеть между двумя ПК помогите пожалуйста

Настройка маршрутизатора 2811
Cisco Packet Tracer В общем задание я выполнил где-то наполовину, в принципе...

Настройка маршрутизатора cisco 851
Здравствуйте.Помогите пожалуйста.Как настройкой cisco 851.Если можно по...

6
corlovito
455 / 436 / 75
Регистрация: 26.12.2012
Сообщений: 2,876
13.02.2015, 13:30 2
первое что бросается в глаза это список доступа NAT
зачем расширенный используете ?, вот такой пропишите
access-list 1 permit 192.168.10.0 0.0.0.255
1
saiman88
1 / 1 / 0
Регистрация: 30.01.2015
Сообщений: 20
17.02.2015, 16:28  [ТС] 3
Список доступа NAT поправил, но ничего не поменялось (в плане доступа к интернету из лок.сети).
А проблему устранил прописав ip name-server.
ip name-server 213.108.X.X (шлюз провайдера)
ip name-server 213.108.X.X (шлюз провайдера)
ip name-server 8.8.8.8 (Goole DNS server(публичный))
0
IceG
28 / 28 / 5
Регистрация: 17.11.2013
Сообщений: 546
18.02.2015, 13:54 4
Цитата Сообщение от saiman88 Посмотреть сообщение
ip route 0.0.0.0 0.0.0.0 213.108.182.1

это зачем?

Добавлено через 1 минуту
и поправьте слепого, не вижу я у вас пул адресов, вы ведь делаете трансляцию с серых, а как компы у вас получают серые адреса? статика да на пк?

Добавлено через 1 минуту
по хорошему создайте пул, там укажите диапазон адреса исключите и тд
1
corlovito
455 / 436 / 75
Регистрация: 26.12.2012
Сообщений: 2,876
18.02.2015, 13:57 5
ip route 0.0.0.0 0.0.0.0 213.108.182.1

это зачем?
знаете другой способ как задать маршрут по умолчанию ?
1
IceG
28 / 28 / 5
Регистрация: 17.11.2013
Сообщений: 546
18.02.2015, 13:58 6
пример

ip dhcp pool имя
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 77.88.8.7

Добавлено через 19 секунд
и пк получат все нужные адреса
1
saiman88
1 / 1 / 0
Регистрация: 30.01.2015
Сообщений: 20
19.02.2015, 08:11  [ТС] 7
Изначально в сети DHCP не включал. Только статические адреса.
*Так как не хочу что-бы сотрудники тащили из дома свои супер мощные ноутбуки и со всем барахлом включали их в общую сеть. Техникой просмотра и переноса адресов они не владеют

ip route 0.0.0.0 0.0.0.0 213.108.182.1 (последний блок - это шлюз провайдера)
Подобную запись увидел в одном из уроков Cisco. Хотя еще работает вариант: ip route 0.0.0.0 0.0.0.0 dhcp (так как провайдер работает через DHCP).

Пул адресов не использовал. Еще не знаю, пока, как к нему "подойти". Пока, создал acl :
access-list 10 permit 192.168.10.0 0.0.0.255
0
19.02.2015, 08:11
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.02.2015, 08:11

Настройка маршрутизатора Cisco 1841
в общем название темы говорящее. притащили - положили на стол - сказали...

Cisco Packet Tracer(настройка маршрутизатора)
как настроить роутер что бы он видел интерфейс следующего устройства, через...

Cisco Packet Tracer (настройка маршрутизатора)
Добрый день! Прошу помочь.Необходимо создать сеть в Cisco Packet Tracer. Есть...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru