Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.67/9: Рейтинг темы: голосов - 9, средняя оценка - 4.67
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
1

Соедниене 2-х CISCO CATALYST 3750

09.04.2015, 16:20. Просмотров 1750. Ответов 29
Метки нет (Все метки)

Добрый вечер!!!

Подскажите пожалуйста знающие люди...

Насколько я понимаю 2 коммутатора между собой должны соединиться через транк, чтобы через них пропустить несколько тегированных вланов.

в моем случае есть 3 сегменты географический отдаленный друг от друга, и CISCO CATALYST 3750 в каждом сегменте по одному, и они подключены через аксесс порт, на обойх концах интерфейсы в одинаково влане.

ТО есть получается следущая картина.
Соедниене 2-х CISCO CATALYST 3750


Мне не понятно во первых. Как через CATALYST 3750 проходят остальные вланы, то есть влан 70,80,90 если они через аксессоыве порты подключены?
В2-ой вопрос. Почему те самые вланы 70,80,90 не разрешаются натранковом порту к маршрутизатору, как они доходят до маршрутизаторов?

Все работает, проблем нет, НО КАК???
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.04.2015, 16:20
Ответы с готовыми решениями:

Маршрутизация на Cisco Catalyst 3750
Схема: Свитч 3750, к нему подключены 2 два свитча 2950. На 3750 включен ip routing. На всех...

IGMP-filtering на cisco catalyst 3750
Добрый день. Прошу помощи, цискарь я никакой! Вкратце: Есть мультиплексор (стример), на нем...

Интернет в vlan, cisco catalyst 3750
Здравствуйте , помогите разобраться с cisco, подарили мне cisco вот пытаюсь его изучить в свободное...

Catalyst 3750 настроить интернет и роутинг
Всем привет =). Встала простая на первый взгляд задача, как получить интернет на 3750 (Catalyst),...

Передать через порт тэгированный и нетегированный трафик Catalyst 3750
Всем добрый день, подскажите пожалуйста как через порт Catalyst 3750 передать тэгированный и...

29
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 16:29 2
да вроде как все понятно, у вас на свитч который по середине слева приходит 10 влан справа 20 с роутером свич соединен транком так то все норм
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 19:36  [ТС] 3
а как тогда влан 70,80,90 доходят от каталиста слеваа к остальным двум, если порты настроены как аксес порт?
настройка на коммтутаоре слева:

interface FastEthernet1/0/10
switchport access vlan 10
switchport mode access


2-ой каталист:
interface FastEthernet1/0/10
switchport access vlan 10
switchport mode access

interface FastEthernet1/0/20
switchport access vlan 20
switchport mode access

3-каталист
interface FastEthernet1/0/20
switchport access vlan 20
switchport mode access
как между ними ходят влан 70, 90, 100? Вот этот вопрос мучает меня...
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 20:08 4
это с каких свичей настройки ?
0
09.04.2015, 20:08
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 20:14  [ТС] 5
настройки с каталист 3750

Добавлено через 2 минуты
мне не понятно как между каатлистами 3750 будут ходит трафики из вланов 70, 80, 100 - они же должны каким то образом маркироваться ведь, правильно? так как у нас выходные интерфейсы с катал. 3750 не транковые, как проходят влан 70,80,100...

Добавлено через 1 минуту
и 2-ой вопрос, почему эти вланы не доходят до роутеров, ведь н атракновых портах от 3750 к роутеру вланы 70,80,100 не разрешены же....
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 20:16 6
все бы настройки со свичей глянуть, но вот например смотрю я на рисунок ваш и если по нему судить то там и по транкам они не должны идти, там только 10 и 20 разрешены

Добавлено через 39 секунд
Цитата Сообщение от Nyrlan Посмотреть сообщение
почему эти вланы не доходят до роутеров, ведь н атракновых портах от 3750 к роутеру вланы 70,80,100 не разрешены же
ничего не понял
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 20:17  [ТС] 7
и к тому же влан 10 и 20 , - этим вланам относятся только вот эти интерфейсы что в конфиге, они больше нигде не используются, такое ошущение что их создали только для того чтобы объеденить эти каталисты 3750...
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 20:18 8
вообщем схему подробней надо и конфиги
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 20:24  [ТС] 9
попробую поставить вопрос иначе...

между коммутаторами связь должна идти через транк, если с 1-го коммутатора на другой коммутатор нужно передать трафик из нескольких вланов, правильно? согласны с этим?

Если да, то почему коммутаторы соединены через аксесс порт, а не через транк...

Добавлено через 1 минуту
а вот между Каталист 3750 и 2960 кстати, порты транковые, и там разрешены все эти вланы, влан 10,20,70,80,100, но между каталистами 3750 АКСЕЕС ПОРТ...НЕПОНЯТНО..
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 20:38 10
Цитата Сообщение от Nyrlan Посмотреть сообщение
почему коммутаторы соединены через аксесс порт, а не через транк
может так "надо было" может руки кривые у кого,
вообщем
с этим согласен
Цитата Сообщение от Nyrlan Посмотреть сообщение
между коммутаторами связь должна идти через транк, если с 1-го коммутатора на другой коммутатор нужно передать трафик из нескольких вланов
а по остальному
Цитата Сообщение от corlovito Посмотреть сообщение
вообщем схему подробней надо и конфиги
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 21:02  [ТС] 11
corlovito,

Первый 3750...
Building configuration...

Current configuration : 9627 bytes
!
! Last configuration change at 13:59:27 UTC Fri Jan 17 2014 by root
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname OPSWCORE
!
boot-start-marker
boot-end-marker
!

!
!
!
aaa session-id common
switch 1 provision ws-c3750-48p
system mtu routing 1500
authentication mac-move permit
ip routing
no ip domain-lookup

ip dhcp excluded-address 172.16.2.1
ip dhcp excluded-address 172.16.2.2
ip dhcp excluded-address 172.16.2.3
ip dhcp excluded-address 172.16.2.4
ip dhcp excluded-address 172.16.2.5
ip dhcp excluded-address 172.16.2.6
ip dhcp excluded-address 172.16.2.7
ip dhcp excluded-address 172.16.2.8
ip dhcp excluded-address 172.16.2.9
ip dhcp excluded-address 172.16.2.10
!
!
!
!

!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
lldp run
!
ip ssh version 2
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Port-channel1
description TO_ROUTER
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,344,401,402
switchport mode trunk
!
interface FastEthernet1/0/1
description_to_Provider
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,344
switchport mode trunk
no cdp enable
spanning-tree bpdufilter enable
!
interface FastEthernet1/0/2
switchport access vlan 401
switchport mode access
!
interface FastEthernet1/0/3
switchport access vlan 142
switchport mode access
!
interface FastEthernet1/0/4
switchport access vlan 344
switchport mode access
!
interface FastEthernet1/0/5
switchport access vlan 402
description_tp_222
switchport mode access

!
interface FastEthernet1/0/6
description member_portchannel_1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,344,401,402
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/7
description member_portchannel_1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,344,401,402
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/8
description member_portchannel_1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,344,401,402
switchport mode trunk
channel-group 1 mode on

!
interface FastEthernet1/0/29
switchport access vlan 400
switchport mode access
switchport voice vlan 500
spanning-tree portfast
!
interface FastEthernet1/0/30
switchport access vlan 400
switchport mode access
switchport voice vlan 500
spanning-tree portfast
!
interface FastEthernet1/0/31
switchport access vlan 400
switchport mode access
!
interface FastEthernet1/0/32
switchport access vlan 400
switchport mode access
switchport voice vlan 500
spanning-tree portfast


interface FastEthernet1/0/42
switchport access vlan 500
switchport trunk encapsulation dot1q
switchport mode access
switchport voice vlan 500
spanning-tree portfast


!
interface FastEthernet1/0/47
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,400,500
switchport mode trunk
!
interface FastEthernet1/0/48
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,400,500
switchport mode trunk
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
description MNG
ip address 10.10.2.1 255.255.255.0
!
interface Vlan400
ip address 192.168.60.225 255.255.255.0
!
interface Vlan401
ip address 192.168.0.10 255.255.255.248
!
interface Vlan500
ip address 172.16.2.1 255.255.255.0
!
router ospf 10
log-adjacency-changes
passive-interface Vlan100
passive-interface Vlan400
passive-interface Vlan500
network 10.10.2.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 0
network 192.168.0.8 0.0.0.7 area 0
network 192.168.60.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.9
ip route 10.10.1.0 255.255.255.0 192.168.0.9
ip route 10.10.3.0 255.255.255.128 192.168.100.6
ip route 10.10.3.128 255.255.255.128 192.168.100.6
ip route 172.16.1.0 255.255.255.0 192.168.0.9
ip route 172.16.3.0 255.255.255.128 192.168.100.6
ip route 172.16.3.128 255.255.255.128 192.168.100.6
ip route 192.168.50.0 255.255.255.0 192.168.0.9
ip route 192.168.70.0 255.255.255.128 192.168.100.6
ip route 192.168.70.128 255.255.255.128 192.168.100.6
no ip http server
no ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
line vty 0 4
exec-timeout 30 0
password 7 123E0D15161F225773
logging synchronous
transport input ssh
line vty 5 15
transport input none
!
ntp clock-period 36029169
ntp server 192.168.50.117
end

_______________________________________________

2-ой 3750

Building configuration...

Current configuration : 5597 bytes
!
! No configuration change since last restart
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname BRSWCORE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$CzT8$nd1gQI/5R9t2Hjqu1pkK1/
!
username root privilege 15 secret 5 $1$wFrU$q.jomU94Xcjk1Xeu.s6KU.
!
!
aaa new-model
!
!
!
!
!
aaa session-id common
clock timezone Aqtau 5
switch 1 provision ws-c3750v2-24ps
system mtu routing 1500
ip routing

ip dhcp remember
!
ip dhcp pool KMT_LAN
network 192.168.70.0 255.255.255.128
default-router 192.168.70.1

dns-server 192.168.50.117
!
!
!
!

!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142-144,402-404
switchport mode trunk
!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142-144,402-404
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142-144,402-404
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142-144,402-404
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/4
description to_ap_111
switchport access vlan 402
switchport mode access
!
interface FastEthernet1/0/5
description to_ap_333
switchport access vlan 403
switchport mode access

interface FastEthernet1/0/12
description abk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,400,500
switchport mode trunk
!
interface FastEthernet1/0/13
switchport access vlan 400
switchport mode access
switchport voice vlan 500
spanning-tree portfast


!
interface Vlan1
no ip address
!
interface Vlan100
ip address 10.10.3.1 255.255.255.128
!
interface Vlan400
ip address 192.168.70.1 255.255.255.128
!
interface Vlan404
ip address 192.168.0.18 255.255.255.248
!
interface Vlan500
ip address 172.16.3.129 255.255.255.128
!
router ospf 10
log-adjacency-changes
passive-interface default
no passive-interface Vlan404
network 10.10.3.0 0.0.0.127 area 0
network 172.16.3.128 0.0.0.127 area 0
network 192.168.0.16 0.0.0.7 area 0
network 192.168.70.0 0.0.0.127 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.17
ip http server
ip http secure-server
!
!
!
line con 0
line vty 0 4
exec-timeout 30 0
transport input ssh
line vty 5 15
exec-timeout 30 0
transport input ssh
!
ntp clock-period 36029548
ntp server 192.168.50.117
end

__________________________________

Третий 3750

Building configuration...

Current configuration : 5328 bytes
!
! Last configuration change at 16:40:25 Aqtau Tue Aug 20 2013 by root
! NVRAM config last updated at 16:10:24 Aqtau Tue Aug 20 2013 by root
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname TLSWCORE1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$7sOh$iOtC0KQiohjSeWgexdZRZ.
!
username root privilege 15 secret 5 $1$gHpd$wqgI50cBtdohN1iKOV8bR0
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
aaa session-id common
clock timezone Aqtau 5
switch 1 provision ws-c3750v2-24ps
system mtu routing 1500
ip routing

ip dhcp remember
!
ip dhcp pool KMT_LAN
network 192.168.70.128 255.255.255.128
default-router 192.168.70.129
dns-server 192.168.50.117
!
!
!

!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
lldp run
!
ip ssh version 2
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,402,403
switchport mode trunk
!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,402,403
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,402,403
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 142,143,402,403
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/0/4
switchport access vlan 403
switchport mode access
description to_222

i
interface FastEthernet1/0/20
switchport access vlan 400
switchport mode access
switchport voice vlan 500
spanning-tree portfast
!
i
interface FastEthernet1/0/22
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,400,500
switchport mode trunk
!
interface FastEthernet1/0/23
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,400,500
switchport mode trunk

!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 10.10.3.129 255.255.255.128
!
interface Vlan400
ip address 192.168.70.129 255.255.255.128
!
interface Vlan402
ip address 192.168.0.26 255.255.255.248
!
interface Vlan500
ip address 172.16.3.1 255.255.255.128
!
router ospf 10
log-adjacency-changes
passive-interface default
no passive-interface Vlan402
network 10.10.3.128 0.0.0.127 area 0
network 172.16.3.0 0.0.0.127 area 0
network 192.168.0.24 0.0.0.7 area 0
network 192.168.70.128 0.0.0.127 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.25
ip http server
ip http secure-server
!
kron policy-list restart
cli reload
!
!
!
line con 0
line vty 0 4
exec-timeout 30 0
logging synchronous
transport input ssh
line vty 5 15
exec-timeout 30 0
logging synchronous
transport input ssh
!
ntp clock-period 36029600
ntp server 192.168.50.117
end

Добавлено через 1 минуту
там где отметил желтыми, если плохо видно - попробуйте просто выделить - вот тогда можно увидеть хорошо..
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 21:12 12

Не по теме:

оёёй в следующий раз в спойлер заворачивайте



Добавлено через 5 минут
что то я названные вами вланы вообще не вижу на них
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 21:18  [ТС] 13
ну здесь они названы
влан 10 - это влан 402,
влан 20 это 403,
влан 70-это влан 100,
влан 80-это влан 400,
влан100-это влан 500,
я просто их отметил желтым цветом чтобы было наглядно, а там получилось что их плохо видно.. просто выделите желтым отмеченные, и они будут видны

Добавлено через 2 минуты
Это на 1-ом каталисте 3750

interface FastEthernet1/0/5
switchport access vlan 402
description_tp_222
switchport mode access

Это на 2-ом каталисте 3750

interface FastEthernet1/0/4
description to_ap_111
switchport access vlan 402
switchport mode access

Это на 3-ем каталисте 3750
interface FastEthernet1/0/4
switchport access vlan 403
switchport mode access
description to_222

i
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 21:19 14
т.е желтым выделены порты которыми между собой свичи соединены ?
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 21:23  [ТС] 15
corlovito, в общем 100,400, 500 -манадж, дата, войс... 402,403 вланы-для соединения каталистов 3750...

Добавлено через 38 секунд
corlovito, да,

Добавлено через 1 минуту
мне непонятно как трафики из 100,400,500 бегают между 3750, раз соединяющие их между собой порты нетегированные...
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 21:25 16
а почему вы думаете что они у вас между свичами бегают
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 21:30  [ТС] 17
corlovito, но у меня же между сегментами связь то есть, хосты между сегментами соединяются же как то... пингуются, видят друг друга... когда я с сегмента 111 на сегмент 222 передаю трафик по ДАТА ВЛАН 400 как они переходят на сегмент 222?
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 21:32 18
Лучший ответ Сообщение было отмечено Nyrlan как решение

Решение

это происходит на 3 уровне, который про ваши вланы ничего знать не знает у вас ведь L3 свичи
0
Nyrlan
0 / 0 / 0
Регистрация: 28.02.2015
Сообщений: 26
09.04.2015, 21:37  [ТС] 19
может они как то по другому передаются? факт в том что у меня между сегментами хосты обмениваются данными, рабатает айпи телефония... а между каталистамми 3750, которые соединяют географически разделенные сегменты - аксес влан...

Добавлено через 3 минуты
вот.. сейчас что то проясняется... ВОт про L3 ...я плохо разбираюсь... можете подсказать, или посоветовать мануал, чтоб в этом разобраться, или вкратце объяснить???

Добавлено через 1 минуту
ТО есть на уровне L3, L3 свичи все вланы инкапсулирует в один пакет пропускают через один влан?
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
09.04.2015, 21:39 20
вкратце даже не знаю, про модель OSI вам почитать надо, смысл в том что когда пакет приходит на свитч он ведь его как конфетку разворачивает т.е второй уровень где вланы прописаны удаляется потом он смотрит ip адрес по нему решает куда отправлять пакет дальше, там уже опять спукается вниз и если надо то вешает влан если не надо не вешает

Добавлено через 1 минуту
это на L3 свиче так на L2 по другому немного
0
09.04.2015, 21:39
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.04.2015, 21:39

Есть ли способ анализировать сетевой трафик на Catalyst 3750 с ios 12.2(50)SE3
Имеем устройство c3750-ipservices-mz.122-50.SE3.bin Требуется удаленно смотреть tcpdump-подобным...

Настройка cisco 3750
Есть сеть 10.0.0.0 и есть выход в интернет адрес 22.22.22.22 шлюз 22.22.22.23. нужно сделать выход...

Trunk port между cisco 3750
Добрый день. Кто знает как создать транковый порт между двумя cisco 3750 ? По подробней...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru