Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.63/8: Рейтинг темы: голосов - 8, средняя оценка - 4.63
Arhivvarius666
0 / 0 / 0
Регистрация: 30.05.2013
Сообщений: 31
1

Cisco Packet Tracer. ACL на свичах

28.11.2015, 22:07. Просмотров 1560. Ответов 13
Метки нет (Все метки)

Здравствуйте. Помогите понять как применить ACL на свиче в проге. Создавать ACL свич WS-C2950-24 умеет, и даже создаёт (конфигурация под катом ниже).. а вто как повесить её - не пойму. при конфигурировании интерфейса он не понимает 'ip access-group'. Поискал 'access-group' в других местах (через ' ?') - не нашёл. На роутерах, да, она есть. и даже работает, а вот на коммутаторах, если есть списки, то их же можно как-то применить? Подскажите как.
Ну и маленький вопросик впридачу. Зачастую реальный свич умеет больше чем в программе (возможно версия ОС поновее) есть ли шанс что на реальном коммутаторе (catalyst 2950, 24+2) можно фильтровать трафик?
Заранее благодарен за ответ.

Switch0_running-config
Bash
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
access-list 100 deny tcp any any eq 7
access-list 100 deny udp any any eq 7
access-list 101 deny udp any any eq 7
access-list 101 deny tcp any any eq 7
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.11.2015, 22:07
Ответы с готовыми решениями:

Стандартный ACL Cisco Packet Tracer 7.1
Здравствуйте! Столкнулся со странной проблемой при изучении ACL на cisco : В теории адреса...

Расширенные ACL (в cisco packet tracer)
Добрый день! Буду признательна, если укажете на ошибки (файл в архиве) Не уверена, что правильно...

Cisco Packet Tracer создание сети с DHCP, VLAN и ACL
Необходимо спроектировать небольшую сеть с 3 подсетями и DNS-сервером. Изначально имеется сеть...

Настройка сети с оборудивания Cisco, в Cisco Packet Tracer
Добрий день. Помогите настроить сеть. Есть физическая топология, есть разпределени между собой...

Вопрос по боевой Cisco 800. Ну и по Cisco Packet Tracer
Имеется 800й роутер. В нем присутствует аксесс лист, в котором есть следующая строчка: permit ip...

13
xeonz
724 / 285 / 37
Регистрация: 16.05.2014
Сообщений: 2,194
28.11.2015, 22:27 2
Вешать ACL надо на L3 интерфейс. Т.е. на vlan1 к примеру.
0
insect_87
Эксперт по компьютерным сетям
5722 / 4395 / 966
Регистрация: 25.12.2012
Сообщений: 18,673
28.11.2015, 22:36 3
3560 на vlan-интерфейсы вроде вешает
2950 нет, он работает на 2 уровне
Цитата Сообщение от Arhivvarius666 Посмотреть сообщение
Поискал 'access-group' в других местах (через ' ?') - не нашёл.
вроде можно , например, access-list повесить на virt terminal через access-class, если не ошибаюсь
0
Arhivvarius666
0 / 0 / 0
Регистрация: 30.05.2013
Сообщений: 31
28.11.2015, 22:42  [ТС] 4
Цитата Сообщение от insect_87 Посмотреть сообщение
2950 нет, он работает на 2 уровне
А какой смысл тогда от создания ACL? Они же создаются
0
insect_87
Эксперт по компьютерным сетям
5722 / 4395 / 966
Регистрация: 25.12.2012
Сообщений: 18,673
28.11.2015, 22:59 5
выше написал
https://khlebalin.wordpress.com/2012...catalist-2950/
0
xeonz
724 / 285 / 37
Регистрация: 16.05.2014
Сообщений: 2,194
28.11.2015, 23:23 6
Цитата Сообщение от Arhivvarius666 Посмотреть сообщение
А какой смысл тогда от создания ACL? Они же создаются
Для ограничения удаленного управления.
0
sheogorat96
0 / 0 / 0
Регистрация: 02.05.2015
Сообщений: 4
21.10.2016, 17:16 7
Отпишусь пожалуй. Фишка в чем: работал на реальном оборудовании с коммутаторами cisco 2960 и 3560. Они воспринимали команду ip access-group исправно. Но эмулятор это делать не хочет. Это, к сожалению факт, и сам не знаю, что делать. ip access-group не работает в привязке конкретно к интерфейсам, чего хотелось бы иметь.
0
insect_87
Эксперт по компьютерным сетям
5722 / 4395 / 966
Регистрация: 25.12.2012
Сообщений: 18,673
21.10.2016, 20:41 8
Цитата Сообщение от sheogorat96 Посмотреть сообщение
Но эмулятор это делать не хочет. Это, к сожалению факт, и сам не знаю, что делать. ip access-group не работает в привязке конкретно к интерфейсам, чего хотелось бы иметь.
работает...... какая версия cpt?
0
sheogorat96
0 / 0 / 0
Регистрация: 02.05.2015
Сообщений: 4
22.10.2016, 14:37 9
Цитата Сообщение от insect_87 Посмотреть сообщение
работает...... какая версия cpt?
версия 7.0 и версия 6.1.1. ситуации идентичные.
пруфы прикреплены. так на всех свичах(коммутаторах т.е.) в cpt. также у автора. то есть команда ip access-group просто не существует для физ.интерфейсов коммутаторов. для vlan1 существует только у 3560
0
Миниатюры
Cisco Packet Tracer. ACL на свичах  
insect_87
Эксперт по компьютерным сетям
5722 / 4395 / 966
Регистрация: 25.12.2012
Сообщений: 18,673
22.10.2016, 14:57 10
такой acl вешается на интерфейс 3 уровня
команду no switchport в конфиге самого интерфейса порта делал перед этим?
по умолчанию портыв 3560 и 3750 - интерфейсы второго уровня, и ip routing на свитчах выключен
1
sheogorat96
0 / 0 / 0
Регистрация: 02.05.2015
Сообщений: 4
22.10.2016, 15:34 11
Цитата Сообщение от insect_87 Посмотреть сообщение
такой acl вешается на интерфейс 3 уровня
команду no switchport в конфиге самого интерфейса порта делал перед этим?
по умолчанию портыв 3560 и 3750 - интерфейсы второго уровня, и ip routing на свитчах выключен
Не подумал о таком). Единственный вопрос: каким образом на физ оборудовании не ругалось на switchport (то есть он был включен и на его настройку не ругалось) и при этом давало настраивать access-group?) вот тут я до сих пор голову ломаю

Добавлено через 12 минут
скажу больше: его настройка даже работала. по ip, заданному во vlan 1, подключались и взаимодействовали все компы(switchport access vlan 1), при этом также работала настройка access-group, точно уверен в этом
0
insect_87
Эксперт по компьютерным сетям
5722 / 4395 / 966
Регистрация: 25.12.2012
Сообщений: 18,673
22.10.2016, 16:07 12
ну эти acl будут работать только на интерфейсах 3 уровня - интерфейсах VLAN, туннелей и портах 3 уровня
не знаю, что там было у тебя на физ оборудовании, но я с этим каждый день работаю и по умолчанию cisco L3 настроены на уровень 2 - те роутинг отключен и порты уровня 2
0
sheogorat96
0 / 0 / 0
Регистрация: 02.05.2015
Сообщений: 4
22.10.2016, 17:32 13
я так понял, у нас настроены на 3 уровень за неимением нормальных роутеров)
0
insect_87
22.10.2016, 17:48     Cisco Packet Tracer. ACL на свичах
  #14

Не по теме:

если дискутировать, роутеры немного для другого предназначены нежели свитчи L3

0
22.10.2016, 17:48
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.10.2016, 17:48
Привет! Вот еще темы с ответами:

VLAN на коммутаторах CISCO (в Cisco Packet Tracer)
Здравствуйте! Имелась схема (во вложении): три коммутатора и три маршрутизатора соединялись...

Telnet и ACL (в Cisco Packet tracker)
Доброго времени суток всем! в Cisco packet taracer вообщем надо делать следующее, 1) есть 1...

Cisco packet tracer 7.1
Привет всем! Такое дело, когда кликаешь, например, на роутер открывается окошко с 3-мя вкладками:...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.