Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/14: Рейтинг темы: голосов - 14, средняя оценка - 4.71
Igor-vrn
7 / 7 / 2
Регистрация: 14.12.2013
Сообщений: 94
1

OSPF через GRE туннели Cisco (в Packet Tracer)

26.01.2016, 04:10. Просмотров 2843. Ответов 10
Метки нет (Все метки)

Проблема. Туннель числится, как Up. На деле пинг на него не проходит и, соответственно, в OSPF отношения соседства нет.
Маршрутизатор Root:
CSS
1
2
3
4
5
6
7
8
9
10
11
12
13
interface Tunnel0
 ip address 172.16.0.141 255.255.255.252
 tunnel source GigabitEthernet0/0.789
 tunnel destination 172.16.0.134
 
ip route 172.16.0.134 255.255.255.255 172.16.0.129
 
router ospf 1
 router-id 172.16.0.255
 log-adjacency-changes
 network 172.16.0.0 0.0.0.127 area 0
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.2.0 0.0.1.255 area 0
Маршрутизатор Root2:
CSS
1
2
3
4
5
6
7
8
9
10
interface Tunnel0
 ip address 172.16.0.142 255.255.255.252
 tunnel source GigabitEthernet0/0.789
 tunnel destination 172.16.0.130
 
ip route 172.16.0.130 255.255.255.255 172.16.0.133
 
router ospf 1
 router-id 172.16.0.235
 network 172.16.64.0 0.0.0.127 area 0
Что имею: с Root пинг на 172.16.0.134 успешный. По статик маршруту проходит, т.е. не работает именно туннель.
пинг на 172.16.0.142 безуспешный.

Первоначально туннель установился и тут же упал по причине "recursive routing". Насколько я понимаю, причиной послужила первоначальная настройка network у OSPF. Она охватывала всю подсеть 172 из-за чего сеть 172.16.0.132/30 стала анонсироваться из туннеля, хотя маршрутизатор считал ее своей локальной. Внес правки, исключив из анонсирования подсети, отведенные на туннели. В итоге отношения соседства нет. Вернул всю 172... и все равно тишина. "Подкинул" роутеру Root2 соседа. Он с ним без проблем установил отношение соседства.

Проблем со связью между маршрутизаторами нет. Router4 (который по центру) пропинговал всех окружающих успешно.

В чем проблема? Бьюсь не первый час...
PT. Все трое Cisco 1941
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.01.2016, 04:10
Ответы с готовыми решениями:

NAT и OSPF (в Cisco Packet Tracer)
Здравствуйте, помогите разобраться. Уже давно бьюсь и уже по запарке видимо что то упускаю. За...

OSPF + статическая маршрутизация (в Cisco Packet tracer)
И снова я, и снова здравствуйте :D Роутеры(подписаны как OSPF) маршрутизируют динамически vlan...

Не работает OSPF после настройки NAT (Cisco Packet Tracer 5.3.1)
Добрый вечер, джентльмены. Во время настройки динамической NAT на 2-м роутере при уже настроенном...

Делаю курсовую в Cisco Packet Tracer. Осталось только связать RIP,OSPF и EIGRP
не получается пингануть rip и eigrp, пакеты от rip доходят до eigrp, но подтверждение не отсылается...

Раздача DHCP через маршрутизатор (Cisco Packet Tracer)
Добрый день. Сеть в прикрепленной картинке. Кратко о настройках: часть слева - это 192.168.1.X;...

10
Igor-vrn
7 / 7 / 2
Регистрация: 14.12.2013
Сообщений: 94
26.01.2016, 04:13  [ТС] 2
OSPF через GRE туннели Cisco (в Packet Tracer)

Модель выглядит так
0
cat_driver
57 / 48 / 3
Регистрация: 19.12.2013
Сообщений: 203
26.01.2016, 10:13 3
Приветствую, сам файлик CPT кидайте, посмотрим, так проще чем на словах выпытывать инфу
0
MonaxGT
Эксперт по компьютерным сетям
277 / 277 / 25
Регистрация: 02.08.2012
Сообщений: 1,230
26.01.2016, 11:11 4
Может быть у вас есть возможность снять лог по ospf ?
Проверьте МТУ как вариант, помнится ospf чувствителен к этому параметру.
0
26.01.2016, 11:11
Igor-vrn
7 / 7 / 2
Регистрация: 14.12.2013
Сообщений: 94
26.01.2016, 15:04  [ТС] 5
Цитата Сообщение от MonaxGT Посмотреть сообщение
Проверьте МТУ как вариант, помнится ospf чувствителен к этому параметру
Да, вот этот момент я видел на одном из сайтов. Там рекомендуют поставить его 1436 дабы избежать проблем с DF флажком. Но в show runn для туннеля есть запись mtu 1476, установленная по-умолчанию. Причем выполнить команду mtu для интерфейса туннеля нельзя. Установка mtu на выходном ethernet порту так же не помогла

Добавлено через 1 минуту
Цитата Сообщение от cat_driver Посмотреть сообщение
сам файлик CPT кидайте
https://yadi.sk/d/w6mnxeGynkzRC
0
deniskv
83 / 83 / 30
Регистрация: 01.07.2015
Сообщений: 240
26.01.2016, 15:18 6
поставьте в настройках тунеля tunnel0 source GigabitEthernet0/0.789

Добавлено через 21 секунду
на обоих роутерах
0
Igor-vrn
7 / 7 / 2
Регистрация: 14.12.2013
Сообщений: 94
26.01.2016, 15:52  [ТС] 7
Цитата Сообщение от deniskv Посмотреть сообщение
поставьте в настройках тунеля tunnel0 source GigabitEthernet0/0.789
Ставил.
CSS
1
2
3
4
interface Tunnel0
 ip address 172.16.0.141 255.255.255.252
 tunnel source GigabitEthernet0/0.789
 tunnel destination 172.16.0.134
tunnel is up

Добавлено через 3 минуты
Интересует момент: почему тунельные интерфейсы в настройках ospf нельзя сделать passive или наоборот не passive? Чую, если заменю 1941-е на какие-то другие, то и проблема испарится, не?
0
deniskv
83 / 83 / 30
Регистрация: 01.07.2015
Сообщений: 240
26.01.2016, 17:12 8
!
interface Tunnel0
ip address 172.16.0.142 255.255.255.252
mtu 1476
tunnel destination 172.16.0.130
!
это в прикрепленном файле на роутере root2
!
interface Tunnel0
ip address 172.16.0.141 255.255.255.252
mtu 1476
tunnel destination 172.16.0.134
!
это на роутере root
как прописываете соурс тоннель поднимается и соседство ospf тоже, но там
%OSPF-5-ADJCHG: Process 1, Nbr 172.16.0.255 on Tunnel0 from LOADING to FULL, Loading Done
%ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of 0 65E900C0 - looped chain attempting to stack
%TUN-5-RECURDOWN: 0 temporarily disabled due to recursive routing
%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down
%ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of 0 65E900C0 - looped chain attempting to stack
'это ограничение CPT в GNS3 можно поставить в passive тоннель

Добавлено через 46 секунд
всмысле не ошибка ограничение CPT а passive

Добавлено через 26 секунд
а ошибка изза петли маршрутизации
0
Igor-vrn
7 / 7 / 2
Регистрация: 14.12.2013
Сообщений: 94
26.01.2016, 17:27  [ТС] 9
Цитата Сообщение от deniskv Посмотреть сообщение
но там
да, собственно, об этом говорил. С каких таких соображений появляется петля? На Router4 не поднят ospf. Какие соображения?
Цитата Сообщение от Igor-vrn Посмотреть сообщение
Насколько я понимаю, причиной послужила первоначальная настройка network у OSPF. Она охватывала всю подсеть 172 из-за чего сеть 172.16.0.132/30 стала анонсироваться из туннеля, хотя маршрутизатор считал ее своей локальной
Таково?
Стандартнейшие методы протягивания туннелей. На работе на микротик никогда таких проблем нет... (

Добавлено через 1 минуту
убрал из анонсирования подсети, относящиеся к туннелям с обеих сторон. И все равно
0
deniskv
83 / 83 / 30
Регистрация: 01.07.2015
Сообщений: 240
26.01.2016, 17:38 10
маршрут к сети 172.16.64.0/27 directly connected на root2 и root а они в разных broadcast
0
Igor-vrn
7 / 7 / 2
Регистрация: 14.12.2013
Сообщений: 94
26.01.2016, 17:46  [ТС] 11
Цитата Сообщение от deniskv Посмотреть сообщение
маршрут к сети 172.16.64.0/27 directly connected на root2 и root а они в разных broadcast
Нет, на Root такой нет. Есть:
CSS
1
2
C       172.16.0.64/27 is directly connected, GigabitEthernet0/0.4
L       172.16.0.67/32 is directly connected, GigabitEthernet0/0.4
Специально делил на подсети (офисы), чтобы суммировать можно было.

Проверил. У них нет перекрывающихся маршрутов в таблицах.
0
26.01.2016, 17:46
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.01.2016, 17:46

Построение сети через Cisco Packet Tracer Student
Нужно настроить сеть, что бы всё работала. Нужна помощь в настройке :help:

Построение сети через Cisco Packet Tracer Student
Здравствуйте есть Главный офис нужно соединить с филиалом как это можно сделать?я пробывал vpn...

Cisco Packet Tracer. Не могу настроить соединение через облако.
Здравствуйте! В колледже дали задание настроить сетку. Я вроде все настроил кроме тех участков где...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru