Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/9: Рейтинг темы: голосов - 9, средняя оценка - 4.67
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
1

Настройка маршрутизации между L3 свичем и роутером

05.04.2016, 17:47. Просмотров 1732. Ответов 19
Метки нет (Все метки)

Добрый день!
Помогите настроить маршрутизацию.
Есть 3 пк, 2 в одной сети, 1 в другой. Необходимо настроить маршрутизацию между ни

PC0 -10.0.1.1/24, PC1 - 10.0.1.2/24 они находятся в VLAN4 ip - 10.0.1.30/24
PC 2 - 10.0.3.1, шлюз у него порт роутера с адресом 10.0.3.3/24
Интерфейс между свичем и роутером засунул в VLAN 10 с адресом 10.0.5.20/24
0
Миниатюры
Настройка маршрутизации между L3 свичем и роутером  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
05.04.2016, 17:47
Ответы с готовыми решениями:

Настройка маршрутизации между VLAN
Бьюсь уже пару часов. Совсем что-то не получается. Помогите, пожалуйста, как настроить...

Настройка маршрутизации
Здравствуйте уважаемые админы!!!! У меня на локальной машине стоят 2 сетевых карты WIN-7x64. На...

Настройка маршрутизации
Всем привет.Интересует вопрос: Собрал сеть. Пакеты идут где 2 роутера. А вот как настроить...

Настройка маршрутизации
Ребята к вам следующийсвопрос - существует сервер windows server 2008 с двумя сетями ...

Настройка маршрутизации
Понимаю, что эта тема уже была http://www.cyberforum.ru/cisco/thread2083626.html но свою ошибку...

19
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 17:49 2
Цитата Сообщение от venraz Посмотреть сообщение
настроить маршрутизацию между ними
динамику или статику ?
что уже сделали ?
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 17:50  [ТС] 3
Статику, могу прислать настройки свича и роутера, чтобы было понятнее
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 17:53 4
схему сами собирали ? или условие такое, по идее их можно смаршрутизировать на L3 свиче марш тут не нужен
0
05.04.2016, 17:53
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 17:54  [ТС] 5
такое условие, поставили задачу по работе...у самого не получается настроить правильно
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 17:58 6
покажите конфиги с обоих устройств
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 18:03  [ТС] 7
L3 свич
Кликните здесь для просмотра всего текста
Building configuration...

Current configuration : 1424 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan4
ip address 10.0.1.30 255.255.255.0
!
interface Vlan10
ip address 10.0.5.20 255.255.255.0
!
ip classless
ip route 10.0.1.0 255.255.255.0 10.0.5.1
ip route 10.0.5.0 255.255.255.0 10.0.5.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
!


роутер
Кликните здесь для просмотра всего текста
Building configuration...

Current configuration : 494 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 10.0.5.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.3.3 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 18:05 8
еще нарисуйте схему по новому и на ней пропишите ип адреса и какими портами зацеплены между собой циски
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 18:06  [ТС] 9
могу нарисовать по новому и отправить файл пакет трейсера
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 18:16  [ТС] 10
Скрин со схемой
0
Миниатюры
Настройка маршрутизации между L3 свичем и роутером  
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 19:13 11
почему на схеме ип адресация не соответсвует конфигу ?
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 19:26  [ТС] 12
Не правильный конфиг Вам отправил, отправляю верный:

свич
Кликните здесь для просмотра всего текста
Switch#sh ru
Building configuration...

Current configuration : 1389 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan4
ip address 10.0.1.30 255.255.255.0
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
!
ip classless
ip route 10.0.1.0 255.255.255.0 192.168.10.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan4
ip address 10.0.1.30 255.255.255.0
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
!
ip classless
ip route 10.0.1.0 255.255.255.0 192.168.10.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
!
!
!
end




роутер
Кликните здесь для просмотра всего текста
Router#sh ru
Building configuration...

Current configuration : 498 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.3.3 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 19:44 13
сделайте на свиче порт fa 0/24 как L3 не нужен влан там
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 20:24  [ТС] 14
Код
interface FastEthernet0/24
 no switchport
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
так?
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 22:05 15
так
0
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 22:15  [ТС] 16
все равно не работает...что я могу не так делать?
0
corlovito
456 / 437 / 75
Регистрация: 26.12.2012
Сообщений: 2,880
05.04.2016, 22:46 17
сначала добейтесь чтобы миски между собой пинговались
1
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
05.04.2016, 22:49  [ТС] 18
пинг от свича к роутеру идет
Кликните здесь для просмотра всего текста
Switch#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/6 ms


и обратно

Кликните здесь для просмотра всего текста
Router#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/6 ms
0
insect_87
Эксперт по компьютерным сетям
4858 / 3934 / 811
Регистрация: 25.12.2012
Сообщений: 16,690
06.04.2016, 08:14 19
1) у компов дефолтные шлюзы прописаны?
2) на роутере пропиши дефолтный маршрут (или маршрут до сети 10.0.1.0/24) через 192.168.10.1 (он у тебя почему-то на свитче прописан)
3) на свитче пропиши дефолтный маршрут (или маршрут до сети 10.0.3.0/24) через 192.168.10.2
4) убери на свитче старые записи об интерфейсе vlan 10
1
venraz
0 / 0 / 0
Регистрация: 16.02.2015
Сообщений: 21
06.04.2016, 13:56  [ТС] 20
Благодарю Вас, ребята!!
0
06.04.2016, 13:56
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.04.2016, 13:56

Настройка маршрутизации
Доброго времени суток! Стоит задача настроить маршрутизацию для трех сетей. Для сетей 10.1.1.0/24 и...

Настройка маршрутизации
Добрый день. Прошу помощи, поскольку имеющихся знаний не хватает для решения проблемы. Имеется сеть...

Настройка маршрутизации
Здравствйте. Возник небольшой вопросец. Есть в одной гос. конторе сетка. есть в ней роутер (zyxel,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.