Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
insect_87
Эксперт по компьютерным сетям
5365 / 4191 / 898
Регистрация: 25.12.2012
Сообщений: 17,792
1

Динамическая маршрутизация с использованием EBGP

10.07.2016, 15:11. Просмотров 877. Ответов 3
Метки нет (Все метки)

Пинг с R4 не идет ни на 90.0.0.1, ни на 80.0.0.1. Идет только, если source указать 10.0.2.1. Но задача другая.
Динамическая маршрутизация с использованием EBGP

R1-sh run
Кликните здесь для просмотра всего текста
interface Loopback0
ip address 100.64.0.1 255.255.255.0
!
interface Loopback1
ip address 80.0.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 90.0.0.1 255.0.0.0
duplex full
!
interface FastEthernet1/0
ip address 10.0.0.1 255.255.255.0
duplex full
!
interface FastEthernet2/0
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
!
router bgp 64500
no synchronization
bgp log-neighbor-changes
network 80.0.0.0
network 90.0.0.0
neighbor 10.0.0.2 remote-as 64501
neighbor 10.0.0.2 prefix-list DEFAULT_IN in
neighbor 10.0.0.2 weight 100
neighbor 10.0.1.2 remote-as 64502
neighbor 10.0.1.2 prefix-list DEFAULT_IN in
neighbor 10.0.1.2 route-map DENY_ALL_TRAFFIC_IN out
neighbor 10.0.1.2 weight 120
no auto-summary
!
ip classless
ip route 80.0.0.0 255.0.0.0 Null0
ip route 90.0.0.0 255.0.0.0 Null0
no ip http server
!
!
!
ip prefix-list DEFAULT_IN seq 5 permit 0.0.0.0/0
no cdp log mismatch duplex
!
route-map DENY_ALL_TRAFFIC_IN permit 10
set origin incomplete

R1-sh ip bgp
Кликните здесь для просмотра всего текста
Network Next Hop Metric LocPrf Weight Path
* 0.0.0.0 10.0.0.2 100 64501 i
*> 10.0.1.2 120 64502 i
*> 80.0.0.0 0.0.0.0 0 32768 i
*> 90.0.0.0 0.0.0.0 0 32768 i

R1-sh ip rou
Кликните здесь для просмотра всего текста
Gateway of last resort is 10.0.1.2 to network 0.0.0.0

100.0.0.0/24 is subnetted, 1 subnets
C 100.64.0.0 is directly connected, Loopback0
80.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 80.0.0.0/24 is directly connected, Loopback1
S 80.0.0.0/8 is directly connected, Null0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, FastEthernet1/0
C 10.0.1.0 is directly connected, FastEthernet2/0
S 90.0.0.0/8 is directly connected, Null0
B* 0.0.0.0/0 [20/0] via 10.0.1.2, 00:03:36

R2-sh run
Кликните здесь для просмотра всего текста
interface Loopback0
ip address 100.64.1.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.0.0.0
!
interface Loopback2
ip address 30.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 10.0.0.2 255.255.255.0
duplex full
!
interface FastEthernet2/0
ip address 10.0.3.2 255.255.255.0
duplex auto
speed auto
!
router bgp 64501
no synchronization
bgp log-neighbor-changes
network 20.0.0.0
network 30.0.0.0
neighbor 10.0.0.1 remote-as 64500
neighbor 10.0.0.1 default-originate
neighbor 10.0.0.1 prefix-list DEFAULT out
neighbor 10.0.3.1 remote-as 64503
neighbor 10.0.4.2 remote-as 64502
no auto-summary
!
ip classless
no ip http server
!
!
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0

R2-sh ip bgp
Кликните здесь для просмотра всего текста
Network Next Hop Metric LocPrf Weight Path
*> 0.0.0.0 10.0.0.1 0 64500 64502 i
*> 20.0.0.0 0.0.0.0 0 32768 i
*> 30.0.0.0 0.0.0.0 0 32768 i
* 40.0.0.0 10.0.3.1 0 64503 64502 i
*> 10.0.4.2 0 0 64502 i
* 50.0.0.0 10.0.3.1 0 64503 64502 i
*> 10.0.4.2 0 0 64502 i
* 60.0.0.0 10.0.4.2 0 64502 64503 i
*> 10.0.3.1 0 0 64503 i
* 70.0.0.0 10.0.4.2 0 64502 64503 i
*> 10.0.3.1 0 0 64503 i
* 80.0.0.0 10.0.4.2 0 64502 64500 ?
*> 10.0.0.1 0 0 64500 i
* 90.0.0.0 10.0.4.2 0 64502 64500 ?
*> 10.0.0.1 0 0 64500 i

R2-sh ip rou
Кликните здесь для просмотра всего текста
Gateway of last resort is 10.0.0.1 to network 0.0.0.0

B 50.0.0.0/8 [20/0] via 10.0.4.2, 00:06:42
100.0.0.0/24 is subnetted, 1 subnets
C 100.64.1.0 is directly connected, Loopback0
B 70.0.0.0/8 [20/0] via 10.0.3.1, 00:06:48
B 80.0.0.0/8 [20/0] via 10.0.0.1, 00:07:10
C 20.0.0.0/8 is directly connected, Loopback1
B 40.0.0.0/8 [20/0] via 10.0.4.2, 00:06:42
10.0.0.0/24 is subnetted, 3 subnets
C 10.0.3.0 is directly connected, FastEthernet2/0
C 10.0.0.0 is directly connected, FastEthernet1/0
C 10.0.4.0 is directly connected, FastEthernet0/0
B 90.0.0.0/8 [20/0] via 10.0.0.1, 00:07:10
B 60.0.0.0/8 [20/0] via 10.0.3.1, 00:06:48
C 30.0.0.0/8 is directly connected, Loopback2
B* 0.0.0.0/0 [20/0] via 10.0.0.1, 00:07:18

R3-sh run
Кликните здесь для просмотра всего текста
interface Loopback0
ip address 100.64.2.1 255.255.255.0
!
interface Loopback1
ip address 40.0.0.1 255.0.0.0
!
interface Loopback2
ip address 50.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address 10.0.4.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 10.0.2.2 255.255.255.0
duplex full
!
interface FastEthernet2/0
ip address 10.0.1.2 255.255.255.0
duplex auto
speed auto
!
router bgp 64502
no synchronization
bgp log-neighbor-changes
network 40.0.0.0
network 50.0.0.0
neighbor 10.0.1.1 remote-as 64500
neighbor 10.0.1.1 default-originate
neighbor 10.0.1.1 prefix-list DEFAULT out
neighbor 10.0.2.1 remote-as 64503
neighbor 10.0.4.1 remote-as 64501
no auto-summary
!
ip classless
no ip http server
!
!
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0

R3-sh ip bgp
Кликните здесь для просмотра всего текста
Network Next Hop Metric LocPrf Weight Path
* 20.0.0.0 10.0.2.1 0 64503 64501 i
*> 10.0.4.1 0 0 64501 i
* 30.0.0.0 10.0.2.1 0 64503 64501 i
*> 10.0.4.1 0 0 64501 i
*> 40.0.0.0 0.0.0.0 0 32768 i
*> 50.0.0.0 0.0.0.0 0 32768 i
* 60.0.0.0 10.0.4.1 0 64501 64503 i
*> 10.0.2.1 0 0 64503 i
* 70.0.0.0 10.0.4.1 0 64501 64503 i
*> 10.0.2.1 0 0 64503 i
* 80.0.0.0 10.0.2.1 0 64503 64501 64500 i
* 10.0.4.1 0 64501 64500 i
*> 10.0.1.1 0 0 64500 ?
* 90.0.0.0 10.0.2.1 0 64503 64501 64500 i
* 10.0.4.1 0 64501 64500 i
*> 10.0.1.1 0 0 64500 ?

R3-sh ip rou
Кликните здесь для просмотра всего текста
Gateway of last resort is not set

C 50.0.0.0/8 is directly connected, Loopback2
100.0.0.0/24 is subnetted, 1 subnets
C 100.64.2.0 is directly connected, Loopback0
B 70.0.0.0/8 [20/0] via 10.0.2.1, 00:09:34
B 80.0.0.0/8 [20/0] via 10.0.1.1, 00:09:56
B 20.0.0.0/8 [20/0] via 10.0.4.1, 00:09:56
C 40.0.0.0/8 is directly connected, Loopback1
10.0.0.0/24 is subnetted, 3 subnets
C 10.0.2.0 is directly connected, FastEthernet1/0
C 10.0.1.0 is directly connected, FastEthernet2/0
C 10.0.4.0 is directly connected, FastEthernet0/0
B 90.0.0.0/8 [20/0] via 10.0.1.1, 00:09:56
B 60.0.0.0/8 [20/0] via 10.0.2.1, 00:09:34
B 30.0.0.0/8 [20/0] via 10.0.4.1, 00:09:58

R4-sh run
Кликните здесь для просмотра всего текста
interface Loopback0
ip address 100.64.3.1 255.255.255.0
!
interface Loopback1
ip address 60.0.0.1 255.0.0.0
!
interface Loopback2
ip address 70.0.0.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
duplex half
!
interface FastEthernet1/0
ip address 10.0.2.1 255.255.255.0
duplex full
!
interface FastEthernet2/0
ip address 10.0.3.1 255.255.255.0
duplex auto
speed auto
!
router bgp 64503
no synchronization
bgp log-neighbor-changes
network 60.0.0.0
network 70.0.0.0
neighbor 10.0.2.2 remote-as 64502
neighbor 10.0.3.2 remote-as 64501
no auto-summary

R4-sh ip bgp
Кликните здесь для просмотра всего текста
Network Next Hop Metric LocPrf Weight Path
*> 0.0.0.0 10.0.3.2 0 64501 64500 64502 i
* 20.0.0.0 10.0.2.2 0 64502 64501 i
*> 10.0.3.2 0 0 64501 i
* 30.0.0.0 10.0.2.2 0 64502 64501 i
*> 10.0.3.2 0 0 64501 i
* 40.0.0.0 10.0.3.2 0 64501 64502 i
*> 10.0.2.2 0 0 64502 i
* 50.0.0.0 10.0.3.2 0 64501 64502 i
*> 10.0.2.2 0 0 64502 i
*> 60.0.0.0 0.0.0.0 0 32768 i
*> 70.0.0.0 0.0.0.0 0 32768 i
* 80.0.0.0 10.0.2.2 0 64502 64500 ?
*> 10.0.3.2 0 64501 64500 i
* 90.0.0.0 10.0.2.2 0 64502 64500 ?
*> 10.0.3.2 0 64501 64500 i

R4-sh ip rou
Кликните здесь для просмотра всего текста
Gateway of last resort is 10.0.3.2 to network 0.0.0.0

B 50.0.0.0/8 [20/0] via 10.0.2.2, 00:13:13
100.0.0.0/24 is subnetted, 1 subnets
C 100.64.3.0 is directly connected, Loopback0
C 70.0.0.0/8 is directly connected, Loopback2
B 80.0.0.0/8 [20/0] via 10.0.3.2, 00:13:40
B 20.0.0.0/8 [20/0] via 10.0.3.2, 00:13:40
B 40.0.0.0/8 [20/0] via 10.0.2.2, 00:13:13
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.2.0 is directly connected, FastEthernet1/0
C 10.0.3.0 is directly connected, FastEthernet2/0
B 90.0.0.0/8 [20/0] via 10.0.3.2, 00:13:40
C 60.0.0.0/8 is directly connected, Loopback1
B 30.0.0.0/8 [20/0] via 10.0.3.2, 00:13:40
B* 0.0.0.0/0 [20/0] via 10.0.3.2, 00:13:41


Ах, да . На R1 сделал так, чтобы весь исходящий трафик ехал через правого соседа, а входящий приходил от левого, и дабы не перегружать таблицы от соседей приходят лишь дефолтные маршруты. Остальные роутеры держат полные таблицы BGP

и еще, напоследок

R1#trace 60.0.0.1
Tracing the route to 60.0.0.1

1 10.0.1.2 [AS 64502] 4 msec 32 msec 68 msec
2 10.0.2.1 [AS 64502] 108 msec 100 msec 100 msec

R4#trace 90.0.0.1
Tracing the route to 90.0.0.1

1 10.0.3.2 [AS 64502] 36 msec 64 msec 68 msec
2 * * *
3 * * *
и тд

R4#ping 80.0.0.1 sou 10.0.2.1

Sending 5, 100-byte ICMP Echos to 80.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 172/186/196 ms

R4#ping 80.0.0.1 sou 10.0.3.1

Sending 5, 100-byte ICMP Echos to 80.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.3.1
.....
Success rate is 0 percent (0/5)
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.07.2016, 15:11
Ответы с готовыми решениями:

Динамическая маршрутизация
Не удается через интерфейс CPT настроить работу динамической маршрутизации в локальной сети 3. Кто...

Динамическая маршрутизация
Посмотрите сеть. VLAN-ы настроены. нужно задать ip адреса компьютерам. Помогите с чего начать...

Динамическая маршрутизация [CPT]
Доброго времени суток, объясните как сделать динамическую маршрутизацию к такой схеме:

Динамическая маршрутизация [CPT]
Подскажите пожалуйста. Как настроить динамическую маршрутизацию, если у меня 5 подсетей...

Динамическая маршрутизация между маршрутизаторами
Приветствую. Настраивая маршрутизацию, я столкнулся с проблемой - компы, подключенные к разным...

3
Jabbson
Эксперт по компьютерным сетям
3467 / 2508 / 776
Регистрация: 03.11.2009
Сообщений: 7,945
Записей в блоге: 3
10.07.2016, 17:05 2
Лучший ответ Сообщение было отмечено insect_87 как решение

Решение

думаю, R4 посылает запрос на 90.0.0.1 (по дефолту с сорсом 10.0.3.1), он уходит на R2, оттуда на R1
от R1 ответ по DG уходит на R3, который ничего не знает о 10.0.3.1 и дропает пакет.

мое предположение можно легко проверить сделав на R3
Код
ip route 10.0.3.1 255.255.255.255 10.0.2.1
и опять попробовать попинговать
0
micho
4 / 4 / 1
Регистрация: 07.05.2014
Сообщений: 19
13.07.2016, 09:47 3
insect_87, у вас на R1 отсутствуют маршруты к лупбэкам R4. Уберите для начала все роутмапы и префикслисты с R1 и посмотрите что получится.
0
insect_87
Эксперт по компьютерным сетям
5365 / 4191 / 898
Регистрация: 25.12.2012
Сообщений: 17,792
15.07.2016, 08:00  [ТС] 4
micho, спс, мы уже разобрались
0
15.07.2016, 08:00
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.07.2016, 08:00

Динамическая маршрутизация. Протокол RIP
Ребята, помогите решить лабораторную, уже нервоз берет, в CISCO вообще не шарю( или инструкцию хотя...

Динамическая маршрутизация протоколом OSPF
Проблема собственно такая же, как и была у меня при протоколе RIP.Вроде бы тщательно проверил, но...

DHCP + динамическая маршрутизация (rip) [CPT]
ребят помогите проблема в том что покеты не проходят через маршрутизаторы. в одной влан...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.