Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
1

Создание vlan-ов

02.01.2017, 20:28. Просмотров 1090. Ответов 12
Метки нет (Все метки)

Всем привет!
Собственно требуется разбить сеть на три влана.
0
Миниатюры
Создание vlan-ов  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.01.2017, 20:28
Ответы с готовыми решениями:

Доступ из одного vlan к электронному ключу в другом vlan
Возникла ситуация. При переводе компьютера в отдельный vlan программа 1С он перестала видеть...

Переброс траффика из одного Vlan в другой Vlan
Подскажите добрые люди умеют ли коммутаторы 2960S, 3750 перекидывать трафик из одного vlan в другой...

Cisco Packet Tracer создание сети с DHCP, VLAN и ACL
Необходимо спроектировать небольшую сеть с 3 подсетями и DNS-сервером. Изначально имеется сеть...

Создание 2х VLAN
Здравствуйте. Возникла необходимость разделить две сети (расположенных в одном офисе\помещении)....

VLAN создание и настройка
Заранее извиняюсь если такая тема уже была. Прошу дать ссыль на информацию по созданию и настройке...

12
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
02.01.2017, 20:55  [ТС] 2
Всё функционирует, пакеты передаются, но нужны вланы. Смотрел посты о том как это делать, не понял. Прошу помощи. По моему надо прописать транк порты...
Могу скинуть файл конфигурации.
0
insect_87
Эксперт по компьютерным сетям
4843 / 3926 / 803
Регистрация: 25.12.2012
Сообщений: 16,687
04.01.2017, 08:22 3
Цитата Сообщение от Viels Посмотреть сообщение
Могу скинуть файл конфигурации.
скидывай
0
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
04.01.2017, 14:48  [ТС] 4
Отправляю конфигурацию (как на картинке). Думаю нужно на каждом коммутаторе для каждого порта прописать, что он входит в созданный vlan. Скажем vlan 2. Но как потом будет происходить отправка пакетов? Нужно по моему прописать команды для отправки...
Уже пробовал так, но, что-то не пингуется...
0
Вложения
Тип файла: rar example (с vlan).rar (110.9 Кб, 7 просмотров)
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
04.01.2017, 15:50  [ТС] 5
Выражаясь точнее, не для каждого коммутатора прописать, что его порты по которым подключено его подмножество pc входят в vlan 2 (для всех коммутаторов и его pc), а для каждого коммутатора и его pc, отдельный vlan ( 2, 3, 4) соответственно. Ну думаю вы меня поняли)

Добавлено через 47 минут
Могут ли пк из разных вланов обмениваться пингами?
0
insect_87
Эксперт по компьютерным сетям
4843 / 3926 / 803
Регистрация: 25.12.2012
Сообщений: 16,687
05.01.2017, 10:10 6
Лучший ответ Сообщение было отмечено Viels как решение

Решение

тут косяк на косяке с адресацией, маршрутами и шлюзами.
1. на свитчах порты в сторону конечных хостов перевести в access mode и соответствующий vlan, порты в сторону роутеров в trunk.
2. на роутерах убрать адреса с интерфейсов fa0/0, создать сабинтерфейсы в соответствующих vlan и присвоить им эти адреса (int fa0/0.4 на левом роутере; int fa0/0.2 на роутере в центре; int fa0/0.3 на правом);
3. на всех компах выставить правильные шлюзы, в качестве них и будут соответствующие адреса сабинтерфейсов роутеров.
4. исправить адреса serial интерфейсов
на роутере справа:
Код
interface Serial1/0
ip address 192.169.10.2 255.255.255.252
interface Serial1/1
ip address 192.169.12.2 255.255.255.252
на роутере в центре:
Код
Router(config)#interface Serial1/1
Router(config-if)#ip address 192.169.12.1 255.255.255.252
Router(config-if)#exit
Router(config)#interface Serial1/0
Router(config-if)#ip address 192.169.11.2 255.255.255.252
5. на каждом из роутеров прописать кратчайшие маршруты до сетей за двумя другими роутерами
на левом:
Код
ip route 192.169.6.0 255.255.255.0 192.169.11.2
ip route 192.169.7.0 255.255.255.0 192.169.10.2
в центре:
Код
ip route 192.169.5.0 255.255.255.0 192.169.11.1
ip route 192.169.7.0 255.255.255.0 192.169.12.2
на правом:
Код
ip route 192.169.5.0 255.255.255.0 192.169.10.1
ip route 192.169.6.0 255.255.255.0 192.169.12.1
6. убрать лишние маршруты по умолчанию, оставить лишь те, по которым будет кратчайший путь в сторону сервера.
оставляем
на правом:
Код
ip route 0.0.0.0 0.0.0.0 fastEthernet 0/1
в центре:
Код
ip route 0.0.0.0 0.0.0.0 Serial1/1
на левом:
Код
ip route 0.0.0.0 0.0.0.0 Serial1/0

___________________________________________________________________________________________________
7. в приложении в архиве выложил файл проекта, в котором все пингуется
1
Вложения
Тип файла: rar example (с vlan).rar (113.1 Кб, 5 просмотров)
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
05.01.2017, 11:18  [ТС] 7
Премного благодарен за исчерпывающий ответ. Сам, используя полезнейшие ролики (Курс молодого бойца), кое-что сконфигурировал.
Вот скрин. Скину саму конфигурацию. Может, кому-нибудь пригодится.

Switch2
Код
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/3
 switchport trunk allowed vlan 2-3
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 ip address 192.168.22.1 255.255.255.0
!
!
Switch1
Код
interface FastEthernet0/1
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/3
 switchport trunk allowed vlan 2-3
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan3
 ip address 192.168.33.1 255.255.255.0
!
Multilayer Switch0
Код
interface FastEthernet0/1
 switchport trunk allowed vlan 2-3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk allowed vlan 2-3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
 switchport trunk allowed vlan 4
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport access vlan 5
 switchport mode access
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 ip address 2.2.2.1 255.255.255.0
!
interface Vlan3
 ip address 3.3.3.1 255.255.255.0
!
interface Vlan4
 ip address 4.4.4.1 255.255.255.0
!
interface Vlan5
 ip address 192.168.55.2 255.255.255.0
!
ip classless
!
Switch0
Код
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport access vlan 4
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 4
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
Router0
Код
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.55.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.22.0 255.255.255.0 192.168.55.2 
ip route 192.168.33.0 255.255.255.0 192.168.55.2 
ip route 192.168.44.0 255.255.255.0 192.168.55.2 
!
ip flow-export version 9
!
!
0
Миниатюры
Создание vlan-ов  
Вложения
Тип файла: rar example2.rar (145.1 Кб, 2 просмотров)
insect_87
Эксперт по компьютерным сетям
4843 / 3926 / 803
Регистрация: 25.12.2012
Сообщений: 16,687
05.01.2017, 13:05 8
в этой схеме ядром выступает уже L3 свитч, есть ошибка одна:
Multilayer Switch0
Цитата Сообщение от Viels Посмотреть сообщение
interface Vlan2
ip address 2.2.2.1 255.255.255.0
!
interface Vlan3
ip address 3.3.3.1 255.255.255.0
!
interface Vlan4
ip address 4.4.4.1 255.255.255.0
адреса должны быть такими уж наверное:
Код
interface Vlan2
 ip address 192.168.22.2 255.255.255.0
interface Vlan3
 ip address 192.168.33.2 255.255.255.0
interface Vlan4
 ip address 192.168.44.2 255.255.255.0
они будут дефолтными шлюзами для конечных хостов в этих VLAN
0
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
05.01.2017, 13:36  [ТС] 9
Дело в том, что там выпуски шли по очереди и в 8 выпуске конфигурировалось с вот такими ip "неправильными" (для удобства).

Multilayer Switch0
Код
interface Vlan2
ip address 2.2.2.1 255.255.255.0
!
interface Vlan3
ip address 3.3.3.1 255.255.255.0
!
interface Vlan4
ip address 4.4.4.1 255.255.255.0
В 9-ом же выпуске он был настроен с другими 192.168....
Я настроил смотря 8-ой и не исправил как в 9-ом. Все собирался.
Не обратил внимания.
Спасибо.

По-моему не:
Код
interface Vlan2
 ip address 192.168.22.2 255.255.255.0
interface Vlan3
 ip address 192.168.33.2 255.255.255.0
interface Vlan4
 ip address 192.168.44.2 255.255.255.0
а:
Код
interface Vlan2
 ip address 192.168.22.1 255.255.255.0
interface Vlan3
 ip address 192.168.33.1 255.255.255.0
interface Vlan4
 ip address 192.168.44.1 255.255.255.0
Исходя из того, что это Default Gateway.

Добавлено через 9 минут
Хотя...
Может и наоборот...

Добавлено через 10 минут
вылезло вот это:
Код
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int vlan 2
Switch(config-if)#ip address 192.168.22.2
% Incomplete command.
Switch(config-if)#ip address 192.168.22.2 255.255.255.0
Switch(config-if)#%IP-4-DUPADDR: Duplicate address 192.168.22.2 on Vlan2, sourced by 0001.4384.B88C

Switch(config-if)#end
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#show run
0
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
05.01.2017, 13:42  [ТС] 10
Настроил так:
Код
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 ip address 192.168.22.2 255.255.255.0
!
interface Vlan3
 ip address 192.168.33.2 255.255.255.0
!
interface Vlan4
 ip address 192.168.44.2 255.255.255.0
!
interface Vlan5
 ip address 192.168.55.2 255.255.255.0
!
ip classless
!
ip flow-export version 9
Пинги не идут.
0
insect_87
Эксперт по компьютерным сетям
4843 / 3926 / 803
Регистрация: 25.12.2012
Сообщений: 16,687
05.01.2017, 13:42 11
Цитата Сообщение от Viels Посмотреть сообщение
По-моему не:
Код
interface Vlan2
ip address 192.168.22.2 255.255.255.0
interface Vlan3
ip address 192.168.33.2 255.255.255.0
interface Vlan4
ip address 192.168.44.2 255.255.255.0
а:
Код
interface Vlan2
ip address 192.168.22.1 255.255.255.0
interface Vlan3
ip address 192.168.33.1 255.255.255.0
interface Vlan4
ip address 192.168.44.1 255.255.255.0
но тогда адреса не должны совпадать с адресами int vlan 2 и int vlan 3 на свитчах 2 и 1 /////////////иначе конфликт
Цитата Сообщение от Viels Посмотреть сообщение
вылезло вот это:
Цитата Сообщение от Viels Посмотреть сообщение
Duplicate address 192.168.22.2 on Vlan2, sourced by 0001.4384.B88C
вот уже конфликт
смотри конфиги других или по маку в этом VLAN ищи

или выкладывай все конфиги или файл проекта в архиве - найдем
0
Viels
0 / 0 / 1
Регистрация: 07.05.2016
Сообщений: 41
05.01.2017, 13:47  [ТС] 12
Выкладываю конфиг-ию в архиве.
0
Вложения
Тип файла: rar example(great vlan).rar (145.4 Кб, 2 просмотров)
insect_87
Эксперт по компьютерным сетям
4843 / 3926 / 803
Регистрация: 25.12.2012
Сообщений: 16,687
05.01.2017, 14:19 13
Лучший ответ Сообщение было отмечено Viels как решение

Решение

вот исправил, адресов на компах не было и шлюзов
1
Вложения
Тип файла: rar example(great vlan).rar (145.3 Кб, 5 просмотров)
05.01.2017, 14:19
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.01.2017, 14:19

Создание VLAN, скрытие одного свича
Всем привет. Имеется HP 1810 - 24G. Хотелось бы скрыть бухгалтерию от посторонних глаз. Как сделать...

Немного непонятно про VLAN на основе протоколов (Protocol-Based VLAN)
Немного непонятно про VLAN на основе протоколов (Protocol-Based VLAN). В таких VLAN так же, как и в...

Маршрутизация между vlan и сетью без vlan
Была у нас раньше сеть(192.168.0.0) без vlanov,предприятие расширялось и со временем пришлось...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru