Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
vladyslavh
1 / 1 / 1
Регистрация: 24.01.2017
Сообщений: 47
1

Лабораторная работа CCNA #FastPass - DHCP and NAT Lab 1 Basics

27.10.2018, 14:46. Просмотров 150. Ответов 4
Метки нет (Все метки)

Здравствуйте форумчане, прошу вашей помощи в сети (проектировалась в Packet tracer), а именно настройки NAT. Сколько не настраивал, не могу понять в чем проблема, не хочет настраиваться как статический так и динамический, прошу прошу поддержки.

Для настройки статического NAT, я использовал:
R2(config)#ip nat inside source static 192.168.3.254 203.0.113.254

Потом указал inside и outside интерфейсы

R2(config)#interface serial 1/1
R2(config-if)#ip nat outside
R2(config-if)#interface fa0/0
R2(config-if)#ip nat inside

Но когда нужно сделать
ISP#ping 203.0.113.254
Пинг не проходит и команда
R2#show ip nat translations

Ничего не показывает, подскажите, где моя ошибка ?

P.S. Прикрепил файл в PacketTracer + настройки конфигурации каждого роутера

Если что, версия PacketTracer 7.2.0.0226
0
Миниатюры
Лабораторная работа CCNA #FastPass - DHCP and NAT Lab 1 Basics  
Вложения
Тип файла: rar 12_DHCP.rar (78.6 Кб, 2 просмотров)
Тип файла: rar Routers_info.rar (1.0 Кб, 3 просмотров)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.10.2018, 14:46
Ответы с готовыми решениями:

DHCP на маршрутизаторе. Лабораторная Работа
Здравствуйте, у меня возникла неточность при выполнение лабораторной работы. Лабораторная работа...

DHCP и NAT, DNS для switch на отельном компьютере
Всем доброго времени суток! Ситуация имеется свитч(не управляемый), по умолчанию, естественно не...

Шлюз на Debian (nat, dhcp)
Доброго времени суток Debian 7, ядро 3.2.0 Четыре интерфейса сетевых: eth0 = wan, eth1-eth4 =...

Работа с dvd-lab pro
почему эта прога не видит фильмы в формате avi ? подскажите как с этой прогой работать? как сделать...

WPF: Не работают библиотеки Open.NAT, Mono.NAT
Доброго времени суток! Хочу витащить свой IP. У меня "серый ip". (кто не в курсе го в Википедию)...

4
Korax
Эксперт по компьютерным сетям
577 / 303 / 71
Регистрация: 20.04.2014
Сообщений: 830
27.10.2018, 21:58 2
На ISP у S1/1 задан адрес с маской /30. 203.0.113.254 в эту сеть не входит и ISP не знает как его достичь. Пакет просто дропается, на R2 ничего не отправляется.

Исправить (2 способа):
1. можно у концов сериал-линка сделать маску покороче. /24 например.
2. добавить статический маршрут на ISP к 203.0.113.254 через s1/1
1
vladyslavh
1 / 1 / 1
Регистрация: 24.01.2017
Сообщений: 47
28.10.2018, 12:07  [ТС] 3
Спасибо за ответ, однако все также не вышло, сделал команду:
ISP(config)#ip route 0.0.0.0 0.0.0.0 203.0.113.254
Следовательно пакет с ISP на R2 доставляется и обратно, но в show ip nat translations показывает лишь один NAT, а в примере задания там список должно показать, и с компов нельзя достучаться по пингу, а мне кажется, что настраивать и там статичный маршрут нет необходимости, или я не прав?
1)Что нужно сделать, что бы показать список NAT?
2) Как достучаться с компов до ISP

Заранее спасибо.
0
Миниатюры
Лабораторная работа CCNA #FastPass - DHCP and NAT Lab 1 Basics  
Korax
Эксперт по компьютерным сетям
577 / 303 / 71
Регистрация: 20.04.2014
Сообщений: 830
28.10.2018, 23:14 4
Маршрут неверный - во все сети (дефолтный), в качестве шлюза - адрес из неизвестной сети.
Нужно ISP(config)#ip route 0.0.0.0 0.0.0.0 203.0.113.225

И да, научитесь пользоваться режимом симуляции - первейшая штука для обучения.
1
vladyslavh
1 / 1 / 1
Регистрация: 24.01.2017
Сообщений: 47
29.10.2018, 08:24  [ТС] 5
Korax, с ISP вышло достучаться до любого устройства, однако NAT статические по идеи (а также по заданию), должен бы показывать что-то вроде

NAT я настраивал так:

Для настройки статического NAT, я использовал:
R2(config)#ip nat inside source static 192.168.3.254 203.0.113.254

Потом указал inside и outside интерфейсы

R2(config)#interface serial 1/1
R2(config-if)#ip nat outside
R2(config-if)#interface fa0/0
R2(config-if)#ip nat inside

R2#show ip nat translations

Динамический так:
R2(config)#ip nat pool Pool4Nat 203.0.113.241 203.0.113.246 netmask 255.255.255.248

• Создать extended ACL определяющий адреса для динамической трансляции

R2(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any
R2(config)#access-list 100 permit ip 192.168.2.0 0.0.0.255 any

• Настроить динамическую трансляцию для локальных IP-адресов, определяемых ACL 100,в реальные IP-адреса из пула Pool4Nat.

R2(config)#ip nat inside source list 100 pool Pool4Nat

• Указать inside интерфейс для данного вида трансляции (outside интерфейс уже был сконфигурирован в предыдущем примере )

R2(config)#interface serial 1/0
R2(config-if)#ip nat inside

• Проверить выполненные настройки командой ping и show ip nat translations

R2#show ip nat translations


R2#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 203.0.113.254:53192.168.3.254:53 203.0.113.226:53 203.0.113.226:53
icmp 203.0.113.254:54192.168.3.254:54 203.0.113.226:54 203.0.113.226:54
icmp 203.0.113.254:55192.168.3.254:55 203.0.113.226:55 203.0.113.226:55
icmp 203.0.113.254:56192.168.3.254:56 203.0.113.226:56 203.0.113.226:56
icmp 203.0.113.254:57192.168.3.254:57 203.0.113.226:57 203.0.113.226:57
--- 203.0.113.254 192.168.3.254 --- ---

А в моем же случае, я вижу
R2#show ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 203.0.113.254 192.168.3.254 --- ---

Если же взять динамику, то должно было быть
icmp 203.0.113.241:53192.168.1.11:53 203.0.113.226:53 203.0.113.226:53
--- 203.0.113.241 192.168.1.11 --- ---
--- 203.0.113.254 192.168.3.254 --- ---

А у меня опять таки здесь без изменения, как быть?
0
29.10.2018, 08:24
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.10.2018, 08:24

Лабораторная работа №5. Работа с файлами и алгоритмы сортировки
1. Написать функцию Load для считывания из текстового файла (например, Workers.txt) информации о...

Работа DHCP, DNS
Доброго времени суток, суть: Начал развивать навыки администрирования, столкнулся с некоторыми...

Linux DHCP + DHCP Relay Win2003(vpn)
Всем привет. У меня проблема. Когда линукс клиент подключается к виндовому VPN серверу, ему...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru