Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/8: Рейтинг темы: голосов - 8, средняя оценка - 4.50
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
1

L3 3560 и Router 2911, DCHP SERVER, ospf

25.11.2018, 15:34. Просмотров 1567. Ответов 17
Метки нет (Все метки)

Кароче суть в чём, у меня должен сервак раздавать на VLANы айпишники, у меня он раздаёт на 10,20,30,40....а на 50 и 60 не хочет....пакет прерывается после L3...Как путь правильно прописать?? и какие там должны быть соединения транк или акцесс??? помогите плиз DCHP relay не полностью сработал..... и потом надо OSPF ещё
0
Миниатюры
L3 3560 и Router 2911, DCHP SERVER, ospf  
Вложения
Тип файла: rar Моя1.rar (115.9 Кб, 1 просмотров)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.11.2018, 15:34
Ответы с готовыми решениями:

Настройка ospf на cisco 3560
Здравствуйте. Решил освоить cisco и только начал изучать ospf, но появился халявный доступ к...

OSPF между двумя роутерами 2911
Никак не могу настроить OSPF между двумя маршрутизаторами 2911(именно он), как это сделать именно в...

Cisco Router + ISA server
Здравствуйте, уважаемые форумчане. Понимаю, что эта тема стара, но я никак не могу найти...

DCHP невыдает IP
Добрый день, попробую как смогу лучше описать суть проблемы. На ноуте с ОС 7*64 настроил точку...

Router-Switcher-Router
Пытаюсь пропинговать с Laptop 0-1(10.0.255.11) роутер Router20(101.14.8.9). Router2 пингуется. ...

17
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
27.11.2018, 00:49 2
Лучший ответ Сообщение было отмечено faggot48 как решение

Решение

А можно задание посмотреть? Потому как путей решения много. Ошибки:

1) Транзитный свич 3 не знает о других VLAN, может они ему не нужны?
2) IP интерфейсов Multilayer Switch0 VLAN 70 и Router1 GigabitEthernet0/0.70 совпадает
3) Router0 и Router2 конфиг не полон
4) Router1 - сервис DHCP не поднят и релэй не настроен.
1
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
27.11.2018, 01:15 3
Лучший ответ Сообщение было отмечено faggot48 как решение

Решение

Красный А - access и IP настроен на интерфейсе.
Зеленый B - Транки. IP на SVI у Multilayer Switch и на сабинтрефейсах Router1

Синяя зона - OSPF соседство, не используем эту подсеть по возможности.
1
Миниатюры
L3 3560 и Router 2911, DCHP SERVER, ospf  
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
27.11.2018, 09:25  [ТС] 4
stroyer, Да, здравствуйте, спасибо за ответ. Это как бы продолжение, но пока там ждал ответа 9999999999999 лет у же сам решил всё...То что вы объяснили я прекрасно понимаю. На роутер 2 и 0 пока пофиг))) У меня не получается пройти вот эту вот дыру где вынаписали "OSPF". Вас можно попросить подробнее описать что сделать на этих двух устройствах? 1) Ну вот допустим поставил я Access порты 2) Мне у L3 свича нужно на порт навесить айпишник, это я понял, но какой VLAN выбирать? Vlan 1 пойдёт? 3) Нужно у L3 VLAN 50 и 60 убирать полностью? 4) У роутера 1 нужно делать кроме сабинтерфейсов физические? 5) У роутера 1 то что справа выход там будет два саба - для 50 и 60 вланов, а то что слева будет тока для 70?? Не будут ли они перекрещиваться с L3?)) ....Видите у меня более глубокие вопросы, я не тупой и понимаю, что мне нужно делать, я не знаю как и что где прописать, в инете нет подобной инфы чтобы СВЯЗАТЬ ДВА УПРАВЛЯЮЩИХ УСТРОЙСТВА. По сути тут можно было оставить L3 и всё...А то это то же самое что взять хлеб, намазать его маслом, положить колбасу и сверху ещё масло....Тупо)))Спасибо за помощь...может вам будет удобнее прописать в циске чтоб я посмотрел или просто навести куда что...Relay прописываться на роутере будет также через ip helper-address?
0
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
27.11.2018, 20:40 5
Цитата Сообщение от faggot48 Посмотреть сообщение
Мне у L3 свича нужно на порт навесить айпишник, это я понял, но какой VLAN выбирать? Vlan 1 пойдёт?
На L3 свиче это будет no switchport, то есть L3 интерфейс принадлежащий к тому VLAN который настроен на L2 Switch 3
Цитата Сообщение от faggot48 Посмотреть сообщение
3) Нужно у L3 VLAN 50 и 60 убирать полностью?
Да, он о них не знает, эти подсети доступны ему через роутинг протокол.
Цитата Сообщение от faggot48 Посмотреть сообщение
4) У роутера 1 нужно делать кроме сабинтерфейсов физические? 5) У роутера 1 то что справа выход там будет два саба - для 50 и 60 вланов, а то что слева будет тока для 70?? Не будут ли они перекрещиваться с L3?
В сторону Switch3 физический, в сторону Switch4 - сабинтерфейсы. 70й VLAN существует только для Сервера Server0
Я видел фото схемы сети, но там не расписаны подсети. Так что если есть текст задания, то было бы неплохо взглянуть. Для самостоятельного изучения сетей Циско поищите "Сети для самых маленьких. LinkMeUp" Там все шикарно разобрано и разжевано.
Если будет время - я сделаю ПКТ файл, но обещать не могу.
0
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
27.11.2018, 21:33  [ТС] 6
stroyer, Нет текста задания, есть только задача а как решать это сам)) да смотрел я миллиард раз. Там НЕТ ПУНКТА НИГДЕЕЕЕЕЕЕ про то как связать ДВА УПРАВЛЯЮЩИХ вланами устройства))) есть либо то либо другое.....

Добавлено через 5 минут
stroyer, там по идее работы на 10 минут....

Добавлено через 2 минуты
stroyer, Всё равно не до конца понятно как их связать, попробу на основе OSPF
0
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
27.11.2018, 22:17 7
Цитата Сообщение от faggot48 Посмотреть сообщение
как связать ДВА УПРАВЛЯЮЩИХ вланами устройства
Говорят: "вопрос - половина ответа". Ваш вопрос некорректен, вот и не удается найти ответ. По-хорошему: L3 устройства, обменивающиеся маршрутами друг с другом должны "соседствовать" на L3 уровне. А вот что использовать для этого: L3 интерфейсы или саб-интерфейсы, это выбор, диктуемый условиями и используемыми устройствами. Особенно, когда в дело вступает отказоустойчивость по физическим линкам или по устройствам.
В данной конкретной задаче, мне кажется, надо делать проще - L3 интерфейсы на Router 0, Router 1 и Multilayer Switch в сторону Switch 3. Посадить их в какую-либо мелкую подсеть, скажем 10.10.10.0/29 и объявить OSPF. Кстати, так как между Router 1 и Router 2 используется статика, то на Router 1 надо не забыть редистрибуцию из статики в OSPF

Вообще задача красивая, комплексная. Часик на то, чтобы разгрести мусор или пару часов, чтобы поднять все с нуля.
0
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 00:55  [ТС] 8
stroyer, Я всё настроил теперь вланы пингуются и айпи раздаёт, вы мне главное с портами помогли) остальную писанину я так и не понял)) Сейчас другой вопрос...как сделать чтобы сети со статикой и OSPF пинговались между собой?? И роутер самый верхний чёт не пингуется (нужно будет ещё NAT настроит на роутере и PAT на серваке)...и всёёёё

Добавлено через 2 минуты
stroyer, а нет я вас обманул у меня роутер верхни пингуется... ДВА ВОПРОСА!!!! 1) как объединить статику с OSPF?? 2) Как настроит НАТ на роутере и ПАТ на серваке

Добавлено через 43 секунды
вот она МОЯ ПРЕЛЕСТЬ, я почти испытал оргазмические ощущения
0
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 00:56  [ТС] 9
схема в циске
0
Вложения
Тип файла: rar 111.rar (115.4 Кб, 1 просмотров)
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 00:59  [ТС] 10
картиночка
0
Миниатюры
L3 3560 и Router 2911, DCHP SERVER, ospf  
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 07:58  [ТС] 11
Вот тут где я красным выделил это мертвая зона трафик не идёт!!! 1) как связать Роутер 5 (ОСПФ) и Роутер 2 (СТАТИКА) 2) Должен ли идти пинг на вланы с Роутера 2? 3) Сеть какую брать у Роутера 2? Там просто и акцесс и транк, может из за этого не идёт? 4) У Роутера 5 Саб интерфейся в сторону вланов, а у Роутера 2 чё писать?
0
Миниатюры
L3 3560 и Router 2911, DCHP SERVER, ospf  
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 10:40  [ТС] 12
эщкерееееееее...если всё через ospf связывать то всё пингуется, но возможно ли связать ospf и статику чтоб они плавно перетекали в друг друга? в том месте где я отметил или надо ещё чёт писаь?

Добавлено через 32 минуты
Всё уже не надо объяснять я понял как связать OSPF и статику...там как бы не скока связь скока пути прописывать ручками.....

Добавлено через 3 минуты
НАТ и ПАТ объясните плез
0
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
28.11.2018, 21:30 13
Интересно было бы посмотреть на решение...
NAT: для R6 нужен сосед снаружи - скажем 1.1.1.1/30 это ISP а 1.1.1.2/30 это fa0/1 на R6, тогда для NAT

Код
interface FastEthernet0/0
 ip address 10.0.10.3 255.255.255.0
 ip nat inside

interface FastEthernet0/1
 ip address 1.1.1.2 255.255.255.252
 ip nat outside

router ospf 1
 log-adjacency-changes
 network 10.0.10.0 0.0.0.255 area 0
 default-information originate

ip nat inside source list 100 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 1.1.1.1
Добавлено через 4 минуты
ОСПФ
Код
R5
router ospf 1
 log-adjacency-changes
 redistribute static subnets 
 network 10.0.9.0 0.0.0.255 area 0
 network 10.0.11.0 0.0.0.255 area 0
 network 10.0.10.0 0.0.0.255 area 0
!
ip classless
ip route 10.0.0.0 255.255.255.0 10.0.13.1 
ip route 10.0.1.0 255.255.255.0 10.0.13.1 
ip route 10.0.3.0 255.255.255.0 10.0.13.1 

R2
ip route 10.0.0.0 255.255.255.0 10.0.3.1 
ip route 10.0.1.0 255.255.255.0 10.0.3.2 
ip route 0.0.0.0 0.0.0.0 10.0.13.2 

R3
ip route 10.0.1.0 255.255.255.0 10.0.3.2 
ip route 0.0.0.0 0.0.0.0 10.0.3.3 

R4
ip route 10.0.0.0 255.255.255.0 10.0.3.1 
ip route 0.0.0.0 0.0.0.0 10.0.3.3
0
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 22:44  [ТС] 14
stroyer, и как проверить что всё это работает?)) это какой нат динамических или статика? а ПАТ?
0
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
28.11.2018, 23:07 15
Добавить на наружном соседе Loopback интерфейсы, никаких маршрутов не писать, попинговать эти адреса изнутри и посмотреть в пакеты.
Маршрут по умолчанию должен прийти по OSPF
Switch3:
Кликните здесь для просмотра всего текста
10.0.0.0/24 is subnetted, 11 subnets
O E2 10.0.0.0 [110/20] via 10.0.10.2, 00:00:05, Vlan1
O E2 10.0.1.0 [110/20] via 10.0.10.2, 00:00:05, Vlan1
O E2 10.0.3.0 [110/20] via 10.0.10.2, 00:00:05, Vlan1
C 10.0.5.0 is directly connected, Vlan10
C 10.0.6.0 is directly connected, Vlan20
C 10.0.7.0 is directly connected, Vlan30
C 10.0.8.0 is directly connected, Vlan40
O 10.0.9.0 [110/2] via 10.0.10.2, 00:00:05, Vlan1
C 10.0.10.0 is directly connected, Vlan1
O 10.0.11.0 [110/2] via 10.0.10.2, 00:00:05, Vlan1
C 10.0.12.0 is directly connected, Vlan70
O*E2 0.0.0.0/0 [110/1] via 10.0.10.3, 00:00:05, Vlan1

Switch#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Какие требования для PAT?
0
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 23:23  [ТС] 16
stroyer, никаких, там он на схеме около сервака нарисован. Все проверил, работает Nat, транслирует, какие строчки непонятные, айпи адреса перерабатываются и после них двоеточие и какие цифры
0
faggot48
0 / 0 / 0
Регистрация: 24.08.2016
Сообщений: 31
28.11.2018, 23:27  [ТС] 17
Мы все так же сделали?))) у меня динамический Nat получился.... Я ввёл точто препод написал, теперь при команде проверке трансляции просто висят строки типа 10.0.12.2:80. И ещё какая то такая же... Нафиг они нужны и че они дают??? При технологии nat там хоть что то меняется
0
Миниатюры
L3 3560 и Router 2911, DCHP SERVER, ospf   L3 3560 и Router 2911, DCHP SERVER, ospf  
stroyer
20 / 14 / 7
Регистрация: 06.11.2018
Сообщений: 76
Записей в блоге: 1
28.11.2018, 23:53 18
Тогда в R6 нужно
Код
ip nat inside source static tcp 10.0.12.2 80 1.1.1.2 80
0
28.11.2018, 23:53
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.11.2018, 23:53

Router:connection From Server Myserv/mydomen...
Router: Connection from server myserv/mydomen not used; Server not in lokal domain. Что это...

Службы DCHP DNS и AD
Добрый день, хотел спросить можно ли как-то настроить службы DCHP DNS и AD на Windows 7 x86...

DCHP сервер на роутере
надо сделать форвардинг порта, но в сети роутер раздает сам айпишники. то есть я ввожу в настройках...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
18
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru