Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.67/12: Рейтинг темы: голосов - 12, средняя оценка - 4.67
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
1

Конфигурирование маршрутизатора

10.12.2018, 12:38. Просмотров 2492. Ответов 20

Добрый день! Схема во вложении. Мне нужно чтобы пинг с каждого компа проходил на маршрутизатор главный, но при этом, чтобы компьютеры между собой не пинговались.
IP-адреса на компах идут так (пример 1 кольцо, самое маленькое внутри). На switch 0 одна сеть 192.168.10.1/29, на switch 1 другая 192.168.10.9/28 и т.д. в 1 первом кольце. Так вот не пойму как настроить маршрутизатор с субинтерфейсами, если у меня на каждом компе vlan индивидуальный?
Может как-то по иному нужно конфигурировать?
0
Миниатюры
Конфигурирование маршрутизатора  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.12.2018, 12:38
Ответы с готовыми решениями:

Конфигурирование VLAN на маршрутизаторе и коммутаторах
Помогите пожалуйста сделать работу, завтра уже сдать нужно.

2 маршрутизатора
Здравствуйте. Есть 2 сети в которой в одной 2 пк и коммутатор она подключена к роутеру 0 и сеть в...

подключение маршрутизатора
Вообщем купил я себе маршрутизатор Wireless-N jwnr2000 на стационарном компе есть инет, провайдер...

Выбор маршрутизатора
Доброго времени суток. Предисловие. Есть главный офис(cisco 2811) к нему подключены...

Выбор маршрутизатора
Всем здрасти! Прошу помощи в выборе маршрутизатора. Схема такая: Интернет приходит по кабелю...

20
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 13:16 2
Цитата Сообщение от tosha56 Посмотреть сообщение
Так вот не пойму как настроить маршрутизатор с субинтерфейсами, если у меня на каждом компе vlan индивидуальный?
Делаете пачку сабинтерфейсов, по одному для каждого влана.
0
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 13:22  [ТС] 3
xeonz, так а какой прописывать адрес сети например для для PC-1? У PC-0 адрес 192.168.10.2, а у PC-1 192.168.10.3. Шлюз у них один 192.168.10.1 и соответственно у всех компьютеров и первого кольца.
0
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 13:27 4
Лучший ответ Сообщение было отмечено tosha56 как решение

Решение

Цитата Сообщение от tosha56 Посмотреть сообщение
Шлюз у них один 192.168.10.1 и соответственно у всех компьютеров и первого кольца.
Не может быть у них один шлюз, если вланы разные. Каждый влан обязан иметь свой уникальный шлюз, если вам нужна единая IP сеть.
0
10.12.2018, 13:27
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 13:28  [ТС] 5
xeonz, т.е. я не правильно задал ip адреса компам и шлюзы соответственно?
0
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 13:30 6
А я не знаю, какие вы задали адреса на остальные ПК в первом кольце.
0
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 13:32  [ТС] 7
xeonz, вот такие ip. Это прям подряд слева направо адреса идут
0
Миниатюры
Конфигурирование маршрутизатора  
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 13:40 8
А маски вы какие собрались ставить?
1
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 13:50  [ТС] 9
xeonz, спасибо большое! Все получилось вроде! Пинг на маршрутизатор идет, а между компами нет.
А еще вопрос. Как можно настроить списки доступа, чтобы изолировать vlan от лишних подключений, ну т.е. у него пинг идёт только на маршрутизатор и не больше? Своего рода защита на сеть.

Добавлено через 1 минуту
xeonz, маски сейчас прописал другие с префиксом 30.

Добавлено через 6 минут
Ошибочка вышла. Между компами идёт пинг. Получается нужны списки доступа? Как их настроить? Вот в них плохо разбираюсь.
0
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 14:43 10
Ну вы бы все таки написали сюда, что вы там настроили.
0
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 14:50  [ТС] 11
xeonz, приложил схему. Распишите пожалуйста, как мне настроить списки доступа, чтобы пинг шел только на маршрутизатор с каждого компа, а с свою очередь компы были изолированы друг от друга. У меня пока только на первое кольцо настроена маршрутизация.
0
Вложения
Тип файла: rar v1.0.rar (88.2 Кб, 3 просмотров)
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 15:06 12
У меня нет пакет трейсера, не могу посмотреть
0
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 15:50  [ТС] 13
xeonz, на роутере
C++
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
Router#sh run
Building configuration...
 
Current configuration : 1757 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524OK70
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.252
!
interface GigabitEthernet0/0.11
 encapsulation dot1Q 11
 ip address 192.168.11.2 255.255.255.252
!
interface GigabitEthernet0/0.12
 encapsulation dot1Q 12
 ip address 192.168.12.1 255.255.255.248
!
interface GigabitEthernet0/0.13
 encapsulation dot1Q 13
 ip address 192.168.13.1 255.255.255.248
!
interface GigabitEthernet0/0.14
 encapsulation dot1Q 14
 ip address 192.168.14.1 255.255.255.248
!
interface GigabitEthernet0/0.15
 encapsulation dot1Q 15
 ip address 192.168.15.1 255.255.255.248
!
interface GigabitEthernet0/0.16
 encapsulation dot1Q 16
 ip address 192.168.16.1 255.255.255.248
!
interface GigabitEthernet0/0.17
 encapsulation dot1Q 17
 ip address 192.168.17.1 255.255.255.248
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/2/0
!
interface FastEthernet0/2/1
!
interface FastEthernet0/2/2
!
interface FastEthernet0/2/3
!
interface Serial0/3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line 0/1/0 0/1/7
 login
!
line vty 0 4
 login
!
!
!
end
Добавлено через 11 минут
xeonz, на свитчах такие аналогичные
C++
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
Switch#sh run
Building configuration...
 
Current configuration : 1191 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 11
 switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end
 
 
Switch#
Добавлено через 29 минут
xeonz, + на центральном свитче
C++
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
Switch#sh run
Building configuration...
 
Current configuration : 1308 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
 
 
Switch#
0
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 16:18 14
Лучший ответ Сообщение было отмечено tosha56 как решение

Решение

А на ПК что?

по идее что бы разрешить пинги только на маршрутизатор, можно сделать вот так:
Код
ip access-list extended acl01
 permit ip any host 192.168.10.1
 permit ip any host 192.168.11.1
 permit ip any host 192.168.12.1
....
 deny ip any any

interface GigabitEthernet0/0.10
 ip access-group acl01 in
interface GigabitEthernet0/0.11
 ip access-group acl01 in
interface GigabitEthernet0/0.12
 ip access-group acl01 in
....
0
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 16:24  [ТС] 15
xeonz, на ПК ip такие
192.168.10.2
192.168.11.2
192.168.12.2
192.168.13.2
192.168.14.2
И т.д.
Хорошо. Попробую!
Это получается расширенный список. Почему входящий трафик блокировать надо, можешь объяснить?
0
xeonz
705 / 257 / 36
Регистрация: 16.05.2014
Сообщений: 2,046
10.12.2018, 16:29 16
Лучший ответ Сообщение было отмечено tosha56 как решение

Решение

Можно и исходящий, в рамках вашей задачи без разницы какой блокировать. Входящий блокируем для блокировки запроса. Если блокировать исходящий, то запрос придет, но заблокируется ответ. Результат один - пингов не будет. В общем случае если ничего не мешает, блокируют именно запросы, а не ответы.

Добавлено через 1 минуту
Цитата Сообщение от tosha56 Посмотреть сообщение
Это получается расширенный список.
Да, потому что если дальше вам придется как то подкрутить этот список, то на стандартном вы это не всегда сможете сделать. И придется переделывать на расширенный. А так вам не надо будет переделывать тип списка, просто добавите то, что будет нужно и все.
0
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 17:14  [ТС] 17
xeonz, спасибо большое! Очень помог!
0
stroyer
76 / 56 / 26
Регистрация: 06.11.2018
Сообщений: 327
Записей в блоге: 1
10.12.2018, 20:59 18
Я бы по физическим подключениям советовал бы такую схему:
И, имхо, так как это для поселка и требуется разделение клиентов, то я бы создавал отдельные VLAN на дом, со вторым октетом, скажем "номер дома" и DHCP сервисом на ядре. Чтобы клиент к своему свич-порту мог подключить любое количество своих устройств не пересекаясь с соседями.
0
Миниатюры
Конфигурирование маршрутизатора  
tosha56
0 / 0 / 0
Регистрация: 26.10.2015
Сообщений: 32
10.12.2018, 21:02  [ТС] 19
stroyer, мне нужно именно кольцо. По диплому так
0
stroyer
76 / 56 / 26
Регистрация: 06.11.2018
Сообщений: 327
Записей в блоге: 1
10.12.2018, 21:33 20
А как именно звучит задание?
"С использованием кольцевой топологии" или "используя топологию кольцо" ?
0
10.12.2018, 21:33
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2018, 21:33

Настройка маршрутизатора
Доброго времени суток! возникла проблема по настройке сети состоящей из трех роутеров на которых...

Выбор маршрутизатора
Помогите выбрать маршрутизатор, соответствующий следующим требованиям: GUI-интерфейс для...

Выбор маршрутизатора
Прошу помощи в выборе маршрутизатора с wi-fi для парка до 50 машин. не мыльницу, но и не за...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.