Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
guard_2007
0 / 0 / 0
Регистрация: 07.12.2014
Сообщений: 118
1

Не проходит пинг из одного vlan в другой

22.01.2019, 23:43. Просмотров 304. Ответов 5

Еще раз добрый вечер уважаемые форумчани. Получил задание на курсовой проект разработать отказоустойчивую локальную сеть с выходом в wan в которой имеется 8 отделов, с 4,5 отдела имеется выход в WAN с остальных доступ закрыт. схема реализации весьма условна, тк делается все на учебном реальном оборудовании. По заданию из некоторых отделов нельзя послать пинг в другой реализовано это списками доступов. Столнулся с тем что по заданию все мои возможные варианты пингов совпали кроме одного. Я делаю пинг из 5 vlana в 9 но пинг доходит только до шлюза, дальше на хост пинг почему то не проходит. Проверил асл все вроде хорошо перепроверил весь конфиг. Пожалуйста помогите найти ошибку в конфиге. Прилагаю свой адресный план, и схему доступов из отдела в отдел. Заранее огромное спасибо и извиняюсь за глупые вопросы.

Конфиги

SW1
Lisp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
interface GigabitEthernet0/1
 switchport access vlan 2
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport access vlan 3
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/3
 switchport access vlan 4
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/4
 switchport access vlan 5
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
 
!
interface GigabitEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 12
 switchport trunk allowed vlan 2-5,12
 switchport mode trunk
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 12
 switchport trunk allowed vlan 2-5,12
 switchport mode trunk
SW2
Lisp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
interface GigabitEthernet0/1
 switchport access vlan 6
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport access vlan 7
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/3
 switchport access vlan 8
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/4
 switchport access vlan 9
 switchport trunk native vlan 12
 switchport mode access
 spanning-tree portfast
!
 
interface GigabitEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 12
 switchport trunk allowed vlan 6-9,12
 switchport mode trunk
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 12
 switchport trunk allowed vlan 6-9,12
 switchport mode trunk

OSPF
Lisp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
ip dhcp excluded-address 192.168.3.1
ip dhcp excluded-address 192.168.3.2
ip dhcp excluded-address 192.168.5.1
ip dhcp excluded-address 192.168.5.2
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool vlan5
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.2
!
ip dhcp pool vlan6
 network 192.168.3.0 255.255.255.128
 default-router 192.168.3.2
!
ip dhcp pool vlan4
 network 192.168.5.0 255.255.255.192
 default-router 192.168.5.1
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FCZ172560EN
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.9.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 2
 ip address 192.168.3.130 255.255.255.128
 ip access-group 112 out
!
interface GigabitEthernet0/0.3
 encapsulation dot1Q 3
 ip address 192.168.4.1 255.255.255.128
 ip access-group 112 out
!
interface GigabitEthernet0/0.4
 encapsulation dot1Q 4
 ip address 192.168.5.1 255.255.255.192
 ip access-group 112 out
!
interface GigabitEthernet0/0.5
 encapsulation dot1Q 5
 ip address 192.168.1.1 255.255.255.0
 ip access-group 112 out
 standby 3 ip 192.168.1.2
 standby 3 priority 105
 standby 3 preempt
!
interface GigabitEthernet0/1
 ip address 192.168.8.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.6
 encapsulation dot1Q 6
 ip address 192.168.3.1 255.255.255.128
 ip access-group 112 out
 standby 2 ip 192.168.3.2
 standby 2 priority 105
 standby 2 preempt
!
interface GigabitEthernet0/2
 ip address 10.0.0.1 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 network 10.0.0.0 0.0.0.3 area 0
 network 12.0.0.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.3.128 0.0.0.127 area 0
 network 192.168.4.0 0.0.0.127 area 0
 network 192.168.5.0 0.0.0.63 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
access-list 112 permit udp any any eq bootpc
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.5.0 0.0.0.63
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.1.0 0.0.0.255
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.3.0 0.0.0.127
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.4.128 0.0.0.127
access-list 112 permit ip 192.168.5.0 0.0.0.63 192.168.4.0 0.0.0.127
access-list 112 permit ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.127
access-list 112 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 112 permit ip 192.168.1.0 0.0.0.255 12.0.0.0 0.0.0.255
access-list 112 permit ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255
access-list 112 permit ip 192.168.3.0 0.0.0.127 192.168.5.0 0.0.0.63
access-list 112 permit ip 192.168.3.0 0.0.0.127 12.0.0.0 0.0.0.255
access-list 112 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 112 permit ip 192.168.4.128 0.0.0.127 192.168.4.0 0.0.0.127
access-list 112 permit ip 192.168.3.0 0.0.0.127 192.168.4.0 0.0.0.127
access-list 112 deny   ip any any
RIP

Lisp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
ip dhcp excluded-address 192.168.3.127
ip dhcp excluded-address 192.168.3.2
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.4
!
ip dhcp pool vlan6
 network 192.168.3.0 255.255.255.128
 default-router 192.168.3.2
!
ip dhcp pool vlan5
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.2
!
ip dhcp pool vlan4
 network 192.168.5.0 255.255.255.192
 default-router 192.168.5.1
!
!
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
voice-card 0
!
!
!
!
!
!
!
license udi pid CISCO2921/K9 sn FCZ171860MF
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.5
 encapsulation dot1Q 5
 ip address 192.168.1.1 255.255.255.0
 ip access-group 112 out
 standby 3 ip 192.168.1.2
 standby 3 preempt
!
interface GigabitEthernet0/1
 ip address 192.168.11.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.6
 encapsulation dot1Q 6
 ip address 192.168.3.1 255.255.255.128
 ip access-group 112 out
 standby 2 ip 192.168.3.2
 standby 2 preempt
!
interface GigabitEthernet0/1.7
 encapsulation dot1Q 7
 ip address 192.168.2.2 255.255.255.0
 ip access-group 112 out
!
interface GigabitEthernet0/1.8
 encapsulation dot1Q 8
 ip address 192.168.4.130 255.255.255.128
 ip access-group 112 out
!
interface GigabitEthernet0/1.9
 encapsulation dot1Q 9
 ip address 192.168.0.2 255.255.255.0
 ip access-group 112 out
!
interface GigabitEthernet0/2
 ip address 11.0.0.1 255.255.255.252
 --More--
Jan 22 13:33:53.302: %IP-4-DUPADDR: Duplicate address 192.168.1.1 on GigabitEthernet0/0.5, sourced by bc16 duplex auto
 speed auto
!
router rip
 version 2
 network 11.0.0.0
 network 192.168.0.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
access-list 112 permit udp any any eq bootpc
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.5.0 0.0.0.63
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.1.0 0.0.0.255
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.3.0 0.0.0.127
access-list 112 permit ip 192.168.4.0 0.0.0.127 192.168.4.128 0.0.0.127
access-list 112 permit ip 192.168.5.0 0.0.0.63 192.168.4.0 0.0.0.127
access-list 112 permit ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.127
access-list 112 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 112 permit ip 192.168.1.0 0.0.0.255 12.0.0.0 0.0.0.255
access-list 112 permit ip 192.168.3.0 0.0.0.127 192.168.5.0 0.0.0.63
access-list 112 permit ip 192.168.3.0 0.0.0.127 12.0.0.0 0.0.0.255
access-list 112 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 112 permit ip 192.168.4.128 0.0.0.127 192.168.4.0 0.0.0.127
access-list 112 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 112 deny   ip any any
MAIN
Lisp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
interface GigabitEthernet0/0
 ip address 10.0.0.2 255.255.255.252
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 11.0.0.2 255.255.255.252
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 12.0.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
router ospf 1
 redistribute static
 redistribute rip subnets
 network 10.0.0.0 0.0.0.3 area 0
 network 12.0.0.0 0.0.0.3 area 0
 default-information originate
!
router rip
 version 2
 redistribute static metric 1
 redistribute ospf 1 metric 1
 network 11.0.0.0
 network 12.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat pool NAT-POOL-OVERLOAD 209.165.200.226 209.165.200.240 netmask 255.255.255.0
ip nat inside source list 100 pool NAT-POOL-OVERLOAD overload
ip route 0.0.0.0 0.0.0.0 12.0.0.2
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
access-list 100 permit ip 192.168.3.0 0.0.0.127 any
access-list 100 permit ip 10.0.0.0 0.0.0.255 any
access-list 100 permit ip 11.0.0.0 0.0.0.255 any
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.01.2019, 23:43
Ответы с готовыми решениями:

Переброс траффика из одного Vlan в другой Vlan
Подскажите добрые люди умеют ли коммутаторы 2960S, 3750 перекидывать трафик из одного vlan в другой...

Получение доступа из одного VLAN в другой
Не получается получить доступ из одного VLAN в другой. Транковку вродже настроил и адреса на...

Не получается получить доступ из одного VLAN в другой
У меня не получается получить доступ из одного VLAN в другой. Из 10 в 20-ый и наоборот. Подскажите...

Доступ из одного vlan к электронному ключу в другом vlan
Возникла ситуация. При переводе компьютера в отдельный vlan программа 1С он перестала видеть...

Не проходит пинг
Самая простая схема без вланов, 6 сегментов, ip прописаны, транки настроены. Не проходит пинг между...

5
guard_2007
0 / 0 / 0
Регистрация: 07.12.2014
Сообщений: 118
22.01.2019, 23:49  [ТС] 2
Картинки задачи
0
Миниатюры
Не проходит пинг из одного vlan в другой   Не проходит пинг из одного vlan в другой   Не проходит пинг из одного vlan в другой  

stroyer
24 / 17 / 8
Регистрация: 06.11.2018
Сообщений: 130
Записей в блоге: 1
23.01.2019, 00:26 3
Честно говоря - лень строить ПТ, по этому вопросы:
Если ACL убрать то пинги ходят? В обе стороны?
0
guard_2007
0 / 0 / 0
Регистрация: 07.12.2014
Сообщений: 118
23.01.2019, 11:07  [ТС] 4
Да пинги ходят в обе стороны, если снести acl

Добавлено через 24 секунды
stroyer,

Добавлено через 1 минуту
Lisp
1
access-list 112 permit ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255

По данной строке у меня должен был разрешен пинг с 4 отдела до 8-го

Добавлено через 4 минуты
Накатив только эту строку из acl и не применяя других, ситуация такая же. Может я с маской где то напутал вот понять не могу никак?(
0
guard_2007
0 / 0 / 0
Регистрация: 07.12.2014
Сообщений: 118
23.01.2019, 12:24  [ТС] 5
Вот что показывает пинг
0
Миниатюры
Не проходит пинг из одного vlan в другой  
guard_2007
0 / 0 / 0
Регистрация: 07.12.2014
Сообщений: 118
23.01.2019, 19:14  [ТС] 6
Собрал пакет в ПКТ все тоже самое, очень прошу помочь
0
Вложения
Тип файла: rar no work.rar (47.9 Кб, 1 просмотров)
23.01.2019, 19:14
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.01.2019, 19:14

Не проходит пинг на второй маршрутизатор
прикрепила файл.посмотрите пожалуйста ,почему пинг не проходит с компа на роутер ,где прописан...

Статическая маршрутизация. Не проходит пинг
Доброго времени суток, появилась проблема с пингованием. Прикрепляю самую топологию. Суть...

CISCO, в Gateway, через WAN, не проходит пинг в обе стороны
Помогите с такой проблемой: При переходе в режим роутинга Gateway, при подключении через WAN,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru