Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
ArturkaG
0 / 0 / 0
Регистрация: 02.05.2016
Сообщений: 5
1

Проблемы с конфигурацией DHCP на маршрутизаторе Cisco (VLANs)

13.03.2019, 22:34. Просмотров 124. Ответов 2

Делаю лабку на eve-ng.

Топология (Активная часть)
https://imageban.ru/show/2019/03/13/...18b42b18bb/jpg
Круто у вас ссылки на imgur не пропускаются, есть повод для беспокойства?

Задача получить DHCP на PC1 (CentOS7), в сети настроены VLAN
VLAN100 - MGT 172.16.10.0/24
VLAN200 - DATA 172.16.20.0/30
VLAN300 - OFFICE 30.30.30.0/24
Trunk's созданы и работают через VTP.

На HQ1 (Router) настроил DHCP pool с Network 30.30.30.0/24
На PC1 пытаюсь получить DHCP, и вижу (WireShark) что HQ1 получает DHCP Discovery, но не отвечает.
Вывод команды (sh ip dhcp server statistics) говорит о том же:
Кликните здесь для просмотра всего текста
Код
Memory usage         23511
Address pools        1
Database agents      0
Automatic bindings   0
Manual bindings      0
Expired bindings     0
Malformed messages   0
Secure arp entries   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         28
DHCPREQUEST          18
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            0
DHCPACK              0
DHCPNAK              0

Проблема точно не в топологии, т.к если я создаю DHCP pool с Network 192.168.254.0/24 (Подсеть из физического интерфейса), то всё работает, но не работает с саб-интерфейсом (30.30.30.0/24)
Конфиг роутера:
Кликните здесь для просмотра всего текста

Код
Current configuration : 1826 bytes
!
! Last configuration change at 21:04:49 EET Wed Mar 13 2019
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ1
!
boot-start-marker
boot-end-marker
!
!
enable password cisco
!
no aaa new-model
!
!
!
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone EET 2 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
ip dhcp pool OFFICE
 network 30.30.30.0 255.255.255.0
 default-router 30.30.30.1
!
!
!
ip domain name wsr2018.ru
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
!
!
username wsr2018 privilege 15 secret 5 $1$ry02$F//7pj2xXnRmQ/NkTbI4I0
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 ip address 192.168.254.1 255.255.255.0
!
interface Ethernet0/1.100
 encapsulation dot1Q 100
 ip address 172.16.10.1 255.255.255.0
!
interface Ethernet0/1.200
 encapsulation dot1Q 200
 ip address 172.16.20.1 255.255.255.252
!
interface Ethernet0/1.300
 encapsulation dot1Q 300
 ip address 30.30.30.1 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
 no cdp enable
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 no cdp enable
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
 transport input telnet
!
!
end

Конфиги свичей:
SW1
Кликните здесь для просмотра всего текста

Код
Current configuration : 2242 bytes
!
! Last configuration change at 19:48:53 EET Wed Mar 13 2019
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
enable password cisco
!
username wsr2018 privilege 15 secret 5 $1$4DVT$r.Ghf8lXhNNi4ggANKaC41
no aaa new-model
clock timezone EET 2 0
!
!
!
!
!
!
!
!
ip domain-name wsr2018.ru
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 100,200 priority 20480
spanning-tree vlan 300 priority 24576
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
!
interface Ethernet0/0
 switchport access vlan 200
 switchport mode access
 switchport nonegotiate
 spanning-tree portfast edge
 spanning-tree bpduguard enable
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
 spanning-tree guard root
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet1/0
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
 channel-group 1 mode active
 spanning-tree guard root
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
 channel-group 1 mode active
 spanning-tree guard root
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
 channel-group 1 mode active
 spanning-tree guard root
!
interface Ethernet2/0
!
interface Ethernet2/1
!
interface Ethernet2/2
!
interface Ethernet2/3
!
interface Ethernet3/0
!
interface Ethernet3/1
!
interface Ethernet3/2
!
interface Ethernet3/3
!
interface Ethernet4/0
!
interface Ethernet4/1
!
interface Ethernet4/2
!
interface Ethernet4/3
!
interface Ethernet5/0
!
interface Ethernet5/1
!
interface Ethernet5/2
!
interface Ethernet5/3
!
interface Vlan1
 ip address 192.168.254.10 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
 transport input telnet
!
!
end

SW2
Кликните здесь для просмотра всего текста

Код
Current configuration : 2360 bytes
!
! Last configuration change at 19:01:03 EET Wed Mar 13 2019
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
enable password cisco
!
username wsr2018 privilege 15 secret 5 $1$TYY/$PGCG1WaJhEaOZYsG9Edua0
no aaa new-model
clock timezone EET 2 0
!
!
!
!
!
!
!
!
ip domain-name wsr2018.ru
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 100,200,300 priority 28672
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface Ethernet0/0
 switchport access vlan 300
 switchport mode access
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-group 2 mode desirable
 spanning-tree guard root
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-group 2 mode desirable
 spanning-tree guard root
!
interface Ethernet1/0
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 channel-group 1 mode passive
 spanning-tree guard root
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 channel-group 1 mode passive
 spanning-tree guard root
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 channel-group 1 mode passive
 spanning-tree guard root
!
interface Ethernet2/0
 switchport access vlan 300
 switchport mode access
 switchport nonegotiate
!
interface Ethernet2/1
!
interface Ethernet2/2
!
interface Ethernet2/3
!
interface Ethernet3/0
!
interface Ethernet3/1
!
interface Ethernet3/2
!
interface Ethernet3/3
!
interface Ethernet4/0
!
interface Ethernet4/1
!
interface Ethernet4/2
!
interface Ethernet4/3
!
interface Ethernet5/0
!
interface Ethernet5/1
!
interface Ethernet5/2
!
interface Ethernet5/3
!
interface Vlan1
 ip address 192.168.254.20 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
 transport input telnet
!
!
end

SW3
Кликните здесь для просмотра всего текста

Код
Current configuration : 1864 bytes
!
! Last configuration change at 19:01:03 EET Wed Mar 13 2019
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
enable password cisco
!
username wsr2018 privilege 15 secret 5 $1$Wzgn$cxIT6anHZ0g8gmX1YCerq.
no aaa new-model
clock timezone EET 2 0
!
!
!
!
!
!
!
!
ip domain-name wsr2018.ru
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface Ethernet0/0
 switchport mode access
 switchport nonegotiate
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-group 2 mode auto
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 channel-group 2 mode auto
!
interface Ethernet1/0
!
interface Ethernet1/1
!
interface Ethernet1/2
!
interface Ethernet1/3
!
interface Ethernet2/0
!
interface Ethernet2/1
!
interface Ethernet2/2
!
interface Ethernet2/3
!
interface Ethernet3/0
!
interface Ethernet3/1
!
interface Ethernet3/2
!
interface Ethernet3/3
!
interface Ethernet4/0
!
interface Ethernet4/1
!
interface Ethernet4/2
!
interface Ethernet4/3
!
interface Ethernet5/0
!
interface Ethernet5/1
!
interface Ethernet5/2
!
interface Ethernet5/3
!
interface Vlan1
 ip address 192.168.254.30 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
 transport input telnet
!
!
end

По сути работая в EVE, это всё равно, что работать с реальным оборудованием (Я использую Cisco IOL), просто у одногруппников всё работает в Cisco Packet Tracer, а у меня в EVE нет, хотя конфигурация одинаковая. Видимо есть нюансы которые в Packet Tracer не учитываются... Ну я просто не знаю в чем еще может быть проблема, не судите строго...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.03.2019, 22:34
Ответы с готовыми решениями:

Cisco 881-k9 Проблемы с работой WAN порта, как клиент DHCP
Доброго времени суток! К сожалению, я новичок в работе с Cisco. Пришел на этот форум за помощью...

DHCP на маршрутизаторе. Лабораторная Работа
Здравствуйте, у меня возникла неточность при выполнение лабораторной работы. Лабораторная работа...

Подключение слота HWIC-2A/S на маршрутизаторе Cisco 2811
Всем привет! Нужна помощь, настраивала схему на реальном оборудовании, столкнулась с проблемой при...

Как создать интерфейс serial на маршрутизаторе 1841 эмулятора Cisco PT?
Друзья! вот ресурс, там сказано, какие команды нужно выполнять, чтобы поднять такой интерфейс,...

Cisco CUCME в GNS3. На каком маршрутизаторе и с какой прошивкой можно это организовать?
Собираюсь запустить CUCME на какомнибудь цисковском маршрутизаторе для практики, кто уже делал...

2
Korax
Эксперт по компьютерным сетям
597 / 319 / 76
Регистрация: 20.04.2014
Сообщений: 869
14.03.2019, 09:21 2
SW1 E2/0 не настроен
0
ArturkaG
0 / 0 / 0
Регистрация: 02.05.2016
Сообщений: 5
14.03.2019, 11:25  [ТС] 3
Да вы правы, совсем упустил из виду, но тем не менее ситуация остаётся прежней, я что-то снова упускаю?

В SW1 добавил следующие настройки:
Кликните здесь для просмотра всего текста

Код
!
interface Ethernet2/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
!

sh int switchport
Кликните здесь для просмотра всего текста

Код
Name: Et2/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL


Добавлено через 1 час 51 минуту
Проблема решилась, нужно было донастроить access vlan 300 на SW3 и Trunk на SW1.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.03.2019, 11:25

Cisco и DHCP Avaya
Как настроить dhcp для avaya на cisco? на данный момент dhcp вертится на линуксе, увидел там опцию...

Проблемы с конфигурацией DHCP
Здравствуйте, я новичок в работе с Linux. Есть машинка gw (CentOS 7), которая является шлюзом для...

Проблемы с типовой конфигурацией 1С 8.1
Добрый день. Подскажите, пожалуйста,что делать в сложившейся ситуации: есть типовая конфигурация...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru