Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
silverhov
0 / 0 / 0
Регистрация: 22.05.2019
Сообщений: 2
1

Shaping и приоритетные очереди

22.05.2019, 16:42. Просмотров 266. Ответов 3
Метки нет (Все метки)

Здравствуйте, подскажите пожалуйста, не могу понять что делаю не так. На маршрутизаторе необходимо 2811 установить приоритетные очереди и на выходной интерфейс повесить rate-limit. Проблема в том, что вместе эти два механизма не работают, а работает только RL, как будуто установлен обычный FIFO. Как только убираю RL, PQ работает. Как подружить их? Конфиг прилагаю
Кликните здесь для просмотра всего текста

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface FastEthernet00
ip address 192.168.1.1 255.255.255.0
duplex auto
speed 100
!
interface FastEthernet01
ip address 192.168.2.1 255.255.255.0
rate-limit output 1048000 196608 393216 conform-action transmit exceed-action drop
duplex auto
speed 100
priority-group 1
!
!
!
no ip http server
no ip http secure-server
!
access-list 101 permit ip any any precedence critical
access-list 102 permit ip any any precedence priority
access-list 103 permit ip any any precedence routine
priority-list 1 protocol ip high list 101
priority-list 1 protocol ip medium list 102
priority-list 1 protocol ip low list 103
priority-list 1 queue-limit 32767 20000 20000 20000
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000

!
webvpn cef
!
end
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.05.2019, 16:42
Ответы с готовыми решениями:

Сломался Traffic Shaping.
Стояла Traffic Shaping v-512. Обновил до 6.00, после чего в настройки могу зайти только на ...

Регулятор интернета (traffic-shaping)
нужно создать программу, которая устанавливается на компьютере пользователя и может ограничивать...

Приоритетные знания для джуниора
Добрый день. Устроился недавно на свою первую работу в качестве веб программиста. Работается...

Приоритетные списки. Не удается преобразовать типы
Доброго времени суток! Создаю пример реализации приоритетного списка, созникла следующая проблема...

Выведите содержимое очереди на экран и посчитайте количество элементов образованной очереди
Дан текстовый файл. Проанализировав в программе содержимое файла, выберите из него имена и занесите...

3
xeonz
650 / 244 / 35
Регистрация: 16.05.2014
Сообщений: 1,930
23.05.2019, 08:38 2
Замените все это на CBWFQ, в нем все это (шейпинг, полисинг и приоритезацию) можно использовать вместе.
0
silverhov
0 / 0 / 0
Регистрация: 22.05.2019
Сообщений: 2
23.05.2019, 12:48  [ТС] 3
Так вот работа подразумевает исследования именно алгоритма PQ. Странно, что чем бы я не ограничивал, оно упорно не работает. Функционирует только в том случае, если физически ограничил интерфейс
0
xeonz
650 / 244 / 35
Регистрация: 16.05.2014
Сообщений: 1,930
23.05.2019, 12:54 4
PQ входит в CBWFQ. Работа запрещает исследовать PQ внутри CBWFQ?
0
23.05.2019, 12:54
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.05.2019, 12:54

Очереди. С помощью первой очереди упорядочить числа во второй и третьей очередях
Даны три очереди. Одна пуста а в двух других находятся натуральные числа. С помощью первой очереди...

Обеспечить операции ведения стека из начала очереди, дополнения и продвижения очереди
Доброе времени суток. Давно читаю ваш форум, и всегда находил ответы на вопросы, но на вопрос...

Очереди. Каким образом считать две очереди из одного текстового файла?
Здравстуйте. В задании первый пункт состоит в том, что нужно сформировать две очереди по n...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru