Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
Deyckstra
0 / 0 / 0
Регистрация: 17.05.2016
Сообщений: 7
1

Настройка IPv6

04.06.2019, 17:21. Просмотров 538. Ответов 9

Добрый день!

Столкнулся с тем, что на роутере не могу настроить IPv6 на WAN интерфейсе. IPv4 работает нормально.
Провайдер Domru.ru, IPv6 поддерживает, в личном кабинете поддержка IPv6 включена. На все мои письма в саппорт были ответы либо ваш роутер не поддерживает IPv6, купите нормальный роутер и настройте по нашим инструкциям, либо настраивайте в соответствии с технологией DHPCv6 Prefix Delegation.


show version

Cisco IOS Software, C890 Software (C890-UNIVERSALK9-M), Version 15.2(4)M4, RELEASE SOFTWARE (fc2)
9 FastEthernet interfaces
1 Gigabit Ethernet interface
1 Serial interface
1 terminal line
1 Virtual Private Network (VPN) Module
256K bytes of non-volatile configuration memory.
250880K bytes of ATA CompactFlash (Read/Write)
License UDI:
-----------------
PID
----------------
CISCO891-K9


show run

interface GigabitEthernet0
no ip address
duplex auto
speed auto
ipv6 enable
pppoe enable group global
pppoe-client dial-pool-number 1

interface Dialer1
description WAN_ISP
mtu 1400
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1360
dialer pool 1
dialer-group 1
ipv6 address dhcp
ipv6 enable
ipv6 dhcp client pd ISP
ppp authentication chap callin
ppp chap hostname ***
ppp chap password ***
ppp ipcp dns request


show ipv6 interface gig0

GigabitEthernet0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::26E9:B3FF:FE74:61A3
No Virtual link-local address(es):
No global unicast address is configured
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF74:61A3
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use stateless autoconfig for addresses.


show ipv6 interface dial1

Dialer1 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::26E9:B3FF:FE74:618B
No Virtual link-local address(es):
Description: WAN_ISP
No global unicast address is configured
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF74:618B
MTU is 1400 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
Input features: Common Flow Table Stile classification Dialer i/f override IPv6 TCP Adjust MSS
Output features: Common Flow Table Stile Classification IPv6 TCP Adjust MSS Dialer idle reset
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND RAs are suppressed (periodic)
Hosts use stateless autoconfig for addresses.


Перепробовал кучу разных настроек, всё бестолку. Пробовал получить IPv6 на Wi-Fi роутере tplink archer c7 v1, там ipv6 поднялся. Прошу помочь.

Добавлено через 9 минут
Забыл указать часть конфига:

ipv6 unicast-routing
ipv6 cef
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.06.2019, 17:21
Ответы с готовыми решениями:

Настройка DHCP сервера ipv6
Здравствуйте! Начал изучать Ipv6, всё хорошо, настроил DNS,HTTP сервера, но вот с DHCP вышла...

Настройка cisco series 800 для ipv6
Добрый вечер, Пытаюсь настроить маршрутизацию ipv6 на рутере cisco и получаю непонятное...

DHCP IPv6, тунелирование IPv6 в Cisco
Здравствуйте! у меня диплом на тему:маршрутизация IPv6: DHCP,тунелирование. Мне интересна эта тема...

ipv6
собираюсь поднять ipv6 по принцепу работы протокола вроде все понятно и ничего сложно нет,...

Ipv6
Поясните пожалуйста какие надо назначать адреса ipv6 хостам, а какие роутерам, вроде и в сети...

9
Robocop01
35 / 29 / 12
Регистрация: 30.09.2017
Сообщений: 100
04.06.2019, 21:01 2
попробуйте на интерфейсе wan (GigabitEthernet0) прописать свой адрес, например:
intrface GigabitEthernet0
router(config-if)# ipv6 address 2001:128:abab:aa1a::1/64
0
Deyckstra
0 / 0 / 0
Регистрация: 17.05.2016
Сообщений: 7
05.06.2019, 08:34  [ТС] 3
Я не знаю какой у меня адрес, он выдается с помощью DHCP из пула 2а02. И тогда уж если настраивать его статически, то на интерфейсе dialer1, а не на gigabit. В любом случае ни то, ни то не сработало.

1)
show run

ipv6 access-list kek
permit ipv6 any any
!
interface GigabitEthernet0
no ip address
ip access-group kek in
duplex auto
speed auto
ipv6 address 2A02:128:ABAB:AA1A::1/64
ipv6 enable
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
description WAN_ISP
mtu 1400
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1360
dialer pool 1
dialer-group 1
ipv6 enable
ppp authentication chap callin
ppp chap hostname ***
ppp chap password ***
ppp ipcp dns request

router#show access-lists kek
IPv6 access list kek
permit ipv6 any any (18 matches) sequence 10
router#ping
Protocol [ip]: ipv6
Target IPv6 address: google.com
Translating "google.com"...domain server (109.195.144.4) [OK]

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Sweep range of sizes? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2A00:1450:4010:C0A::8B, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
router#show access-lists kek
IPv6 access list kek
permit ipv6 any any (28 matches) sequence 10


2)
show run

ipv6 access-list kek
permit ipv6 any any
!
interface GigabitEthernet0
no ip address
ip access-group kek in
duplex auto
speed auto
ipv6 enable
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
description WAN_ISP
mtu 1400
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1360
dialer pool 1
dialer-group 1
ipv6 enable
ipv6 address 2A02:128:ABAB:AA1A::1/64
ppp authentication chap callin
ppp chap hostname ***
ppp chap password ***
ppp ipcp dns request

router#show ipv6 access-list kek
IPv6 access list kek
permit ipv6 any any (40 matches) sequence 10
router#ping
Protocol [ip]: ipv6
Target IPv6 address: google.com
Translating "google.com"...domain server (109.195.144.4) [OK]

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Sweep range of sizes? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2A00:1450:4010:C05::71, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
router#show ipv6 access-list kek
IPv6 access list kek
permit ipv6 any any (50 matches) sequence 10
0
Robocop01
35 / 29 / 12
Регистрация: 30.09.2017
Сообщений: 100
05.06.2019, 12:43 4
У вас в локальной сети ipv4 или ipv6?
0
05.06.2019, 12:43
Deyckstra
0 / 0 / 0
Регистрация: 17.05.2016
Сообщений: 7
05.06.2019, 13:46  [ТС] 5
Планируется использование двойного стека. В локальной сети ipv6 пока не настроен.
0
Robocop01
35 / 29 / 12
Регистрация: 30.09.2017
Сообщений: 100
05.06.2019, 14:50 6
Это ваш случай https://networklessons.com/ipv6/cisco-nat64-static-configuration
0
Deyckstra
0 / 0 / 0
Регистрация: 17.05.2016
Сообщений: 7
05.06.2019, 14:57  [ТС] 7
Нет, вы не поняли. Мой провайдер предоставляет как IPv6 так и IPv4 по PPPoE. IPv4 работает, IPv6 не подымается. Задача в том, чтобы поднять IPv6.
0
Korax
Эксперт по компьютерным сетям
605 / 326 / 77
Регистрация: 20.04.2014
Сообщений: 891
05.06.2019, 23:24 8
на WAN интерфейсе - получить префикс:
(config-if)# ipv6 dhcp client pd pool_IPv6

на LAN интерфейсе - назначить адрес c использованием этого префикса (узловая часть будет 1)
(config-if)# ipv6 address pool_IPv6 ::1/64

далее клиенты в локалке будут получать префикс через NDP RA, и выбирать узловые части и шлюз себе сами.

Есть один нюанс: У меня тоже Эр-телеком. По крайней мере, у нас в городе, через PD получается префикс и шлюз,
IPv6 DNS не назначается (подозреваю, у них IPv6 DNS spoofing не работает) - и чистого IPv6 не получится, DNS все
равно работает через IPv4.
0
Deyckstra
0 / 0 / 0
Регистрация: 17.05.2016
Сообщений: 7
06.06.2019, 07:38  [ТС] 9
Korax, будьте добры, проверьте правильность, роутер не получает префикс

show run

ipv6 unicast-routing
ipv6 cef
!
interface GigabitEthernet0
no ip address
ip access-group kek in
duplex auto
speed auto
ipv6 enable
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
description WAN_ISP
mtu 1400
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1360
dialer pool 1
dialer-group 1
ipv6 enable
ipv6 dhcp client pd pool_IPv6
ppp authentication chap callin
ppp chap hostname ***
ppp chap password ***
ppp ipcp dns request
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address pool_IPv6 ::1/64
ipv6 enable


show ipv6 interface br

Dialer1 [up/up]
FE80::26E9:B3FF:FE74:618B
GigabitEthernet0 [up/up]
FE80::26E9:B3FF:FE74:61A3
Vlan1 [up/up]
FE80::26E9:B3FF:FE74:618B
0
Deyckstra
0 / 0 / 0
Регистрация: 17.05.2016
Сообщений: 7
Вчера, 16:30  [ТС] 10
Доброго времени суток, форумчане!
В общем попинал провайдера, была какая-то проблема с их стороны, они там молча что-то поковыряли и заработало.
Поднятие протокола заметил тем, что притормаживало соединение, причём по спидтестам скорость была чуть выше купленного пакета услуг (75Мб/с). Посмотрел на роутере проблема со скоростью была в либо том, что адрес был только сконфигурирован только на внутреннем интерфейсе, либо в размере MTU. Поднастроив роутер, получил следующий результат:

Кликните здесь для просмотра всего текста
Код
show run

ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool LANv6
 import dns-server
 import domain-name
!
interface FastEthernet1
 switchport access vlan 2
 no ip address
!
interface Vlan2
 description LAN
 ip address 192.168.2.1 255.255.255.192
 ip nat inside
 ip virtual-reassembly in
 ipv6 address prefix_IPv6 ::2:0:0:1/80
 ipv6 enable
 ipv6 nd other-config-flag
 ipv6 dhcp server LANv6
!
interface GigabitEthernet0
 no ip address
 duplex auto
 speed auto
 ipv6 enable (пробовал без этой опции, IPv6 не поднимался на Dialer)
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dialer1
 description WAN_ISP
 mtu 1400
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1360
 dialer pool 1
 dialer-group 1
 ipv6 address IPv6 ::1/80
 ipv6 address autoconfig (без этой опции не конфигурируется адрес на локальных интерфейсах)
 ipv6 enable
 ipv6 mtu 1400 (поправьте, на сколько достаточно понизить MTU)
 ipv6 dhcp client pd hint "желаемый префикс к получению"::/64 (префикс теперь всегда выдается желаемый)
 ipv6 dhcp client pd prefix_IPv6
 ppp authentication chap callin
 ppp chap hostname XXX
 ppp chap password 7 XXX
 ppp ipcp dns request
!
ipv6 route ::/0 Dialer1
Код
show ipv6 interface brief

Dialer1                [up/up]
    FE80::ffff:fff:fff:fffB
    2002:ffff:ffff:fff::1
FastEthernet1          [up/up]
    unassigned
GigabitEthernet0       [up/up]
    FE80::ffff:ffff:ffff:fff3
Vlan2                 [up/up]
    FE80::fff:fff:fff:fffB
    2002:ffff:ffff:fff:2:0:0:1


Теперь появилась следующие проблемы:

Если выбрать способ dhcp без отслеживания состояни или с выдачей некоторых параметров, то рабочие станции под Windows 10 отказываются себе делать адрес, потому что длина префикса не 64 и алгоритм eui64 не срабатывает, включение рандомного адреса (netsh interface ipv6 set global randomizeidentifiers=enabled) проблему не решило;

Если выбрать способ с полным использованием dhcp, то нет функции выдачи полученного префикса от провайдера с добавлением допустим ещё одного гекстета.
В общем решение мне не нравится, но работает все нормально со статическими адресами.

NAT 66 использовать не хочу. Если есть идеи - подскажите.

Добавлено через 1 час 59 минут
Попробовал на разных сетевых картах прием с рандомным адресом, поперезагружал и вот так вот заработало:

Кликните здесь для просмотра всего текста
Код
show run

ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool LANv6
 address prefix 2001:aaaa:aaaa:aaaa:2::/80
 dns-server 2001:4860:4860::8844
 dns-server 2001:4860:4860::8888
 import domain-name
 import information refresh 
!
interface Vlan2
 description LAN
 ip address 192.168.2.1 255.255.255.192
 ip nat inside
 ip virtual-reassembly in
 ipv6 address IPv6 ::2:0:0:1/80
 ipv6 enable
 ipv6 mtu 1400
 ipv6 nd managed-config-flag
 ipv6 dhcp server LANv6 rapid-commit
Код
show ipv6 dhcp binding

Client: FE80::3196
  DUID: 
  Username : unassigned
  IA NA: IA ID , T1 43200, T2 69120
    Address: 2001:aaaa:aaaa:aaaa:2:0:0:abcd
            preferred lifetime 86400, valid lifetime 172800
            expires at Jun 18 2019 06:13 PM (172619 seconds)
Client: FE80::25E7
  DUID:
  Username : unassigned
  IA NA: IA ID , T1 0, T2 0
    Address: 2001:aaaa:aaaa:aaaa:2:0:0:dabc
            preferred lifetime 86400, valid lifetime 172800
            expires at Jun 18 2019 06:14 PM (172673 seconds)


Задача с полным использованием dhcp с функцией выдачи полученного префикса от провайдера с добавлением допустим ещё одного гекстета всё ещё актуальна и ещё бы найти решение задания статического биндинга по маку на роутере.
0
Вчера, 16:30
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
Вчера, 16:30

IPv6 помоги с заданием
Всем привет. Есть задание, которое необходимо выполнить в Packet Tracer. Помогите, пожалуйста...

Тунель через IPv6 сеть
Сабж, подскажите как настроить тунель через IPv6 сеть, у меня стоит такая задача: с одного и...

GNS3 IpV6 не работают маршруты
Собственно дело очень интересное, прописываю на 5 роутере, допустим, ipv6 route ::/0 fde4:1:1:4::1...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru