Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
ltyxbr
5 / 5 / 1
Регистрация: 14.07.2012
Сообщений: 64
1

Выбор направления пути

07.06.2019, 11:14. Просмотров 252. Ответов 3

Приветствую всех.
Такая задача стоит передо мной: есть HQ (на рисунке сверху, далее головной) и некий бранч офис (снизу, далее просто офис). В офисе, на ядре, несколько сетей, что я отдаю на бордеры по еигрп. Далее эти сети редистрибьютятся в бгп, головной принимает и обратно редистрибьютит в еигрп. Нужно выбрать направление, по которому пойдет весь трафик (доп. задача: часть трафика послать по другому пути). Причем выбираться он должен только в одном месте, в ядре офиса.
Основную задачу я решаю так: ставлю таг на маршрут в дистрибьют листе на ядре, на бордерах на основе тага ставиться комьюнити, с которой отдается на бордеры в головной, где по комьюнити выставляется метрика при редистрибьюте в еигрп. Этим я управляю входящим на офис трафиком. Исходящим же управляю делеем на интерфейсах в сторону бордеров.
Но при доп. задаче у меня возникают проблемы, ведь делей ставиться на интерфейс, а не на маршрут, поэтому им рулить я не могу. При этом мапа с тегами отрабатывает как надо: из головного трафик идет в нужных направлениях для разных сетей.

В идеале бы одним тагом управлять путем, но я не могу навесить таг на другой маршрут, при получении первого, знаний не хватает. Возможно ли это вовсе? Две разных подзадачи (до каких я додумался, просто не знаю как реализовать): 1) ставим таг, на основе этого тага на бордерах при редистрибьюте из бгп в еигрп ставим нужную метрику; 2) на ядре в головном на основе пути до сетей в офисе ставить таг, а дальше то же самое, только в обратную сторону.

Подскажите, есть ли такая реализация в cisco?
0
Миниатюры
Выбор направления пути  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.06.2019, 11:14
Ответы с готовыми решениями:

Выбор направления
Помогите решить задачу как лучше выбрать направление, то есть в какую сторону двигаться лучше...

Выбор направления
Какое направление в программировании более востребовано, а то зашел на авито, а там одни ремонтники...

выбор направления
Можете пожалуйста помочь мне определится с направлением? Я не могу определится в каком направлении...

Выбор направления
Помогите решить задачу как лучше выбрать направление, то есть в какую сторону двигаться лучше...

Выбор направления развития
Здравствуйте! Наверное, это уже сотая тема с таким названием, но по чужим кейсам найти ответ для...

3
ltyxbr
5 / 5 / 1
Регистрация: 14.07.2012
Сообщений: 64
07.06.2019, 17:22  [ТС] 2
Буду рад любым умозаключениям, лишь бы сдвинуться. Поделюсь своими набросками конфигов, если есть желающие
0
Robocop01
36 / 30 / 12
Регистрация: 30.09.2017
Сообщений: 102
07.06.2019, 22:15 3
С конфига надо начинать в любом случае...
0
ltyxbr
5 / 5 / 1
Регистрация: 14.07.2012
Сообщений: 64
08.06.2019, 10:33  [ТС] 4
Вставлю код и опишу работу над каждым спойлером

Два п2п линка до бордеров. Внутренняя сеть 192.168.0.0/16 разделена по разным вланам. Мы общаемся с бордерами через еигрп. Отдавая маршрут, мы его метим тегом: тег 1 - левая сторона приоритетнее, тег 2 - правая. Есть возможность разделить сети по сторонам, для этого добавить в префикс-лист ALT_BNETS нужную нам сеть, и выставить для неё другой тег в роут-мапе.
Исходящий трафик идет через правую сторону, так как поставил задержку больше для левого интерфейса.
R6

F#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
R6
!
interface Ethernet0/0
 ip address 46.0.0.6 255.255.255.0
 delay 1000
!         
interface Ethernet0/1
 ip address 56.0.0.6 255.255.255.0
!
interface Ethernet0/2
 no ip address
!
interface Ethernet0/2.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0/2.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface Ethernet0/3
 no ip address
!
interface Ethernet0/3.30
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
interface Ethernet0/3.40
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
!
!
router eigrp BRANCH
 !
 address-family ipv4 unicast autonomous-system 1
  !
  topology base
   distribute-list route-map SET_TAG out Ethernet0/0
   distribute-list route-map SET_TAG out Ethernet0/1
  exit-af-topology
  network 46.0.0.0 0.0.0.255
  network 56.0.0.0 0.0.0.255
  network 192.168.0.0 0.0.255.255
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!         
ip prefix-list ALT_BNETS seq 5 permit 192.168.10.0/24
!
ip prefix-list BNETS seq 5 permit 192.168.0.0/16 le 24
!
route-map SET_TAG permit 10
 match ip address prefix-list ALT_BNETS
 set tag 2
!
route-map SET_TAG permit 20
 match ip address prefix-list BNETS
 set tag 2

На бордерах настроен бгп для связи с головным офисом. Туда мы передаем маршруты, полученные из еигрп. И в зависимости от полученного тега ставим коммьюнити (для левой стороны тег 1 переходит в коммьюнити 120, а тег 2 в 90, для правой 120 для тега 2). Так же полученные с головного офиса маршруты передаем в еигрп.
R5
F#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
R5
!
interface Ethernet0/0
 ip address 56.0.0.5 255.255.255.0
!
interface Ethernet0/1
 ip address 35.0.0.5 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
!
router eigrp BRANCH
 !
 address-family ipv4 unicast autonomous-system 1
  !
  topology base
   redistribute bgp 11111 metric 10000 100 255 1 1500
  exit-af-topology
  network 56.0.0.0 0.0.0.255
 exit-address-family
!
router bgp 11111
 bgp log-neighbor-changes
 redistribute eigrp 1 route-map EIGRP_TO_BGP
 neighbor 35.0.0.3 remote-as 22222
 neighbor 35.0.0.3 send-community both
!
ip forward-protocol nd
!
ip bgp-community new-format
!
no ip http server
no ip http secure-server
!
!
route-map EIGRP_TO_BGP permit 10
 match tag 2
 set community 11111:120
!
route-map EIGRP_TO_BGP permit 20
 match tag 1
 set community 11111:90
!

R4
F#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
R4
!
interface Ethernet0/0
 ip address 24.0.0.4 255.255.255.0
!
interface Ethernet0/1
 ip address 46.0.0.4 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
!
router eigrp BRANCH
 !
 address-family ipv4 unicast autonomous-system 1
  !
  topology base
   redistribute bgp 11111 metric 10000 100 255 1 1500
  exit-af-topology
  network 46.0.0.0 0.0.0.255
 exit-address-family
!
router bgp 11111
 bgp log-neighbor-changes
 redistribute eigrp 1 route-map EIGRP_TO_BGP
 neighbor 24.0.0.2 remote-as 22222
 neighbor 24.0.0.2 send-community both
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
route-map EIGRP_TO_BGP permit 10
 match tag 2
 set community 728170586
!
route-map EIGRP_TO_BGP permit 20
 match tag 1
 set community 728170616
!

На бордерах в головном офисе мы принимаем маршруты с коммьюнити. Проверяем их роут-мапой и выставляем метрику в соответствии с правилом "для коммьюнити 120 метрика меньше". С этой метрикой мы отдаем маршруты в еигрп, а дальше они уходят в ядро головного офиса.
R3
F#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
R3
!
interface Ethernet0/0
 ip address 35.0.0.3 255.255.255.0
!
interface Ethernet0/1
 ip address 13.0.0.3 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
!
router eigrp HQ
 !
 address-family ipv4 unicast autonomous-system 2
  !
  topology base
   redistribute bgp 22222 route-map BGP_TO_E
  exit-af-topology
  network 13.0.0.0 0.0.0.255
 exit-address-family
!
router bgp 22222
 bgp log-neighbor-changes
 redistribute eigrp 2 route-map HQ_ONLY
 neighbor 35.0.0.5 remote-as 11111
!
ip forward-protocol nd
!
ip bgp-community new-format
ip community-list 1 permit 11111:120
ip community-list 2 permit 11111:90
!
no ip http server
no ip http secure-server
!
!
ip prefix-list HQ_ONLY seq 5 permit 10.0.0.0/8 le 32
!
route-map BGP_TO_E permit 10
 match community 1
 set metric 10000 10 255 1 1500
!
route-map BGP_TO_E permit 20
 match community 2
 set metric 10000 1000 255 1 1500
!         
route-map BGP_TO_E permit 30
 set metric 10000 100 255 1 1500
!
route-map HQ_ONLY permit 10
 match ip address prefix-list HQ_ONLY
!

R2
F#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
R2
!
interface Ethernet0/0
 ip address 12.0.0.2 255.255.255.0
!
interface Ethernet0/1
 ip address 24.0.0.2 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
!
router eigrp HQ
 !
 address-family ipv4 unicast autonomous-system 2
  !
  topology base
   redistribute bgp 22222 route-map BGP_TO_E
  exit-af-topology
  network 12.0.0.0 0.0.0.255
 exit-address-family
!
router bgp 22222
 bgp log-neighbor-changes
 redistribute eigrp 2 route-map HQ_ONLY
 neighbor 24.0.0.4 remote-as 11111
!
ip forward-protocol nd
!
ip bgp-community new-format
ip community-list 1 permit 11111:120
ip community-list 2 permit 11111:90
!
no ip http server
no ip http secure-server
!
!
ip prefix-list HQ_ONLY seq 5 permit 10.0.0.0/8 le 32
!
route-map BGP_TO_E permit 10
 match community 1
 set metric 10000 10 255 1 1500
!
route-map BGP_TO_E permit 20
 match community 2
 set metric 10000 1000 255 1 1500
!         
route-map BGP_TO_E permit 30
 set metric 10000 100 255 1 1500
!
route-map HQ_ONLY permit 10
 match ip address prefix-list HQ_ONLY
!

Ну а на ядре только еигрп пока что. Согласно метрике, полученной от бордеров, мы отправляем маршрут в нужную нам сторону.
R1

F#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
R1
!
interface Ethernet0/0
 ip address 12.0.0.1 255.255.255.0
!
interface Ethernet0/1
 ip address 13.0.0.1 255.255.255.0
!
interface Ethernet0/2
 no ip address
!
interface Ethernet0/2.100
 encapsulation dot1Q 100
 ip address 10.0.100.1 255.255.255.0
!
interface Ethernet0/2.200
 encapsulation dot1Q 200
 ip address 10.0.200.1 255.255.255.0
!
interface Ethernet0/3
 no ip address
 shutdown
!
!
router eigrp HQ
 !
 address-family ipv4 unicast autonomous-system 2
  !
  topology base
  exit-af-topology
  network 10.0.0.0 0.0.255.255
  network 12.0.0.0 0.0.0.255
  network 13.0.0.0 0.0.0.255
 exit-address-family
!
ip forward-protocol nd
!

Осталось только научиться определять путь для исходящих для разных сетей, а не как сейчас делей на интерфейс, и весь трафик в одном направлении
0
Миниатюры
Выбор направления пути  
08.06.2019, 10:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.06.2019, 10:33

выбор направления/специальности
Помогите с выбором направления/специальности! Хочу стать отличным программистом, прям очень-очень...

выбор направления ВУЗа
Всем привет! Учусь в 10 классе и уже чуть более года осталось до сдачи ЕГЭ, с предметами вроде...

Правильный выбор направления
Всем привет. Мне 21 год. Образование только школьное (и то плохие оценки). Попробовал заняться...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru