Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.78/9: Рейтинг темы: голосов - 9, средняя оценка - 4.78
KOSA11
0 / 0 / 0
Регистрация: 28.07.2016
Сообщений: 9
1

Настройка L3 коммутатора в качестве ядра

10.07.2019, 10:21. Просмотров 1788. Ответов 7
Метки нет (Все метки)

Помогите разобраться в cisco tracer. Начинаю изучать cisco и столкнулся с проблемой, не ходит трафик на внешний интерфейс роутера.
Картина такова:
1. Имеется L3 коммутатор он же шлюз по умолчанию (vlan2: ip: 192.168.2.3/24 fe0/2 смотрит на роутер, fe0/1 смотрит на коммутатор с хостом)
2. Имеется роутер с внутреннем интерфейсом (ip: 192.168.2.1/24 fe0/1.2 внутренний fe0/0 внешний ) и внешний интерфейс (ip: 213.230.10.1/24) на нём настроен NAT
3. Хост с ip 192.168.2.2 и шлюзом 192.168.2.3/24
4. Имеется типа роутера провайдера и сервером от него (Ip роутера 213.230.10.2/24 и 213.230.20.1/24) (Сервер: 213.230.20.2/24)
Трафик ходит от хоста к внутреннему интерфейса роутера, но вот никак не хочет идти на внешний.
помогите я уже 2 неделю бьюсь с этим.

Конфиг с L3 коммутатора:

Код
interface FastEthernet0/1
switchport trunk allowed vlan 2
!
interface FastEthernet0/2
switchport trunk allowed vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk

interface Vlan1
no ip address
shutdown
!
interface Vlan2
mac-address 000a.41d8.2901
ip address 192.168.2.3 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1 
!
ip flow-export version 9
Конфиг с роутера:

Код
interface FastEthernet0/0
ip address 213.230.10.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
ip nat inside
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list nat interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 213.230.10.2 
!
ip flow-export version 9
!
!
ip access-list standard nat
permit 192.168.2.0 0.0.0.255
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.07.2019, 10:21
Ответы с готовыми решениями:

Настройка коммутатора HP 1810-8g
Ребята помогите настроить HP 1810-8g. Нужно сделать 1 и 2 порт транковыми и остальные объединить и...

Настройка коммутатора HP 1810-48g
Не могу разобраться как сделать интернет видимым для всех сетей, но чтобы сети не видели друг -...

настройка коммутатора H3C S3600
Помогите плиз настроить NaT на коммутаторе H3C S3600

Cisco настройка портов коммутатора
настройки которые ввожу не работают всяко разно уже пробовала. 1.настройте ipv4-адрес для vlan1...

Настройка сети из коммутатора и роутера
Добрый день. Подскажите пожалуйста, как можно настроить роутинг, чтобы стала доступна локальная...

7
Robocop01
49 / 40 / 16
Регистрация: 30.09.2017
Сообщений: 125
10.07.2019, 12:09 2
Вы бы файл для cisco tracer выложили...
0
KOSA11
0 / 0 / 0
Регистрация: 28.07.2016
Сообщений: 9
10.07.2019, 16:06  [ТС] 3
Отправил
0
Вложения
Тип файла: rar Пинг внешнего IP.rar (81.7 Кб, 2 просмотров)
Robocop01
49 / 40 / 16
Регистрация: 30.09.2017
Сообщений: 125
10.07.2019, 21:14 4
Для того, что б ПК пинговал внешнюю сеть в данной конфигурации, на ПК прописать шлюз 192.168.2.1.
Если хотите полноценно использовать L3 тогда маршрутизация должна проходить на нем и интерфейсы на роутере не нужны (у роутера порт настраивается как обычный физический). Так же между роутером и L3 должна быть своя сеть (например 192.168.10.0).

Во вложении конфиг с правильными настройками, L3 как ядро.
0
Вложения
Тип файла: zip Пинг внешнего IP.zip (78.2 Кб, 2 просмотров)
10.07.2019, 21:14
KOSA11
0 / 0 / 0
Регистрация: 28.07.2016
Сообщений: 9
11.07.2019, 11:16  [ТС] 5
Так как Вы сделали у меня получалось. Но проблема в том что пакеты от хоста 192.168.2.2 на порт роутера "R-Провйдер" не NATтся. Приходят с IP 192.168.2.2 и получается что с роутера провайдера можно пингануть внутреннюю сеть.
0
Robocop01
49 / 40 / 16
Регистрация: 30.09.2017
Сообщений: 125
11.07.2019, 23:01 6
Лучший ответ Сообщение было отмечено KOSA11 как решение

Решение

Прописал access list
1
Вложения
Тип файла: zip Пинг внешнего IP.zip (78.2 Кб, 1 просмотров)
KOSA11
0 / 0 / 0
Регистрация: 28.07.2016
Сообщений: 9
12.07.2019, 16:39  [ТС] 7
Спасибо.

Добавлено через 5 часов 35 минут
А Вы можете написать что именно вы сделали что бы пакеты начали NATятся ? Я сделал такую же сеть прописал всё также добавил ACL которые Вы добавили пакеты ходят на роутер провайдера но всё равно они не NATятся. Приходят с IP локальной сети.
Я добавил ACL
ip access-list extended nat
deny tcp any host 217.230.10.2 eq telnet
permit tcp any host 217.230.10.2

применил его к интерфейсу который смотрит на роутер провайдера.
0
Robocop01
49 / 40 / 16
Регистрация: 30.09.2017
Сообщений: 125
12.07.2019, 21:02 8
Лучший ответ Сообщение было отмечено KOSA11 как решение

Решение

Я прописал access list, что бы из внешки по маршруту нельзя было пинговать внутреннюю сеть. Так же переподключил все устройства правильными сетевыми кабелями (хотя это не должно было сказываться). Попробуйте в моей схеме заменять мои устройства своими и тогда найдете причину.
1
12.07.2019, 21:02
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.07.2019, 21:02

Настройка коммутатора на работу с двумя провайдерами
Прошу помочь советом. Сеть: модем WiMax от Freshtel (раздает адреса), от него кабель в...

Настройка коммутатора PCI fmx-24nx
Всем привет , В офисе есть несколько коммутаторов PCI fmx-24nx, используют как хабы, Вообще их...

Как создать локальную сеть с выходом в Интернет, используя ADSL модем в качестве коммутатора и точки беспроводного доступа?
Исходные данные: 1. Есть Интернет, который приходит от провайдера по витой паре. Этот Интернет...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru