Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.90/89: Рейтинг темы: голосов - 89, средняя оценка - 4.90
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
1

настройка vlan на маршрутизаторе

23.07.2011, 18:37. Просмотров 16899. Ответов 13

Добрый вечер! Есть маршрутизатор cisco на нем надо поднять сети 192.168.0.0/24 и 192.168.2.0.4/24 на разных vlan, так как в cisco новичок возникает вопрос, при настройке vlan не дает создать такие айпишники с такой маской, пишет неправильная маска, если проставить маску 255.0.0.0 у первого ай пи, то второй ай пи не создается пишет, что такой уже существует, можно ли как нибудь создать такие сети с такими ай пи или это опечатка в задании?? Заранее спасибо
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.07.2011, 18:37
Ответы с готовыми решениями:

Конфигурирование VLAN на маршрутизаторе и коммутаторах
Помогите пожалуйста сделать работу, завтра уже сдать нужно.

Настройка протокола RIP на маршрутизаторе (в Packet Tracer)
Почему 1 роутер (второй) никак не контактирует с другими? Где я допустил ошибку? Подскажите,...

Настройка VLAN
Есть сеть 12.0.0.0. Хочу реализовать что ПК Rukovoditel3 мог пинговать всех в сети, а его...

Настройка vlan
Привет. Есть одна сеть (192.168.10.1/24), но несколько vlan (101,102,103). Как сделать, чтобы...

Cisco настройка VLAN
Router 3900 Switch SW1 - 2960, SW2 - 2950 Не получается настроить VLAN, т.е. вланы то настроены,...

13
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
23.07.2011, 23:24 2
Цитата Сообщение от Ksana_ Посмотреть сообщение
192.168.0.0/24 и 192.168.2.0.4/24

первое (192.168.0.0/24) - это адрес сети, а вот второе (
192.168.2.0.4/24) - это адрес фиг знает чего, так как в нем 5 октетов. Если именно так написано в Вашем задании - это точно ошибка.

Цитата Сообщение от Ksana_ Посмотреть сообщение
при настройке vlan
а как именно Вы настраиваете vlanы
на маршрутизаторе? и главное зачем? на субинтерфейсах? Укажите точное задание и мы с Вами все быстро соорудим.

Жду Ваших ответов.
0
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
24.07.2011, 10:11  [ТС] 3
насчет, адреса сети это я опечаталась ) адрес 192.168.2.0/24. Скажем так, надо vlan, именно на маршрутизаторе, так как это задание лабораторной работы, и настраиваю на под интерфейсах.

interface fa0/1.1
encapsulation dot1q 1
ip address 192.168.0.0 255.255.255.0

Здесь и выдает ошибку
Bad mask /24 for address 192.168.0.0

По заданию надо настроить сеть, как показано во вложении, но мне хотя бы разобраться с vlan
0
Миниатюры
настройка vlan на маршрутизаторе  
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
24.07.2011, 11:23 4
Цитата Сообщение от Ksana_ Посмотреть сообщение
ip address 192.168.0.0 255.255.255.0
так и ясно) ведь Вы пытаетесь присвоить интерфейсу адрес сети.

в сети 192.168.2.0 /24 мы имеем

* Адрес 192.168.2.0 - адрес сети
* Адреса 192.168.2.1 - 192.168.2.254 - назначаемые адреса
* Адрес 192.168.2.255 - широковещательный адрес.

Вашему интерфейсу можно назначить адрес только из диапазона адресов .1 -- .254


P.S.> если не трудно, укажите точное задание к картинке (какие виланы должны быть, какие каких видеть и т.д.).
1
24.07.2011, 11:23
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
24.07.2011, 11:33  [ТС] 5
Спасибо, а то я думала, что раз в задании написано, то можно и назначить интерфейсу такой айпи, и я что то не так делаю, привожу полностью задание:
необходимо настроить маршрутизаторы R1 и R2 и коммутаторы S1 и S2 таким образом, чтобы:
1) маршрутизаторы R1 и R2 были соединены приватным линком с сетью 172.16.0.0/30
2) на свитчах S1 и S2 настроить managment сети заведенные на маршрутизаторах R1 и R2 для коммутаторов S1 и S2 соответственно.
3) на маршрутизаторе R1 поднять сети 192.168.0.0/24 и 192.168.2.0/24 на разных vlan`нах
4) на маршрутизаторе R2 поднять сети 192.168.1.0/24 и 192.168.4.0/24 на разных vlan`нах
5) настроить коммутатор S1 таким образом чтобы компьютеры 192.168.0.2 и 192.168.2.3 видели шлюз по умолчанию и друг друга?
6) настроить коммутатор S2 таким образом чтобы компьютеры 192.168.1.2 и 192.168.4.3 видели шлюз по умолчанию и друг друга
7) настроить access list таким образом, чтобы доступ на коммутатор S1 был возможен с сети 192.168.0.0/24 и невозможен с других сетей.?
8) настроить access list таким образом, чтобы доступ на коммутатор S2 был возможен с хоста 192.168.4.3 и невозможен с других сетей.
9) настроить маршрутизаторы R1 и R2 таким образом, чтобы с сети 192.168.0.0/24 были видны сети 192.168.0.0/24, 192.168.1.0/24, 192.168.4.0/24?

И еще вопрос, правильно ли я настраиваю vlan на под интерфейсах, а то есть команда для настройки отдельно vlan?
int vlan 1
ip address z.z.z.z y.y.y.y
или все таки правильно через под интерфейс?
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
24.07.2011, 13:09 6
Думаю вот так? Если же что-то не так или нужно поправить - пишите.
1
Вложения
Тип файла: rar intervlanroute.pkt.rar (8.8 Кб, 867 просмотров)
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
25.07.2011, 12:29  [ТС] 7
Спасибо огромное, очень помогли, а то тыкаю, делаю, и даже не могу оценить правильно или нет ) А теперь многое стало понятно

Добавлено через 23 часа 1 минуту
А можно еще вопрос, а почему коммутатор тоже на под интерфейс подключается, а не на порт fa0/1?
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
25.07.2011, 20:31 8
что значит
Цитата Сообщение от Ksana_ Посмотреть сообщение
коммутатор тоже на под интерфейс
коммутатор физически подключается транком как раз-таки на порт fa0/1 маршрутизатора.
0
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
26.07.2011, 07:09  [ТС] 9
То есть, зачем для него создается дополнительный vlan?

Добавлено через 2 минуты
На под интефейсе fa0/1.111 по-моему, просто вашей схемы нет под рукой не могу посмотреть точно
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
26.07.2011, 08:37 10
Вы имеете ввиду почему сеть управления выделена в отдельный вилан и тоже висит на субинтерфейсе fa0/1.111 (тем не менее, находясь на физическом интерфейсе fa0/1)? По соображениям безопасности и логического распределения - так сказать бест практисес. Да и смотрите - мы же на свитче создаем инетрфейс управления - interface vlan - так как же он будет подходить к маршрутизатору если не на логический суб?

Добавлено через 11 минут
Если только нэйтив изменить на транке маршрутизатора. Но имхо удобнее в отдельный вилан - надежнее.
0
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
26.07.2011, 08:44  [ТС] 11
Спасибо, еще раз, и еще один вопрос ))) В задании 5 надо настроить, чтоб свитч получал пакеты от 192.168.0.1, но не получал от всех остальных, это настраивать через акцес листы?? Просто вроде акцес лист настраиваю, но у меня тогда свитч не от кого пакеты не получает, в том числе и от 192.168.0.1((
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
26.07.2011, 09:13 12
я настроил аксес-лист на как раз том субинтерфейсе маршрутизатора fa0/1.111

ip access-list extended MAN
permit ip 192.168.0.0 0.0.0.255 host 10.1.0.254

и применяю его

interface FastEthernet0/1.111
ip access-group MAN out

После этого - как только пакет пытается выйти из этого интерфейса в сторону свитча - он проверяется через этот аксес лист и убивается в случае, когда source не из 192.168.0.x (из-за невидимого deny ip any any в конце acl).
1
Ksana_
92 / 46 / 22
Регистрация: 11.02.2010
Сообщений: 187
26.07.2011, 10:33  [ТС] 13
Это снова я )) Возник еще один вопрос, во втором задании, надо настроить managment сети, это разве не snmp сервер надо настраивать на маршрутизаторе, если нет, то что значит настроить managment сети?
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,936
Записей в блоге: 3
26.07.2011, 14:30 14
Не, не думаю.
Более вероятно, что это значит нужно создать SVI на свитче для удаленного управления - менеджмента, через к примеру telnet\ssh.
1
26.07.2011, 14:30
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.07.2011, 14:30

Настройка VLAN на Sg200-50
Железо Cisco SG200-50. Добавил VLAN с ID 10 и 11 Порты 1 - 6 добавил как Tagged в 10 Порты 7 -...

Настройка маршрутизации между VLAN
Бьюсь уже пару часов. Совсем что-то не получается. Помогите, пожалуйста, как настроить...

Настройка VLAN на Cisco 2811
Недавно решил объединить всю организацию в одну сеть чтобы был общий доступ в инет(оптоволокно),...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru