Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.65/20: Рейтинг темы: голосов - 20, средняя оценка - 4.65
Former_Human
0 / 0 / 0
Регистрация: 29.07.2011
Сообщений: 5
1

проблеммы с копированием ключей/rc на TFTP

29.07.2011, 12:09. Просмотров 4040. Ответов 5

\\если тема похожая была - я извиняюсь за кривизну рук при поиске
Доброго времени суток!

Господа, специалисты, помогите слоупоку(

Был собран корявый стенд GNS3 - VMWare (Windows XP SP2), топология выглядит где-то так (циски 7200):

Конфиг R0:
Код
Current configuration : 1481 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R0
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
interface FastEthernet0/0
 ip address 192.168.1.20 255.255.255.0
 duplex full
!
interface Serial1/0
 ip address 12.1.1.1 255.255.255.252
 serial restart-delay 0
!
!
router eigrp 1
 redistribute static
 network 12.0.0.0
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 12.1.1.2
!
no ip http server
no ip http secure-server
!
control-plane
!
gatekeeper
 shutdown
!
!
line con 0
 password 7 110A1016141D
 login
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password 7 05080F1C2243
 login
!
!
end
Пинги между Варей и Р0 проходят.
Задача следующая была: сгенерировать ключи RSA и экспортировать их на TFTP сервер.
Сделать это ну никак не выходит. При попытке сохранить ключ на ТФТП:
Код
R0(config)#crypto key export rsa test_keys_rsa pem url tftp: 3des 123456789
, получаю ошибку:
Код
% Key name: test_keys_rsa
   Usage: General Purpose Key
Exporting public key...
Address or name of remote host []? 192.168.1.29
Destination filename [test_keys_rsa.pub]?
TFTP: error code 2 received - 16739
% Error: failed to open file.
% Error: failed to export key.
При создании ключей, добавлял параметр "exportable".
Код
R0#show crypto key mypubkey rsa
% Key pair was generated at: 09:04:35 UTC Jul 28 2011
Key name: test_keys_rsa
 Usage: General Purpose Key
 Key is exportable.
 Key Data:
  305C300D 06092A86 4886F70D 01010105 00034B00 30480241 00C4B29D CDB14B5C
  18BC1B94 A4D2E75D 467A5FA4 7A1EAB70 31F81D41 1B840642 8DA1904A 59F4426A
  7D3FB33D 43DD6D29 132A5A34 95FBAAC2 8FB14734 D6A6884B 9F020301 0001
% Key pair was generated at: 09:52:36 UTC Jul 29 2011
также присутствует другая борода - не могу копировать файл конфигурации на ТФТП:
Код
R0#copy running-config tftp:
Address or name of remote host []? 192.168.1.29
Destination filename [r0-confg]?
TFTP: error code 2 received - 16739
 
%Error opening tftp://192.168.1.29/r0-confg (Permission denied)
Службу ТФТП в Винде вручную ставил, руководствуясь данным гайдом: http://www.panvasoft.com/rus/blog/144/
Фаервол погасил.
Сразу извиняюсь, если понаписывал (-ваю) глупостей - я в цисках нуб.
Помогите-спасите. Заранее спасибо)
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.07.2011, 12:09
Ответы с готовыми решениями:

Вывод значения ключей массива по условию совпадения других ключей
Есть массив $arElements Array ( => Array ( => first ...

Генерация и проверка на работоспособность ключей активации (регистрационных ключей)
Помогите придумать как можно осуществить сие деяние. Суть заключается в чем, первая программа...

Массив ключей из ключей двух массивов
Добрый день. Необходимо собрать все ключи с двух массивов как можно эффективнее и менее...

tftp-протокол
Добрый день! Пишу tftp-сервер. Согласно RFC 1350 по tftp протоколу надо присваивать каждому...

TFTP и медот get();
Всем доброго времени суток. Есть интересная проблемка)Опишу всё попорядку: Есть свой чат с...

5
Jabbson
Эксперт по компьютерным сетям
3446 / 2491 / 777
Регистрация: 03.11.2009
Сообщений: 7,930
Записей в блоге: 3
29.07.2011, 16:07 2
Только что попробовал сохранить конфиг и экспортировать ключ из роутера в гнс3 через MS Loopback интерфейс на tftp. Все замечательно ушло. Удостоверьтесь, что тфтп сервер разрешает читать и писать, а не только читать.

Советую попробовать tftpd32
Очень стабильный tftp сервер на винду.

Добавлено через 14 минут
Все что может быть - коннект, фаервол, ограничение на запись и кривой виндовс-тфтп сервер.
1
Former_Human
0 / 0 / 0
Регистрация: 29.07.2011
Сообщений: 5
29.07.2011, 16:40  [ТС] 3
Цитата Сообщение от Jabbson Посмотреть сообщение
Советую попробовать tftpd32
Очень стабильный tftp сервер на винду.
tftpd32 выдает ошибочку:
Error in Recv.
Error code in 10054 (Удаленный хост принудительно разорвал существующее подключение.)

Цитата Сообщение от Jabbson Посмотреть сообщение
Добавлено через 14 минут
Все что может быть - коннект, фаервол, ограничение на запись и кривой виндовс-тфтп сервер.
с коннектом проблем нет (пинги идут нормально...)
фаервол отключен
Ну...ТФТП служба ставилась вручную, с диска винды (см.первый пост
Службу ТФТП в Винде вручную ставил, руководствуясь данным гайдом: http://www.panvasoft.com/rus/blog/144/
) О настройках этой службы, увы не знаком, мб вы что-нибудь подскажите.
0
Jabbson
Эксперт по компьютерным сетям
3446 / 2491 / 777
Регистрация: 03.11.2009
Сообщений: 7,930
Записей в блоге: 3
29.07.2011, 17:03 4
Цитата Сообщение от Former_Human Посмотреть сообщение
tftpd32 выдает ошибочку: Error in Recv. Error code in 10054 (Удаленный хост принудительно разорвал существующее подключение.)
а на каком месте происходит эта ошибка? Папка сервера точно открыта для записи?
0
Former_Human
0 / 0 / 0
Регистрация: 29.07.2011
Сообщений: 5
29.07.2011, 18:01  [ТС] 5
вопрос решился

Ошибка выскакивала при попытке ТФТП-клиентом загрузить или получить файлы от роутера.
Остановил установленную ранее службу и уже без нее запустил TFTPD32.
Конфиги и ключи копируются.
Посему проблема решена, спасибо Jabbson за ссылку!
0
Jabbson
Эксперт по компьютерным сетям
3446 / 2491 / 777
Регистрация: 03.11.2009
Сообщений: 7,930
Записей в блоге: 3
29.07.2011, 18:10 6
Всегда пожалуйста. Спасибо за плюсик (сотый, кстати).
0
29.07.2011, 18:10
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.07.2011, 18:10

tftp сервер
Доброго времени суток, ни кому, совершенно случайно, не попадался TFTP сервер с открытыми...

Red Hat TFTP
Всем привет! кто знает помогите пожалуйста советом! Проблема следующего характера есть tftp сервер...

PXE: TFTP failed
Устанавливаю WinXP через PXE. На сервере все настроено по инструкции. Кому лень читать опишу...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru