Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.70/33: Рейтинг темы: голосов - 33, средняя оценка - 4.70
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
1

Настройка NAT на CISCO 851

30.07.2011, 15:56. Просмотров 6233. Ответов 12

Добрый день. Никак не получается настроить NAT
Система состоит из 2х роутеров (соответственно 2 подсети)
WAN 87.255.xx.xxx -> cisco 851 (lan 192.168.2.1) -> 192.168.2.2 роутер dlink n1000 (lan 192.168.10.1) -> 192.168.10.90 ПК2
К роутеру cisco подключен ПК1, имеет статический ip 192.168.2.99

необходимо с ПК1 подключаться к ПК2 через RAdmin (порт 4899)

Раньше вместо роутера cisco 851 стоял роутер LinkSys wrt54gl(ddwrt), там все работало (В nat было прописано port 4899 и 192.168.2.2)

Сейчас вот такие настройки, но порт 4899 закрыт (проверяю через ping.eu -> port check)


router#sh run
Building configuration...

Current configuration : 5136 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$cD2A$rk8BCcxpusZ9RG1YKSduc0
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
ip subnet-zero
no ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.99
!
ip dhcp pool ccp-pool1
import all
network 192.168.2.0 255.255.255.0
dns-server 10.10.250.250 10.10.140.250
default-router 192.168.2.1
!
!
ip cef
ip tcp synwait-time 10
no ip bootp server
ip domain name mptaxi
ip name-server 10.10.250.250
ip name-server 10.10.140.250
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
crypto pki trustpoint TP-self-signed-1583126224
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1583126224
revocation-check none
rsakeypair TP-self-signed-1583126224
!
!
crypto pki certificate chain TP-self-signed-1583126224
certificate self-signed 01
30820245 308201AE A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31353833 31323632 3234301E 170D3032 30333031 30323430
35365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35383331
32363232 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100D1A7 E1B7099B 18800067 5521F80A 0D2AAC95 E6FBE7B0 05C4F535 4E21EAC0
7EF558AD E5F1CB11 B77F982F 3073D771 9993B69F CC7C15A0 A69A1609 AE827101
945935F9 E4B37E25 AF126494 3C17879B AA2F6925 4892010C BEF2EA48 6EF2E189
488D15A5 39AA1E35 749DBC5A 2195E702 06FB5F7B 26D252E5 53D43213 DAE24F42
F0910203 010001A3 6D306B30 0F060355 1D130101 FF040530 030101FF 30180603
551D1104 11300F82 0D726F75 7465722E 6D707461 7869301F 0603551D 23041830
168014F5 032BA67B 85CD070D CF4ECC75 2F3099A8 FF2E5730 1D060355 1D0E0416
0414F503 2BA67B85 CD070DCF 4ECC752F 3099A8FF 2E57300D 06092A86 4886F70D
01010405 00038181 007CFA25 A43A1204 37DAA344 CFFC6D22 A1AB54CC 64CBDC58
ABA515E2 7CF26DB9 466D8274 B225A589 459441B9 679F7F8E D5C6F093 A7C2F0B1
90FC718C 1A9B6708 C548B9E9 19B38507 26A7DA05 7557D78F 3384C6C8 77A3ED86
04754121 DE80196C A9850683 0BB2AFA5 E4D9263D 2617EA8E 1CEE498A 75D75EE0
C4C86F97 7604699C 01
quit
username admin privilege 15 secret 5 $1$9nBa$U6zmiHr1DBsQLIg0fmpRL1
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ES_WAN$$FW_OUTSIDE$
ip address 87.255.хх.ххх 255.255.255.224
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 192.168.2.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
!
ip classless
ip route 0.0.0.0 0.0.0.0 87.255.хх.хх
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp 192.168.2.2 4899 87.255.хх.ххх 4899 extendable
ip nat inside source static udp 192.168.2.2 4899 87.255.хх.ххх 4899 extendable
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 192.168.2.0 0.0.0.255
no cdp run
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you
want to use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.07.2011, 15:56
Ответы с готовыми решениями:

Cisco 851 - настройка интернета
Подскажите, как настроить интренет на cisco 851 провайдер дал ip адрес статический, маску, ip...

Настройка маршрутизатора cisco 851
Здравствуйте.Помогите пожалуйста.Как настройкой cisco 851.Если можно по подробнее пожалуйста, я не...

Настройка NAT на Cisco
Здравствуйте. Есть локальная сеть с двумя коммутаторами L2 доступа, одним L3 доступа, и...

Настройка NAT (CISCO)
Здравствуйте, решил изучать Циску, и придумал себе задачу, спроектировать простенькую сеть на 100...

Настройка NAT Cisco 881
Всем доброго времени суток! Собственно столкнулся с данным оборудованием впервые. Изучив...

12
Jabbson
Эксперт по компьютерным сетям
3460 / 2503 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
30.07.2011, 21:30 2
Добрый день, нарисуйте схематично как все соединено, пожалуйста (ван, оба роутера и оба пк), а то я как-то не до конца понял - и подумаем.
И еще вопрос - я правильно понимаю, что оба ПК в локальной сети? Если да - то зачем нат? И еще - как Cisco роутер узнает как попасть в 192.168.10.x сеть?
0
Jabbson
Эксперт по компьютерным сетям
3460 / 2503 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
30.07.2011, 22:01 3
Схема отражает реальность?
0
Миниатюры
Настройка NAT на CISCO 851  
Jabbson
Эксперт по компьютерным сетям
3460 / 2503 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
30.07.2011, 23:40 4
Исключая то, что линк между Cisco Router и ПК1 и Cisco Router и второй роутер должен быть ST, а не CO
0
30.07.2011, 23:40
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
31.07.2011, 02:36  [ТС] 5
вот нарисовал схему
0
Миниатюры
Настройка NAT на CISCO 851  
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
31.07.2011, 02:52  [ТС] 6
Цитата Сообщение от Jabbson Посмотреть сообщение
И еще - как Cisco роутер узнает как попасть в 192.168.10.x сеть?
В роутере Dlink в NAT прописаны порты, в том числе посылки на порт 4899 направляются на ip 192.168.10.90
До cisco стоял linksys, все работало, то есть на роутере dlink все нормально настроено, прикрепляю скрин с рабочими настройками роутера linksys
0
Миниатюры
Настройка NAT на CISCO 851  
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
31.07.2011, 03:22  [ТС] 7
Цитата Сообщение от Jabbson Посмотреть сообщение
Исключая то, что линк между Cisco Router и ПК1 и Cisco Router и второй роутер должен быть ST, а не CO
Не совсем понял, что такое ST и CO ?
0
Jabbson
Эксперт по компьютерным сетям
3460 / 2503 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
31.07.2011, 11:02 8
Цитата Сообщение от exhale Посмотреть сообщение
И еще - как Cisco роутер узнает как попасть в 192.168.10.x сеть?
В роутере Dlink в NAT прописаны порты, в том числе посылки на порт 4899 направляются на ip 192.168.10.90
Пинганите с ПК1 комп ПК2. Пингуется?

Сделайте, пожалуйста, на роутере cisco
show ip route
и покажите что он ответит.

И про картинку ответьте - похоже на правду?

Проброс портов нужен был бы, если бы вы пытались стучаться РАдмином извне (из интернета). Зачем вам проброс портов в локальной сети, где все компы и там могут общаться друг с другом по уникальным локальным адресам?
0
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
31.07.2011, 14:21  [ТС] 9
ПК2 с ПК1 не пингуется


router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.2.0/24 is directly connected, Vlan1
router#

Картинка похожа

Через RAdmin будут заходить на ПК2 с ПК1 и с интернета, для этого нужен проброс. Дело в том, что даже в локальной сети не работает RAdmin. И с интернета тоже не заходит, подскажите, может что с настройками не так?
0
Jabbson
Эксперт по компьютерным сетям
3460 / 2503 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
31.07.2011, 14:59 10
Цитата Сообщение от exhale Посмотреть сообщение
ПК2 с ПК1 не пингуется
потому что Cisco роутер не знает как попасть в сеть 192.168.10.x

а вот тут мы видим этому прямое подтверждение - роутер знает только про сеть 192.168.2.x:
Цитата Сообщение от exhale Посмотреть сообщение
router#sh ip route
C 192.168.2.0/24 is directly connected, Vlan1
router#
Для того, чтобы работал РАдмин в локальной сети (пока без интернета) и компьютеры видели друг друга - просто напишите в Cisco роутере:

ip route 192.168.10.0 255.255.255.0 192.168.2.2

после этого show ip route будет выдавать вот это:

Router#show ip route
Gateway of last resort is not set

C 192.168.2.0/24 is directly connected, Vlan1
S 192.168.10.0/24 [1/0] via 192.168.2.2
после этого можно будет и пинговать и РАдминиться в локальной сети.

Прилагаю картинку с минимумом настроек на Cisco роутере.
Попробуйте, потом поговорим дальше про НАТ для того, чтобы извне РАдминиться.
0
Миниатюры
Настройка NAT на CISCO 851  
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
01.08.2011, 11:06  [ТС] 11
router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 87.255.xx.xx to network 0.0.0.0

87.0.0.0/27 is subnetted, 1 subnets
C 87.255.xx.xx is directly connected, FastEthernet4
S 192.168.10.0/24 [1/0] via 192.168.2.2
C 192.168.2.0/24 is directly connected, Vlan1
S* 0.0.0.0/0 [1/0] via 87.255.xx.xx
router#


Прописал, все равно не пингуется ПК2 (192.168.10.90) с ПК1 (192.168.2.99) и не Radmin-ится

Добавлено через 17 минут
Цитата Сообщение от Jabbson Посмотреть сообщение
Прилагаю картинку с минимумом настроек на Cisco роутере.
Попробуйте, потом поговорим дальше про НАТ для того, чтобы извне РАдминиться.

router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
router(config)#int fa0
router(config-if)#switchport access vlan1
^
% Invalid input detected at '^' marker.

router(config-if)#switchport access vlan 1
router(config-if)#switchport mode access
router(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches, bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION

%Portfast has been configured on FastEthernet0 but will only
have effect when the interface is in a non-trunking mode.
router(config-if)#int fa1
router(config-if)#switchport access vlan 1
router(config-if)#switchport mode access
router(config-if)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single host.
Connecting hubs, concentrators, switches, bridges, etc.to this interface
when portfast is enabled, can cause temporary spanning tree loops.
Use with CAUTION

%Portfast has been configured on FastEthernet1 but will only
have effect when the interface is in a non-trunking mode.
router(config-if)#int fa4
router(config-if)#ip address 87.255.хх.ххх 255.255.255.224
router(config-if)#ip nat outside
router(config-if)#int vlan 1
router(config-if)#ip address 192.168.2.1 255.255.255.0
router(config-if)#ip nat inside
router(config-if)#^Z
router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
router(config)#ip nat inside source list 1 interface FastEthernet4 overload
%Dynamic mapping in use, cannot change
router(config)#ip route 192.168.10.0 255.255.255.0 192.168.2.2
router(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet4
router(config)#access-list 1 permit 192.168.2.0 0.0.0.255
router(config)#^Z
router#write mem
Building configuration...
[OK]
router#

Проверьте пожалуйста, правильно ли я все ввел, а то что то с интернета не радминится

Добавлено через 9 часов 42 минуты
В старом роутере маршруты не прописаны, просто с ПК1 отправлялись пакеты на порт маршрутизатора dlink (192.168.2.2), а там уже прописано, что порт 4899 это отправлять на ПК2
0
Jabbson
Эксперт по компьютерным сетям
3460 / 2503 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
01.08.2011, 12:02 12
Значит что-то не так со вторым роутером - смотрите:
0
Вложения
Тип файла: rar forum.rar (7.2 Кб, 37 просмотров)
exhale
0 / 0 / 0
Регистрация: 15.07.2011
Сообщений: 7
01.08.2011, 13:42  [ТС] 13
со вторым роутером все ок, если я ставлю вместо циски линксис, все работает ведь
0
01.08.2011, 13:42
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.08.2011, 13:42

Настройка PPPOE и NAT на Cisco 881
Здравствуйте, друзья! С cisco в живую столкнулся впервые, до этого в покет трейсере пробовал что-то...

Настройка NAT (Cisco Packet Tracer)
Проблема такая: Имеется топология, на ней нужно настроить NAT для всей сети, но при этом...

Настройка NAT на трех маршрутизаторах Cisco
С горем пополам я сделал настройку NAT на 2 маршрутизаторах(inside и outside) но не сталкивался с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.