Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.93/14: Рейтинг темы: голосов - 14, средняя оценка - 4.93
ThisIsMyName
8 / 8 / 4
Регистрация: 17.11.2009
Сообщений: 36
1

Trunk port

21.08.2012, 15:23. Просмотров 2730. Ответов 11
Метки нет (Все метки)

Имеется 3 каталиста 3550. нужно настроить между ними связь с помощью транkовых портов.
Схема примерно такова:

Calatyst1(fa0/1(trunk)) --- catalyst2(fa0/1(trunk)+ fa0/2(trunk)-----catalyst3(fa0/1)

Ранее делалось очень быстро:
!
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,11
switchport mode trunk
!

Но после этих манипуляций в "sh int status" должно было в статусе интерфейса появиться примерно следующее:
Код
Fa0/2                        connected    trunk      a-full  a-100 10/100BaseTX
Но я имею вот такие данные:
Код
Fa0/2                        connected    1         a-full  a-100 10/100BaseTX
хотя 1ый порт с такой же конфигурацией очень даже хорошо работает.

Конфигурация каталистов идеинтичны, естественно кроме их айпи адресов
Код
Current configuration : 2927 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname c3550_3_11_1
!
ip subnet-zero
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,11
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 2,11
 switchport mode trunk
!
delete
!

interface FastEthernet0/24
 switchport access vlan 11
 switchport mode access
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 172.16.0.58 255.255.255.0
!
interface Vlan11
 no ip address
!
ip default-gateway 172.16.0.200
ip classless
ip http server
!
Так же пытался сделать данные действия на других портах - результат один и тот же.


Помагите разобраться, почему не прописывается транк порт на втором интерфейсе.

Добавлено через 16 минут
Может будет зацепкой, раньше второй порт на втором каталисте был в режиме "switchport mode access"
Хотя я до этого менял порты с аксеса на транк и было всё гуд.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.08.2012, 15:23
Ответы с готовыми решениями:

Trunk port между cisco 3750
Добрый день. Кто знает как создать транковый порт между двумя cisco 3750 ? По подробней...

2911 Trunk
Народ как на 2911 порт в транк поставить? IOS-c2900-universalk9_npe-mz.SPA.154-2.T1.bin

Trunk и access порты
есть порт который настроен на access vlan <какой то там> делаю его trunk, но при выводе инфы по...

Trunk порты в vlan
Есть 4 vlan-а ,которые имеют одинаковую структуру (Приведена на картинке). Маршрутизация между...

Trunk mode в sg200-26p
Доброго времени суток, коллеги! Возникла проблема с нарезкой VLANов и настройкой транка ...

11
Jabbson
Эксперт по компьютерным сетям
3458 / 2501 / 780
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
21.08.2012, 16:46 2
Можно взглянуть на вывод команд

Код
show interface fa0/2 switchport
show interface fa0/2 trunk
0
ThisIsMyName
8 / 8 / 4
Регистрация: 17.11.2009
Сообщений: 36
21.08.2012, 21:35  [ТС] 3
Код
show interface fa0/2 trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/2      on           802.1q         not-trunking  1

Port      Vlans allowed on trunk
Fa0/2      none

Port        Vlans allowed and active in management domain
Fa0/2      none

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/2      none

Код
#show interface fa0/2 switchport
Name: Fa0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: NONE
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
0
Jabbson
Эксперт по компьютерным сетям
3458 / 2501 / 780
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
21.08.2012, 21:47 4
Operational Mode: down
проблема может заключаться в:
1) с одной из сторон Вы забыли сделать no shutdown
2) Вы используете неверный тип кабеля (3550 не знает MDIX).
1
21.08.2012, 21:47
ThisIsMyName
8 / 8 / 4
Регистрация: 17.11.2009
Сообщений: 36
21.08.2012, 21:48  [ТС] 5
Цитата Сообщение от Jabbson Посмотреть сообщение
проблема может заключаться в:
1) с одной из сторон Вы забыли сделать no shutdown
2) Вы используете неверный тип кабеля (3550 не знает MDIX).
С 1ым вариантом навряд ли, а вот со вторым надо подумать
Спасибо большое. Завтра попробую!
0
Jabbson
21.08.2012, 21:50
  #6

Не по теме:

Всегда пожалуйста. Ждем завтра)

1
ThisIsMyName
8 / 8 / 4
Регистрация: 17.11.2009
Сообщений: 36
22.08.2012, 10:24  [ТС] 7
А если судить из логики конфигурации: даже если кабель не был бы подключен, в sh int status должен появитьcя "vlan" - "trunk", а не "1". как это можно объяснить?
0
Jabbson
Эксперт по компьютерным сетям
3458 / 2501 / 780
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
22.08.2012, 10:28 8
Это можно объяснить тем, что транк не согласовался между двумя свитчами.
1
ThisIsMyName
8 / 8 / 4
Регистрация: 17.11.2009
Сообщений: 36
22.08.2012, 10:30  [ТС] 9
Цитата Сообщение от Jabbson Посмотреть сообщение
Это можно объяснить тем, что транк не согласовался между двумя свитчами.
т.е. он должен подняться сам, после подключения ещё свича с транковым портом. Правильно?
0
Jabbson
Эксперт по компьютерным сетям
3458 / 2501 / 780
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
22.08.2012, 10:42 10
так точно
0
ThisIsMyName
8 / 8 / 4
Регистрация: 17.11.2009
Сообщений: 36
22.08.2012, 10:55  [ТС] 11
Цитата Сообщение от Jabbson Посмотреть сообщение
так точно
Спасибо большое за помощь! Всё работает.
0
Jabbson
22.08.2012, 11:11     Trunk port
  #12

Не по теме:

Цитата Сообщение от ThisIsMyName Посмотреть сообщение
Спасибо большое за помощь!
Всегда пожалуйста.

0
22.08.2012, 11:11
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.08.2012, 11:11
Привет! Вот еще темы с ответами:

Удаление trunk на cisco 3750g
Здравствуйте. Извиняюсь, не опытен я в сетевом оборудовании. Сеть состоит из мастера cisco...

Trunk в Cisco Packet Tracer
доброго времени суток! проблема следующая. имеется топология сети (в архиве). PC0-2 принадлежат...

Sip trunk от Cisco до Zycoo
Приветствую всех! Возникла такая проблема: настроил sip trunk от CUCM до IP PBX Zycoo CooVox-U20 в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru