Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.86/21: Рейтинг темы: голосов - 21, средняя оценка - 4.86
Silentheat
0 / 0 / 0
Регистрация: 12.04.2011
Сообщений: 11
1

Vlan на интерфейс маршрутизатора

19.02.2013, 21:11. Просмотров 4326. Ответов 9
Метки нет (Все метки)

Здравствуйте! Подскажите пожалуйста как повесить Vlan на интерфейс маршрутизатора (Cisco 2900 series)? А если более подробно, то есть маршрутизатор с тремя портами. Один из них должен быть транковым, чтобы принять Vlan"ы c другого конца (как это сделать?), а два других должны разделяться между собой. Конечно это легко делается с коммутаторами, но за неимением их мудрю с Циской.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.02.2013, 21:11
Ответы с готовыми решениями:

Редирект http трафика в Vlan на другой интерфейс
Уважаемые админы, возможно ли сделать следующее: Имеется Cisco 3560, через которую транзитом...

Не могу зайти в интерфейс маршрутизатора tl-wr720n
Помогите пожалуйста. Сказано зайти на http://tplinkwifi.net/ но там мне пишут Oops! It looks...

Доступ из одного vlan к электронному ключу в другом vlan
Возникла ситуация. При переводе компьютера в отдельный vlan программа 1С он перестала видеть...

Переброс траффика из одного Vlan в другой Vlan
Подскажите добрые люди умеют ли коммутаторы 2960S, 3750 перекидывать трафик из одного vlan в другой...

Немного непонятно про VLAN на основе протоколов (Protocol-Based VLAN)
Немного непонятно про VLAN на основе протоколов (Protocol-Based VLAN). В таких VLAN так же, как и в...

9
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
19.02.2013, 21:32 2
Код
interface fa 0/0
no shutdown
Код
interface fa0/0.1
encap dot1q 1 ,
где 1 номер первого влана
Код
interface fa0/0.2
encap dot1q 2
, где 2 номер второго влана

Технология называется sub-interface. Второй строчкой вы прописываете инкапсуляцию.
0
Silentheat
0 / 0 / 0
Регистрация: 12.04.2011
Сообщений: 11
19.02.2013, 22:12  [ТС] 3
А это прописывается на интерфейсе, который смотрит на Транк? и надо ли вешать на эти Vlanы ip-адреса?
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
19.02.2013, 22:49 4
Да, да нужно вещать...
0
19.02.2013, 22:49
Silentheat
0 / 0 / 0
Регистрация: 12.04.2011
Сообщений: 11
20.02.2013, 17:27  [ТС] 5
Ок, я повесил на vlan1 и vlan2 fa0/0 ip-адреса. Теперь у меня нужно, чтобы fa0/1 видел vlan1, а fa0/2 видел vlan2. Что мне нужно прописать на fa0/1 и fa0/2 ?
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
20.02.2013, 18:17 6
Ничего. Просто ip адреса.

int fa 0/1
ip add
no shu

Добавлено через 5 минут
Специфика работы в том, что VLAN это виртуальная сеть, поэтому если у нас транк порт на коммутаторе - мы расшиваем на порту маршрутизатора этот транк методом саб интерфейсов.

А если вы просто пишете int fa 0/1 и затем ip адреса, то вы КАК БЫ этим портом подключены к access порту.
0
Silentheat
0 / 0 / 0
Регистрация: 12.04.2011
Сообщений: 11
20.02.2013, 19:04  [ТС] 7
Но ведь, насколько я понимаю, fa0/1 и fa0/2 ,будут между собой видеть друг друга, так как они на одном маршрутизаторе. и если я на машине, подключенной к интерфейсу fa0/1 пропишу шлюз данного интерфейса, то моя машина будет также видеть и fa0/2. как мне избежать этого?
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
20.02.2013, 20:03 8
Да будет, создайте лист доступа а каждом интерфейсе влана с разрешенными сетями в вланах.
0
Silentheat
0 / 0 / 0
Регистрация: 12.04.2011
Сообщений: 11
20.02.2013, 21:20  [ТС] 9
))) Так, вот уже интереснее, подскажите пожалуйста синтаксис создания ACL.
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
20.02.2013, 23:23 10
access-list 100 permit ip 192.168.1.0 255.255.255.0 any host

access-list 101 permit ip 192.168.2.0 255.255.255.0 any host

interface fa 0/0.2
ip access-group 100

interface fa 0/0.3
ip access-group 101


Примерно так, где 192.168.1.0 это подсеть в влане 2, следовательно все что не в ней - дропается.
Следовательно на интерфейсах маршрутизатора 0/1 и 0/2 так же стоит прописать эти листы.

П.С. Листы не тестил. Попробуйте, если не получится - пишите, решим)
Сейчас занят просто.
0
20.02.2013, 23:23
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.02.2013, 23:23

VLAN и VLAN как увидеть друг друга
Доброго всем дня ! Захотелось значит нашему генеральному централизовать видео наблюдение и что б...

Маршрутизация между vlan и сетью без vlan
Была у нас раньше сеть(192.168.0.0) без vlanov,предприятие расширялось и со временем пришлось...

Iptables, правила, перенаправляющие на интерфейс eth1 все пакеты, приходящие на интерфейс eth0
Добрый день, подскажите, пожалуйста, как Iptables написать правила, перенаправляющие на интерфейс...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru