Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.73/15: Рейтинг темы: голосов - 15, средняя оценка - 4.73
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
1

Удаленный доступ к серверу

26.04.2013, 21:28. Просмотров 2940. Ответов 17

Здравствуйте.Подскажите пожалуйсто.
На работе есть Сервер пол Виндой и Cisco.В Cisco настроен тунель для удаленного доступа RDP также есть филиалы которые могут подключаться по удаленке к серверу но я из дома не могу подключиться.
Дома есть роутер Dlink dir 300.Я одного не могу догнать, Cisco нужно настраивать под мой роутер или мой роутер нужно настроить по Cisco?????
Прочитал,что надо делать проброс портов,только не понял,из дома или из работы из Cisco??????
На работе стстический ip.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.04.2013, 21:28
Ответы с готовыми решениями:

Cisco Firewall - удаленный доступ к серверу через VPN
Имеется сеть примерно на 20 машин, 2 файловых сервера, еще один с АД. Свитч в который это все...

Удаленный доступ к контроллеру
hi All, Сразу скажу, что я не админ и с cisco имею дело первый раз. Прошу сильно не пинать, если...

VPN JBPM удаленный доступ
В двух словах: Имеется сервер x.x.x.x, на котором выделена машинка. Коннект выполняется чере...

Удаленный доступ по telnet (в Packet Tracer)
Здравствуйте, товарищи. Только вот начал разбираться в Cisco Packet Tracer St. Думаю вас не...

Доступ к серверу
Построил сеть. Каждая группа из 12 робочих станций, отдельный vlan. Между собою сеть работает все...

17
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 21:44 2
На работе надо делать проброс или и на работе, и дома туннель.
0
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 21:59  [ТС] 3
Немного непонял,на работе уже настроен тунедль,как мне из дома подключиться к этому тунелю.
Знаю внешний ip
Знаю стистический ip
Знаю DNS
Знаю внутренний ip
Что сделать?
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 22:01 4
Цитата Сообщение от zura87 Посмотреть сообщение
на работе уже настроен тунедль
куда? не бывает просто туннель)
легче пробросить себе порт, доступ к консоли есть?
0
26.04.2013, 22:01
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 22:07  [ТС] 5
Да ести?Подключаюсь через Putty.
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 22:13 6
вывод
Код
show run | inc ip nat
0
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 22:18  [ТС] 7
А у меня дома динамичесеий IP,это прокатит?
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 22:19 8
прокатит
1
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 22:22  [ТС] 9
Спасибо.
В Cisco нужно указать мой внешний ip?
Что еще понадобится?
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 22:25 10
Ваш адрес не нужно будет указывать.
Нужно будет создать правило трансляции при обращении на внешний адрес циски по произвольному порту или 3389 во внутренний адрес (сервера) по порту 3389.
0
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 22:41  [ТС] 11
Правило уже настроено для порта 3389,потому ,что два филиала работают по удаленке.Значит у меня дома нужно пробросить порт?
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 22:45 12
Нет, не значит.
0
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 22:49  [ТС] 13
Почему?Если другие люди могут подключаться у кого настроено.Значит правило настроено...Ну а мне что делаль,посоветуйте конкретно пожалуйсто.....
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 22:54 14
Тогда покажите конфиг. Я исчерпал лимит экстрасенсорных способностей на сегодня.
0
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 23:03  [ТС] 15
Current configuration : 5632 bytes
!
! Last configuration change at 06:00:42
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco1
!
boot-start-marker
boot-end-marker
!
enable password s2
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login clientauth local
aaa authorization exec default local
aaa authorization exec clientauth local
aaa authorization network groupauthor local
!
!
!
!
!
aaa session-id common
memory-size iomem 10
clock timezone
!
crypto pki trustpoint TP-self-signed-409229217
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-409229217
revocation-check none
rsakeypair TP-self-signed-409229217
!
!
crypto pki certificate chain TP-self-signed-409229217
certificate self-signed 01
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
quit
ip source-route
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.150
!
ip dhcp pool DATA_1
network 192.168.0.0 255.255.255.0
domain-name mydomain.ru
default-router 192.168.0.1
dns-server 192.168.0.1
!
!
ip cef
ip name-server 21x.xx.xx.x
ip name-server 21x.xx.xxx.4
!
!
license udi pid CISCO861-K9 sn xxxxxxx

vtp mode transparent
username xxadmin privilege 15 secret 5 $1$ct/.$Br.HpWR.UFx7um.5C2V2q0
username administrator privilege 15 password 0 xxxxxxxx
!
!
!
!
crypto isakmp policy 1
hash md5
authentication pre-share
!
crypto isakmp policy 2
hash md5
authentication pre-share
group 2
crypto isakmp key xxxxxxx address 0.0.0.0 0.0.0.0
!
crypto isakmp client configuration group secure
key xxxxxx
dns 192.168.0.1
pool ippool
acl 150
save-password
max-users 10
crypto isakmp profile VPNclient
description === VPN clients profile ===
match identity group secure
client authentication list clientauth
isakmp authorization list groupauthor
client configuration address respond
virtual-template 1
!
!
crypto ipsec transform-set rtpset esp-des esp-md5-hmac
!
crypto ipsec profile VPNaccess
set transform-set rtpset
set isakmp-profile VPNclient
!
!
crypto dynamic-map rtpmap 10
set transform-set rtpset
match address 115
!
!
crypto map rtptrans 10 ipsec-isakmp dynamic rtpmap
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address 17x.xx.x.xx 255.255.255.224
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map rtptrans
!
interface Virtual-Template1 type tunnel
ip unnumbered Vlan1
tunnel mode ipsec ipv4
tunnel protection ipsec profile VPNaccess
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip local pool ippool 192.168.0.20 192.168.0.30
ip forward-protocol nd
no ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source route-map nonat interface FastEthernet4 overload
ip nat inside source static tcp 192.168.0.xx80 17x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.xx 81 17x.x.x.x 81 extendable
ip nat inside source static tcp 192.168.0.xx 3389 17x.x.x.x 3389 extendable
ip nat inside source static udp 192.168.0.xx 3389 17x.x.x.x 3389 extendable
ip nat inside source static tcp 192.168.0.xx 8080 17x.x.x.x 8080 extendable
ip nat inside source static tcp 192.168.0.xx 8081 17x.x.x.x 8081 extendable
ip route 0.0.0.0 0.0.0.0 17x.x.x.x
!
access-list 115 remark ==== for crypto ====
access-list 115 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 115 permit ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 115 deny ip 192.168.0.0 0.0.0.255 any
access-list 120 remark ==== For NAT ACL ====
access-list 120 deny ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 120 deny ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 120 permit ip 192.168.0.0 0.0.0.255 any
access-list 150 remark ==== EzVPN network ====
access-list 150 permit ip 192.168.0.0 0.0.0.255 any
access-list 150 permit ip 192.168.1.0 0.0.0.255 any
access-list 150 permit ip 192.168.2.0 0.0.0.255 any
route-map nonat permit 10
match ip address 120
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
transport input ssh
transport output all
!
scheduler max-task-time 5000
end
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 23:09 16
А чем не подходят уже существующие правила?
0
zura87
1 / 1 / 0
Регистрация: 22.12.2012
Сообщений: 37
26.04.2013, 23:14  [ТС] 17
Что мне в роутере моеи настроить,чтоб потключиться к удаленке,у меня DIR-300NRU rev.B7?
Я это и хотел узнать изначально . Просто так запарился уже,незнаю,что делать?
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
26.04.2013, 23:19 18
Ничего не нужно настраивать. Если те адреса, что Вы закрыли звездами - это внешние маршрутизируемые в интернете адреса, то ничего на вашей строне делать не нужно.
0
26.04.2013, 23:19
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.04.2013, 23:19

Доступ к внешнему серверу
Доброго времени суток! Прошу прощения, за скорее всего избитый вопрос, но увы не очень понимаю. ...

Доступ к серверу из vlan
Задание: 1 – компьютеры comp1, comp2 и comp3 находятся в одном VLAN 10, доступны только друг для...

Как разным vlan дать доступ к общему серверу?
У меня есть несколько компьютеров и сервер. Моя задача разбить компьютеры на под-сети таким образом...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
18
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.