Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.85/13: Рейтинг темы: голосов - 13, средняя оценка - 4.85
Avtandilko
1 / 1 / 1
Регистрация: 02.06.2012
Сообщений: 39
1

DHCP раздача адресов со свича третьего уровня

01.05.2013, 22:55. Просмотров 2502. Ответов 13

Добрый день возникла проблема. Есть следующая топология:

DHCP раздача адресов со свича третьего уровня


Порты на свиче 3-его уровня с no sw
На каждом порте свой IP c 10.0.1.1 по 10.0.5.1
Все хосты кроме одного находятся в 10-ом VLAN.
Необходимо сделать раздачу адресов на каждый порт из соответствующей подсети, но чего-то не получается.
Конфиг свича 3-его уровня:
Кликните здесь для просмотра всего текста
Код
Current configuration : 1830 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip dhcp pool 1
 network 10.0.1.0 255.255.255.0
 default-router 10.0.1.1
ip dhcp pool 2
 network 10.0.2.0 255.255.255.0
 default-router 10.0.2.1
ip dhcp pool 3
 network 10.0.3.0 255.255.255.0
 default-router 10.0.3.1
ip dhcp pool 4
 network 10.0.4.0 255.255.255.0
 default-router 10.0.4.1
ip dhcp pool 5
 network 10.0.5.0 255.255.255.0
 default-router 10.0.5.1
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
 no switchport
 ip address 10.0.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/2
 no switchport
 ip address 10.0.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/3
 no switchport
 ip address 10.0.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/4
 no switchport
 ip address 10.0.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/5
 no switchport
 ip address 10.0.5.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


На свичах второго уровня один порт trunk, остальные access, там проблем вроде как нет.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.05.2013, 22:55
Ответы с готовыми решениями:

Настройка свича уровня доступа (VLAN)
Всем привет! Подскажите пожалуйста, готовлюсь к сдаче теста по настройке свича...

Привязка адресов к mac DHCP
Не могу настроить ip dhcp pool unifi host 10.0.0.153 255.255.255.0 ...

Расширение пула адресов DHCP
Здравствуйте! Закончились адреса в 1 области DHCP. Создал суперобласть и...

Раздача DHCP через маршрутизатор (Cisco Packet Tracer)
Добрый день. Сеть в прикрепленной картинке. Кратко о настройках: часть слева -...

DNS/DHCP - ASUS DSL-N12U раздача интернета на компы со своими ip
Добрый день подскажите как заставить этот модем раздавать интернет в локалке с...

13
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
01.05.2013, 23:28 2
Цитата Сообщение от Avtandilko Посмотреть сообщение
На свичах второго уровня один порт trunk, остальные access, там проблем вроде как нет.
пардон, где там транк? со свитча 2го уровня в сторону L3 интерфейс на верхнем свитче? Зачем?
1
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
01.05.2013, 23:28 3
На 2 уровне в сторону 3 уровня висит Транк?
1
Avtandilko
1 / 1 / 1
Регистрация: 02.06.2012
Сообщений: 39
01.05.2013, 23:37  [ТС] 4
Да, транк в сторону коммутатора 3 уровня. Это сделано затем, чтобы была возможность подключать клиентов с белыми IP, которые будут сидеть уже в другом вилане со статическими адресами.
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
01.05.2013, 23:43 5
Логично предположить, если два человека сразу сделали акцент на Вашем выборе в использовании trunk интерфейса, значит возможно в нем ваши беды)
0
Avtandilko
1 / 1 / 1
Регистрация: 02.06.2012
Сообщений: 39
01.05.2013, 23:43  [ТС] 6
provider_network.zip
приложил саму схему в PT.
Действительно, при изменении на access адреса раздаются, но как тогда быть с белыми адресами за теми же свичами из абсолютно другой сети и в другом вилане?
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
01.05.2013, 23:48 7
Я вам подскажу: "А что если не переводить порт в no sw, а повесить адрес шлюза на vlan?"
0
Avtandilko
1 / 1 / 1
Регистрация: 02.06.2012
Сообщений: 39
02.05.2013, 00:05  [ТС] 8
Тогда я не вижу способа раздавать на разные порты L3 коммутатора адреса из разных пулов 1.0 - 5.0 с помощью единственного vlan 10.

Добавлено через 10 минут
Корректно ли будет на каждую подсеть создавать отдельный vlan? А если подсетей несколько сотен? Или я неправильно понял суть подсказки?
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
02.05.2013, 00:14 9
А у Вас именно такая задача? Почему не использовать разные vlan ?

Если проблема в доступности всем машин между собой, то есть router-on-stick.

Если Вам необходимо реализовать именно такой функционал....
Можно попробывать:
1)Создать несколько sub interface на физическом порту и повесив один и тот же vlan указать разные шлюзы ( Я так не пробывал, пакет трейсера под рукой нет)
2) Реализовать функционал с разными vlan )
0
Avtandilko
1 / 1 / 1
Регистрация: 02.06.2012
Сообщений: 39
02.05.2013, 00:18  [ТС] 10
Спасибо, буду все-таки реализовывать через несколько vlan.
Не знаю, как в реальных устройствах, но в packet tracer на интерфейсах L3 коммутатора нельзя создавать подынтерфейсы.
% Only routers can have sub interfaces in this version.
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
02.05.2013, 00:22 11
Тьфы ты, я забыл что это L3 свитч.

Да тока с помощью vlan. Возможно Jabbson знает и другие способы.
0
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
02.05.2013, 04:03 12
Цитата Сообщение от MonaxGT Посмотреть сообщение
Да тока с помощью vlan. Возможно Jabbson знает и другие способы.
Во-первых, идея одного вилана с несколькими подсетями мне не очень нравится.
Тем не менее, мне приходит в голову по крайней мере два выхода -

c транком: перетечь в другой вилан по транку между свитчами по native
без транка: для внешних адресов иметь secondary interface на L3 интерфейсе свитча.
0
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
03.05.2013, 11:52 13
вариант с перетеканием vlan
provider_network.rar
второй вариант с секондари адресами показать не могу - в CPT они не поддерживаются, а в гнс мне лень собирать.
0
Rayrik
0 / 0 / 0
Регистрация: 02.02.2013
Сообщений: 8
04.05.2013, 21:10 14
Удалено!
0
04.05.2013, 21:10
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.05.2013, 21:10

Съем статистики с коммутатотора третьего уровня
Добрый день. Стоит задача: снять сетевую статистику и таблицу маршрутизации с...

DIR-615 (2.5.5) по DHCP пускает в интернет. Без DHCP - не пускает. Как так?
Настраиваю на роутере (допустим 10.100.100.1) DHCP. Получаю IP, браузер, выхожу...

Однозначное отделение (классификация) оборудования уровня ядра/аггрегации от уровня доступа
Всем привет. Возник такой вопрос: можно ли по функциям или по железу понять...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru