Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/10: Рейтинг темы: голосов - 10, средняя оценка - 4.60
disnet
0 / 0 / 0
Регистрация: 05.12.2012
Сообщений: 21
1

Минимальная настройка BGP

14.05.2013, 16:48. Просмотров 1865. Ответов 4

коллеги, задача методом bgp получить доступ к сетям соседней AS ( см. вложение)


R1
R1#sh ip int bri
Код
R1#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.10.10.1      YES manual up                    up
Serial0/1                  unassigned      YES unset  administratively down down
Loopback0                  1.1.1.1         YES manual up                    up
R1#sh run | section router bgp
Код
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 10.10.10.2 remote-as 200
 no auto-summary

R2
R2#sh ip int bri
Код
R2#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.10.10.2      YES manual up                    up  
Serial0/1                  172.16.10.1     YES manual up                    up  
Serial0/2                  172.16.20.1     YES manual up                    up  
Loopback0                  2.2.2.2         YES manual up                    up
R2#sh run | sec router bgp
router bgp 200
no synchronization
bgp log-neighbor-changes
network 2.2.2.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 10.10.10.1 remote-as 100
neighbor 172.16.10.2 remote-as 200
neighbor 172.16.20.2 remote-as 200
no auto-summary[/CODE]

R3
R3#sh ip int bri
Код
R3#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  172.16.10.2     YES manual up                    up  
Loopback0                  3.3.3.3         YES manual up                    up
R3#sh run | section router bgp
Код
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 172.16.10.1 remote-as 200
 no auto-summary

R4
R4#sh ip int bri
Код
R4#sh ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  172.16.20.2     YES manual up                    up  
Loopback0                  4.4.4.4         YES manual up                    up
R4#sh run | section router bgp
Код
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 200
 no auto-summary



sh ip bgp на R1
Код
R1#sh ip bgp
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
*> 2.2.2.0/24       10.10.10.2               0             0 200 i
*> 3.3.3.0/24       10.10.10.2                             0 200 i
*> 4.4.4.0/24       10.10.10.2                             0 200 i
sh ip route на R1
Код
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 10.10.10.2, 01:48:49
     3.0.0.0/24 is subnetted, 1 subnets
B       3.3.3.0 [20/0] via 10.10.10.2, 01:43:28
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 10.10.10.2, 01:41:34
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial0/0


сети удаленной AS видны, маршруты тоже, но почему то указаны как iBGP соответственно связи нет.
Внутри AS 200 все сети друг друга видят. чего не хватает для сети AS 100?
я так понимаю для транзитного R2 нужно указать next-hop-self к сетям AS 200. как правильно применить не вкурю
0
Миниатюры
Минимальная настройка BGP  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.05.2013, 16:48
Ответы с готовыми решениями:

настроить cisco пограничные маршрутизаторы ospf-bgp,eigrp-bgp,rip-bgp
Помогите настроить cisco пограничные маршрутизаторы...

BGP маршрутизация
Добрый день, Пытаюсь настроить BGP, но не выходит, наверное какую-нибудь...

Wildcard и BGP
3 вопросика Wildcard, BGP , L2 VPN 1) Заметил что в ACL и в настройке...

BGP+eigrp
Вобщем встала задача из внутренней сети LAN LOCAL (192.168.0.0/21) пустить...

BGP. теория
Здарова. Сейчас прочитал про BGP и интересуют несоклько вопросов. Первый...

4
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,773
Записей в блоге: 3
14.05.2013, 17:28 2
на R2
neighbor 172.16.10.2 next-hop-self
neighbor 172.16.20.2 next-hop-self
0
disnet
0 / 0 / 0
Регистрация: 05.12.2012
Сообщений: 21
14.05.2013, 17:55  [ТС] 3
спасибо, разобрался
плюс ко всему нужно было анонсировать сети 10.10.10.0 и 172.16.10/20.0
кому интересно готовые части конфигов касаемых bgp:

R1
Код
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 network 10.10.10.0 mask 255.255.255.0
 neighbor 10.10.10.2 remote-as 200
 neighbor 10.10.10.2 update-source Serial0/0
 no auto-summary
R2
Код
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 network 10.10.10.0 mask 255.255.255.0
 neighbor 10.10.10.1 remote-as 100
 neighbor 10.10.10.1 update-source Serial0/0
 neighbor 10.10.10.1 next-hop-self
 neighbor 172.16.10.2 remote-as 200
 neighbor 172.16.10.2 next-hop-self
 neighbor 172.16.20.2 remote-as 200
 neighbor 172.16.20.2 next-hop-self
 no auto-summary
R3
Код
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 172.16.10.1 remote-as 200
 no auto-summary
R4
Код
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 network 172.16.20.0 mask 255.255.255.0
 neighbor 172.16.20.1 remote-as 200
 no auto-summary
0
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,773
Записей в блоге: 3
14.05.2013, 21:39 4
Цитата Сообщение от disnet Посмотреть сообщение
плюс ко всему нужно было анонсировать сети 10.10.10.0 и 172.16.10/20.0
смотря для чего

Объясните зачем нужны следующие строки?

R1
Цитата Сообщение от disnet Посмотреть сообщение
neighbor 10.10.10.2 update-source Serial0/0
R2
Цитата Сообщение от disnet Посмотреть сообщение
neighbor 10.10.10.1 update-source Serial0/0
Цитата Сообщение от disnet Посмотреть сообщение
neighbor 10.10.10.1 next-hop-self
или просто уже от безысходности все подряд писали?
0
disnet
0 / 0 / 0
Регистрация: 05.12.2012
Сообщений: 21
14.05.2013, 22:08  [ТС] 5
замечания приняты )
от безысходности давно бы бросил это дело )
не до конца разобрался со значениями команд, поэтому принудительно писал источник апдейта
0
14.05.2013, 22:08
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.05.2013, 22:08

BGP не работает
Схема: Роутер 6 прописал: Router(config)#interface FastEthernet2/0...

Как на Wi-Fi настроить BGP
Есть схема: Необходимо настроить BGP на роутерах. Всё работает, но вот как...

Двойной NAT и BGP
Каааак??? Нужно настроить двойной NAT на BGP-маршрутизаторе, подключенном к...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru