Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.70/91: Рейтинг темы: голосов - 91, средняя оценка - 4.70
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
1

Флапают маки в сети

23.05.2013, 15:57. Просмотров 16917. Ответов 15

Добрый день!
Возникла в сети проблема, прыгают маки по портам, вот логи:
006551: May 6 08:22:54: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.33ad.7146 in vlan 500 is flapping between port Gi1/0/4 and port Gi1/0/12
006552: May 6 08:22:57: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.33ad.7146 in vlan 500 is flapping between port Gi1/0/4 and port Gi1/0/12
006553: May 6 08:25:45: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.33ad.7146 in vlan 500 is flapping between port Gi1/0/4 and port Gi1/0/12
006554: May 6 08:26:34: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.33ad.7146 in vlan 500 is flapping between port Gi1/0/4 and port Gi1/0/12

mac адрес от cisco, int vlan 500 ядро слева.

Схема сети cisco3750 - cisco 3750 ядро
| \ / |
cisco3750 cisco3750 дистрибуция
| |
cisco 2960 cisco2960 доступ
Порт gi0/4 соединяет ядро слева с уровень дистрибуции, gi1/0/12 соединяет между собой ядра. Поднят HSRP. Вопрос, что может служить причиной данных логов, что мак адрес прыгает с порта.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.05.2013, 15:57
Ответы с готовыми решениями:

Почему на Сландо такие дешевые Маки?
Например этот:...

Можно ли с помощью TcpListener производить операции в сети Интернет, а не в локальной сети
Добрый день, извиняюсь за идиотский вопрос, но можно ли с помощью TcpListener производить операции...

Нейронные сети. Ошибка при обработке изоброжения для транировки сети
Здравствуйте, Работа над нейросетью в срде матлаб. На моменте с работой базой данных изображений...

Расчет маски сети, деление на подсети, постройка сети.Теория
Помогите разобраться в теории деления сетей на подсети на основе данной задачи. требуется: 1)...

Пропадает подключение к локальной сети и к сети интернет. Помогите пожалуйста.
Товарисчи, помогите пожалуйста! Всегда сеть работала нормально, но неожиданно появилось сообщение...

15
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
23.05.2013, 16:10 2
Цитата Сообщение от Spart87 Посмотреть сообщение
Схема сети cisco3750 - cisco 3750 ядро
| \ / |
cisco3750 cisco3750 дистрибуция
| |
cisco 2960 cisco2960 доступ
какая-то неконструктивная схема...исправьте, пжлст, добавьте порты, приложите конфиги.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
23.05.2013, 16:21  [ТС] 3
схема съехала, в ядре 2 cisco, на них поднят HSRP. Они между собой соединены g1/0/12 - g1/0/12. А также идут линки на уровень распределения, каждый с каждым. Уровень распеделения между собой никак не соединен. И от уровня распеделения на уровень доступа идет линк. Схема во вложении.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
23.05.2013, 16:28  [ТС] 4
вот
0
Миниатюры
Флапают маки в сети  
23.05.2013, 16:28
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
23.05.2013, 16:40 5
и мак адрес чего точно это?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
23.05.2013, 16:46  [ТС] 6
ядро 1
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1,5,200,400 priority 28672
spanning-tree vlan 10-11,100,300,500 priority 24576
!
vlan internal allocation policy ascending
!
vlan 5,10,200,300,400,500
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
----------------------------------------
----------------------------------------
interface GigabitEthernet1/0/12
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface Vlan1
ip address 172.16.*.* 255.255.254.0
ip helper-address 172.16.*.*
standby authentication md5 key-chain
standby 1 ip 172.16.*.*
standby 1 priority 110
ядро 2
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1,5,200,400 priority 24576
spanning-tree vlan 10-11,100,300,500 priority 28672
!
vlan internal allocation policy ascending
!
vlan 5,10,200,300,400,500
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk

interface Vlan1
ip address 172.16.*.* 255.255.254.0
ip helper-address 172.16.*.*
standby authentication md5 key-chain
standby 1 ip 172.16.*.*
Аналогичные конфиги на остальные порты и влан интерефейсы.
конфиги от уровня распределения
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10,100,200,300,400,500
!
interface GigabitEthernet1/0/1
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree portfast

-------------------------------------
interface GigabitEthernet1/0/51
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/52
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk

Добавлено через 2 минуты
это мак адрес созданного на ядре влан интерфейса. По данным ошибкам, было больше макфлапов, и все мак адреса vlan интерфейсов на cisco.
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
23.05.2013, 18:32 7
полностью бы конфиги (заменить внешние ip и пароли, поместить под спойлер), как-то пока проблем не вижу, вроде, кроме того, что на свитчах выславлен stp приорити для vlan 10 и 100, которые не заведены. И по "бест-практис" hsrp мастером для вилана должен быть рут - а у Вас наоборот.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
05.06.2013, 16:40  [ТС] 8
Сегодня проблема повторилась. На уровне распределение сначала пошли логи:
<180>1715: 001713: Jun 5 12:56:58: %SW_MATM-CLUSTER_MEMBER_5-4-MACFLAP_NOTIF: Host 0023.33ad.7146 in vlan 500 is flapping between port Gi1/0/47 and port Gi1/0/51
Порт gi1/0/47 смотрит в сторону access свитча
gi1/0/51 в сторону ядра.

На уровне ядра вот логи:
<180>12176: 012174: Jun 5 12:56:58: %SW_MATM-4-MACFLAP_NOTIF: Host 0023.33ad.7146 in vlan 500 is flapping between port Gi1/0/4 and port Gi1/0/12
Порт gi1/0/4 в сторону уровня распределения
Порт gi1/0/12 соединяется с вторым ядром. Поднят HSRP

причем вначале начинают прыгать mac адреса цисковского оборудования (0023.33ad.7146 - мак interface vlan 500, созданный на ядре).

Проблема возникает с разной периодичностью, то раз в неделю, то раз в 2 недели.
В чем может быть проблема

Добавлено через 11 минут
вот полный конфиг ядра 1
CORE
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1,5,200,400 priority 28672
spanning-tree vlan 10-11,100,300,500 priority 24576
!
vlan internal allocation policy ascending
!
vlan 5,10,200,300,400,500
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/5
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/6
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/7
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/8
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/9
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/10
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/11
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/12
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface Vlan1
ip address 172.16.*.* 255.255.254.0
ip helper-address 172.16.*.*
standby authentication md5 key-chain ****
standby 1 ip 172.16.*.*
standby 1 priority 110
!
interface Vlan5
ip address 172.42.*.* 255.255.255.240
ip access-group 105 in
standby authentication md5 key-chain ****
standby 1 ip 172.42.*.*
standby 1 priority 110
!
interface Vlan10
no ip address
!
interface Vlan100
no ip address
!
interface Vlan200
ip address 172.16.*.* 255.255.255.0
ip helper-address 172.16.*.*
standby authentication md5 key-chain ****
standby 1 ip 172.16.*.*
standby 1 priority 110
!
interface Vlan300
ip address 172.16.*.* 255.255.255.0
ip helper-address 172.16.*.*
standby authentication md5 key-chain ****
standby 1 ip 172.16.*.*
!
interface Vlan400
ip address 172.16.*.* 255.255.254.0
ip access-group 140 in
ip helper-address 172.16.*.*
standby authentication md5 key-chain ****
standby 1 ip 172.16.*.*
standby 1 priority 110
!
interface Vlan500
ip address 172.16.*.* 255.255.254.0
ip access-group 150 in
ip helper-address 172.16.*.*
standby authentication md5 key-chain ****
standby 1 ip 172.16.*.*
Ядро 2 аналогично, только priority различны

Конфиг уровня распределения.
DISTRIBUTION
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10,100,200,300,400,500
!
interface GigabitEthernet1/0/1

!
interface GigabitEthernet1/0/2

!
interface GigabitEthernet1/0/3

!
interface GigabitEthernet1/0/4

!
interface GigabitEthernet1/0/5

!
interface GigabitEthernet1/0/6

!
interface GigabitEthernet1/0/7

!
interface GigabitEthernet1/0/8

!
interface GigabitEthernet1/0/9

!
interface GigabitEthernet1/0/10

!
interface GigabitEthernet1/0/11

!
interface GigabitEthernet1/0/12

!
interface GigabitEthernet1/0/13

!
interface GigabitEthernet1/0/14

!
interface GigabitEthernet1/0/15

!
interface GigabitEthernet1/0/16

!
interface GigabitEthernet1/0/17

!
interface GigabitEthernet1/0/18

!
interface GigabitEthernet1/0/19

!
interface GigabitEthernet1/0/20

!
interface GigabitEthernet1/0/21

!
interface GigabitEthernet1/0/22

!
interface GigabitEthernet1/0/23

!
interface GigabitEthernet1/0/24

!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
!
interface GigabitEthernet1/0/34
!
interface GigabitEthernet1/0/35
!
interface GigabitEthernet1/0/36
!
interface GigabitEthernet1/0/37
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45

!
interface GigabitEthernet1/0/46
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/47
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/48
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/49
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/50
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/51
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/52
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
spanning-tree portfast trunk
!
interface Vlan1
ip address 172.16.*.* 255.255.255.0

конфиг уровня доступа
ACCESS
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
name vlan2
!
vlan 10,100,400,500
!
interface FastEthernet0/1
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/2
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/3
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/4
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/5
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/6
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/7
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/8
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/9
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/10
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/11
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/12
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/13
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/14
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/15
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/16
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/17
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/18
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/19
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/20
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/21
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/22
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/23
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/24
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/25
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/26
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/27
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/28
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/29
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/30
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/31
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/32
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/33
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/34
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/35
switchport access vlan 500
switchport mode access
switchport voice vlan 400
speed 100
duplex full
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/36
switchport access vlan 500
switchport mode access
switchport voice vlan 400
speed 100
duplex full
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/37
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/38
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/39
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/40
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/41
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/42
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/43
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/44
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/45
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/46
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/47
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface FastEthernet0/48
switchport access vlan 500
switchport mode access
switchport voice vlan 400
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface GigabitEthernet0/1
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
!
interface GigabitEthernet0/2
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust cos
auto qos voip trust
!
interface Vlan1
ip address 172.16.*.* 255.255.255.0
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
05.06.2013, 19:14 9
Неизвестные устройства могут быть в сети? В обратном случае, не понятно как может мак ядра может приходить от доступа.
0
MonaxGT
Эксперт по компьютерным сетям
275 / 275 / 25
Регистрация: 02.08.2012
Сообщений: 1,219
05.06.2013, 20:18 10
Я может сейчас чушь скажу)) но может привести их к единому стандарту stp?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
05.06.2013, 21:19  [ТС] 11
в сети есть хабы, подключенные к уровню доступа. По логам на ядре, маки прыгали на 4 ядре и 12, 4 и 3, 4 и 1. Единый порт 4, привел меня к уровню распредиления, который подключен на 4 этаже. НА уровне распределения маки прыгали на 47 и 51, 47 и 52. Единый порт 47, к нему подключен аксесс свитч. Я стал отключать программно порты, частями, пока ошибки не прекратились.ПОнять не смог с какого порта идут ошибки. И петля рассасалась. К этому свичу подключены три неуправляемых ус-ва(хаба), но в данный момент ошибок нет.
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
06.06.2013, 00:47 12
Код
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
мне кажется, в такой связке работать будет только filter, может оставить только guard?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
06.06.2013, 08:58  [ТС] 13
Возможно!!! я не так давно занимаюсь сетями, поэтому черпаю инфу из разных исочников и от гуру!
Скажите, как лучше настроить порты на коммутаторах.
В моем понимании, на портах access свичей лучше поставить только настройку bpdu guard и bpdu portfast - что приведет порт при получении bpdu в режим откл. Нет возможности отслеживать, есть ли за портами хабы или нет, потому что люди постоянно перемещаются с хабами. Лучше отключится один порт на аксесс свитче, чем пойдут ошибки по всей сети.
Вопрос, лучше ставить настройку bpdu guard глобально или на интерфейсах.

В случае, если к порту подключен сервер, сделать настройку bpdu filter и bpdu portfast.
На транковых портах поставить bpdu portfast, чтобы порт переходил в состояние форвардинг без замедления.

Скажите, как лучше произвести настройки, в каком сочетании, имея схему, которую я выкладывал ранее.
Спасибо!!!
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
06.06.2013, 17:17 14
Просто bpdufilter точно не нужно оставлять - это выключение stp. Можно guard (пришло bpdu - выключились), можно portfast guard (интерфейсы, которые в портфаст - юзают bpduguard), portfast bpdufilter (не посылаются bpdu, а как только приходят - порт выключает portfast и работает в обычном режиме). Выбирайте тот, что Вам ближе.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
06.06.2013, 21:45  [ТС] 15
настрою на портах доступа spanning-tree bpduguard
spanning-tree portfast
Сегодня ошибки повторились, я уже знал на какой access свитч смотреть и знал в каких портах подключены пользовательскте хабы. Отключая их, понял когда ошибки закончились.Проверил хаб, закальцован он не был, но тем не менее его выкинул. Это уже второй хаб, при выключении которого ошибки прекращаются.
ВОт не знаю, на верном ли я пути(((. В конфигах не указано, но в сети у нас есть пользователи, которые подключены в уровень распределения, там на этих портах такие же настройки, как на access свитчах(bpduguard, bpduilter)
А какие лучше настройки делать на транковом линке от акссес свитча к уровню распределения(избыточных соединений нет, только один патчкорд), и от уровня распределения к ядрам (там два оптических патча, и порты работают, в зависимости от заданного приоритета HSRP для влан интерфейсов.) У меня в данный момент на транках только portfast.
Заранее спасибо!
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,935
Записей в блоге: 3
06.06.2013, 22:56 16
бест практисом на транках считается
Код
выключить dtp
разрешить только те vlan, которые нужны
native - неиспользуемый вилан
по стп
Код
rstp из-за быстроты
stp на доступе работает
руты мануально назначеные
stp рут совпадает с hsrp мастером
лупгарды на аплинке доступа
лупгарды между распределением
рутгарды на даунлинке распределения
рутгарды / бпдугарды / портфаст на даунлинке доступа
Вот тут есть выжимка BP по STP.
0
06.06.2013, 22:56
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.06.2013, 22:56

По заданным IP-адресу узла сети и маске определите адрес сети
В терминологии сетей TCP/IP маской сети называют двоичное число, которое показывает, какая часть...

Настройка сети, adsl модем и свитч (20 компьютеров в сети и интернет)
Мне нужно объеденить в сеть 20 пк. И раздать на них интернет. В наличии есть модем-роутер TP-Link...

Узнать ip-адрес компьютера по сети, зная его имя в сети
Ребята подскажите, пожалуйста, по такому вопросу. Как можно узнать ip-адрес компьютера в сети зная...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru