Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.54/13: Рейтинг темы: голосов - 13, средняя оценка - 4.54
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
1

QOS

28.05.2013, 22:52. Просмотров 2651. Ответов 20

Стоит задача промаркировать трафик IP телефонии, и видеоконференции, задать им необходимую полосу, в случае надобности. Т.е. если трафик есть, то он идёт с приоритетом, если нет, то вся полоса предоставляется для остального трафика.
Есть две cisco. На одной поднят сабинтерфейс, на второй физический интерфейс fa0/0. Канал L2, 10мбит.
конфигурация с fa0/0:
class-map match-any Real-Time
match protocol rtp audio
match access-group 120
!
policy-map QOS
class Real-Time
set ip precedence 5
priority 2500
!
interface FastEthernet0/0
description ###Moscow through Vest Call###
bandwidth 10000
ip address 10.*.*.* 255.255.255.192
ip flow ingress
ip flow egress
duplex auto
speed auto
max-reserved-bandwidth 90
service-policy output QOS


По данному конфигу, я понимаю, что под трафик в классе Real-Time, будет выделяться гарантированная полоса 2,5мбит/с, не больше. Остальное под оставшийся.
И что значит max-reserved-bandwidth 90 ? не понимаю до конца сути.

На сабинтерфейс данную политику не повесишь, как быть?

с сабинтерфейсом
class-map match-any Real-Time
match protocol rtp audio
match access-group 120

policy-map RTP
class Real-Time
priority 2500

policy-map QOS
class class-default
shape average 10000000
service-policy Real-Time

interface ethernet0/0.1
service-policy out QOS


по этому конфигу, будет ли он работать?

Заранее спасибо!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.05.2013, 22:52
Ответы с готовыми решениями:

Cisco SG300-10 QoS и очереди?
Уважаемые форумчане, доброго времени. На новой работе столкнулся с коммутатором Cisco SG300-10....

Настройка QoS на коммутаторе cisco в gns3
В общем нужно наконфить простенький QoS, очереди не нужны, необходима простая приоритезация. 1) 2...

Cisco 1841 + QoS + RTP непонятная работа
Добрый день уважаемые форумчане, а кому и не день, а ночь =). Прошу помочь с разъяснение работы...

6500 sup720-3b qos vlan-based нарезка скорости
Приветствую. Столкнулся с проблемой. Пытаюсь нарезать скорость для юзверей на uplink влане. Но при...

QoS mode отличия
Здравствуйте! Подскажите, пожалуйста, в настройках роутера есть два режима для QoS : Restricted...

20
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
29.05.2013, 13:42 2
Можно Вас попросить приложить схему, где было бы отражено откуда трафик идет, куда уходит, где Вы пытаетесь организовать маркировку и где политику с указанием портов.

Цитата Сообщение от Spart87 Посмотреть сообщение
И что значит max-reserved-bandwidth 90 ? не понимаю до конца сути.
по умолчанию циска разрешит зарезервировать до 75% полосы под политики qos.
этой командой можно сдвинуть границу возможной резервации.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
29.05.2013, 14:46  [ТС] 3
Схема во вложении.
маршрутизатор MOSCOW сабинтерфейсом fa0/0.1 смотрим на маргрутизатор PITER fa0/0, что и является узким местом10 мбит/с.
Есть MCU 4510, от которой идет трафик видеоконференции. На основе acl трафик промаркировать.
Телефония, на основе rtp audio.
0
Миниатюры
QOS  
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
29.05.2013, 14:56  [ТС] 4
Будет ли выполнять необходимые функции конфиг, который я выложил, а точнее: в момент загруженности канала, трафику критичному к потерям будет выделяться полоса не более 2,5 мбит гарантировано. Пробовал маркировать трафик, приходит с метками, т.е. провайдер не перекрашивает его.

Добавлено через 6 минут
Политики соответсвенно вешать буду на сабинтерфейс и интерфейс, смотрящие в провайдера.
0
29.05.2013, 14:56
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
29.05.2013, 15:13 5
Да, LLQ сделан верно. Хочу отметить, что:
  • политика будет отрабатывать только когда на интерфейсе будет "перегрузка" (congestion)
  • priority не только выделяет приоритетную полосу классу, но и лимитирует этот класс указанным значением.

нераскрытой осталась тема про "set ip precedence 5"

также интересует - правда ли имелось ввиду match-any - то есть под политику попадает трафик rtp audio или любой трафик от адресов указанных в 120 acl?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
29.05.2013, 15:26  [ТС] 6
Спасибо за ответы!
А перегруз будет считаться по параментру bandwidth на интерфейсе, который указан, т.е. при превышении 10мбит?

а со стороны маршрутизатора MOSCOW, политика на сабинтерфейсе также должна отрабатывать?
команда shape average 10000000 что значит?
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
29.05.2013, 15:40 7
Цитата Сообщение от Spart87 Посмотреть сообщение
А перегруз будет считаться по параментру bandwidth на интерфейсе, который указан, т.е. при превышении 10мбит?
нет, перегруз будет считаться при переполнении hardware-буфера интерфейса.
Цитата Сообщение от Spart87 Посмотреть сообщение
а со стороны маршрутизатора MOSCOW, политика на сабинтерфейсе также должна отрабатывать?
я про него и говорил
Цитата Сообщение от Spart87 Посмотреть сообщение
команда shape average 10000000 что значит?
значит, что вест трафик будет шейпиться под 10Мб/с
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
29.05.2013, 15:48  [ТС] 8
а хард буфер какой у интерфейса? как его задать?

По поводу "нераскрытой осталась тема про "set ip precedence 5"

также интересует - правда ли имелось ввиду match-any - то есть под политику попадает трафик rtp audio или любой трафик от адресов указанных в 120 acl? "

под политику попадает rtp audio (это телефония), а в acl указан access-list 100 permit ip host 10.10.0.1 any одной стороны, с другой всё что идёт на 10.10.0.1
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
29.05.2013, 16:00 9
Цитата Сообщение от Spart87 Посмотреть сообщение
а хард буфер какой у интерфейса? как его задать?
эта очередь на то и хардварная, чтобы быть железно зашитой. cisco не рекомендует менять это значениа (hold-queue)

Цитата Сообщение от Spart87 Посмотреть сообщение
под политику попадает rtp audio (это телефония), а в acl указан access-list 100 permit ip host 10.10.0.1 any одной стороны, с другой всё что идёт на 10.10.0.1
если нужно чтобы было как rtp от ip из acl 120, то нужно match-all
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
29.05.2013, 16:08  [ТС] 10
ок!!!
вы пишите, что "политика будет отрабатывать только когда на интерфейсе будет "перегрузка" (congestion) "
перегруз зашит программно!
а мне нужно, чтобы политика срабатывала при превышении потока трафика в 10 мбит, когда и возможны потери пакетов.
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
29.05.2013, 16:17 11
Цитата Сообщение от Spart87 Посмотреть сообщение
а мне нужно, чтобы политика срабатывала при превышении потока трафика в 10 мбит, когда и возможны потери пакетов.
если у вас 10 Мб на 100 Мб интерфейсе - делайте шейпинг, как и на другой стороне.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
30.05.2013, 09:16  [ТС] 12
конфиг со стороны интефейса FA0/0 будет тогда следующий:

class-map match-any Real-Time
match protocol rtp audio
match access-group 120

policy-map QOS
class Real-Time
shape peak 10000000
set ip precedence 5 " данная строчка никакой нагрузки не носит, только смотрю, приходит ли маркированный трафик с другой стороны "
class class-default
shape peak 7500000

service-police output QOS


Данный конфиг, как я понимаю подразумевает, следующее, если я не прав, поправте!!!
Трафику, попадающему под Real-Time в случае свободной полосы, может выделиться 10 мбит/с.
Default трафику может выделиться 7,5 мбит/с, не больше.
В случае загрузки канала на полную, до 10 мбит/с, Real-time трафику гарантирована полоса в 2,5 мбит, а т.е. голос и видео страдать не должны....
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
30.05.2013, 11:31 13
Цитата Сообщение от Spart87 Посмотреть сообщение
class-map match-any Real-Time
match protocol rtp audio
match access-group 120
policy-map QOS
class Real-Time
shape peak 10000000
set ip precedence 5 " данная строчка никакой нагрузки не носит, только смотрю, приходит ли маркированный трафик с другой стороны "
class class-default
shape peak 7500000
service-police output QOS
не правильно. почему Вы не хотите сделать так, как с другой стороны - шейпинг дефолту, и иерархический сервис полиси?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
30.05.2013, 11:45  [ТС] 14
хочу разобрать разные варианты, а в чем у меня в последнем конфиге проблема?
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
30.05.2013, 11:51 15
Цитата Сообщение от Spart87 Посмотреть сообщение
В случае загрузки канала на полную, до 10 мбит/с, Real-time трафику гарантирована полоса в 2,5 мбит
почему?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
30.05.2013, 11:58  [ТС] 16
я так понимаю данную команду,
для класса трафика Real-Time доступна пиковая полоса 10000000 бит/сек, и этот трафик на выходе маркируется классом 5. Всему остальному трафику (class class-default) гарантируется не более 7500000 бит/сек. Таким образом, для Real-Time неявным образом гарантируется 10000000 - 7500000 = 2500000 бит/сек.
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
30.05.2013, 12:03 17
Цитата Сообщение от Spart87 Посмотреть сообщение
я так понимаю данную команду,
для класса трафика Real-Time доступна пиковая полоса 10000000 бит/сек, и этот трафик на выходе маркируется классом 5. Всему остальному трафику (class class-default) гарантируется не более 7500000 бит/сек. Таким образом, для Real-Time неявным образом гарантируется 10000000 - 7500000 = 2500000 бит/сек.
а если RT трафик придет первым и займет полосу, как потом пропускная способность будет отжиматься для остального трафика? Как роутер поймет кого приоритировать?
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
30.05.2013, 12:11  [ТС] 18
мммм, подскажите, что нужно поправить в этом конфиге????чтобы было вытеснение приоритетным трафиком не приоритетрного.

в нашей сети, по данному каналу Real-Time трафик не превышает 2500000 бит/с, т.е. он не может никак забить все 10 мбит, а вот class-defaul может спокойно вылазить за эти пределы, поэтому я задал ему не больше 7500000. Данный конфиг я понимаю не грамотный(((, но работать должен и видео и телефония не должны страдать.
0
Jabbson
Эксперт по компьютерным сетям
3454 / 2498 / 779
Регистрация: 03.11.2009
Сообщений: 7,939
Записей в блоге: 3
30.05.2013, 12:26 19
шейпинг всего трафика на 10М, priority на приоритетный трафик, - когда полоса свободная остальной трафик берет столько, сколько надо - когда загрузка - приоритетный вытесняет остальной, но не вылезает за значение приорити. а вообще можете и свой - ну не будет работать как надо - переделаете.
0
Spart87
1 / 1 / 0
Регистрация: 23.05.2013
Сообщений: 95
30.05.2013, 12:28  [ТС] 20
спасибо вам!за информацию
0
30.05.2013, 12:28
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.05.2013, 12:28

Настройка QoS TP Link TD-W8951 ND
Всем привет. Помогите настроить QoS для модема Tp Link. Дома стоят 2 компа, и если на одном из них...

3G и QoS
Подскажите,W 8.1 сильно режет интернет 3G,в настройках QoS стоит резервирование системой...

Настройка QoS
Доброго дня всем! У меня такой вопрос : знает ли кто нибудь как правильно настроить QoS на Tenda...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru