Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/11: Рейтинг темы: голосов - 11, средняя оценка - 5.00
Molnus
0 / 0 / 0
Регистрация: 16.12.2012
Сообщений: 11
1

Cisco Packet Tracer - общий ресурс для всех VLAN

13.06.2013, 17:34. Просмотров 2147. Ответов 9

Здравствуйте.
Помогите разобраться с этим чудо-эмулятором сетей..

Хочу сделать следующее:
3 VLANа, компы каждой имеют доступ только к компам родной VLAN, но все компы должны иметь доступ к одному общему серверу.
В инете находил руководство по этому делу, там куча разнообразных настроек через команд.строку. Но я запутался и ничего не понял=((( Смог лишь изолировать ВЛАНы друг от друга..но с сервером никак..=\\

Если таки можно сее настроить не прибегая к команд.строке, а чисто визуально (как я сделал все эти ВЛАНы) - напишите пожалуйста..


Проект прилагаю.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.06.2013, 17:34
Ответы с готовыми решениями:

Vlan (Cisco Packet Tracer)
Настроил vlan создал dhcp pool выдал айпи но ноутбук получает апипа не могу понять почему?

Cisco packet tracer vlan
Вопрос довольно глупый, но все же. Может ли один и тот же компьютер быть в 2 vlan?

VLAN на коммутаторах CISCO (в Cisco Packet Tracer)
Здравствуйте! Имелась схема (во вложении): три коммутатора и три маршрутизатора соединялись...

Cisco Packet Tracer Vlan на роутерах
Всем привет! Пытаюсь настроить небольшую сеть: роутер (2911), коммутатор (2960) и нисколько РС. На...

Команды Vlan (Cisco Packet Tracer)
Здравствуйте. Можете подсказать какие команды нужно ввести в настройках коммутатора, чтоб удалить...

9
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
13.06.2013, 17:51 2
на ядре делаете SVI (interface vlan). его делаете шлюзом для своих компов, на SVI вешаете ACL.
0
Molnus
0 / 0 / 0
Регистрация: 16.12.2012
Сообщений: 11
13.06.2013, 18:06  [ТС] 3
Цитата Сообщение от Jabbson Посмотреть сообщение
на ядре делаете SVI (interface vlan). его делаете шлюзом для своих компов, на SVI вешаете ACL.
А чуть-чуть подробней можно? Что и где?) Я впервые слышу все эти странные слова =\\
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
13.06.2013, 18:28 4
Тема 1: InterVLAN Routing
Тема 2: ACL
0
13.06.2013, 18:28
Molnus
0 / 0 / 0
Регистрация: 16.12.2012
Сообщений: 11
13.06.2013, 18:50  [ТС] 5
Мдя...т.е. визуально с этим делом никак не разобраться..
Сложновато=(( еще и по английски))

Но все равно спасибо. Буду разбираться=)
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
13.06.2013, 21:51 6
Визуально с этим делом точно не разобраться, это факт.
Если будут вопросы - задавайте, будем вместе разбираться.

можете посмотреть пример настройки маршрутизации между VLAN тут. Вам нужно тоже сделать такие логические L3 интерфейсы (interface vlan), включить роутинг. А потом на эти интерфейсы применить фильтрующие правила. Интерфейс в сторону сервера можно перевести в L3 режим (no switchport) и выдать ему ip address из подсети, в которой находится сам сервер.
0
Molnus
0 / 0 / 0
Регистрация: 16.12.2012
Сообщений: 11
15.06.2013, 16:55  [ТС] 7
Цитата Сообщение от Jabbson Посмотреть сообщение
Визуально с этим делом точно не разобраться, это факт.
Если будут вопросы - задавайте, будем вместе разбираться.

можете посмотреть пример настройки маршрутизации между VLAN тут. Вам нужно тоже сделать такие логические L3 интерфейсы (interface vlan), включить роутинг. А потом на эти интерфейсы применить фильтрующие правила. Интерфейс в сторону сервера можно перевести в L3 режим (no switchport) и выдать ему ip address из подсети, в которой находится сам сервер.
Сделал следующую сеть.
Два обычных коммутатора (PT-Empty) каждому по два компа прицепил. Эти два коммутатора присоединил к одному многоуровневому, к нему же прицепил сервер.
Создал VLAN2 и VLAN3, с адресами 192.168.2.1 и 192.168.3.1 соответственно.
Адреса задавал в CLI многоуровн.ком-ра вот таким образом:
sw3(config)# interface Vlan2
sw3(config-if)# ip address 192.168.2.1 255.255.255.0
sw3(config-if)# no shutdown

Перед этим включил роутинг.
У компов в VLAN2 адреса от 192.168.2.2. В VLAN3 по тому же принципу.
Интерфейс на сервер сделал так:
sw3(config)#interface FastEthernet 0/3
sw3(config-if)# no switchport
sw3(config-if)# ip address 192.168.4.1 255.255.255.0
sw3(config-if)# no shutdown

Сам сервер имеет адрес 192.168.4.2

На всякий случай файл проекта вот.

Из Ваших указаний вроде всё, кроме фильтрующих правил.
Как назначить эти фильтрующие правила теперь?)) В статье такого не нашел.. Что-то про правила есть в этой статьей, там под конец, но я не совсем понял + до этого пытался сделать подобное - ничего не вышло..=\

И еще, как настроить транки? Сейчас они установлены по умолчанию, в ацесс 1.
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
15.06.2013, 17:17 8
Смотрите,
  • настройте виланы на L2 свитчах
  • поместите порты в сторону PC в соответствующие виланы
  • линки в сторону L3 свитча сделайте транками.
  • задайте компам и серверу шлюзы (адреса на L3 свитче)
  • создайте на L3 свитче access-list, где разрешите обращаться только на сервер.
    Код
    ip access-list extended ONLY_TO_SERVER
     permit ip any host 192.168.4.2
  • примените его на interface vlan 2 и interface vlan 3 командой
    Код
    ip access-group ONLY_TO_SERVER in

Все должно работать согласно вашему плану.

Если это не так, то можно сравнить с моим вариантом.
VLAN3.rar
1
Molnus
0 / 0 / 0
Регистрация: 16.12.2012
Сообщений: 11
15.06.2013, 17:47  [ТС] 9
Цитата Сообщение от Jabbson Посмотреть сообщение
Все должно работать согласно вашему плану.
Если это не так, то можно сравнить с моим вариантом.
VLAN3.rar
Эх..ваш проект моя 5.3.2 версия к сожалению не осилила..%)
Но и ладно. В принципе получилось. Но получилось вот что - у меня теперь с любого компа есть доступ на любой, в т.ч. и на сервер=)) Как бы теперь изолировать сети?

Добавлено через 11 минут
Вроде разобрался. Настроил транки соответствующим образом и теперь при попытке обращения к чужой ВЛАН-сети выдает "хост назначения недоступен". думаю, это нормально)) Просто раньше обычно таймаут был)

В общем, цели достиг=))
Спасибо Вам большое за помощь
0
Jabbson
Эксперт по компьютерным сетям
3448 / 2492 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
15.06.2013, 18:03 10
Цитата Сообщение от Molnus Посмотреть сообщение
Спасибо Вам большое за помощь
всегда пожалуйста.
1
15.06.2013, 18:03
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.06.2013, 18:03

Команды Vlan (Cisco Packet Tracer)
Здравствуйте. Можете подсказать какие команды нужно ввести в настройках коммутатора, чтоб удалить...

Лаба в Cisco Packet Tracer на Vlan
Доброй ночи. При выполнении лабы столкнулся с одной проблемой. Необходимо связать несколько...

Соединение ПК с vlan (в Cisco Packet Tracer)
Необходимо создать доступ с сервера к vlanу который не состоит в нем. Подскажите как можно это...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru