Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.78/9: Рейтинг темы: голосов - 9, средняя оценка - 4.78
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
1

не поднимается после ребута interface Virtual-Template2

02.07.2013, 10:53. Просмотров 1783. Ответов 15
Метки нет (Все метки)

Помогите разобраться. Вопрос стоит в том что при перезагрузке машика виртуальный интерфейс interface Virtual-Template2 type tunnel не поднимается пока его ручками не заведешь. В чем может быть проблема?
Кликните здесь для просмотра всего текста

crypto isakmp policy 10
encr aes
authentication pre-share
crypto isakmp key cisco address 10.8.8.10
crypto isakmp invalid-spi-recovery
crypto isakmp keepalive 20 periodic
!
!
crypto ipsec transform-set baza esp-aes esp-sha-hmac
!
crypto ipsec profile bazavti
set transform-set baza

!
interface Virtual-Template2 type tunnel
ip address 10.0.3.9 255.255.255.252
keepalive 10 3
tunnel source 10.8.8.9
tunnel destination 10.8.8.10
tunnel mode ipsec ipv4
tunnel protection ipsec profile bazavt

BAZA#sh ip int brief | include Virtual-Template1
Virtual-Template1 10.0.3.10 YES NVRAM down down

при этом туннель есть

dst src state conn-id slot status
10.8.8.9 10.8.8.10 QM_IDLE 1001 0 ACTIVE
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.07.2013, 10:53
Ответы с готовыми решениями:

После ребута пк, устанавливается вредоносное по
Скачал программу с неизвестным издателем, после её запуска установилось множество ненужного софта,...

Нету выбора ОС после ребута !
Драствуйте! наломал дров ... проблема : на до ето проблеми у меня было 3 раздела ( C: Windows...

Перезапись cron`a после ребута
Здравствуйте. На работе возникла необходимость автоматизировать процесс перезагрузки "серверов", на...

Сетевой принтер после ребута не активен
День добрый, прошу подсказать куда рыть. Есть мини сеть без домена (роутер asus rt-n-16) около 10...

Не определяется жесткий диск после ребута
Всем дрбрый вечер! Вот когда не лазил в комп все работало, решил родителям собрать комп из старых...

15
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 11:45 2
Интерфейс virtual-template не может быть не down/down - потому как это не интерфейс как таковой, а шаблон. У него нет ни физики, ни логики.
0
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 11:55  [ТС] 3
Цитата Сообщение от Jabbson Посмотреть сообщение
Интерфейс virtual-template не может быть не down/down - потому как это не интерфейс как таковой, а шаблон. У него нет ни физики, ни логики.
тогда что посоветует сделать?? переделать int tunnel ? или что нужно добавить что бы он поднимался после перезагрузки?
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 12:09 4
Мне вообще не понятно зачем делать темплейт, если в нем есть сразу и сорс и дестинейшн. Сама природа темплейта подразумевает шаблонную используемость этого интерфейса.

Он будет down/down всегда, даже в рабочем состоянии - это не физический интерфейс.

Что Вы имлементируете?
0
02.07.2013, 12:09
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 12:21  [ТС] 5
Цитата Сообщение от Jabbson Посмотреть сообщение
Мне вообще не понятно зачем делать темплейт, если в нем есть сразу и сорс и дестинейшн. Сама природа темплейта подразумевает шаблонную используемость этого интерфейса.

Он будет down/down всегда, даже в рабочем состоянии - это не физический интерфейс.

Что Вы имлементируете?
дело касается еще прошлой темы по скорости туннеля между точками - 100 мегабит канал. При использование шаблона выжимаю максимум скорости из 1841 21 мегабит, а если беру интерфейс тунеля то максимум 12. При этом после ребута делаю sh/no sh на на инт темплейт и он up/up и только после этого идет трафик между роутерами.
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 13:21 6
при попытке выключить "шаблон" последний должен говорить:
Shutdown not allowed on virtual template interface
и это правильно, потому что это шаблон, а не реальный физический или логический интерфейс.

Но с type tunnel shutdown работает.

Почему в Вашем случае так не случается, я честно говоря не знаю, скорее всего из-за того, что DVTI по своему дизайну не предназначен для того, чтобы инициировать соединение и вот после перезагрузки и получается, что у нас висят два интерфейса, которые не инициируют соединение и ждут.
0
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 13:31  [ТС] 7
ну у меня не dvti а svti
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 14:02 8
нет, у вас не svti - svti настраивается на tunnel interface. а когда вы добавили сорс и дестинейшн в DVTI - я даже не знаю как это назвать, SVTI-ем он от этого точно не стал.

так или иначе, шаблон не будет инициировать соединение.
0
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 14:31  [ТС] 9
Цитата Сообщение от Jabbson Посмотреть сообщение
нет, у вас не svti - svti настраивается на tunnel interface. а когда вы добавили сорс и дестинейшн в DVTI - я даже не знаю как это назвать, SVTI-ем он от этого точно не стал.

так или иначе, шаблон не будет инициировать соединение.
так если будет интерфейс тунеля то будет gre/ip а не ipsec/ip и тут site-to-site а не remote access, даже в гвайде циска советует использовать vti вместо gre
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 14:53 10
я ничего не говорил про gre. где и почему там будет gre? tunnel mode ipsec ipv4 (с ipsec) / tunnel mode ipip (без ipsec)
0
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 15:36  [ТС] 11
Цитата Сообщение от Jabbson Посмотреть сообщение
я ничего не говорил про gre. где и почему там будет gre? tunnel mode ipsec ipv4 (с ipsec) / tunnel mode ipip (без ipsec)
http://www.cisco.com/en/US/docs/ios-...0-7866A92A6487
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 15:51 12
Да, я знаю этот сайт) Что Вы мне пытаетесь показать?
0
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 15:57  [ТС] 13
Цитата Сообщение от Jabbson Посмотреть сообщение
Да, я знаю этот сайт) Что Вы мне пытаетесь показать?
то что мой пример конфига тунеля svti а не dvti ))
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
02.07.2013, 16:12 14
Да нет же, уверяю Вас.

по ссылке что дали Вы:

Configuring Dynamic IPsec Virtual Tunnel Interfaces

SUMMARY STEPS

1. enable
2. configure terminal
3. crypto ipsec profile profile-name
4. set transform-set transform-set-name [transform-set-name2...transform-set-name6]
5. exit
6. interface virtual-template number
7. tunnel mode ipsec ipv4
8. tunnel protection IPsec profile profile-name [shared]
9. exit
10. crypto isakamp profile profile-name
11. match identity addressip-addressmask
12. virtual template template-number
13. end
Configuring Static IPsec Virtual Tunnel Interfaces

SUMMARY STEPS

1. enable
2. configure terminal
3. crypto IPsec profile profile-name
4. set transform-set transform-set-name [transform-set-name2...transform-set-name6]
5. exit
6. interface type number
7. ip address address mask
8. tunnel mode ipsec ipv4
9. tunnel source interface-type interface-type
10. tunnel destination ip-address
11. tunnel protection IPsec profile profile-name [shared]
12. end
видите, где настраивается virtual-template? Да даже если рассудить логично - интерфейс виртуального шаблона - он для того и нужен, чтобы к нему "как по шаблону" динамически подключались удаленные коробки.
0
Dmitriy_Nik
2 / 2 / 0
Регистрация: 26.06.2013
Сообщений: 54
02.07.2013, 20:29  [ТС] 15
Цитата Сообщение от Jabbson Посмотреть сообщение
Да нет же, уверяю Вас.

видите, где настраивается virtual-template? Да даже если рассудить логично - интерфейс виртуального шаблона - он для того и нужен, чтобы к нему "как по шаблону" динамически подключались удаленные коробки.
6. interface type number - здесь же можно использовать не только интерфейс туннеля?) или там прям и написано что только интерфейс тунеля? явно не указано,а то что в примере взято , тогда почему они не написали interface tunnel number? а просто interface type? извините за мою дотошность))
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
03.07.2013, 02:27 16
достаточно заглянуть в примен сразу после шагов настройки. так или иначе, два DVTI ждут инициации соединения. соединение подниматься не будет. чтобы починить можно только разве что написать eem applet.
0
03.07.2013, 02:27
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.07.2013, 02:27

Acer 5920G не стартует после ребута
Привет всем Есть три аппаратных проблемы с ноутом, вот думаю пора менять или можно починить....

Mysql и сокеты (после внезапного ребута)
Добрый день, подскажите по такому вопросу. Стоит CentOS, Apache+PHP+Mysql. Работает и...

Запуск Рекавери после Ребута системы
При включении смартфона он переходит в recovery mode. При нажатии "reboot system now", он...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru