Форум программистов, компьютерный форум CyberForum.ru

С++ для начинающих

Войти
Регистрация
Восстановить пароль
 
Pro100 Andrei
4 / 4 / 0
Регистрация: 19.05.2014
Сообщений: 43
#1

Что выполняют данные процедуры? - C++

20.11.2014, 12:15. Просмотров 249. Ответов 2
Метки нет (Все метки)

Определить результат выполнения следующих рекурсивных
процедур при п = 5:
а) алг Процедура1(арг дел п)
нач
если п>0
то
вывод п
Процедура1(п-1)
все
кон
б) алг Процедура2(арг пел п)
нач
если п>0
то
Процедура2(п-1)
вывод п
все
кон
в) м г ПроцедураЗ(арг цел п)
нач
если п>0
то.
вывод п
ПроцедураЗ(п-1)
вывод п
все
кон
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.11.2014, 12:15     Что выполняют данные процедуры?
Посмотрите здесь:

C++ Что выводит данные програмы
Как сделать что б из потока выводились данные на листбокс C++
Нужно написать функцию, что не возвращает значения(типа процедуры на паскале) C++
Какое действие выполняют операторы: j1=a<<3; и j2=015>>3; C++
Что означают данные процедуры??? C++
C++ Что означают данные
абстрактный класс как реализовать данные, над которыми методы выполняют какие-либо действия C++
Указатели(Какую роль выполняют &* и *&) C++
C++ Какую роль выполняют идентификаторы в приведенном коде?
C++ Что выполняют операции --i и ++j
C++ Коментарии к программе. Объясните пожалуйста что выполняют функции
C++ Создать две функции потоков, которые выполняют следующие расчеты:

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Max Dark
В поиске работы
1612 / 1413 / 506
Регистрация: 09.10.2013
Сообщений: 3,205
Записей в блоге: 8
Завершенные тесты: 2
20.11.2014, 12:22     Что выполняют данные процедуры? #2
а) вывод от п до 1
б) вывод от 1 до п
в) догадайтесь сами
Pro100 Andrei
4 / 4 / 0
Регистрация: 19.05.2014
Сообщений: 43
20.11.2014, 12:24  [ТС]     Что выполняют данные процедуры? #3
код програмы нужен срочно! С++
Yandex
Объявления
20.11.2014, 12:24     Что выполняют данные процедуры?
Ответ Создать тему
Опции темы

Текущее время: 00:30. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru