Форум программистов, компьютерный форум CyberForum.ru

Рекурсивное разбиение прямоугольной области правильным n-угольником - C++

Восстановить пароль Регистрация
 
stimsa
 Аватар для stimsa
0 / 0 / 0
Регистрация: 13.02.2010
Сообщений: 30
03.03.2011, 23:32     Рекурсивное разбиение прямоугольной области правильным n-угольником #1
Имеется алгоритмический язык.Помогите реализовать на паскале.
алг RectangleDraw(арг цел Current_It,int Count_It, арг вещ Radius, Xc, Yc, арг цел n)
нач
цел i;
если Current_It = Count_It то
Count1:= Count1+1;
если (Xc - Radius >= Xm и Xc + Radius <= XM и Yc - Radius >= Ym и Yc + Radius <=YM ) то
нц для i от 0 до n
Coord[i].x:=IX(Xc + Radius*cos(i*2*M_PI/n))
Coord[i].y:=IY(Yc + Radius*sin(i*2*M_PI/n))
кц
Coord[n]:=Coord[0]
Polygon(Coord,n+1)
все
иначе
нц для i от 0 до n
RectangleDraw (Current_It+1, Count_It, Radius/2., Xc+Radius/2. *cos(i*2*M_PI/n),Yc +Radius/2.*sin(i*2*M_PI/n),n)

RectangleDraw (Current_It+1,Count_It, Radius/2.,Xc, Yc, n)
кц
все
кон

алг RunProcess
нач
цел j, NumberG, IterNo, Xm, Ym, XM, YM;

вещ Radius, Xc, Yc;
Radius:= sqrt(pow(XM - Xm,2)+pow(YM - Ym,2))/2.;
Xc = Xm+(XM - Xm)/2.
Yc = Ym+(YM - Ym)/2.;

нц для j от 1 до IterNo
RectangleDraw(1,j,Radius,Xc,Yc, NumberG)
кц
кон
Iax=(double)(right - top -10)/(MaxX - MinX);
Ibx=(double)(right -5 - Iax*MaxX);
Iay=(double)(bottom - top -10)/(MinY - MaxY);
Iby=(double)(bottom -5 - Iay*MinY);


IX(double x) Iax*x+Ibx+0.5;
IY(double y) Iay*y+Iby+0.5
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.03.2011, 23:32     Рекурсивное разбиение прямоугольной области правильным n-угольником
Посмотрите здесь:

C++ Напишите программу, которая сравнивает ответ пользователя на вопрос с правильным ответом.
Определить, является ли строка правильным скобочным выражением (Перевод кода из Паскаля в С++) C++
C++ Проверить является ли скобочное выражение правильным
C++ Определить является ли лабиринт правильным
Определить является ли лабиринт правильным. C++
C++ Раскраска произвольной прямоугольной области
C++ Как проверить, является ли строка правильным идентификатором?
C++ Является ли правильным проектирование классов с методами у которых есть определённый порядок вызова
C++ Обычный односвязный список, а именно с правильным с пониманием)
C++ Вывести на экран введенную сумму словами + название валюты с правильным окончанием
C++ Является ли заданная строка правильным IP-адресом
Рекурсивное наследование C++

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ma3a
Эксперт C++
612 / 456 / 31
Регистрация: 28.01.2011
Сообщений: 605
03.03.2011, 23:39     Рекурсивное разбиение прямоугольной области правильным n-угольником #2
Вы не ошиблись разделом? Вам, вероятно, сюда http://www.cyberforum.ru/pascal/
Yandex
Объявления
03.03.2011, 23:39     Рекурсивное разбиение прямоугольной области правильным n-угольником
Ответ Создать тему
Опции темы

Текущее время: 18:45. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru