Форум программистов, компьютерный форум CyberForum.ru

библиотека openVC - C++

Восстановить пароль Регистрация
 
mirag0505
0 / 0 / 0
Регистрация: 22.04.2013
Сообщений: 17
25.06.2013, 17:57     библиотека openVC #1
Здравствуйте не могу поставить на убунту 13 библиотеку openVC, вот мануал
http://karytech.blogspot.ru/2012/05/...untu-1204.html
выдает ошибку когда ввожу команду make
Код
root@Mozart:~/Загрузки/OpenCV-2.4.0# make
[  0%] Building NVCC (Device) object modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_matrix_operations.cu.o
In file included from /usr/lib/nvidia-cuda-toolkit/include/cuda_runtime.h:59:0,
                 from <command-line>:0:
/usr/include/host_config.h:82:2: ошибка: #error -- unsupported GNU version! gcc 4.7 and up are not supported!
CMake Error at cuda_compile_generated_matrix_operations.cu.o.cmake:208 (message):
  Error generating
  /home/mozart/Загрузки/OpenCV-2.4.0/modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_matrix_operations.cu.o


make[2]: *** [modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_matrix_operations.cu.o] Ошибка 1
make[1]: *** [modules/core/CMakeFiles/opencv_core.dir/all] Ошибка 2
make: *** [all] Ошибка 2
root@Mozart:~/Загрузки/OpenCV-2.4.0# make
[  0%] Building NVCC (Device) object modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_matrix_operations.cu.o
In file included from /usr/lib/nvidia-cuda-toolkit/include/cuda_runtime.h:59:0,
                 from <command-line>:0:
/usr/include/host_config.h:82:2: ошибка: #error -- unsupported GNU version! gcc 4.7 and up are not supported!
CMake Error at cuda_compile_generated_matrix_operations.cu.o.cmake:208 (message):
  Error generating
  /home/mozart/Загрузки/OpenCV-2.4.0/modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_matrix_operations.cu.o


make[2]: *** [modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_matrix_operations.cu.o] Ошибка 1
make[1]: *** [modules/core/CMakeFiles/opencv_core.dir/all] Ошибка 2
make: *** [all] Ошибка 2
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.06.2013, 17:57     библиотека openVC
Посмотрите здесь:

Библиотека C++
C++ библиотека C++
Библиотека. C++
Библиотека С++ C++
C++ Библиотека Си++
Библиотека C++
Библиотека C++
библиотека C++

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
OstapBender
 Аватар для OstapBender
581 / 519 / 35
Регистрация: 22.03.2011
Сообщений: 1,585
25.06.2013, 19:53     библиотека openVC #2
может дело в этом:
Цитата Сообщение от mirag0505 Посмотреть сообщение
#error -- unsupported GNU version! gcc 4.7 and up are not supported!
?
mirag0505
0 / 0 / 0
Регистрация: 22.04.2013
Сообщений: 17
25.06.2013, 23:24  [ТС]     библиотека openVC #3
Понятное дело, что в этом, а вот как обойти ошибку ,не удаляя установленную сейчас версию?
Yandex
Объявления
25.06.2013, 23:24     библиотека openVC
Ответ Создать тему
Опции темы

Текущее время: 10:17. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Рейтинг@Mail.ru