Форум программистов, компьютерный форум, киберфорум
Наши страницы
С++ под Linux
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.59/22: Рейтинг темы: голосов - 22, средняя оценка - 4.59
DiffEreD
1442 / 779 / 257
Регистрация: 21.06.2011
Сообщений: 1,740
Записей в блоге: 2
#1

Version `GLIBCXX_3.4.21' not found

25.08.2015, 19:39. Просмотров 4116. Ответов 4
Метки нет (Все метки)

Возникает такая ошибка при динамической линковке библиотек:
Bash
1
2
3
/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/lib/libboost_filesystem.so.1.58.0)
/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/local/lib/libboost_system.so.1.58.0)
/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/local/lib/libboost_filesystem.so.1.58.0)
Нашел похожую проблему тут: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found Вроде, как самым правильным решение этой проблемы это экспорт в LD_LIBRARY_PATH нужных директорий. Открыл консоль, вбил
Bash
1
export LD_LIBRARY_PATH=/usr/local/lib:/usr/local/lib32:/usr/local/lib64:$LD_LIBRARY_PATH
, перегрузился - не помогло, дальше те же ошибки. Что посоветуете?
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.08.2015, 19:39
Ответы с готовыми решениями:

GLIBCXX_3.4.21 not found
Добрый день. На форуме находил уже схожую тему, но решение, предложенное там...

./massdown: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./massdown)
всем хай! собираю свою программу на новом железе х86_64 долго не получалось...

Python version 3.4.3 not found in registry matplotlib
Добрый вечер. При установке пакета matplotlib появляется ошибка, прикрепленная...

Ошибка cannot be opened because it is version 782. This server supports version 706 and earlier
Есть проект для которого база данных (далее-БД) создается с использованием Code...

Какая разница в живом спецификации Multipage Version от Developer Version ?
Какая разница в живом спецификации Multipage Version от Developer Version ? ...

4
gng
807 / 552 / 167
Регистрация: 08.09.2013
Сообщений: 1,495
25.08.2015, 21:57 #2
Лучший ответ Сообщение было отмечено DiffEreD как решение

Решение

Цитата Сообщение от DiffEreD Посмотреть сообщение
Открыл консоль, вбил
export LD_LIBRARY_PATH=/usr/local/lib:/usr/local/lib32:/usr/local/lib64:$LD_LIBRARY_PATH
, перегрузился - не помогло, дальше те же ошибки. Что посоветуете?
Экспортируемые переменные окружения устанавливаются для текущего процесса (оболочки, в которой вы вбили команду export) и его потомков (программ, которые запускаются из этой оболочки).
Соответсвенно, и программу, выдавшую ошибки, нужно запускать из этой оболочки.
После завершения работы оболочки, её переменные теряются, тем более, после перезагрузки системы.
Системные переменные устанавливаютя в зависимости от дистрибутива и от оболочки в /etc/profile, /etc/environment..., пользовательские - в $HOME/.profile, $HOME/bashrc... В этом случае служба илициализации экспортирует их при загрузке системы.
1
DiffEreD
1442 / 779 / 257
Регистрация: 21.06.2011
Сообщений: 1,740
Записей в блоге: 2
25.08.2015, 22:04  [ТС] #3
Так я могу эту запись (export LD_LIBRARY_PATH) просто записать в конце файла $HOME/.profile ?
0
gng
807 / 552 / 167
Регистрация: 08.09.2013
Сообщений: 1,495
25.08.2015, 22:40 #4
Цитата Сообщение от DiffEreD Посмотреть сообщение
я могу эту запись (export LD_LIBRARY_PATH) просто записать в конце файла $HOME/.profile ?
Да, после чего выйти из системы и снова авторизоваться.
Проверить можно
Bash
1
echo $имя_переменной
1
DiffEreD
1442 / 779 / 257
Регистрация: 21.06.2011
Сообщений: 1,740
Записей в блоге: 2
26.08.2015, 09:31  [ТС] #5
Решил проблему вчера таким способом:
Bash
1
2
3
4
sudo add-apt-repository ppa:ubuntu-toolchain-r/test 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
0
26.08.2015, 09:31
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.08.2015, 09:31

ORA-00201: control file version 11.2.0.2.0 incompatible with ORACLE version 11.2.0.0.0
Пожалуйста отзовитесь монстры оракла))) помогите кто чем может, я взял базу с...

Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3
ребят почему так пишет Bootstrap's JavaScript requires jQuery version 1.9.1 or...

"Error: This version of PyQt5 and the commercial version of Qt have incompatible licenses" при установке Pyqt
Никак не могу установить pyqt, вылезает такая ошибка Error: This version of...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru