Форум программистов, компьютерный форум, киберфорум
Наши страницы

C# для начинающих

Войти
Регистрация
Восстановить пароль
 
SergeyXUB
0 / 0 / 0
Регистрация: 09.12.2013
Сообщений: 3
#1

Как сделать приложение для версий framework 2.0 и старше - C#

09.12.2013, 18:49. Просмотров 395. Ответов 6
Метки нет (Все метки)

Всем привет! Кто знает как сделать приложение для версий framework 2.0 и старше? Если рядом с файлом класть файл конфигурации с <supportedRuntime... то все работает, но необходимо чтоб программа была одним файлом. Кто знает решение, буду очень признателен)
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.12.2013, 18:49
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Как сделать приложение для версий framework 2.0 и старше (C#):

Приложение создано для Net.Framework 4.5/Как сделать его мультиплатформенным? - C#
Какие идеи есть? Хочу чтоб мое приложение работало на как можна большем количестве операционок., имею ввиду семейство виндовс. Что нужно...

Как скомпилировать С# приложение, для работы без .NET Framework - C#
Доброго времени суток вам! Вопрос в том, что нужно написать приложение на чистом С#, но скомпилировать так, чтоб можно было запускать его...

.NET Framework 2 - отличия версий - C#
Может немного тупой вопрос, но все же хотелось бы знать. Есть .NET Framework 2, .NET Framework 2 SP1, .NET Framework 2 SP2. В чем...

Не получается построить приложение C# (framework 3.5) для запуска на другом компьютере (winXP) - C#
Здравствуйте! У меня такая проблема: создаю приложение в VS2012 (в настройках указан Framework 3.5) на компьютере с Windows 7, x64. Строю...

Перенаправление версий сборки. Приложение не читает .exe.config - C#
Всем привет. Читаю Э.Троелсена дошел до главы где он объясняет как перенаправить версию сборки от которой зависит приложение при помощи...

Сделать несколько версий метода с разными видами аргументов - C#
сделать несколько версий использованного метода - метод возвращает искомое значение; - метод ничего не возвращает, искомое значение...

6
ViterAlex
6220 / 3424 / 1040
Регистрация: 11.02.2013
Сообщений: 7,540
Завершенные тесты: 3
09.12.2013, 19:00 #2
А что мешает создавать проект на этой версии?
0
SergeyXUB
0 / 0 / 0
Регистрация: 09.12.2013
Сообщений: 3
09.12.2013, 19:03  [ТС] #3
Мне нужно сделать 1 приложение на кучу машин где есть разброс по версиям. Пишу я для v2.0, она может выполняться и на v4 но только с файлом ...exe.config и параметром supportedRuntime в нем.
0
tezaurismosis
Администратор
Эксперт .NET
8220 / 3699 / 505
Регистрация: 17.04.2012
Сообщений: 8,380
Записей в блоге: 14
09.12.2013, 22:47 #4
Цитата Сообщение от ViterAlex Посмотреть сообщение
А что мешает создавать проект на этой версии?
Почти всё, что делает студия для этого - создаёт конф. файл с supportedRuntime для соответствующей версии и ограничивает выбор программиста на "наименьшем общем знаменателе", т.е. на .NET Framework 2.0
SergeyXUB, если ваш код совсем не использует возможности, появившиеся после версии 2.0, то программа будет работать на любой версии Framework, начиная с 2.0 (3.0, 3.5, 4.0, 4.5, 4.5.1), даже без конфигурационного файла.
0
SergeyXUB
0 / 0 / 0
Регистрация: 09.12.2013
Сообщений: 3
09.12.2013, 23:02  [ТС] #5
По теории да, но на моих тестах получается что машина без FW 2.0 не стартует приложение.
0
Миниатюры
Как сделать приложение для версий framework 2.0 и старше  
ViterAlex
6220 / 3424 / 1040
Регистрация: 11.02.2013
Сообщений: 7,540
Завершенные тесты: 3
09.12.2013, 23:40 #6
Сдаётся мне, что проблема в Windows XP. Нужно проверять, что из используемых функций несовместимо с Windows XP
0
tezaurismosis
Администратор
Эксперт .NET
8220 / 3699 / 505
Регистрация: 17.04.2012
Сообщений: 8,380
Записей в блоге: 14
10.12.2013, 10:31 #7
Цитата Сообщение от SergeyXUB Посмотреть сообщение
машина без FW 2.0 не стартует приложение
А FW 2.0 у вас установлен? Ведь 4.0 может и без него работать.
0
10.12.2013, 10:31
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2013, 10:31
Привет! Вот еще темы с ответами:

как сделать приложение на framework 2.x - C#
собственно, вопрос: как сделать приложение, которое можно будет запустить на других компах, если там нету ни 3 ни 4 frameworka? при...

Как писать приложение для двух версий iOS? - Objective-C
Я так понимаю обычно актуальны две версии iOS, на данный момент это 7 и 8. Для отладки и тестирования приложения потребуются два...

Как сделать независимое приложение (без FrameWork) - Mono
Как сделать не зависимое от FrameWork-а приложение? P.S. Если хотите ответить что никак, то скажу что можно и в нете постоянно...

Нужно простое приложение (*.xap) для Windows Phone 8.1 или старше - Windows Phone
Купил люмию 435. Хочу попытаться впервые запустить *.xap на устройстве. А средства разработки не работают. 2010 на моем Win 8 не работает,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru