Форум программистов, компьютерный форум, киберфорум
Наши страницы
Debian, Kali Linux, Raspbian
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/14: Рейтинг темы: голосов - 14, средняя оценка - 4.50
bodrich
101 / 91 / 14
Регистрация: 20.06.2010
Сообщений: 964
Записей в блоге: 16
Завершенные тесты: 1
1

Как установить libnss3 нужной версии ?

17.09.2012, 18:56. Просмотров 2863. Ответов 1
Метки нет (Все метки)

Программа не находит нужных версий библиотек
./libxul.so: /usr/lib/libssl3.so: version `NSS_3.13.2' not found (required by ./libxul.so)
./libxul.so: /usr/lib/libssl3.so: version `NSS_3.13' not found (required by ./libxul.so)
./libxul.so: /usr/lib/libnssutil3.so: version `NSSUTIL_3.13' not found (required by ./libxul.so)
./libxul.so: /usr/lib/libsmime3.so: version `NSS_3.13' not found (required by ./libxul.so)
./libxul.so: /usr/lib/libnss3.so: version `NSS_3.12.10' not found (required by ./libxul.so)
./libxul.so: /usr/lib/libnss3.so: version `NSS_3.13' not found (required by ./libxul.so)
./libxul.so: /usr/lib/libnss3.so: version `NSS_3.12.9' not found (required by ./libxul.so)
Нашел этот пакет здесь http://packages.debian.org/ru/squeeze-backports/i386/libnss3/download Но, при его установки пишет:
Error: Conflicts with the installed package 'libnss3-1d'
Пытаюсь удалить libnss3-1d. В ответ система выдает нечто ужасное:
оно
Следующие действия разрешат зависимости:

Удалить следующие пакеты:
1) chromium-browser
2) deskbar-applet
3) ekiga
4) empathy
5) epiphany-browser
6) epiphany-extensions
7) evolution
8) evolution-data-server
9) evolution-exchange
10) evolution-plugins
11) flashplugin-nonfree
12) gnome
13) gnome-accessibility
14) gnome-applets
15) gnome-control-center
16) gnome-core
17) gnome-desktop-environment
18) gnome-office
19) gnome-panel
20) gnome-session
21) google-chrome-stable
22) hamster-applet
23) iceweasel
24) libcamel1.2-14
25) libebook1.2-9
26) libedata-book1.2-2
27) libedataserverui1.2-8
28) libevolution
29) libgluezilla
30) libnss3-dev
31) libnss3-tools
32) librpm1
33) librpmbuild1
34) librpmio1
35) libswt-mozilla-gtk-3.5-jni
36) openjdk-6-jre
37) openjdk-6-jre-headless
38) openjdk-6-jre-lib
39) openoffice.org
40) openoffice.org-base
41) openoffice.org-base-core
42) openoffice.org-calc
43) openoffice.org-common
44) openoffice.org-core
45) openoffice.org-draw
46) openoffice.org-emailmerge
47) openoffice.org-evolution
48) openoffice.org-filter-binfilter
49) openoffice.org-filter-mobiledev
50) openoffice.org-gcj
51) openoffice.org-gnome
52) openoffice.org-gtk
53) openoffice.org-help-en-us
54) openoffice.org-impress
55) openoffice.org-java-common
56) openoffice.org-math
57) openoffice.org-officebean
58) openoffice.org-report-builder-bin
59) openoffice.org-style-galaxy
60) openoffice.org-style-tango
61) openoffice.org-thesaurus-en-us
62) openoffice.org-writer
63) python-evolution
64) python-uno
65) rpm
66) rpm2cpio
67) tuxguitar
68) tuxguitar-alsa
69) tuxguitar-oss
70) xulrunner-1.9.1

Установить следующие пакеты:
71) javascript-common [7 (stable)]
72) libjs-mootools [1.2.4.0~debian1-1 (stable)]
73) libobparser21 [3.4.11.1-1 (stable)]
74) libobrender21 [3.4.11.1-1 (stable)]
75) midori [0.2.4-3 (stable)]
76) openbox [3.4.11.1-1 (stable)]
77) openbox-themes [1.0.2 (stable)]
78) wwwconfig-common [0.2.1 (stable)]

Оставить следующие зависимости неразрешёнными:
79) chromium-browser-inspector рекомендует chromium-browser
80) libmono-webbrowser0.5-cil рекомендует libgluezilla
81) alacarte рекомендует gnome-panel
82) ca-certificates-java рекомендует libnss3-1d
83) capplets-data рекомендует gnome-control-center (>= 1:2.30.1-2)
84) epiphany-browser-data рекомендует epiphany-browser
85) evolution-common рекомендует evolution
86) evolution рекомендует evolution-plugins
87) file-roller рекомендует rpm2cpio
88) gnome-applets рекомендует deskbar-applet
89) gnome-panel-data рекомендует gnome-panel
90) gnome-panel рекомендует gnome-control-center
91) gnome-panel рекомендует evolution-data-server
92) gnome-system-tools рекомендует gnome-control-center (>= 1:2.10.1-1)
93) gnome-desktop-environment рекомендует gnome-accessibility
94) mousetweaks рекомендует gnome-control-center
95) openoffice.org-evolution рекомендует evolution
96) openoffice.org-help-en-us рекомендует openoffice.org-core (> 1:3.2.1) |
97) openoffice.org-writer рекомендует openoffice.org-filter-binfilter
98) openoffice.org-writer рекомендует openoffice.org-math
99) openoffice.org рекомендует openoffice.org-filter-binfilter
100) xarchiver рекомендует rpm
101) opera рекомендует flashplugin-nonfree


Принять данное решение? [Y/n/q/?] q


А как тогда установить libnss3 версии 3.13.* ? (кроме сноса всей системы)
Система debian 6.0.4 (squeeze)

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.09.2012, 18:56
Ответы с готовыми решениями:

Qt + sqlite нужной версии
Добрый день, коллеги! (впрочем, 4 утра с натягом можно назвать днем - не спится ) Подскажите как...

Запуск из cmd нужной версии
Установлено 2 питона: 2.6 и 3.6. Если в cmd вбиваю python, то показывается версия 2.6, а мне нужно...

Установщик .NET нужной версии
Всем доброго времени суток. Стоит задача написать установщик программ, написанных на C#, чтобы при...

Выбрать по умолчанию нужной версии acad
Добрый день! Установлено 2008 и 2009 acad, по умолчанию все файлы открываются в 2009. нужно чтоб...

Выбор нужной версии PHP IIS10
Установлены разные версии php при phpinfo выдает Loaded Configuration File C:\Program...

1
NeoMatrix
Модератор
Эксперт NIX
5577 / 1358 / 94
Регистрация: 24.05.2011
Сообщений: 10,899
Записей в блоге: 2
18.09.2012, 07:00 2
у меня подобная ситуация: хотел снести ритмбокс, в результате снёс пол-системы.
Вероятно, что-то не так с aptitude
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.09.2012, 07:00

как установить новый плагин в версии wp 3.5.1
добрый день!) обновила версию вордпресс и теперь не могу найти как там установить новый плагин в...

Как установить Ubuntu ? версии начиная с 10.04.3
Совсем не понимаю, как устанавливать. мне сказали что можно образ скопировать на флешку с помощью...

Как установить Django в третьей версии питона?
Добрый день! Установил Django на Kubuntu. Проверяю: >>> import django >>>...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru