Форум программистов, компьютерный форум CyberForum.ru
CyberForum.ru - форум программистов и сисадминов > > >
Восстановить пароль Регистрация
 
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
16.06.2010, 12:27     test1.ru в Денвере не запускается
  #1
Поставил Денвер на флешку, не мог запустить www.test1.ru, снес его и поставил на диск С - такая же проблема. localhost запускается, а при попытке зайти на test1.ru или страничку которую я создал браузер пишет: The requested URL could not be retrieved и т.д.
В hosts адрес прописан: 127.0.0.1 test1.ru
Подскажите пожалуйста с чем это может быть связано?
AdAgent
Объявления
16.06.2010, 12:27
Nazz
WEB-developer
872 / 703 / 3
Регистрация: 12.03.2009
Сообщений: 2,746
Записей в блоге: 2
16.06.2010, 12:48
  #2
вы должни в зделать следуючим образом(создать папки):
home/test1.ru/www/здесь файлы вашего сайта
потом обновляете denwer, и запускаете http://tes1.ru
воаля, всё работает))
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
16.06.2010, 12:52  [ТС]
  #3
Цитата Сообщение от Nazz Посмотреть сообщение
вы должни в зделать следуючим образом(создать папки):
home/test1.ru/www/здесь файлы вашего сайта
потом обновляете denwer, и запускаете http://tes1.ru
воаля, всё работает))
Даже если не брать во внимание мой сайт, должен по идее запускаться сам test1.ru который прописался сам при установке сервера. Физически он находится у меня на c:\WebServers\home\test1.ru\www\index.html. Все проверил, страничка физически есть, но из браузера она не запускается хотя localhost работает!
Nazz
WEB-developer
872 / 703 / 3
Регистрация: 12.03.2009
Сообщений: 2,746
Записей в блоге: 2
16.06.2010, 13:23
  #4
попробуйте отключить интернет соединение, или же сетевое соединение...
бывает что из за соединений такие глюки выбивает((
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
16.06.2010, 13:30  [ТС]
  #5
Цитата Сообщение от Nazz Посмотреть сообщение
попробуйте отключить интернет соединение, или же сетевое соединение...
бывает что из за соединений такие глюки выбивает((
Сеть отключил, денвер перезапустил - тоже самое...((((((
Nazz
WEB-developer
872 / 703 / 3
Регистрация: 12.03.2009
Сообщений: 2,746
Записей в блоге: 2
16.06.2010, 13:46
  #6
а какая у вас ОС?
какая версия Denwer?
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
16.06.2010, 13:49  [ТС]
  #7
Цитата Сообщение от Nazz Посмотреть сообщение
а какая у вас ОС?
какая версия Denwer?
ОС - ХР
Denwer - 3
Nazz
WEB-developer
872 / 703 / 3
Регистрация: 12.03.2009
Сообщений: 2,746
Записей в блоге: 2
16.06.2010, 14:03
  #8
вы денвер качали на офсайте???
должно всё работать, естли конечно же правильно настроен сам денвер...
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
16.06.2010, 15:37  [ТС]
  #9
Цитата Сообщение от Nazz Посмотреть сообщение
вы денвер качали на офсайте???
должно всё работать, естли конечно же правильно настроен сам денвер...
Нет, по моему не с официального сайта. Сейчас узнаю как тот снести правильно и скачаю с официального.....

Добавлено через 43 минуты
с оф. версией все тоже самое ((((((((
Nazz
WEB-developer
872 / 703 / 3
Регистрация: 12.03.2009
Сообщений: 2,746
Записей в блоге: 2
16.06.2010, 16:28
  #10
попробуйте ничего не менять во времья установки... пускай всё установится по умолчанию...
а естли всё таки не работает, тогда пробуйте XAMPP...
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
16.06.2010, 16:34  [ТС]
  #11
Цитата Сообщение от Nazz Посмотреть сообщение
попробуйте ничего не менять во времья установки... пускай всё установится по умолчанию...
а естли всё таки не работает, тогда пробуйте XAMPP...
Да я вроде ничего и не меняю, уже даже согласился с ним что бы установить сервер на диск С. ОК, попробую ХАМРР, но наверно уже завтра.
Спасибо большое!
Arrenius
Форумчанин
2 / 2 / 0
Регистрация: 01.06.2010
Сообщений: 110
22.06.2010, 13:00  [ТС]
  #12
Цитата Сообщение от Nazz Посмотреть сообщение
попробуйте ничего не менять во времья установки... пускай всё установится по умолчанию...
а естли всё таки не работает, тогда пробуйте XAMPP...
Кстати, а почему вы посоветовали именно XAMPP, а не Apache или что то типа того?
magnatya
Гость
Сообщений: n/a
13.09.2010, 22:21
  #13
У меня была аналогичная проблема, ответа в инете не нашел, но пришел к нему сам.

Нужно удалить файл: C:\Windows\System32\drivers\etc\hosts

Перезапускаем Денвер и вооля!
DjArkaim
Гость
Сообщений: n/a
23.03.2011, 09:04
  #14
Всем привет. У меня тоже возникли проблемы с Денвером, хотя пробовал устанавливать и другой сервер - аналогично. В общем при запуске сервера, пишет что мол проблемы с файлом хост(ну или мол возможно что я не в режиме админа). Хотя других учётных записей у меня нет, и там под моей единственной написано что я админ. Когда денвер запускается, то всё нормально, можно даже на локалхост зайти, но остальные домены не работают, ни тест, ни созданные мной.
Пробовал изменить/удалить hosts пишет что это невозможно(типо нельзя, или файл используется др прогой). Проверил через unloker никаких процессов нет! Please help!!!

Добавлено через 14 минут
Извиняюсь за флуд. Сам разобрался, оказалось что дело в Каспере. Отключил переставил. Всё отлично заработало.
Zermond
Форумчанин
4 / 4 / 0
Регистрация: 22.05.2010
Сообщений: 52
23.03.2011, 22:00
  #15
Кстати, а почему вы посоветовали именно XAMPP, а не Apache или что то типа того?
"XAMPP is a free and open source cross-platform web server solution stack package, consisting mainly of the Apache HTTP Server, MySQL database, and interpreters for scripts written in the PHP and Perl programming languages." Wikipedia
hollotech
Гость
Сообщений: n/a
05.09.2012, 12:56
  #16
Решение для win7x64
если коротко:
1. Идем сюда "панель управления - Сеть и интернет -центр управления сетями и общим доступом - дополнительные параметры общего доступа"
2. ставим галочку на включить у параметра "доступ к общим папкам" все!

если подлинее
1. идем сюда С://windows/system32/drivers/etc/
2. смотрим на общий доступ к файлу hosts (по клику правой кнопки мыши)
3. Если стоит замочек на "никому из пользователей", то кликаем на "домашняя группа(чтение и запись)"
4. Выйдет окно "Панель управления - сеть и интернет -Домашняя группа" кликаем на ссылку "Изменение параметров общего доступа..."
5. Выйдет окно "панель управления - Сеть и интернет -центр управления сетями и общим доступом - дополнительные параметры общего доступа"
6. ставим галочку на включить у параметра "доступ к общим папкам" все
Илья Федин
Бог живет в /root
870 / 343 / 1
Регистрация: 12.08.2012
Сообщений: 4,383
Записей в блоге: 5
06.09.2012, 11:43
  #17
У меня был почти такой же случай: почему то то что я писал в hosts применялась через один день и больше или вообще не приминалась. Не помню то ли семёрка была то ли XP.
102podlec
Гость
Сообщений: n/a
23.02.2013, 09:43
  #18
скорее всего вы используете wi-fi роутер, а если оно так, то навремя лучше остаться без него, пока пользуетесь денвером
Илья Федин
Бог живет в /root
870 / 343 / 1
Регистрация: 12.08.2012
Сообщений: 4,383
Записей в блоге: 5
24.02.2013, 01:05
  #19
102podlec, Роутер тут ну ни как не может быть причастен так как Денвер не зависит от подключения
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
24.02.2013, 11:57

Еще ссылки по теме:

Не запускается Apache в Xampp

где прописать в денвере адрес сайта

где в денвере хранится база данных?

Denwer не заходит на localhost и test1.ru

Taatshi
Администратор
24.02.2013, 11:57     test1.ru в Денвере не запускается
  #20

Не по теме:

102podlec, Вы бы на время последнего поста посмотрели...

Yandex
Объявления
24.02.2013, 11:57
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать новую тему
Опции темы

Текущее время: 08:23. Часовой пояс GMT +4.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.7 PL3
Copyright ©2000 - 2014, vBulletin Solutions, Inc.