Форум программистов, компьютерный форум, киберфорум
Наши страницы
FreeBSD
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Bookkc1
3 / 3 / 0
Регистрация: 01.11.2012
Сообщений: 802
1

Не могу установить совместимость с Linux

11.04.2017, 09:40. Просмотров 791. Ответов 2
Метки нет (Все метки)

Код
root@s:/usr/ports/www/linux-f10-flashplugin11 # cd /usr/ports/emulators/linux_ba                                                                             se-f10 && make install clean
===>  linux_base-f10-10_10 has known vulnerabilities:
linux_base-f10-10_10 is vulnerable:
glibc -- gethostbyname buffer overflow
CVE: CVE-2015-0235
WWW: https://vuxml.FreeBSD.org/freebsd/0765de84-a6c1-11e4-a0c1-c485083ca99c.html

linux_base-f10-10_10 is vulnerable:
glibc -- getaddrinfo stack-based buffer overflow
CVE: CVE-2015-7547
WWW: https://vuxml.FreeBSD.org/freebsd/2dd7e97e-d5e8-11e5-bcbd-bc5ff45d0f28.html

1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/linux_base-f10
root@s:/usr/ports/emulators/linux_base-f10 #

Пишет что нужно обновить порты, вот как обновлял

root@s:/usr/ports/emulators/linux_base-f10 # portsnap fetch
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.04.2017, 09:40
Ответы с готовыми решениями:

Не могу установить PhpStorm в Linux
Парни всем привет! Помогите разобраться с такой проблемой! Скачал себе Phpstorm, а на панельку в...

Не могу установить Linux Mint 17.2
Решил перейти c Windows 7 на Linux Mint . Сделал загрузочную флэшку unetbootin-windows-613 ,...

Не могу установить windows после linux
Решил установить линукс минт, но не понравилось хочу вернуться на семерку но не могу скачал образ...

Не могу установить Mint Linux 13 XFCE
Есть диск с Mint Linux 13, я с него устанавливал на 4 ПК, диск не потертый, а на этом ПК возникли...

Не могу установить linux mint по соседству с win7.
Не могу установить как надо linux mint 12, примем аналогичная проблема и в ubuntu 11.10. Итак,...

2
Faust-x
6 / 6 / 1
Регистрация: 09.11.2014
Сообщений: 53
16.04.2017, 22:31 2
Добавить в /etc/rc.conf
Код
linux_enable="YES"
загрузить
Код
#kldload linux
Установить соответствие sysctl. То есть в файл /etc/sysctl.conf вписать строку
Код
compat.linux.osrelease=2.6.18
в /etc/fstab добавить строку
Код
linproc /compat/linux/proc linprocfs rw 0 0
Установить линукс базу
Код
#cd /usr/ports/emulators/linux_base-c6/ && make install clean
Это актуальная база на основе CentOS 6. Есть порт и linux_base-c7 уже, но тут не надо его. Шестой ставьте. Ваш linux_base-f10 был основан на какой-то древней версии Fedora и уже не актуален.

Устанавить Flash плагин и nspluginwrapper из портов:
Код
#cd /usr/ports/www/linux-c6-flashplugin11/ && make install clean
#cd /usr/ports/www/nspluginwrapper && make install clean
От нужного пользователя выполнить

Код
mkdir ~/.mozilla/plugins
cd ~/.mozilla/plugins
nspluginwrapper -v -a -i
Перезагрузится, проверить. Открыть Firefox и написать адрес в адресной строке
Код
about:plugins
0
prZzZ
Программист
112 / 92 / 8
Регистрация: 22.03.2011
Сообщений: 238
22.05.2017, 15:10 3
Bookkc1, здравствуйте.
Я ставил отсюда: https://sergeysl.ru/freebsd-flash-on...ror-and-opera/
Все встало без проблем.
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.05.2017, 15:10

Не могу установить Windows XP из под Linux из-за LVM
Всем привет Был у меня раздел /dev/sda3 где стоял Linux LVM. Разбил его на два раздела. На sda4...

Не могу установить Linux pwp 2009 i586
Скинул образ на диск, в биусе поставил загрузку с сидюка, но грузится масдай?

Не могу установить linux debian netinst с флешки
Всем привет! Столкнулся с задачей, необходимо установить Linux Debian "debian-508-i386-netinst" с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.