Форум программистов, компьютерный форум, киберфорум
Наши страницы
Программирование iOS/iPhone
Войти
Регистрация
Восстановить пароль
 
smth
179 / 48 / 6
Регистрация: 23.06.2011
Сообщений: 248
#1

IOS Simulator пускает в сеть только по https - Программирование iOS

01.05.2015, 15:36. Просмотров 795. Ответов 5

Добрый день! Проблема такова: до вчерашнего дня лень быть обновлять основной рабочий комп до 10.10, работал под мавериком (неохота было перегружаться, сохранять все открытое...). Под 10.9 и предыдущей версией Xcode (не запомнил, то ли 6.1, то ли 6.2) симулятор нормально выходил в инет, если сеть и отваливалась, то помогало стандартное решение (стереть контент). После обновления до 10.10.3 и Xcode 6.3.1 симулятор перестал пускать в сеть по http, открываются сайты (как в safari, так и в webview) только по https. Вечером погуглил немного - не нашел решения (естественно, и перегружался, контент сбрасывал).

Сам мак выходит в интернет нормально, никаких программ (типа little snitch) не установлено. На ноуте с 10.10.3 и Xcode 6.3.1 с доступом в интернет все ок.

Спасибо за удаленное время.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.05.2015, 15:36
Я подобрал для вас темы с готовыми решениями и ответами на вопрос IOS Simulator пускает в сеть только по https (Программирование iOS):

iOS Simulator не подключается к интернету
Здравствуйте. Прокси не пускает в чем может быть проблема? на основной...

Переопределение метода только в iOS >= 7.0
Такое возможно ? К примеру у меня есть класс, в нем метод -...

dsl 2640u Wi Fi пускает только компьютеры, сотки и планшеты не пускает
Здравствуйте. Помогите пожалуйста, пытаюсь подключить планшет и сотку, но модем...

Прозрачный сквид с ssl_bump не пускает на некоторые https сайты
Пришло время задать один сложный вопрос. Форумчане, администраторы, кто хорошо...

OpenServer и хром перестали дружить (http меняет на https и не пускает на сайт)
Обнаружил, что не могу зайти ни на один из моих сайтов, работающих через OS в...

Не пускает роутер в сеть
D-Link Dir 615. Брал у дом ру с их прошивкой залочененной. Сегодня перепрошил...

5
Jabbson
Модератор
Эксперт по компьютерным сетям
3344 / 2419 / 745
Регистрация: 03.11.2009
Сообщений: 7,759
Записей в блоге: 3
01.05.2015, 20:10 #2
А когда открываете по http, что происходит? Ошибка? Таймаут?
0
smth
179 / 48 / 6
Регистрация: 23.06.2011
Сообщений: 248
01.05.2015, 20:24  [ТС] #3
Не могу сказать (я только осваиваю разработку под iOS и с сетью толком не работал). Симптомы такие: в webview просто белый экран, никаких ошибок в лог не выводится, в сафари мгновенно при попытке открыть страницу - "Safari cannot open the page because the network connection was lost".

На web интерфейсы в локальной сети (например, админка роутера или NASа) также заходит только с ssl.
0
Jabbson
Модератор
Эксперт по компьютерным сетям
3344 / 2419 / 745
Регистрация: 03.11.2009
Сообщений: 7,759
Записей в блоге: 3
01.05.2015, 20:37 #4
даже не знаю, я бы тоже попробовал iOS Simulator > Reset Content and Settings, но если не помогает...
А в самом симуляторе в settings - developer - allow http services не помогает?
0
smth
179 / 48 / 6
Регистрация: 23.06.2011
Сообщений: 248
02.05.2015, 10:16  [ТС] #5
Проблема разрешилась чудным образом (по-маковски, я б сказал, когда пересел на мак не мог разобраться, как приоритет сетей назначить, консоль замучал, оказалось, надо было мышкой их передвинуть):
Вспомнил, что у меня у симулятора две версии iOS: 8.3 и 7.1. Загрузил симулятор в 7.1 - работает, вернулся в 8.3 - тоже заработало. Со вчерашнего поста вообще к этому компу не прикасался.

Jabbson, allow http выключен даже на изначально работающем симуляторе. Я не знаю (пока), что оно дает, раз http и так работает.
0
Jabbson
Модератор
Эксперт по компьютерным сетям
3344 / 2419 / 745
Регистрация: 03.11.2009
Сообщений: 7,759
Записей в блоге: 3
02.05.2015, 15:51 #6
Цитата Сообщение от smth Посмотреть сообщение
Проблема разрешилась чудным образом (по-маковски, я б сказал, когда пересел на мак не мог разобраться, как приоритет сетей назначить, консоль замучал, оказалось, надо было мышкой их передвинуть):
да, читал, что есть такой баг, видимо до сих пор не пофикшено
0
02.05.2015, 15:51
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.05.2015, 15:51
Привет! Вот еще темы с решениями:

Не пускает не в одну соц сеть
У знакомого такая проблема не пускает не в одну соц сеть пишет что с этого пк...

Sql пускает только 1 пользователя в 1С
Вообщем проблема такова... переношу 1С SQL базу на новый сервак... ставлю там...

Не пускает только одного юзера по RDP
Такая ошибка выскакивает после ввода (логина \пароля) "Чтобы выполнить вход на...

Волновой алгоритм пускает волну только в одну сторону
День добрый , проблема в том что волновой алгоритм пускает волну только в одну...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru