Форум программистов, компьютерный форум, киберфорум
Наши страницы
Java: IDE, инструментарий
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
meref
0 / -1 / 0
Регистрация: 15.06.2017
Сообщений: 122
1

Eclips Syntax error, parameterized types are only available if source level is 1.5 or greater

20.09.2018, 18:23. Просмотров 896. Ответов 4
Метки нет (Все метки)

Я давно ничего не делал на яве + перешел на новый комп, установил еклипс и яву 1.8, но
Eclips Syntax error, parameterized types are only available if source level is 1.5 or greater
и я проверил какой он использует JRE через project properties in Java Build Path in Libraries и там
Eclips Syntax error, parameterized types are only available if source level is 1.5 or greater
дня 3 мучаюсь что не так??
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.09.2018, 18:23
Ответы с готовыми решениями:

Syntax error 'for each'* statements are only available if source level 1.5
Программировал на университетском компе dct hf,jnfkj домой пришел выдает ошибку "Syntax error...

PDO - Syntax error or access violation: 1064 You have an error in your SQL syntax
public function getAllGategoryId(){ $sql = "SELECT id_cat FROM category ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
rerf2010rerf
45 / 73 / 6
Регистрация: 10.08.2013
Сообщений: 237
Завершенные тесты: 1
20.09.2018, 18:30 2
Не знаю, как в eclipse, но в IDEA, например, у проекта есть настройка language level, которая от используемой в проекте jdk никак не зависит. Полагаю, в eclipse тоже что-то такое должно быть.
0
xoraxax
2250 / 1982 / 579
Регистрация: 05.07.2013
Сообщений: 9,446
Завершенные тесты: 2
20.09.2018, 18:30 3
В настройки проекта зайди и настрой
0
JIeIIIa
955 / 574 / 136
Регистрация: 23.05.2012
Сообщений: 7,370
20.09.2018, 19:12 4
Лучший ответ Сообщение было отмечено meref как решение

Решение

1. Открыть Project properties.
2. 'Java Compiler' -> Check the box ('Enable project specific settings')
3. Изменить compiler compliance level на '5.0' или выше и нажать ok.

Не по теме:

Цитата Сообщение от meref Посмотреть сообщение
дня 3 мучаюсь
Погуглить стоило бы: https://stackoverflow.com/questions/...e-level-is-1-5

0
meref
0 / -1 / 0
Регистрация: 15.06.2017
Сообщений: 122
21.09.2018, 11:11  [ТС] 5
я гуглил, но почему-то не получалось. И я сделал 2 способами, но и там и там 1.7, а у меня стоит 1.8, это нормально?
0
21.09.2018, 11:11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.