Форум программистов, компьютерный форум, киберфорум
Наши страницы
Java
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
moshael
0 / 0 / 0
Регистрация: 23.02.2008
Сообщений: 3
1

В среде jbuilder5 аплет выполняеться,а из броузера-нет. ?

23.02.2008, 19:38. Просмотров 1041. Ответов 10
Метки нет (Все метки)

Сабж. Начинающий посему прошу прощения за может быть глупый вопрос.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.02.2008, 19:38
Ответы с готовыми решениями:

Можно ли запихать MenuBar в аплет или нет?
Доброго времени суток! У меня такой вопрос. Можно ли запихать MenuBar в аплет...

Вопросы по DataExpress в JBuilder5
Здравсвуйте! Есть вопрос про сабж: 1. Есть Interbase 6 и JBuilder 5 2. Есть...

Консоль в NetBeans4 или JBuilder5
Я только делаю первые шаги. Будучи уверен что знания по разработке C/C++ прог...

Сбор исполняемых WINDOWS файлов с помощью JBuilder5
как JBuilderoм собирать исполняемые виндовские файлы?

Не выполняеться CGI
Скрипт выполняется из консоли ./cgi2.cgi, но через веb...

10
JavaUser
70 / 70 / 28
Регистрация: 06.10.2013
Сообщений: 309
23.02.2008, 22:02 2
Если ваш броузер - Internet Explorer, то все очень просто. Он не поддерживает Java 2, которая используется для программирования апплетов и приложеий в JBuilder5. Эту версию Java поддерживет только Netscate 6.0 и выше.
0
mishgun
24.02.2008, 03:14 3
Есть ещё одно но.Если ваш апплет пытается выполнять какие-то действия которые по умолчанию запрещены для него то будет тоже самое.Разница в том что на написаные и выполняемые среде Билдера апплеты 'подписаны' но
при попытке вызвать апплет вне среды Билдера приводят к таким вещам.
iZEN
1 / 1 / 1
Регистрация: 18.08.2007
Сообщений: 289
24.02.2008, 23:48 4
Просто не используйте пакеты из Java2 (это прежде всего Swing), а также IE не поддерживает работу с RMI и JNI.

У меня, даже если я работаю в JB5 с JDK1.3 (без JDK1.1.4!), могу всё равно создавать совместимые с MS JVM апплеты (просто придерживаюсь ограничений о составе пакетов). Байт-код всегда один.

Другой вариант: достать Sun JDK1.1, проинсталлировать и прописать его в JBuilder как вторую платформу для разработки. Потом можно просто переключатся между платформами Java1.1 и Java2.
0
moshael
0 / 0 / 0
Регистрация: 23.02.2008
Сообщений: 3
25.02.2008, 23:25  [ТС] 5
До белого каления довел он меня.
Да именно IE и нужно что бы как раз в нем и работало все.

Выдает load: lab.Applet1 can't be instantiated.
Поставил JDK 1.1.8 и в своствах проекта в путях указал именно его.
Все то же самое.
Помогите!
0
iZEN
1 / 1 / 1
Регистрация: 18.08.2007
Сообщений: 289
25.02.2008, 23:57 6
В MS IE JVM версия JRE не выше 1.1.4.

1. А Вы уверены, что в свойсвах проекта:
Project Properties->Paths->JDK:<Ваш другой JDK> ?

2. А Вы уверены, что не используете ничего из Java2? Посмотрите предложения 'import' в java-файлах проекта, там не должно быть 'import java.rmi.*; import javax.swing.*;' и т.д., а также любого упоминания классов из Java2 в текстах файлов.

3. Повторяю, я использовал JDK1.3 из JBuilder5 для компиляции IE-совместимых апплетов (только на AWT, для Java1.1.4). Ранние версии JDK не устанавливал. Проблем с запуском апплетов под IE не было.
0
iZEN
1 / 1 / 1
Регистрация: 18.08.2007
Сообщений: 289
25.02.2008, 23:59 7
Приведите отрывок HTML-тэга <Applet ...>.
Возможно (и скорее всего) в нём ошибка.
0
Itsme
0 / 0 / 0
Регистрация: 27.02.2008
Сообщений: 56
27.02.2008, 09:14 8
Проверьте в исходнике, может быть, Ваш апплет extends JApplet? Если так, то сделайте, чтобы было extends Applet.
0
moshael
0 / 0 / 0
Регистрация: 23.02.2008
Сообщений: 3
27.02.2008, 22:58  [ТС] 9
Поборол,спасибо за советы. extend был именно Applet.
ПОборол тем что создал новый аплет и скопировал в него текст старого. А лажа эта возникала после смены default layot на XY.И после смены назад и вытирания всего лишнего не исправлялось.
0
iZEN
1 / 1 / 1
Регистрация: 18.08.2007
Сообщений: 289
27.02.2008, 23:22 10
Говорил же, не пользуйтесь Java2-пакетами и, отсюда соответсвенно, пакетами сторонних фирм, использующих Java2.
Но я специально не выяснял, что класс XYLayout из пакетов Borland, работает только в Java2. По-моему, он ещё работал с Java1.1, или я не прав? Если я прав, тогда Ваша ошибка была в том, что Вы не включили в свой рабочий набор пакет Borland-а с классом XYLayout. Вот и все дела.

А с совместимостью исходного Java-кода, произведённого с помощью JBuilder, и с использованием его в других средах разработки проблем никаких нет, уверяю Вас, так как JBuilder полностью сертифицирован для Java2 Platform. Надо только полностью представлять себе, какие классы какому пакету принадлежат и обеспечить присутствие пакетов, не входящих в Sun JRE/JDK, там, где требуется.
0
mishgun
28.02.2008, 01:00 11
XYLayout-такого в Джава2 нет.Это из борландовского пакета
28.02.2008, 01:00
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.02.2008, 01:00

Не выполняеться setTimeout
Данный код выполняется но без 3-х секундной задержки. Он выполняется...

Не выполняеться условия if
Подскажите почему то не выполняеться условия if вот код...

Не выполняеться код js на локалке
Доброй ночи, кто подскажет в чем может быть дело. Есть сайт...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru