Форум программистов, компьютерный форум, киберфорум
Наши страницы
Софт для Linux
Войти
Регистрация
Восстановить пароль
 
Sluchayno
30 / 30 / 21
Регистрация: 22.09.2013
Сообщений: 346
1

Ipsmanager 5 lite не запускается после обновления

08.10.2019, 19:20. Просмотров 292. Ответов 7
Метки нет (Все метки)

Здравствуйте, решил сегодня обновить сервер Ubuntu 16.04 до 18.04 все вроде бы прошло нормально, но вот беда, перестала запускаться панель управления ipsmanager 5 lite. Попытался обновить ее командой

/usr/local/mgr5/sbin/pkgupgrade.sh coremanager
Пишет что установленная последняя версия и обновлений нет

coremanager is already the newest version (5.217.0-1-ubuntu18).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
пытаюсь установить панель заново через их скрипт установки и получаю


sh install.sh ISPmanager

coremanager is already the newest version (5.217.0-1-ubuntu18).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Failed to open libexec part: lib/libmgr.so.5.217.0: undefined symbol: libssh2_session_set_timeout

Облазил все интернеты, но ничего мне не помогло. Может быть тут кто то подскажет решение?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.10.2019, 19:20
Ответы с готовыми решениями:

Не запускается после обновления
Доброго времени суток, принесли мак, после обновления системы (с какой не знаю) на самую последнюю,...

Не запускается ОС после обновления 7-ки до 10-ки
Возникла проблема после обновления 7-ки до 10-ки. Каждый перезапуск компьютера заканчивается...

Steam не запускается после обновления
В общем уже наверное дня 2-3, стим не запускается, его не видно ни на рабочем столе, ни в...

Не запускается после обновления системы
Каждый раз после обновления системы у меня не хочет она запускаться. Приходиться применять...

c++ не запускается после обновления windows 7!
почему после обновления не запускается c++??? и что делать??

7
Sluchayno
30 / 30 / 21
Регистрация: 22.09.2013
Сообщений: 346
09.10.2019, 21:15  [ТС] 2
Ну может кто то все таки поможет? Я бы задал такой вопрос на офф форуме, но там при регистрации надо вводить id лицензии а я ее не знаю т.к она ставилась хостером, посмотреть этот номер можно в самой панели, но зайди, как я написал, туда не могу.
0
gng
906 / 624 / 197
Регистрация: 08.09.2013
Сообщений: 1,688
09.10.2019, 21:37 3
Цитата Сообщение от Sluchayno Посмотреть сообщение
Ну может кто то все таки поможет?
Bash
1
# ldd /usr/local/.../ваша_программа
что пишет?
0
Sluchayno
30 / 30 / 21
Регистрация: 22.09.2013
Сообщений: 346
10.10.2019, 12:53  [ТС] 4
Bash
1
2
ldd /usr/local/mgr5/sbin/pkgupgrade.sh
        not a dynamic executable
0
10.10.2019, 12:53
gng
906 / 624 / 197
Регистрация: 08.09.2013
Сообщений: 1,688
10.10.2019, 13:59 5
Sluchayno, направьте ldd на бинарник манагера.
0
useroot
30 / 27 / 5
Регистрация: 18.08.2016
Сообщений: 135
11.10.2019, 09:23 6
Попробуй изменить ip сервака и установить заново. У них довольно жесткая привязка к этому.
0
Sluchayno
30 / 30 / 21
Регистрация: 22.09.2013
Сообщений: 346
12.10.2019, 12:01  [ТС] 7
ip изменить не могу потому что сайт на хостинге
0
Sluchayno
30 / 30 / 21
Регистрация: 22.09.2013
Сообщений: 346
14.10.2019, 12:18  [ТС] 8
Bash
1
2
3
4
5
6
7
8
9
ldd /usr/local/mgr5/sbin/mgrctl
        linux-vdso.so.1 (0x00007ffd3cfe2000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f3185dc4000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f3185bc0000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f3185822000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f318560a000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f31853eb000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f3184ffa000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f3186352000)
Просто обращаюсь к манагеру

Bash
1
2
/usr/local/mgr5/sbin/mgrctl
Failed to open libexec part: lib/libmgr.so.5.217.0: undefined symbol: libssh2_session_set_timeout
Добавлено через 3 часа 19 минут
libssh2 установлен

Bash
1
2
3
4
5
6
apt install libssh2-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
libssh2-1 is already the newest version (1.8.0-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Добавлено через 2 часа 38 минут
Установил libssh2 и shh2 в ручную и все запустилось, но проблема в том что сбились конфиги и запускается все через apahce2. По всей видимости проще всего будет убить сервак и поднять все по новой...
0
14.10.2019, 12:18
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.10.2019, 12:18

Не запускается Windows после обновления
Добрый вечер. Такая проблема. Новый компьютер, конечно же попёрли тонны обновлений, в пятницу всё...

После обновления Биоса не запускается Windows 7
Здравствуйте, очень нужна ваша помощь. После обновления Биоса не запускается Windows 7. Все железо...

Не запускается bluetooth после обновления Windows 8 на 8.1
При попытке отправления файла выдает(да и при любых других действиях связанных с bluetooth), качал...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.