Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Konstantin®
84 / 85 / 15
Регистрация: 24.10.2013
Сообщений: 594
#1

Realtek RTL8191SU 802.11n подключение к Mikrotik - Mikrotik

11.03.2018, 20:01. Просмотров 446. Ответов 11
Метки нет (Все метки)

Всех приветствую !
Есть необходимость подключить некую железку, в которой используется USB адаптер Realtek RTL8191SU
При попытке подключения к беспроводной сети под управлением CAPsMAN в логах вижу следующее:
Код
00:**:12:**:2B:42@cap2 connected
00:**:12:**:2B:42@cap2 disconnected, 4-way handshake timeout
На подключаемом устройстве при этом просто выдает сообщение "Ошибка"
Все бы можно было решить заменой адаптера на другой более нормальный, но подключаемый девайс не поддерживает другие адаптеры
Подкидываю этот адаптер на десктоп с OS Ubuntu 16.04, пытаюсь подключиться к той же сети и в логах Микротика наблюдаю аналогичную картину, при этом система периодически выкидывает окно с просьбой повторно ввести ключ сети.
В настройках CAPsMAN Security_Cfg пробовал менять Authentication Type и Encryption, результат отрицательный.
Сам адаптер рабочий, подключал к другой сети с шифрованием WPA2 PSK, работает без проблем, отказывается дружить только с Mikrotik...
Дайте совет, в какую сторону смотреть ?

Добавлено через 10 минут
Используемое оборудование:
1. RB952Ui-5ac2nD (основной роутер, он же контроллер Caps)
2. RBwAP2nDr2 (точка доступа в режиме CAP)
Version: 6.41.2
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.03.2018, 20:01
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Realtek RTL8191SU 802.11n подключение к Mikrotik (Mikrotik):

Реальная скорость wi-fi подключения (Адаптер стандарта 802.11ac + ноут со стандартом 802.11n)?
Добрый день! Я честно пытался гуглить, но по запросам мне выдавалась куча...

Вопрос о стандарте 802.11n (150mbps)
Здравствуйте. Дан маршрутизатор (роутер) Zyxel Keenetic Giga Заявленная...

Atheros AR5006X как изменить 802.11a на 802.11b
Всем добрый день! КАК изменить скорость? У меня на ноуте TOSHIBA - винда 7,...

Mikrotik подключение свичей друг за другом
Есть роутер от которого идет подключение в управляемым свичам №1 от него к №2...

Подключение роутера Mikrotik к другому роутеру по кабелю
Есть роутер D-Link DIR-300. Подключаю к нему роутер Mikrotik по схеме DIR-LAN -...

IEEE 802.1Q и 802.1p
Пишу дипломную и возникла ситуация, когда необходимо распознавать передаваемый...

11
insect_87
Модератор
Эксперт по компьютерным сетям
4826 / 3911 / 797
Регистрация: 25.12.2012
Сообщений: 16,621
11.03.2018, 21:18 #2
Цитата Сообщение от Konstantin® Посмотреть сообщение
В настройках CAPsMAN Security_Cfg пробовал менять Authentication Type и Encryption, результат отрицательный.
на какой (-ие)?
0
Konstantin®
84 / 85 / 15
Регистрация: 24.10.2013
Сообщений: 594
12.03.2018, 21:04  [ТС] #3
insect_87, пробовал режимы WPA PSK тип шифрования TKIP.
Думаю что откажусь от CAPsMANанастрою роутер и точку доступа как отдельные SSID и попробую еще раз подключить. К тому же как мне кажется для моих условий и задач CAPsMAN особо и не нужен, по крайней мере я не вижу в нём особой необходимости.

Добавлено через 12 часов 14 минут
Цитата Сообщение от Konstantin® Посмотреть сообщение
настрою роутер и точку доступа как отдельные SSID и попробую еще раз подключить.
В общем не помогает, в логах есть попытка соединения.
Код
00:**:12:**:2B:42@wlan1: connected, signal strength -83
00:**:12:**:2B:42@wlan1: disconnected, unicast key exchange timeout
Добавлено через 1 час 24 минуты
Судя по всему проблема заключается в самом чипе RTL8191, он довольно старый, попробую подобрать другой USB адаптер.
0
NoNaMe
[dead]
Эксперт по компьютерным сетям
636 / 290 / 44
Регистрация: 10.06.2009
Сообщений: 1,313
13.03.2018, 01:02 #4
Konstantin®, вживую видел данную ошибку, вот хоть убейте не помню как но я её победил.
Думаю нужно смотреть логи:
Код
/system logging add prefix=cap_ topics=caps
А ещё проверить работу на обычном Wireless пакедже.

Добавлено через 6 минут
Попробуйте создать копию существующего профиля безопасности, а затем измените пароль и другие необходимые настройки. Так-же такой баг можно добиться поместив несуществующие символы в пароль. Рекомендуемый набор символов латиница.
0
Konstantin®
84 / 85 / 15
Регистрация: 24.10.2013
Сообщений: 594
13.03.2018, 19:43  [ТС] #5
NoNaMe, Спасибо за совет, думаю логи cap уже не помогут, потому как CAP уже отключен.
Цитата Сообщение от NoNaMe Посмотреть сообщение
Так-же такой баг можно добиться поместив несуществующие символы в пароль.
А вот это очень дельный совет, у меня в пароле присутствует символ #
Вечером поменяю пароль и проверю.

Добавлено через 12 часов 26 минут

Не по теме:

Не равный бой продолжается, по хорошему подобрать "свисток" и забыть, но это не интересно


Сделал сеть полностью открытой результат таков:
22:22:42 wireless,info 00:**:12:**:2B:42@wlan1: connected, signal strength -52
22:22:56 wireless,info 00:**:12:**:2B:42@wlan1: disconnected, received deauth: sending station leaving (3)
Изменил пароль сети, убрал знак # оставил только латиницу и цифры, всего 16 символов, результат аналогичен вчерашнему.

Часть конфигурации связанной с wi-fi ниже

Кликните здесь для просмотра всего текста
Код
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    country=kazakhstan disabled=no distance=indoors frequency=2427 mode=\
    ap-bridge ssid=****** wireless-protocol=802.11 wmm-support=enabled
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=\
    localhost101W001 wpa2-pre-shared-key=***************

У кого какие мысли будут ?
0
.None
Эксперт по компьютерным сетям
2342 / 893 / 124
Регистрация: 23.06.2009
Сообщений: 3,158
14.03.2018, 09:31 #6
а другого роутера с wi-fi нет? проверить подключение с этого свистка
0
Dmitry
Эксперт по компьютерным сетямЭксперт NIX
10500 / 6003 / 436
Регистрация: 09.09.2009
Сообщений: 23,705
14.03.2018, 09:38 #7
Цитата Сообщение от Konstantin® Посмотреть сообщение
received deauth
mac-адрес не в бане?
канал не "сильно высокий"?
0
Konstantin®
84 / 85 / 15
Регистрация: 24.10.2013
Сообщений: 594
14.03.2018, 09:47  [ТС] #8
Цитата Сообщение от Dmitry Посмотреть сообщение
mac-адрес не в бане?
Dmitry, Нет фильтрации по MAC нет. Всем разрешено.
Цитата Сообщение от Dmitry Посмотреть сообщение
канал не "сильно высокий"?
Каналы тоже пробовал менять, ну как вариант попробую сегодня выставить самый низкий.

Добавлено через 55 секунд
Цитата Сообщение от .None Посмотреть сообщение
а другого роутера с wi-fi нет? проверить подключение с этого свистка
Проверял с двух разных, без проблем цепляется.
0
NoNaMe
[dead]
Эксперт по компьютерным сетям
636 / 290 / 44
Регистрация: 10.06.2009
Сообщений: 1,313
14.03.2018, 14:51 #9
Konstantin®, попробуйте поиграться с параметрами. Полная информация доступна тут.
0
.None
14.03.2018, 14:55
  #10

Не по теме:

не мала баба клопоту та купила порося

0
Konstantin®
84 / 85 / 15
Регистрация: 24.10.2013
Сообщений: 594
14.03.2018, 22:06  [ТС] #11
Цитата Сообщение от .None Посмотреть сообщение
не мала баба клопоту та купила порося

Не по теме:

А иначе жить скучно будет



Добавлено через 6 часов 23 минуты
В общем я прихожу к выводу, что виной всему именно этот адаптер когда он используется совместно с ядром линукс.
Ниже часть лога
Bash
1
# journalctl -af
Кликните здесь для просмотра всего текста
Bash
1
2
3
4
5
6
7
8
9
10
11
12
мар 15 00:44:36 localhost wpa_supplicant[1121]: wlx00**12**2b42: Trying to associate with 64:**:54:**:cc:e7 (SSID='1WAP2G' freq=2452 MHz)
мар 15 00:44:36 localhost wpa_supplicant[1121]: wlx00**12**2b42: Association request to the driver failed
мар 15 00:44:36 localhost NetworkManager[8271]: <info>  [1521053076.7408] device (wlx00**12**2b42): supplicant interface state: scanning -> associating
мар 15 00:44:41 localhost wpa_supplicant[1121]: wlx00**12**2b42: Authentication with 64:**:54:**:cc:e7 timed out.
мар 15 00:44:41 localhost wpa_supplicant[1121]: wlx00**12**2b42: CTRL-EVENT-DISCONNECTED bssid=64:**:54:**:cc:e7 reason=3 locally_generated=1
мар 15 00:44:41 localhost NetworkManager[8271]: <warn>  [1521053081.7357] sup-iface[0x1f26b70,wlx00**12**2b42]: connection disconnected (reason -3)
мар 15 00:44:41 localhost NetworkManager[8271]: <info>  [1521053081.7405] device (wlx00**12**2b42): supplicant interface state: associating -> disconnected
мар 15 00:44:41 localhost NetworkManager[8271]: <info>  [1521053081.8406] device (wlx00**12**2b42): supplicant interface state: disconnected -> scanning
мар 15 00:44:51 localhost NetworkManager[8271]: <warn>  [1521053091.8257] device (wlx00**12**2b42): Activation: (wifi) association took too long
мар 15 00:44:51 localhost NetworkManager[8271]: <info>  [1521053091.8258] device (wlx00**12**2b42): state change: config -> need-auth (reason 'none') [50 60 0]
мар 15 00:44:51 localhost NetworkManager[8271]: <warn>  [1521053091.8315] device (wlx00**12**2b42): Activation: (wifi) asking for new secrets
мар 15 00:44:51 localhost NetworkManager[8271]: <info>  [1521053091.8480] device (wlx00**12**2b42): supplicant interface state: scanning -> inactive

Остается только проверить это подключившись с этим адаптером к моей сети, используя компьютер с windows на борту.

P.S. та самая железка которую необходимо подключить тоже использует ядро линукс (только более устаревшее).
0
Konstantin®
84 / 85 / 15
Регистрация: 24.10.2013
Сообщений: 594
19.03.2018, 20:22  [ТС] #12
Лучший ответ Сообщение было отмечено insect_87 как решение

Решение

В общем вопрос закрыт, скажем так, через "костыли" установил в качестве клиента беспроводной сети Zyxel Keenetic Start, а к нему через LAN подключил нужный мне девайс
На этом пожалуй и закончу.
P.S. а свисток в связке с windows все-же проверю по возможности, ну и сообщу тут результат.
Всем спасибо за помощь и советы !!!
1
19.03.2018, 20:22
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.03.2018, 20:22
Привет! Вот еще темы с решениями:

Mikrotik TO Mikrotik (VPN)
Подскажите пожалуйста! Организовал VPN тунель м/у 2-мя Микротиками. Проблема...

802.3bq
Нужна длина пакета, скорость и тело (?) стандарт 802.3bq

Длина пакета 802.3 ap
Нужна длина пакета. И короткая характеристика сети (кроме скорости).

Длина пакета 802.3bg
Сабж. Нужна информация( до четверга). Облазил яндекс, гугл, любые сайты,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru