Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
GreyViper
0 / 0 / 0
Регистрация: 23.03.2011
Сообщений: 47
1

Как определить причину периодического отключения роутров Hap Lite?

29.04.2018, 06:52. Просмотров 342. Ответов 14

Всем доброго времени суток!
Итак, имеется роутер Mikrotik HAP Lite RB941-2ND, неделю назад с ним появилась проблема, о ней позже. Я поставил вместо него другой роутер —Mikrotik Hap Lite RB941-2ND-TC, перенес на него все настройки со старого роутера с помощью функции бекапа, однако проблема осталась, роутер ведет себя аналогично. Теперь суть проблемы: включаешь роутер, все работает, спустя какое-то время, при том разное, может 10 минут, может пол часа начинаются траблы, сначала пользователей отключает от нашего сервака (подключены по RDP), потом пропадает инет, в это время если подключатся к инету через Wi-Fi, подключение зависает на "Получение IP-адреса...", далее пишет "Ошибка аутентификации". Также, если был подключен к роутеру через Winbox, он пишет "Router has been disconnect", и к нему подключиться больше нельзя. Притом бывает, что с Winbox выкинет, Вайфай отвалится а по лан-портам связь еще может быть какое-то время. Если его перезагрузить, все работает, потом проблема появляется снова. Помогите как исправить?

Доп. сведения:
1. Роутер достался от прошлого сотрудинка, все настройки делались до меня и все работало, пока в один день не перестало.
2. На роутере настроено несколько VPN PPTP.
3. Не знаю важный ли момент, но через оба роутера пинг на ya.ru составляется 22-23мс, и каждый n-й пакет имеет задержку то 80мс, то 144мс, видел даже больше.
4. Ставил вместо микротиков какой-то Асус, там все работает нормально, но там далеко не все настройки как на Микротике, а точнее только поднято PPPoE подключение и все. И пинг на ya.ru стабильно 22-23мс, без всплесков.
4. При пинге шлюза, когда подключен любой микротик, задержка составляет менее 1мс, что нормально, однако один пакет из нескольких может показать пинг, например 80 мс, или даже выше.
5. Думал свитч проблемный, менял его результата 0. Напомню, роутер Асус работает нормально на любом свитче.
4. Если отключить инет и свитч от Микротика, он стабильно проработал 3 дня (больше просто не тестировал).
5. Сеть организована так: Роутер, один свитч, с занятыми 7-ю портами. Некоторые пользователи имеют доступ в локальную сеть через VPN PPTP.

Если нужны еще сведения - пишите. Спасибо за любую помощь!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.04.2018, 06:52
Ответы с готовыми решениями:

Обрыв PPOE Mikrotik Hap Lite
Всем привет. Есть Mikrotik Hap Lite и провайдер Ростелеком, Инет, поднимается...

Mikrotic hAp Lite и l2tp
Провайдер предоставляет доступ в интернет через l2tp. Вроде настроил правильно,...

Мост между двумя Mikrotik hAP AC lite
Доброго времени суток. Помогите решить задачу. В торговом центре нет...

Найти причину периодического зависания Ubuntu
Привет всем. Установил Ubuntu. где-то недели 2 пользуюсь. всё это время читал...

Как в "Просмотр событий" посмотреть причину отключения пк?
Как в "Просмотр событий" посмотреть причину отключения пк?

14
romsan
Эксперт по компьютерным сетям
1694 / 900 / 165
Регистрация: 17.10.2015
Сообщений: 3,992
29.04.2018, 09:29 2
ух.. сколько проблем. Тут куча "возможно" можно предположить. И петля, и конфликт адресов, и физическая поломка того же свитча.
Первым делом давайте посмотрим Ваш конфиг. (/export compact file=cyber.rsc) Все Ваши пароли и стат адреса можете затереть предварительно.
Второе, исходя из описания, попробуйте заменить свитч. Хотя конечно тут двойное противоречие:
- "ставил Асус - всё ок!"
- "отключал свитч и тырнет от МТ - всё ок!"
Может гдето кабель передавлен? Попробовать заменить на новые патчкорды временно.
1
GreyViper
0 / 0 / 0
Регистрация: 23.03.2011
Сообщений: 47
29.04.2018, 17:22  [ТС] 3
Цитата Сообщение от romsan Посмотреть сообщение
И петля...
Я тоже так подумал, но свитч у нас 8-портовый, 7 из которых уже были заняты, и никто ничего не переподключал.

Цитата Сообщение от romsan Посмотреть сообщение
и конфликт адресов
А вот тут поподробнее можно? У нас в другом месте, где организовано VPN PPTP к нашей локалке также стоит пара таких же Микротиков.

Цитата Сообщение от romsan Посмотреть сообщение
физическая поломка того же свитча.
И свитч и роутер я менял на другой, проблема остаётся.

Цитата Сообщение от romsan Посмотреть сообщение
Первым делом давайте посмотрим Ваш конфиг. (/export compact file=cyber.rsc) Все Ваши пароли и стат адреса можете затереть предварительно.
Вот
Код
# apr/17/2018 11:08:06 by RouterOS 6.41
# software id = 7Z71-CVJC
#
# model = RouterBOARD 941-2nD
# serial number = 7DE307B119D1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=wlan \
    wireless-protocol=802.11
/interface bridge
add admin-mac=000 arp=proxy-arp auto-mac=no name=bridge
/interface ethernet
set [ find default-name=ether1 ] mac-address=000 name=000
set [ find default-name=ether2 ] rx-flow-control=auto tx-flow-control=auto
set [ find default-name=ether3 ] name=switch
/interface pppoe-client
add add-default-route=yes disabled=no interface=000 name=000 password=\
    000 use-peer-dns=yes user=000
/interface l2tp-server
add name=000 user=000
add name=r000 user=r000
/interface pptp-server
add name=C000 user=C000
add name=C000 user=C000
add name=s000 user=s000
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=000 \
    wpa2-pre-shared-key=000
/ip pool
add name=LAN ranges=000.000.0.100-000.000.0.254
add name=VPN ranges=000.000.000.2-000.000.000.254
/ip dhcp-server
add address-pool=LAN disabled=no interface=bridge lease-time=1d name=bridge
/ppp profile
add bridge=bridge change-tcp-mss=yes incoming-filter="" local-address=\
    000.000.000.1 name=VPN only-one=yes remote-address=VPN
add bridge=bridge change-tcp-mss=yes local-address=000.000.000.1 name=VIP \
    only-one=yes remote-address=VPN
/interface l2tp-client
add allow-fast-path=yes connect-to=00.000.000.195 disabled=no name=000k \
    password=0000r profile=default user=00000
/system logging action
set 1 disk-file-count=3 disk-lines-per-file=10000
/interface bridge port
add bridge=bridge interface=ether2
add bridge=bridge interface=switch
add bridge=bridge interface=ether4
add bridge=bridge interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=all
/interface detect-internet
set detect-interface-list=WAN lan-interface-list=LAN
/interface l2tp-server server
set default-profile=VPN enabled=yes
/interface list member
add interface=bridge list=LAN
add interface=000 list=WAN
add interface=000 list=WAN
/interface pptp-server server
set default-profile=VPN enabled=yes
/ip accounting
set enabled=yes
/ip address
add address=000.000.000.1/24 comment=defconf interface=bridge network=\
    000.000.000.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=LDS
/ip dhcp-server lease
add address=000.000.000.72 always-broadcast=yes mac-address=000 \
    server=bridge
add address=000.000.000.74 mac-address=000 server=bridge
add address=000.000.000.71 mac-address=0000 server=bridge
add address=000.000.000 mac-address=000 server=bridge
add address=000.000.000 always-broadcast=yes mac-address=0000 \
    server=bridge
/ip dhcp-server network
add address=000.000.0000/24 comment=LAN gateway=000.000.000.1
add address=000.000.000.0/24 comment=VPN dns-server=000.000.000.1 gateway=\
    000.000.000.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    disabled=yes in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=drop chain=input dst-port=53 in-interface-list=WAN protocol=udp
add action=drop chain=input comment="drop pptp brute forcers" dst-port=1723 \
    protocol=tcp src-address-list=pptp_blacklist
add action=add-src-to-address-list address-list=pptp_blacklist \
    address-list-timeout=1w3d chain=input connection-state=new dst-port=1723 \
    protocol=tcp src-address-list=pptp_stage3
add action=add-src-to-address-list address-list=pptp_stage3 \
    address-list-timeout=1m chain=input connection-state=new dst-port=1723 \
    protocol=tcp src-address-list=pptp_stage2
add action=add-src-to-address-list address-list=pptp_stage2 \
    address-list-timeout=1m chain=input connection-state=new dst-port=1723 \
    protocol=tcp src-address-list=pptp_stage1
/ip firewall nat
add action=masquerade chain=srcnat comment=masquerade ipsec-policy=out,none \
    out-interface=!bridge
add action=dst-nat chain=dstnat comment=Redmine dst-port=80 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000 to-ports=80
add action=dst-nat chain=dstnat comment=RDP dst-port=6 in-interface=!bridge \
    protocol=tcp to-addresses=000.000.000 to-ports=3389
add action=dst-nat chain=dstnat comment=Ftp_Install dst-port=21 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000.70 to-ports=21
add action=dst-nat chain=dstnat comment="RDP 000" dst-port=12850 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000.70 to-ports=\
    12850
add action=dst-nat chain=dstnat comment="RDP 000r" dst-port=156 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000 to-ports=\
    3389
add action=dst-nat chain=dstnat comment="RDP 000m" dst-port=71 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000 to-ports=\
    3389
add action=dst-nat chain=dstnat comment="RDP 000р" dst-port=72 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000 to-ports=\
    3389
add action=dst-nat chain=dstnat comment="RDP 00ey" dst-port=73 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.5.73 to-ports=\
    3389
add action=dst-nat chain=dstnat comment="RDP 0a" dst-port=74 \
    in-interface-list=WAN protocol=tcp to-addresses=000.000.000.74 to-ports=\
    3389
add action=dst-nat chain=dstnat comment=Torrent dst-port=10001 protocol=tcp \
    to-addresses=000.000.000.6 to-ports=10001
add action=dst-nat chain=dstnat comment=Torrent dst-port=10001 protocol=udp \
    to-addresses=000.000.000.6 to-ports=10001
add action=dst-nat chain=dstnat comment=CommFort dst-port=9750 \
    in-interface-list=WAN protocol=tcp to-addresses=1000.000.000.70 to-ports=\
    9750
add action=dst-nat chain=dstnat comment=CommFort dst-address=9000.000.000 \
    in-interface-list=!WAN protocol=tcp src-address=000.000.000/16 \
    to-addresses=000.000.000
add action=masquerade chain=srcnat comment=CommFort dst-address=000.000.000 \
    protocol=tcp
add action=dst-nat chain=dstnat dst-port=25 protocol=tcp to-addresses=\
    000.000.000 to-ports=25
/ip proxy
set enabled=yes port=888 serialize-connections=yes src-address=0.0.0.0
/ip route
add distance=1 dst-address=000.000.0000/24 gateway=000.000.000.50
add distance=1 dst-address=000.000.0008.0/24 gateway=0000
add distance=1 dst-address=000.000.0009.0/24 gateway=000.000.000.254
add distance=1 dst-address=000.000.0000.0/24 gateway=000.000.000.253
/ip service
set telnet disabled=yes port=2323
set ftp port=2121
set www disabled=yes port=8080
set ssh disabled=yes port=2222
set api disabled=yes
/ip upnp
set enabled=yes show-dummy-rule=no
/ip upnp interfaces
add interface=0000t type=external
add interface=bridge type=internal
add interface=rt000 type=internal
/ppp secret
add name=0 password=0 profile=VPN
add name=0 password=0 profile=VPN
add name=0 password=0 profile=VPN
add name=0 password=0R profile=VPN
add name=0 password=0 profile=VIP
add name=R00_00 password=A0 profile=VPN
add name=rtdmn password=0 profile=VIP remote-address=\
    000.00.100.00
add name=0 password=saxsafon profile=VPN remote-address=0.0.0.0
add name=C0R password=0 profile=VPN remote-address=0.0.0.0
add name=C00R password=0 profile=VPN remote-address=\
    0.0.0.0
add name=0n password=C0 profile=VPN remote-address=\
    0.0.0.0
/system clock
set time-zone-autodetect=no time-zone-name=Europe/Moscow
/system identity
set name=Most
/system logging
set 0 action=disk
set 1 action=disk
set 2 action=disk
set 3 action=disk
/system ntp client
set enabled=yes primary-ntp=0.0.0.0 secondary-ntp=0.0.0.00 \
    server-dns-names=прпрпрпрпр
/system routerboard settings
set cpu-frequency=750MHz
/tool graphing interface
add interface=00
add interface=00_Inet
add interface=bridge
add interface=ether2
add interface=switch
add interface=wlan1
add interface=ether4
add
/tool graphing queue
add
/tool graphing resource
add
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Сейчас обратил внимание на:
/ppp secret
add name=0 password=0 profile=VPN
add name=0 password=0 profile=VPN
add name=0 password=0 profile=VPN
add name=0 password=0R profile=VPN
add name=0 password=0 profile=VIP
add name=R00T_ADMIN password=00007 profile=VPN
add name=rtdmn password=0007 profile=VIP remote-address=\
0.0.0.00



Красными выделены логины, которыми пользовался прошлый админ, может он что-то удаленно подправил?

PS: Тут стоит еще прошивка 6.41, обновлял до 6.42 - не помогло.

Цитата Сообщение от romsan Посмотреть сообщение
Второе, исходя из описания, попробуйте заменить свитч. Хотя конечно тут двойное противоречие:
- "ставил Асус - всё ок!"
- "отключал свитч и тырнет от МТ - всё ок!"
Может гдето кабель передавлен? Попробовать заменить на новые патчкорды временно.
Свитч менял, сам удивляюсь что с Асосм все ок, а на микротиках что-то неладное твориться. У нас 1 кабель - это инет, 6 идут от свитча к компам, и еще 1 к серваку. Какой кабель проверять? Или любой может вызывать данные глюки?
0
romsan
Эксперт по компьютерным сетям
1694 / 900 / 165
Регистрация: 17.10.2015
Сообщений: 3,992
30.04.2018, 21:41 4
я чтото путаюсь в Ваших 000. Не пойму, это действительно 000 или затертые данные. (внутреннюю подсеть смысла нет затирать, Вы же за НАТом)
У Вас LAN имеет подсеть ***.***.0.0/24 ?
а VPN какую подсеть имеет?

Цитата Сообщение от GreyViper Посмотреть сообщение
У нас 1 кабель - это инет, 6 идут от свитча к компам, и еще 1 к серваку
вообще какие задачи стоят? Может у Вас куча уже не нужного в МТ?
2
GreyViper
0 / 0 / 0
Регистрация: 23.03.2011
Сообщений: 47
02.05.2018, 20:16  [ТС] 5
romsan, можно я Вам в личку сброшу как есть все без редактирования, я уже не знаю куда смотреть. Вчера опять тоже самое 5-7 минут проработал с запущенным пингом на ya.ru. Далее стал писать "Превышен интервал ожидания", после пары таких строк выдал: "Ответ от [ip роутера] Заданная сеть недоступна". Спустя еще секунд 30 Winbox меня выкинул с сессии и не захотел преподключаться до ребута роутера.
0
GreyViper
0 / 0 / 0
Регистрация: 23.03.2011
Сообщений: 47
12.05.2018, 12:23  [ТС] 6
Сегодня опять пытался разобраться в чем проблема. Появились некоторые подробности. Роутер вырубается после того как определенное время будет загрузка проца на 100%. Также я выше писал что на роутере иногда проскакивают пакеты с повышенным пингом, это совпадает как раз с полной загрузкой проца. В связи с этим у меня несколько вопросов. Может ли загрузка проца "вырубать" роутер? И как найти причину такого поведения? Сегодня подключил роутер, он проработал где-то минут 40, после чего вышеописанная ситуация повторилась - роутер перестал быть доступен. Я обратил внимание что до этого минуты 2-3 загрузка проца была 100%, после этого я перезагрузил роутер, он проработал минут 5 и загрузка проца опять стала 100%. такое поведение ротуре показывает, только если в него втыкнуть кабель интернета. Без подключения к интернету он проработал дня 4 и не перезагружался. Следовательно, этот как-то связано с интернетом. Также напомню, что на роутере есть несколько впнок, я их вроде все отключил, однако в логах все-равно пишет, что невозможно сконнектится с PPTP. Выкладываю "скрин". Извините за фото экрана, на том компе где я был нельзя вставлять свои накопители.

PS: На предыдущем роутере была какая-то команда, которая повышала частоту проца до 750 Мгц. Но при переносе конфигурации на этот роутер, я смотрю, проц остался на 650 Мгц. Похоже, проблема с загрузкой была и раньше.
0
Миниатюры
Как определить причину периодического отключения роутров Hap Lite?  
.None
Эксперт по компьютерным сетям
2357 / 904 / 129
Регистрация: 23.06.2009
Сообщений: 3,207
12.05.2018, 19:01 7
ну вот и причина, ваш роутер не справляется с нагрузкой
при 100% загрузке трафик деградирует очень сильно, возможно перегрев процессора со всеми вытекающими

отключайте прокси сервер, станет полегче, или переходить на более производительную модель

но для начала, я бы рекомендовал сбросить микротик в 0 и заново вдумчиво настроить руками по потребностям, если нужно прокси, то вынести на отдельное устройство

Добавлено через 9 минут
с другой стороны странно что проявляется когда подключен интернет, возможно атака на роутер, нужно смотреть на месте

Добавлено через 15 минут
нужно настроить фаервол, возможно после этого станет полегче
1
GreyViper
0 / 0 / 0
Регистрация: 23.03.2011
Сообщений: 47
12.05.2018, 20:36  [ТС] 8
Цитата Сообщение от .None Посмотреть сообщение
ну вот и причина, ваш роутер не справляется с нагрузкой
при 100% загрузке трафик деградирует очень сильно, возможно перегрев процессора со всеми вытекающими
Ну да, совпадает, как я сказал выше, первый раз после долгого отключения он проработал минут 40, а после ребута - минут 5.

Цитата Сообщение от .None Посмотреть сообщение
для начала, я бы рекомендовал сбросить микротик в 0 и заново вдумчиво настроить руками по потребностям
Помимо PPPoE и Wi-Fi обязательным являются две ВПН-ки, как мне объяснили, одна с другим микротиком на другом офисе, вторая - с обычным виндовым подключением. Это сделано, чтобы их принтеры были в нашей локальной сети.

Цитата Сообщение от .None Посмотреть сообщение
отключайте прокси сервер, станет полегче, или переходить на более производительную модель
... если нужно прокси, то вынести на отдельное устройство
Прокси не нужен. Как его отключить? И еще, если можно, подскажите, может еще что отключить нужно исходя из фото выше?
Там еще процесс есть cpu0, я так понял это просто показывается что весь проц занят другими процессами? Или что это?

Цитата Сообщение от .None Посмотреть сообщение
с другой стороны странно что проявляется когда подключен интернет, возможно атака на роутер, нужно смотреть на месте
Может просто какие-то службы не работают без инета, из-за этого ресурс процессора расходуется меньше. Как можно проверить роутер на атаку?

Цитата Сообщение от .None Посмотреть сообщение
нужно настроить фаервол, возможно после этого станет полегче
Можно поподробнее, что нужно настраивать? Какие правила и т.д.

Спасибо!
0
Konstantin®
94 / 95 / 17
Регистрация: 24.10.2013
Сообщений: 664
14.05.2018, 10:55 9
Цитата Сообщение от .None Посмотреть сообщение
с другой стороны странно что проявляется когда подключен интернет
Думаю ничего странного, возможно NAT так нагружает роутер.
GreyViper, А пользователи случайно торрентами не балуются ?
0
.None
Эксперт по компьютерным сетям
2357 / 904 / 129
Регистрация: 23.06.2009
Сообщений: 3,207
14.05.2018, 11:07 10
там выше есть фотка профайла, не похоже на нат, очень похоже что кто-то с инета юзает прокси, фаервол никакой
1
Konstantin®
94 / 95 / 17
Регистрация: 24.10.2013
Сообщений: 664
14.05.2018, 11:21 11
Цитата Сообщение от .None Посмотреть сообщение
выше есть фотка профайла, не похоже на нат

Не по теме:

Да, уже рассмотрел.



Добавлено через 4 минуты
Цитата Сообщение от .None Посмотреть сообщение
похоже что кто-то с инета юзает прокси
А можно ли это отследить запустив Torch на внешнем интерфейсе ?
0
.None
Эксперт по компьютерным сетям
2357 / 904 / 129
Регистрация: 23.06.2009
Сообщений: 3,207
14.05.2018, 11:23 12
да, будут пакеты с dst тика и портом прокси
1
GreyViper
0 / 0 / 0
Регистрация: 23.03.2011
Сообщений: 47
16.05.2018, 19:47  [ТС] 13
Итак, ребята, отключил прокси, аптайм уже чуть более 3 дней, загрузка проца не более 4-5%. Всем большое спасибо за помощь! Остался последний вопрос, помогите правильно настроить фаервол, пожалуйста. И еще раз всем спасибо!
0
.None
Эксперт по компьютерным сетям
2357 / 904 / 129
Регистрация: 23.06.2009
Сообщений: 3,207
16.05.2018, 19:59 14
ну давайте еще раз /ip firewall filter export
в тег CODE под спойлер
0
romsan
Эксперт по компьютерным сетям
1694 / 900 / 165
Регистрация: 17.10.2015
Сообщений: 3,992
16.05.2018, 20:11 15
Цитата Сообщение от GreyViper Посмотреть сообщение
помогите правильно настроить фаервол, пожалуйста
вот тут мы курили Правила для mikrotik firewall
0
16.05.2018, 20:11
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.05.2018, 20:11

Как определить причину BSOD?
Я в этом вообще не разбираюсь помогите определить что с ПК.

Определить спектр периодического сигнала
Кто может определить

Как определить причину не выполнения скрипта в Cron
Доброго времени суток. Ищу помощи в решении такого вопроса: На сервере...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru