Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
delfoeros
0 / 0 / 0
Регистрация: 28.02.2017
Сообщений: 50
#1

Два адреса wan на устройстве - Mikrotik

15.06.2018, 07:19. Просмотров 167. Ответов 5
Метки нет (Все метки)

Привет all!
Столкнулся с такой ситуацией:
На wan висят два адреса, один 192.168.0.10(это предоставляет провайдер), другой 10.2.110.3 это уже внутри моей сети адрес для управления и т.п. Дело в том, что часть оборудования в том числе телефония нормально работает т.к. Все маршруты прописанно что должны идти через 192.168.0.9 (для меня Некстхоуп провайдера), а вот внутри моей сети с другими офисами связи нет скажем до 3 офисов 10.2.110.10, 10.2.110.20, 10.2.110.30. Но удаленно я прекрасно захожу на 10.2.110.3 с центрального офиса.
Вопрос вот в чем, при пинге 10.2.110.10 я выбираю src.addr, 10.2.110.3 все прекрасно работает, а если не указать адрес принудительно, то нет. Как быть с маршрутами если весь трафик заворачивает 0.0.0.0/16 на 192.168.0.9
Скрины некоторых правил:
http://www.cyberforum.ru/networking-equipment/thread2219824.html
0
Миниатюры
Два адреса wan на устройстве   Два адреса wan на устройстве  
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.06.2018, 07:19
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Два адреса wan на устройстве (Mikrotik):

для чего WAN
для чего нужно гнездо wan? написано что инет надо пдкл в него но а бывает...

Минипорт WAN (IPX)
Всем привет! Как починить минипорт WAN (IPX), отмеченный восклицательным знаком?

Переподключение WAN через telnet
Есть модем ZTE ZXHN H108N, нужно обновить ip адрес с помощью telnet. Есть...

Правильная настройка (IP/Addresses -> WAN)
Привет всем. Хотел-бы попросить немного помощи по настройки Mikrotik(простите,...

выбор маршрутизатора на 2 wan порта
приветствую всех! в связи с нагузкой на канал требуется увеличение мощности, но...

5
delfoeros
0 / 0 / 0
Регистрация: 28.02.2017
Сообщений: 50
15.06.2018, 07:26  [ТС] #2
На скрине адрес не 192.168.0.1, а 192.168.0.9 должен быть
Чёт не хочет у меня скажем 1с из сети 192.168.88.0 цепляться на сервер 10.2.110.10 хотя в подключениях висит соединение syn set
0
NoNaMe
[dead]
Эксперт по компьютерным сетям
636 / 290 / 44
Регистрация: 10.06.2009
Сообщений: 1,316
15.06.2018, 08:43 #3
delfoeros, Как я проверю на стенде. Дайте полный конфиг без логинов и паролей. И схему сети.
0
delfoeros
0 / 0 / 0
Регистрация: 28.02.2017
Сообщений: 50
15.06.2018, 10:57  [ТС] #4
NoNaMe,
Есть, к сожалению только в таком формате:
Кликните здесь для просмотра всего текста
Код
# jun/14/2018 15:23:48 by RouterOS 6.39.2
# software id = VLDM-B3XG
#
/interface bridge
add admin-mac=56:D1:66:70:C7:G6 arp=proxy-arp auto-mac=no comment=defconf \
    name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    distance=indoors frequency=auto mode=ap-bridge ssid=SLV \
    wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] name=eth1-wan
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
set [ find default-name=ether5 ] master-port=ether2-master
/ip neighbor discovery
set eth1-wan discover=no
/interface vlan
add arp=proxy-arp interface=eth1-wan name=vlan218 vlan-id=218
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.20
/ip dhcp-server
add address-pool=dhcp authoritative=after-2sec-delay disabled=no interface=\
    bridge lease-time=3d8h name=dhcp-pc
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge disabled=yes interface=eth1-wan
/ip address
add address=10.2.110.10/27 comment=defconf interface=eth1-wan network=\
    10.2.110.0
add address=192.168.0.10/30 interface=eth1-wan network=192.168.0.8
add address=192.168.88.1/24 comment=defconf interface=ether2-master network=\
    192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid interface=eth1-wan
/ip dhcp-server lease
add address=192.168.88.20 client-id=1:d6:6d:7:17:b:89 mac-address=\
    F4:6D:04:17:0B:D8 server=dhcp-pc
add address=192.168.88.19 mac-address=V7:C3:67:3D:24:9A server=dhcp-pc
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 gateway=\
    192.168.88.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=10.2.110.3 name=router
/ip firewall address-list
add address=10.2.110.0/24 list=NAT
add address=192.168.0.9 list=NAT
add address=10.2.7.0/24 list=NAT
add address=10.2.110.10 list=NAT
add address=10.2.110.20 list=NAT
add address=10.2.110.30 list=NAT
add address=10.2.1.151 comment=WMVARE_TEST list=NAT
add address=192.168.88.0/24 list=NAT
/ip firewall filter
add action=accept chain=input comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \E2\F1\E5 I\
    CMP \E8\E7 \F1\EF\E8\F1\EA\E0 \E0\E4\F0\E5\F1\EE\E2" protocol=icmp \
    src-address-list=NAT
add action=accept chain=input comment="\C4\EE\F1\F2\F3\EF \ED\E0 Mikrotik \E8\
    \E7 \EB\EE\EA\E0\EB\FC\ED\EE\E9 \F1\E5\F2\E8 (TCP)" connection-state=new \
    disabled=yes dst-port=8291,443,80,3389,5060 in-interface=bridge protocol=\
    tcp src-address=10.2.110.0/24 src-address-list=NAT
add action=accept chain=input comment="\C4\EE\F1\F2\F3\EF \ED\E0 Mikrotik \E8\
    \E7 \EB\EE\EA\E0\EB\FC\ED\EE\E9 \F1\E5\F2\E8 (TCP)" connection-state=new \
    dst-port=80,22,8291,443,80,3389,5060 in-interface=bridge protocol=tcp \
    src-address=192.168.88.0/24 src-address-list=NAT
add action=accept chain=input comment="\C4\EE\F1\F2\F3\EF \ED\E0 Mikrotik \E8\
    \E7 \EB\EE\EA\E0\EB\FC\ED\EE\E9 \F1\E5\F2\E8 UDP" connection-state=new \
    dst-port=53,123,5060,8291,3381,5678 in-interface=bridge protocol=udp \
    src-address=192.168.88.0/24 src-address-list=NAT
add action=accept chain=input comment="\C4\EE\F1\F2\F3\EF \ED\E0 Mikrotik \E8\
    \E7 \EB\EE\EA\E0\EB\FC\ED\EE\E9 \F1\E5\F2\E8 UDP" connection-state=new \
    dst-port=53,123,5060,8291,3381,5678 in-interface=eth1-wan protocol=udp \
    src-address=192.168.88.0/24 src-address-list=NAT
add action=accept chain=input comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \EF\E0\EA\
    \E5\F2\FB \F3\E6\E5 \F3\F1\F2\E0\ED\EE\E2\EB\E5\ED\ED\FB\F5 \E8 \F1\E2\FF\
    \E7\E0\ED\ED\FB\F5 \F1\EE\E5\E4\E8\ED\E5\ED\E8\E9" connection-state=\
    established,related src-address-list=NAT
add action=accept chain=input comment="\C4\EE\F1\F2\F3\EF \ED\E0 Mikrotik \E8\
    \E7 \EB\EE\EA\E0\EB\FC\ED\EE\E9 \F1\E5\F2\E8 UDP" connection-state=new \
    disabled=yes dst-port=53,123,5060,8291,3381,5678 in-interface=bridge \
    protocol=udp src-address=10.2.110.0/24 src-address-list=NAT
add action=accept chain=input comment="\C4\EE\F1\F2\F3\EF \ED\E0 Mikrotik \E8\
    \E7 \E2\ED\E5\F8\ED\E5\E9 \F1\E5\F2\E8 (TCP)" connection-mark=allow_in \
    connection-state=new disabled=yes dst-port=\
    443,80,3389,5060,8291,4589,1194 in-interface=eth1-wan protocol=tcp \
    src-address-list=NAT
add action=accept chain=output comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \E8\F1\F5\
    \EE\E4\FF\F9\E8\E9 \F2\F0\E0\F4\E8\EA \EF\EE \E8\E7\E2\E5\F1\F2\ED\FB\EC \
    \F1\EE\E5\E4\E8\ED\E5\ED\E8\FF\EC" connection-state=!invalid \
    dst-address-list=NAT
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \F2\F0\E0\
    \F4\F4\E8\EA \F1\F3\F9\E5\F1\F2\E2\F3\FE\F9\E8\F5 \E8 \ED\EE\E2\FB\F5 \F1\
    \EE\E5\E4\E8\ED\E5\ED\E8\E9 \F2\EE\EB\FC\EA\EE \E2\ED\F3\F2\F0\E5\ED\ED\E5\
    \E9 \F1\E5\F2\E8 \EF\F0\EE\F5\EE\E4\FF\F9\E8\E9 \F7\E5\F0\E5\E7 \EC\E0\F0\
    \F8\F0\F3\F2\E8\E7\E0\F2\EE\F0" connection-state=established,new \
    dst-address-list=NAT in-interface=bridge out-interface=eth1-wan \
    src-address=192.168.88.20
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \F2\F0\E0\
    \F4\F4\E8\EA \F1\F3\F9\E5\F1\F2\E2\F3\FE\F9\E8\F5 \E8 \ED\EE\E2\FB\F5 \F1\
    \EE\E5\E4\E8\ED\E5\ED\E8\E9 SIP \F2\EE\EB\FC\EA\EE \E2\ED\F3\F2\F0\E5\ED\
    \ED\E5\E9 \F1\E5\F2\E8 \EF\F0\EE\F5\EE\E4\FF\F9\E8\E9 \F7\E5\F0\E5\E7 \EC\
    \E0\F0\F8\F0\F3\F2\E8\E7\E0\F2\EE\F0" connection-state=established,new \
    dst-address-list=NAT in-interface=bridge out-interface=eth1-wan \
    src-address=192.168.88.19
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \F2\F0\E0\
    \F4\F4\E8\EA \F1\F3\F9\E5\F1\F2\E2\F3\FE\F9\E8\F5 \E8 \ED\EE\E2\FB\F5 \F1\
    \EE\E5\E4\E8\ED\E5\ED\E8\E9 \F2\EE\EB\FC\EA\EE \E2\ED\F3\F2\F0\E5\ED\ED\E5\
    \E9 \F1\E5\F2\E8 \EF\F0\EE\F5\EE\E4\FF\F9\E8\E9 \F7\E5\F0\E5\E7 \EC\E0\F0\
    \F8\F0\F3\F2\E8\E7\E0\F2\EE\F0" connection-state=established,new \
    disabled=yes dst-address-list=NAT in-interface=bridge out-interface=\
    eth1-wan src-address=192.168.88.0/24
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \E2\F5\EE\
    \E4\FF\F9\E8\E9 \F2\F0\E0\F4\F4\E8\EA \EF\EE \F1\F3\F9\E5\F1\F2\E2\F3\FE\
    \F9\E8\EC \F1\EE\E5\E4\E8\ED\E5\ED\E8\FF\EC" connection-state=\
    established,related in-interface=eth1-wan out-interface=bridge \
    src-address-list=NAT
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \E2\F5\EE\
    \E4\FF\F9\E8\E9 \F2\F0\E0\F4\F4\E8\EA \EF\EE \F1\F3\F9\E5\F1\F2\E2\F3\FE\
    \F9\E8\EC \F1\EE\E5\E4\E8\ED\E5\ED\E8\FF\EC" connection-state=established \
    dst-address=10.2.110.0/24 in-interface=eth1-wan out-interface=bridge \
    protocol=tcp src-address-list=NAT
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \E2\F5\EE\
    \E4\FF\F9\E8\E9 \F2\F0\E0\F4\F4\E8\EA \EF\EE \F1\F3\F9\E5\F1\F2\E2\F3\FE\
    \F9\E8\EC \F1\EE\E5\E4\E8\ED\E5\ED\E8\FF\EC" connection-state=established \
    dst-address=192.168.88.20 in-interface=eth1-wan out-interface=bridge \
    protocol=tcp src-address-list=NAT
add action=accept chain=forward comment="\D0\E0\E7\F0\E5\F8\E8\F2\FC \E2\F5\EE\
    \E4\FF\F9\E8\E9 \F2\F0\E0\F4\F4\E8\EA \EF\EE \F1\F3\F9\E5\F1\F2\E2\F3\FE\
    \F9\E8\EC \F1\EE\E5\E4\E8\ED\E5\ED\E8\FF\EC" connection-state=established \
    dst-address=192.168.88.19 in-interface=eth1-wan out-interface=bridge \
    protocol=tcp src-address-list=NAT
add action=reject chain=input comment=\
    "\C7\E0\EF\F0\E5\F9\E5\ED \C2\D5\CE\C4\DF\D9\C8\C9 \F2\F0\E0\F4\F4\E8\EA" \
    disabled=yes reject-with=icmp-network-unreachable
add action=accept chain=output comment="\C7\E0\EF\F0\E5\F9\E5\ED \C8\D1\D5\CE\
    \C4\DF\D9\C8\C9 \F2\F0\E0\F4\F4\E8\EA" log=yes
add action=accept chain=forward comment="\C7\E0\EF\F0\E5\F9\E5\ED \CF\D0\CE\D5\
    \CE\C4\DF\D9\C8\C9 \F2\F0\E0\F4\F4\E8\EA" log=yes
/ip firewall mangle
add action=mark-connection chain=prerouting connection-state=new dst-port=\
    4589 in-interface=eth1-wan log=yes new-connection-mark=allow_in \
    passthrough=yes protocol=tcp
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" log=yes \
    out-interface=eth1-wan src-address=192.168.88.0/24
add action=redirect chain=dstnat dst-port=4589 in-interface=eth1-wan \
    protocol=tcp to-ports=443
add action=netmap chain=dstnat comment="\CC\C0\C3" dst-port=22562 \
    in-interface=eth1-wan protocol=tcp to-addresses=192.168.88.20 to-ports=\
    22562
/ip route
add check-gateway=ping distance=1 dst-address=10.2.0.0/16 gateway=\
    192.168.0.9
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=\
    10.2.110.180/32,10.2.110.0/24,192.168.88.0/24,10.2.110.151/32
set ssh address=,10.2.110.0/24
set www-ssl address=\
    10.2.110.151/32,10.2.110.0/24,10.2.110.180/32 \
    certificate=SSL disabled=no
set api disabled=yes
set winbox address=10.2.110.0/24,10.2.1.0/24,,192.168.88.0/24
set api-ssl disabled=yes
/system identity
set name=WORK_01
/system routerboard settings
set init-delay=0s
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge


Добавлено через 1 час 34 минуты
Частично проблема сдвинулась, пинг побежал, но вот трафик обратно не идет:
Chain srcnat
Dst adress 10.2.110.10
Action srcnat to adress 10.2.110.3
Dst adress 10.2.110.20
Action srcnat to adress 10.2.110.3
Dst adress 10.2.110.30
Action srcnat to adress 10.2.110.3
Может обратно не так нужно, но ведь у меня три адреса?
Chain dstnat
Src adress 10.2.110.3
Action dstnat to Adress 10.2.110.10
П.Сы. Естественно настроен маскарад на srcnat SrcAddr 192.168.88.0/24 out eth-wan
0
.None
Эксперт по компьютерным сетям
2343 / 894 / 124
Регистрация: 23.06.2009
Сообщений: 3,161
15.06.2018, 16:48 #5
многое не понятно, почему на WAN 2 адреса?
центральный офис и остальные офисы подключены к 1 и тому же провайдеру? в одной локальной сети?

нарисуйте схему как что и куда подключено, и подпишите адресацию WAN и LAN в каждом офисе

может у вас дизайн сети не совсем верно построен?
2
delfoeros
0 / 0 / 0
Регистрация: 28.02.2017
Сообщений: 50
15.06.2018, 20:16  [ТС] #6
.None,
Дело в том, что у меня не один провайдер, и так получилось что в отдельный достаточно удаленный офис провайдер завёл линию и выделил мне 192.168.0.9/30, договор на услугу точка-точка. И было это очень давно, я просто решил в будущем расширить канал и запаковать все в впн.
Но так как архитектура сети 10.2.110.хх насчитывает несколько десятков офисов с одинаковой адресацией которую опять же мне предоставляет хозяен огромного бизнес-центра где все это расположено то отступить я не могу, и ничего изменить в архитектуре его сети тоже. Я просто ставлю на пул выданных адресов mikrotik ВАНами и за ними строится моя сеть в ЛАНе, а в центральном офисе стоит серверная с кучей оборудования которая цепляется по впн и таким образом консолидирует и строит мою сеть из ланов внутри, скажем несколько десятков подметай 192.168.хх.хх
П.сы. Проблему решить удалось настройкой НАТа, убрал правило маскарада только под sip т.к. АТС находится у арендодателя, все остальное как писал выше:
Chain srcnat
Dst adress 10.2.110.10
Action srcnat to adress 10.2.110.3
Dst adress 10.2.110.20
Action srcnat to adress 10.2.110.3
Dst adress 10.2.110.30
Action srcnat to adress 10.2.110.3
0
15.06.2018, 20:16
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.06.2018, 20:16
Привет! Вот еще темы с решениями:

Openwrt wan переназначить на lan
Здравствуйте! От поиска очень устал, рассматривают переброс ван порта на лан,...

Создание на роутере нескольких wan
Возможно я не верно сформулировал заголовок, в общем суть дела такова: ...

Tp link td w8901 переназначить wan
пытался переназначить Wan на Lan. создал две группы как заставить ходить трафик...

WAN и роутер TP-LINK TL-WR642G
Стоит дома давно. Сам настраивал. У него прописан мак юзера сети, по которому...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru