Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
NoNaMe
EkdezMK7
Эксперт по компьютерным сетям
668 / 317 / 52
Регистрация: 10.06.2009
Сообщений: 1,419
1

Переводим заблокированные сайты на свою заглушку

13.07.2018, 19:27. Просмотров 290. Ответов 9
Метки нет (Все метки)

В Российской Федерации только лицензиаты (т.е. операторы связи) обязаны выполнять конкретные действия на основе реестра. Все прочие могут как блокировать для себя запрещенные ресурсы, так и предпринимать специальные усилия (к чему ТС, конечно, не призывает) для того, чтобы получить к этим ресурсам доступ.

Появился очень удобный сервис antifilter. Для владельцев CCR самое оно. Скачиваем: ip.rsc
Код
/ip firewall nat
add action=masquerade chain=srcnat dst-address=[Адрес заглушки] dst-port=8080 protocol=tcp  src-address=[Пул адресов выданный клиентам]
add action=dst-nat chain=dstnat dst-address=![Адрес заглушки] dst-address-list=rkn dst-port=80 protocol=tcp  src-address=[Пул адресов выданный клиентам] to-addresses=[Адрес заглушки] to-ports=8080
В DNS из такого-же листа вносятся адреса на [Адрес заглушки].
2
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.07.2018, 19:27
Ответы с готовыми решениями:

Переводим из 10 системы в 2 систему
Добрый день, как вы поняли из темы, что моя задача это перевод систем. Из 10...

Переводим из 2 системы в 10 систему
Всем программистам добрый вечер! Вот сижу, не знаю как правильно сделать...

Переводим текст из кирилицы в транслит
Парни, нашел такой код на vb6: Private Sub Command1_Click() Dim c Dim i...

Двумерный массив переводим в одномерный
Дан двумерный массив размером 4*5, заполненный целыми числами с клавиатуры....

Боды переводим в байт/секунды
MK AVR соединен через ft232 с компьютером на скорости 9600бод. За какое время...

9
.None
Эксперт по компьютерным сетям
2374 / 920 / 131
Регистрация: 23.06.2009
Сообщений: 3,252
14.07.2018, 08:27 2
сервис и впрямь удобный, поднял bgp, все работает.
0
Dmitry
Эксперт по компьютерным сетямЭксперт NIX
10769 / 6095 / 462
Регистрация: 09.09.2009
Сообщений: 24,168
14.07.2018, 11:24 3
под
Цитата Сообщение от NoNaMe Посмотреть сообщение
Адрес заглушки
...имеется ввиду какая-то своя прокса?
0
NoNaMe
EkdezMK7
Эксперт по компьютерным сетям
668 / 317 / 52
Регистрация: 10.06.2009
Сообщений: 1,419
14.07.2018, 13:18  [ТС] 4
Цитата Сообщение от Dmitry Посмотреть сообщение
...имеется ввиду какая-то своя прокса?
Возможно и на http proxy, которая в свою очередь может иметь выход на socks5, которая в свою очередь может быть не в юрисдикции Российской Федерации. Я-же в свою очередь: - показал как у провайдера работает заглушка. А вот применять ли специальные усилия - это только ваш выбор, к которому Я не призываю.

Добавлено через 8 минут
.None, а как-бы мне хотелось иметь ASN, жаль у меня нет 256+ адресного пространства.

Добавлено через 11 минут
.None, а вы немогли-бы мне для тестов дать любой из 4200000000 - 4294967294 ASN. Очень хотелось-бы в живую на это посмотреть)

AS Number Bits Description Reference
0 16 Reserved [RFC1930]
1 - 23455 16 Public ASN's
23456 16 Reserved for AS Pool Transition [RFC6793]
23457 - 64534 16 Public ASN's
64000 - 64495 16 Reserved by IANA
64496 - 64511 16 Reserved for use in documentation/sample code [RFC5398]
64512 - 65534 16 Reserved for Private Use
65535 16 Reserved
65536 - 65551 32 Reserved for use in documentation and sample code [RFC4893][RFC5398]
65552 - 131071 32 Reserved  
131072 - 4199999999 32 Public 32-bit ASN's  
4200000000 - 4294967294 32 Reserved for Private Use [RFC6996]
4294967295 32 Reserved  
0
Dmitry
14.07.2018, 13:59
  #5

Не по теме:

Цитата Сообщение от NoNaMe Посмотреть сообщение
не в юрисдикции Российской Федерации
меня интересовал сам принцип. а так, я сам - совсем не в юрисдикции РФ :)

0
.None
Эксперт по компьютерным сетям
2374 / 920 / 131
Регистрация: 23.06.2009
Сообщений: 3,252
16.07.2018, 13:50 6
Цитата Сообщение от NoNaMe Посмотреть сообщение
.None, а вы немогли-бы мне для тестов дать любой из 4200000000 - 4294967294 ASN. Очень хотелось-бы в живую на это посмотреть)
на что посмотреть?
1
Миниатюры
Переводим заблокированные сайты на свою заглушку   Переводим заблокированные сайты на свою заглушку  
.None
Эксперт по компьютерным сетям
2374 / 920 / 131
Регистрация: 23.06.2009
Сообщений: 3,252
16.07.2018, 13:51 7
лаги, дубль
0
NoNaMe
EkdezMK7
Эксперт по компьютерным сетям
668 / 317 / 52
Регистрация: 10.06.2009
Сообщений: 1,419
16.07.2018, 20:00  [ТС] 8
.None, не мой бюджет не готов потянуть членские взносы в RIPE.
0
.None
Эксперт по компьютерным сетям
2374 / 920 / 131
Регистрация: 23.06.2009
Сообщений: 3,252
17.07.2018, 08:22 9
с вышеуказанным сервисом не нужны никакие взносы, берете себе AS из Reserved for Private Use и активируете пиринг прямо там на сайте
1
NoNaMe
EkdezMK7
Эксперт по компьютерным сетям
668 / 317 / 52
Регистрация: 10.06.2009
Сообщений: 1,419
18.07.2018, 16:25  [ТС] 10
.None, спасибо разобрался. А Я никак не мог понять как её настроить. =]

Добавлено через 22 часа 18 минут
.None, поднял на RB3011 почти 100к записей. Полёт нормальный)
0
18.07.2018, 16:25
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.07.2018, 16:25

Ставить ли заглушку на сайт?
Здравствуйте. есть проект который будет реализован уже где-то через пол года...

int/double переводим в строку (string)
Добрый день. помогите пожалуйста перевести число int и double в строку...

Заблокированные Google, mail, vk.com
Доброго времени суток! В один прекрасный миг, стал невозможен вход на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru