Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
fredi89
0 / 0 / 0
Регистрация: 02.03.2017
Сообщений: 37
1

Скрипт для выключения правила фаервола

27.12.2018, 06:39. Просмотров 1161. Ответов 1
Метки нет (Все метки)

Здравствуйте. Можно ли скриптом закрыть проброшенный порт. Начальство просит сделать так, что бы можно было бы перекрывать доступ к ресурсу через удаленно с помощью бат файла.
Нашел скрипт на выключения компа.
Правило на срабатывание

add chain=input protocol=tcp port=36745 action=add-src-to-address-list address-list=WAKEPC \

сам скрипт
:local WAKEPC [/ip firewall address-list find where list="WAKEPC"]
:if ($WAKEPC!="") do={
/tool wol mac=00:11:22:33:44:55 interface=bridge_lan
/ip firewall address-list remove [find where list="WAKEPC"]
}

Как его можно доработать что бы он отключал допустим

action=dst-nat chain=dstnat comment=SMK dst-address=xx.xx.xx.xx dst-port=\
33333 in-interface=ether1 protocol=tcp src-address-list=AllowRDP
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.12.2018, 06:39
Ответы с готовыми решениями:

Скрипт для автоматического выключения портов Cisco
Добрый день! Подскажите, как с помощью скриптов можно реализовать выключение(shutdown)...

Задача про гирлянды. Задать правила включения и выключения определенных лампочек
Здравствуйте, подскажите пожалуйста, как решить задачку на CLIPS? Гирлянда. Имеются лампочки...

Небольшой скрипт по автоматичекому подключению локального компа не только к инету, но и самбы и фаервола.
скрипт по автоматичекому подключению локального компа не только к инету, но и самбы и фаервола ...

Скрипт включения/выключения света
Здравствуйте. Я новичок в программировании, решил написать скрипт на включение/выключение света...

Скрипт включения/выключения света
Здравствуйте. Я новичок в программировании, решил написать скрипт на включение/выключение света...

1
NoNaMe
Эксперт по компьютерным сетям
737 / 358 / 62
Регистрация: 10.06.2009
Сообщений: 1,628
Завершенные тесты: 1
09.01.2019, 08:55 2
Да можно. Н-р: через RouterOS API
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.01.2019, 08:55

Ремонт Прежде, чем начать новую тему... (это ПРАВИЛА, читать ВСЕМ!), Правила для всех участников форума!!!
Назначение форума "********" или "куда это я попал?" Форум предназначен для мастеров,...

Скрипт выключения света и прибавления энергии
Добрый вечер. Делаю приложение-питомец.Возник вопрос с одним скриптом.Не понимаю как реализовать....

Программирование фаервола для смартфона
Всем доброго времени суток. Передо мной стоит задача программирования фаервола для смартфона. Если...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru