Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
1

Проблема с DHCP сервером

16.01.2019, 07:26. Просмотров 712. Ответов 21

Всех приветствую. У меня есть пару вопросов.
1) У меня идет тупизм, с раздачей интернета и раздачей IP по DHCP. Получается так что, новый пользователь подключивший себе кабель, получает IP из заданного пула но интернет ему не идет сразу. Потом я иду на роутер и уже через Leases делаю MakeStatic, но интернета опять нету, после я иду в ARP и тупо выделяю все и жму минус, он обновляет все IP и после этого у пользователя идет интернет, но в течении работы бывает так что может и пропасть. Есть предположение что я где-то накосячил, но не могу понять где. Скрины приложил. Просто здача была такова чтоб за каждым ПК был привязан свой IP и был фильтр который смотрел есть в Leases или нету ПК и только тогда отдавать инет.
2) А вторая проблема, связана с интернетом а точней лишний хлам от провайдера. Провайдер предоставил интернет по статике, и я вижу в ARP куча лишних IP (95.47.Х.Х), хотел бы узнать как их отрезать чтоб я их не видел да и роутер не обрабатывал ? По факту он тупо видит 10 микротиков провайдера и другие компы за микротиками. И они сидят у меня в ARP. Спасибо заранее за помощь
0
Миниатюры
Проблема с DHCP сервером   Проблема с DHCP сервером   Проблема с DHCP сервером  

Проблема с DHCP сервером   Проблема с DHCP сервером   Проблема с DHCP сервером  

Проблема с DHCP сервером  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.01.2019, 07:26
Ответы с готовыми решениями:

Не назначен адрес от сети (DHCP сервером)
Есть небольшая сеть, оптика в роутер, тот на хаб раздаёт, всё вроде бы ничего, но на днях случился...

Cеть с доменом, файл обменником, сервером 1С, атс, фаерволом, локальным сервером сайта
Народ помогите схематично хотябы разобраться как организовать ПАРАВЕЛЬНО сеть с доменом, файл...

DIR-615 (2.5.5) по DHCP пускает в интернет. Без DHCP - не пускает. Как так?
Настраиваю на роутере (допустим 10.100.100.1) DHCP. Получаю IP, браузер, выхожу в интернет...

Клиент не соединяется с DHCP-сервером
Установил на debian пакет isc-dhcp-server. В файле /etc/dhcp/dhcpd.conf записано: subnet...

IP адреса сети выданные DHCP сервером
Добрый день. Прошу помочь и сильно не пинать) Вопрос достаточно банальный и я знаю что ответов на...

21
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
16.01.2019, 10:42 2
Цитата Сообщение от FRATER1234 Посмотреть сообщение
Просто задача была такова чтоб за каждым ПК был привязан свой IP
при первом подключении хоста, в DHCP-Leases жмем Make Static, потом открываем эту запись, указываем какой именно нужно данному хосту присвоить адрес и переподключаем хост (выкл/вкл сетевой адаптер, или вытыкнуть и втыкнуть кабель)
Цитата Сообщение от FRATER1234 Посмотреть сообщение
был фильтр который смотрел есть в Leases или нету ПК и только тогда отдавать инет.
это настраивается так Как разрешить доступ в интернет только DHCP адресам
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 10:58  [ТС] 3
romsan, Я понял в принципе что вы сказали. Только вот есть одна странность которая мне не понятна. Когда я подключаю нового пользователя, ему DHCP сразу выдает IP но интернет почему-то сразу не раздаеться ему, и он даже не пингуется как с роутера, так и с машины на роутер по адрессу. Хотя на роутере вижу что появился в Leases и в ARP. После проходит 5-10 мин, и вуаля уже машины с интернетом и т.д. После допустим после перезагрузки может опять отвалиться, и через определенное время, опять появиться. И вот такие качели мне не понятны где косячит. Просто на работе еще натыканно куча мелких свитчей, они могут тупит и не сразу давать инет ? Я беру самого дальнего пользователя в своей сети, до роутера и него разделенно 7 свитчами. И вот бывает помогает вкл/выкл кабеля раз так 3-4 и сеть и интернет появляется. До этого был обычный роутер Zuxel и проблем небыло всем давал DHCP и интернет и проблемы небыло, сейчас сделал базовую настройку, и интернет то есть, то нету, и самое странное что при первом получении он тупо не пингует даже роутер по адрессу, а только с пустя некоторое время.
0
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
16.01.2019, 11:09 4
Меню Bridge, вкладка Bridge. Открываем bridge-local, вкладка General, в поле ARP меняем с enabled на reply-only
это сделал?
На какое время выдаются адреса? Время аренды?
Цитата Сообщение от FRATER1234 Посмотреть сообщение
ему DHCP сразу выдает IP но интернет почему-то сразу не раздаеться ему
ну нужно смотреть, ЧТО этот клиент получил (ipconfig /all), и какая запись в логе микротика в этот момент прошла?
А так же нужно посмотреть КАК именно настроено всё у Вас там. (очень часто сам делаю настройки, о которых слабо понимаю, и получаю нерабочий сервис. Сам ничего не вижу, а со стороны посмотрев конфиг добрые люди тыкают носом в мою ошибку.)
0
16.01.2019, 11:09
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 12:27  [ТС] 5
romsan, Да сделал, после этого кстати и перестал раздаваться интернет. Время аренды я сделал у DHCP 10мин. Конфиг скину чуть попозже
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 13:07  [ТС] 6
Приложил конфиг машины.
0
Вложения
Тип файла: zip config.zip (3.4 Кб, 3 просмотров)
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
16.01.2019, 16:02 7
Цитата Сообщение от FRATER1234 Посмотреть сообщение
Да сделал, после этого кстати и перестал раздаваться интернет.
нет, не сделал! В твоём конфиге
/interface bridge
add arp=proxy-arp name=bridge1
я же выше написал правило
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 16:07  [ТС] 8
Я извиняюсь заранее, я делал все манипуляции в Safe mode. Я забыл что нахожусь в нем и по этому все действия я отменил тогда. По этому пришел старый конфиг.
0
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
16.01.2019, 16:28 9
Цитата Сообщение от FRATER1234 Посмотреть сообщение
по этому все действия я отменил тогда
ну дак при правильных настройках работает? или так же нет?
Ну как бы, я смотрю, в leases прописаны адреса статические. После включения ПК тырнета на нём нет? а появляется он после 5-10 минут сам?
После включения ПК что показывает ipconfig /all ?
Цитата Сообщение от FRATER1234 Посмотреть сообщение
Время аренды я сделал у DHCP 10 мин.
тоже неправда. Я вижу 8 часов.
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 lease-time=8h name=\
dhcp1
1
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 16:55  [ТС] 10
Вот конфиг с правками. Пока на данный момент работает интернет. Но при подключении пк так и думает 5-10мин. Я сперва думал на аренду, но разницы нет. При ipconfig /all прикрепил то что показывает. У меня просто заведенное еще два провайдера. Главный провайдера по статике идет прописан 95.47.х.х (этот интернет в приоритете в раздаче) а второй резервный от модема идет получает он по динамике (192.168.2.1 это адрес модема) . Может они друг друга тушат ?
0
Миниатюры
Проблема с DHCP сервером  
Вложения
Тип файла: zip confignew.zip (3.6 Кб, 2 просмотров)
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
16.01.2019, 19:37 11
Цитата Сообщение от FRATER1234 Посмотреть сообщение
Главный провайдера по статике идет прописан 95.47.х.х
Хорошо, а где главный дефолтный маршрут? У тебя в route есть запись:
/ip route
add disabled=yes distance=1 gateway=95.47.x.x
.. и она отключена!
Цитата Сообщение от FRATER1234 Посмотреть сообщение
Пока на данный момент работает интернет
как??? Где маршрут по умолчанию?
Цитата Сообщение от FRATER1234 Посмотреть сообщение
второй резервный от модема
и...? ну заведен он на ether2, ну висит на данном порту dhcp-клиент (получает адрес) и что дальше? Если ты прописал маскарад на этот интерфейс, то это не значит, что при обрыве тырнета на первом порту, все перескочат автоматом на второй. Нет, так не будет.
Mikrotik: автоматическое переключение канала на резервный и обратно
Резервирование каналов на Mikrotik без скриптов
Или ты не для резервирования второго провайдера завел?

Мне кто нибудь может описать, для чего нужно и что делает эта команда:
/ip dns static
add address=192.168.188.1 name=mikrouter
Я постоянно вижу эту запись в чужих конфигах. Может я дурень и чего то не знаю и себе не прописываю, а она ох как нужна? Подсеть 192.168.1.0/24, статическая запись на другую подсеть задана. Зачем?
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 19:42  [ТС] 12
Код
/ip route
add disabled=yes distance=1 gateway=95.47.x.x
Она отключена потом что я ручками включил как раз таки второй резервный канал (Так как я не мог оставить работу без интернета). Я его руками включать буду. Мне не обязательно переключение на автомате, но за ссылки я благодарен возьму на вооружение.

У меня пока остается одна вещь которая так и осталась не понятна, почему клиент получает IP DHCP, и сразу не получает интернет, а только после куча разных манипуляций (Аля, вкл/выкл кабеля и т.д.) И только тогда он получает.
0
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
16.01.2019, 19:57 13
Цитата Сообщение от FRATER1234 Посмотреть сообщение
пока остается одна вещь которая так и осталась не понятна
еще раз проверь:
1) В DHCP-сервере нужно включить Add ARP For Leases.
2) В bridge1 поле ARP меняем с enabled на reply-only
1
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
16.01.2019, 20:00  [ТС] 14
Хорошо завтра буду на работе отпишусь. Спасибо.
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
17.01.2019, 08:12  [ТС] 15
romsan, Добрый день. Я сделал Add ARP For Leases и поменял reply-only. Пока полет нормальный. Но это пока проверенно на резервной линии. Основная линия временно пока не работает, потому что у провайдера какие то тормоза в связи с погодными условиями. По этому по поводу основного канала отпишусь чуть позже.

Хотел бы уточнить еще один момент, по поводу того что от провайдера лезут лишние IP (95.47.Х.Х). Получает так что мне провайдера выдал интернет по статике, с белым IP. Как только я его подключал, я видел куча разных 95.47.Х.Х и плюс свой белый IP. Я через Dude промониторил и как оказалось в этой сети я вижу 7 микротиков, и еще 10+ пользователей за микротиками. Как это можно отрезать самому? Чтоб допустим мой mikrotik не видел эти сети, да и в ARP они не добовлялись.
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
17.01.2019, 08:27  [ТС] 16
Ну и вот кстати вылез тот косяк о котором я и говорил, комп включился, получил IP но интернета нету.
0
Миниатюры
Проблема с DHCP сервером   Проблема с DHCP сервером  
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
17.01.2019, 08:38  [ТС] 17
После перезагрузки ПК интернет появился. И в списке он увидел. Вот эта бредятина мне не понятна откуда лезет. так как ПК исправен у этого пользователя.
0
Миниатюры
Проблема с DHCP сервером   Проблема с DHCP сервером  
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
17.01.2019, 09:38 18
FRATER1234, а ты случаем при Make Static на клиенте не трогал поле Client ID ? Это поле трогать нельзя - иначе работать не будет (т.е. адрес выдаст, а ничего не будет работать) Проверено мною. Сам натыкался на эти грабли.
0
FRATER1234
4 / 4 / 2
Регистрация: 01.10.2011
Сообщений: 309
17.01.2019, 11:41  [ТС] 19
romsan, Описываю как я делаю.

1.Подключил кабель к ПК.
2. На роутере вижу в разделе Leases клиента, жму Make Static.
И все.
Лишнего ничего не клацаю.
0
romsan
Эксперт по компьютерным сетям
2037 / 1171 / 232
Регистрация: 17.10.2015
Сообщений: 5,190
17.01.2019, 12:21 20
тогда я могу тебе посачувствовать - придется сбросить и всё снуля настроить.
Я у себя не поленился, проверил. Данный функционал нормально работает. Меня смущают некоторые настройки твои - возможно они верны, я не супер-пупер специалист. Однако не иметь дефолтного маршрута на роутере по мне так это странно.
0
17.01.2019, 12:21
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.01.2019, 12:21

Авто-запуск VPN соединения, вычисление назначенного IP сервером DHCP, перемещение значения в текстовый документ.
Доброго времени суток форумчане и спецы! Хотел бы попросить о помощи незначительной, суть задачи...

ENC28J60 + DHCP = проблема
Доброго дня, уважаемые форумчане. Встала задача обмениваться данными по локальной сети. Почитал...

ПРОБЛЕМА С СЕРВЕРОМ
РЕБЯ ТА ПОДСКАЖИТЕ ТАКАЯ ПРОБЛЕМА БЫЛА ПРИШЁЛ В КАНТОРУ И СЛЫШУ ОТ СЕРВЕРА МЕХАНИЧЕСКИЙ ШУМ СНЯЛ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru