Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Todini
0 / 0 / 0
Регистрация: 10.02.2016
Сообщений: 62
1

Настроить отдельную сеть на каждый порт с межсетевой маршрутизацией (Mikrotik RB2011)

10.02.2019, 22:58. Просмотров 314. Ответов 18
Метки нет (Все метки)

Здравствуйте!

Mikrotik RB2011 RouterOS v6

Требуется:
- Для N Ethernet-интерфейсов определить сети 10.N/16 со шлюзами 10.N.0.1, статически назначенных каждому Ethernet-интерфейсу N;
- В каждую сеть назначение IP по DHCP из пула 10.N.x.x;
- Межсетевая маршрутизация.

Прошу подсказать последовательность действий (разделы меню и заполняемые значения).

Заранее благодарен за ответ!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.02.2019, 22:58
Ответы с готовыми решениями:

Нужно настроить межсетевой экран
Здравствуйте! Умирает винт и решено на другую установить систему. На старом стоит Fedora Core 2. На...

Mikrotik, не открывается порт
Добрый вечер! Нужно сделать проброс порта до локальной машины. Вроде делаю все по инструкции, но...

Mikrotik sxt-lite2 настройка передачи в физический порт
Добрый день. Не подскажете, как настроить данный микротик на передачу пойманного сигнала вф от...

Не получается настроить VPN на mikrotik
Есть RB 1100AH. Адрес роутера 192.168.88.1. Настраиваю VPN по PPTP. Прописал адрес для клиента...

Настроить MikroTik CRS125-24G-1S-RM
Доброго времени суток. Имеется MikroTik CRS125-24G-1S-RM в качестве управляемого коммутатора....

18
romsan
Эксперт по компьютерным сетям
1929 / 1089 / 207
Регистрация: 17.10.2015
Сообщений: 4,845
11.02.2019, 08:24 2
1) Сбрасываем устройство на заводские настройки
2) Удаляем дефолтный конфиг
3) Создаём 10 pool-ов
Bash
1
2
3
4
5
/ip pool add name=pool1 ranges=10.1.0.2-10.1.255.254
/ip pool add name=pool2 ranges=10.2.0.2-10.2.255.254
/ip pool add name=pool3 ranges=10.3.0.2-10.3.255.254
.....
/ip pool add name=pool10 ranges=10.10.0.2-10.10.255.254
4) Создаём десять DHCP-серверов:
Bash
1
2
3
4
/ip dhcp-server add name=dhcp1 interface=ether1 lease-time=1d10m address-pool=pool1 
/ip dhcp-server add name=dhcp2 interface=ether2 lease-time=1d10m address-pool=pool2
...
/ip dhcp-server add name=dhcp10 interface=ether10 lease-time=1d10m address-pool=pool10
5) Добавляем (прописываем) подсети:
Bash
1
2
3
4
/ip dhcp-server network add address=10.1.0.0/16 gateway=10.1.0.1 dns-server=10.1.0.1  ntp-server=10.1.0.1
/ip dhcp-server network add address=10.2.0.0/16 gateway=10.2.0.1 dns-server=10.2.0.1  ntp-server=10.2.0.1
...
/ip dhcp-server network add address=10.10.0.0/16 gateway=10.10.0.1 dns-server=10.10.0.1  ntp-server=10.10.0.1
6) По аналогии добавляем DNS (/ip dns) - это если все подсети будут выходить в тырнет (в условии не сказано)
----------------
Ну как бы всё.
По умолчанию, фаервола нету, значит разрешено всё, в том числе доступ из одной подсети в другую.
0
NoNaMe
Эксперт по компьютерным сетям
680 / 328 / 54
Регистрация: 10.06.2009
Сообщений: 1,483
Завершенные тесты: 1
11.02.2019, 08:41 3
romsan, нет не все. Забыли про:
/ip address
add address=10.1.0.1/24 interface=ether1
...

Добавлено через 35 секунд
Иначе не стартанет dhcp сервер. И маршруты не появятся.
0
romsan
Эксперт по компьютерным сетям
1929 / 1089 / 207
Регистрация: 17.10.2015
Сообщений: 4,845
11.02.2019, 09:09 4
Цитата Сообщение от NoNaMe Посмотреть сообщение
Забыли про:
/ip address
а ну да

Добавлено через 2 минуты
Цитата Сообщение от NoNaMe Посмотреть сообщение
/ip address
add address=10.1.0.1/24 interface=ether1
только не /24, а /16

Bash
1
2
3
4
/ip address add address=10.1.0.1/16 interface=ether1
/ip address add address=10.2.0.1/16 interface=ether2
....
/ip address add address=10.10.0.1/16 interface=ether10
0
Dmitry
Эксперт по компьютерным сетямЭксперт NIX
10852 / 6163 / 485
Регистрация: 09.09.2009
Сообщений: 24,591
11.02.2019, 09:28 5
а интерфейсы (порты) из бриджа удалять не нужно?
0
romsan
Эксперт по компьютерным сетям
1929 / 1089 / 207
Регистрация: 17.10.2015
Сообщений: 4,845
11.02.2019, 09:35 6
Цитата Сообщение от Dmitry Посмотреть сообщение
а интерфейсы (порты) из бриджа удалять не нужно?
так после сброса и удаления дефолтного конфига, они не в бридже
Только что с Wlan (Wi-Fi) делать?
0
NoNaMe
Эксперт по компьютерным сетям
680 / 328 / 54
Регистрация: 10.06.2009
Сообщений: 1,483
Завершенные тесты: 1
11.02.2019, 11:09 7
Цитата Сообщение от romsan Посмотреть сообщение
Только что с Wlan (Wi-Fi) делать?
Так Todini, и не говорил что у него с WiFi rb2011, может у него RM серии железка.
Я-бы усложнил задачу: Н-р попросил-бы оставить при этом на уровне L2 1-5 порт в одном сегменте.
0
romsan
Эксперт по компьютерным сетям
1929 / 1089 / 207
Регистрация: 17.10.2015
Сообщений: 4,845
11.02.2019, 11:16 8
Цитата Сообщение от NoNaMe Посмотреть сообщение
может у него RM серии железка.
возможно, ведь написать какая именно железка - это же так сложно, пусть лучше мне на форуме для всех возможных моделей напишут решение, а я потом выбиру, то что мне нужно. Ведь они лохи.... бесплатно помогают....им же делать нечего.
Цитата Сообщение от NoNaMe Посмотреть сообщение
Я-бы усложнил задачу
Так может потренируешь задачками? В отдельной теме
0
Todini
0 / 0 / 0
Регистрация: 10.02.2016
Сообщений: 62
11.02.2019, 11:18  [ТС] 9
Спасибо за помощь!
Прошу подсказать, как назначить IP (принадлежит одной из сетей) для входа на роутер?
0
romsan
Эксперт по компьютерным сетям
1929 / 1089 / 207
Регистрация: 17.10.2015
Сообщений: 4,845
11.02.2019, 11:48 10
Цитата Сообщение от Todini Посмотреть сообщение
Прошу подсказать, как назначить IP
выше расписано всё
0
Todini
0 / 0 / 0
Регистрация: 10.02.2016
Сообщений: 62
11.02.2019, 11:59  [ТС] 11
Благодарю за помощь, но выше указана только настройка сетей на каждый порт. На веб-морду по адресу шлюза не зайти. Возможно, потому что все бриджы в роутере отключены.
0
romsan
Эксперт по компьютерным сетям
1929 / 1089 / 207
Регистрация: 17.10.2015
Сообщений: 4,845
11.02.2019, 12:22 12
Цитата Сообщение от Todini Посмотреть сообщение
На веб-морду по адресу шлюза не зайти
т.е. Вы сделали все вышеперечисленное и, воткнув в ether1 кабель, на 10.1.0.1 нет доступа?

Добавлено через 1 минуту
Цитата Сообщение от Todini Посмотреть сообщение
Возможно, потому что все бриджы в роутере отключены.
они и не должны быть включены. У Вас каждый порт - подсеть. На каждый порт висит свой DHCP
О каких бриджах идет речь?
0
NoNaMe
Эксперт по компьютерным сетям
680 / 328 / 54
Регистрация: 10.06.2009
Сообщений: 1,483
Завершенные тесты: 1
11.02.2019, 13:16 13
Цитата Сообщение от Todini Посмотреть сообщение
На веб-морду по адресу шлюза не зайти.
Код
/ip service set www address=10.0.0.0/8
Добавлено через 11 минут
Цитата Сообщение от romsan Посмотреть сообщение
Так может потренируешь задачками?
Могу дать "На водку" /ip dhcp-relay и/или dhcp option 82. Наверное задали именно такую задачку.
DHCP Option 82 содержит в себе interface от которого был получен запрос + client mac address или relay-info-remote-id(string)
0
Todini
0 / 0 / 0
Регистрация: 10.02.2016
Сообщений: 62
11.02.2019, 14:01  [ТС] 14
Прошу прощения, работает.
Проблема, при реализации 2-х сетей на 2 порта:
сеть 10.9.0.0/25 (шлюз 10.9.0.1) на порт 1;
сеть 10.9.0.128/25 (шлюз 10.9.0.129) на порт 2.

На 10.9.0.1 захожу, 10.9.0.129 - нет.

Добавлено через 35 минут
Цитата Сообщение от Todini Посмотреть сообщение
На 10.9.0.1 захожу, 10.9.0.129 - нет.
Нет пинга на 10.9.0.129, несмотря на то что по DHCP 10.9.0.129 указан шлюзом. На ЭВМ arp-запись на 10.9.0.129 отсутствует
0
NoNaMe
Эксперт по компьютерным сетям
680 / 328 / 54
Регистрация: 10.06.2009
Сообщений: 1,483
Завершенные тесты: 1
11.02.2019, 15:00 15
Todini, 2-ая сеть указанна не верно.
Должна быть 10.9.0.129/25
10.9.0.128/25 относится к адресному пространству. 10.9.0.1/25
0
Todini
0 / 0 / 0
Регистрация: 10.02.2016
Сообщений: 62
11.02.2019, 15:59  [ТС] 16
Цитата Сообщение от NoNaMe Посмотреть сообщение
Должна быть 10.9.0.129/25
Нет сети с таким адресом (с непрерывной маской). Предполагаю, на ЭВМ таблица маршрутизации некорректна.
0
NoNaMe
Эксперт по компьютерным сетям
680 / 328 / 54
Регистрация: 10.06.2009
Сообщений: 1,483
Завершенные тесты: 1
11.02.2019, 16:13 17
Цитата Сообщение от Todini Посмотреть сообщение
Нет сети с таким адресом (с непрерывной маской). Предполагаю, на ЭВМ таблица маршрутизации некорректна.
Это Я ошибся. да именно 10.9.0.128/25
0
Todini
0 / 0 / 0
Регистрация: 10.02.2016
Сообщений: 62
11.02.2019, 17:36  [ТС] 18
Спасибо всем за помощь! Нашел ошибку

/ip address

было:
add address=10.91.0.1/25 interface=ether9 network=10.91.0.0
add address=10.91.0.129/25 interface=ether9 network=10.91.0.128

надо:
add address=10.91.0.1/25 interface=ether9 network=10.91.0.0
add address=10.91.0.129/25 interface=ether10 network=10.91.0.128

Может быть, подскажите как определенному МАК выдаваеть IP из списка значений или по математической закономерности?
0
NoNaMe
Эксперт по компьютерным сетям
680 / 328 / 54
Регистрация: 10.06.2009
Сообщений: 1,483
Завершенные тесты: 1
11.02.2019, 18:09 19
Todini,
Код
/ip dhcp-server lease
add address=10.1.0.100 client-id=1:12:34:56:78:9a:bc comment=Magazin mac-address=12:34:56:78:9a:bc server=server
dhcp server и скрипты:
#$leaseBound 0 если клиент не привязан к IP, 1 – если привязан;
#$leaseServerName имя сервера DHCP который выдал IP;
#$leaseActMAC MAC адрес клиента;
#$leaseActIP IP адрес присвоенный клиенту;
Дальше ручками.
0
11.02.2019, 18:09
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
11.02.2019, 18:09

Каждый пункт меню ввести в отдельную функцию
К исходнику реализовать меню из 5 пунктов: 1)Открыть указанный файл для обработки 2)Обработать...

Домашняя сеть на основе Mikrotik
Всем привет. Я пытаюсь спроектировать сеть для своей квартиры. Изучая рынок роутеров наткнулся на...

Как настроить 3G модем в роутере mikrotik?
помогите настроить интернет именно с модема .модель модема zte mf100.


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
19
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru