Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
John1216
6 / 6 / 0
Регистрация: 08.10.2018
Сообщений: 64
1

Раздача белых IP

09.10.2019, 12:42. Просмотров 844. Ответов 5

Добрый день.
Имеем микротик.
На 1 порт приходит 6 белых IP адресов.
Как отдать на 7,8 порты по одному IP каждому, чтобы весь траффик проходил транзитом ? Соответственно, подключив кабель в 7 или 8 порт, прописав IP/subnet/gateway - получить доступ в инет.
Есть вариант через bridge, добавить туда все порты, на бридж повесить все IP'адресы. Можно как-то по другому?
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.10.2019, 12:42
Ответы с готовыми решениями:

В урне 4 белых и 6 черных шаров. Не глядя берут 2. X подсчитывает количество белых шаров, Y чёрных
В урне 4 белых и 6 черных шаров. Не глядя берут 2. X подсчитывает количество белых шаров, Y...

В урне 10 белых и 5 черных шаров. Чему равна вероятность того, что, вытянув наугад с возвращаением 14 шаров, получим белых не менее 12?
Добрый вечер господа\товарищи :) Прошу помощи в решении задачи на возвращение: В урне 10...

Имеется две корзины с шарами. в первой А белых и В черных, во второй С белых и Б черных
имеется две корзины с шарами. в первой А белых и В черных, во второй С белых и Б черных. из каждой...

Домашний сервер (раздача интернета, раздача-видео, файловое хранилище)
Здравствуйте! Появилась возможность и необходимость собрать домашний сервер для решения...

Имеются 2 ящика с шарами. В первом 3 белых и 7 черных, во втором 6 белых и 7 черных
Имеются 2 ящика с шарами. В первом 3 белых и 7 черных, во втором 6 белых и 7 черных. Из каждого...

5
NoNaMe
Модератор
Эксперт по компьютерным сетям
1002 / 411 / 76
Регистрация: 10.06.2009
Сообщений: 1,826
Завершенные тесты: 1
09.10.2019, 15:50 2
Лучший ответ Сообщение было отмечено John1216 как решение

Решение

John1216, есть 2 пути решения задачи. В первом вы выдаёте клиенту белый адрес, во втором даёте серый из диапазона 100.64.0.0/10.
В первом случае:
Код
/ip address
add address=1.1.1.1 interface=ether7 network=1.1.1.2
add address=1.1.1.1 interface=ether8 network=1.1.1.3
/ip firewall address-list add list="white_ip" address=1.1.1.2
/ip firewall address-list add list="white_ip" address=1.1.1.3
/ip firewall nat add action=masquerade chain=srcnat src-address-list=!white_ip out-interface-list=WAN
Во втором:
Код
/ip address
add address=100.64.0.1 interface=ether7 network=100.64.0.2
add address=100.64.0.1 interface=ether8 network=100.64.0.3
/ip firewall address-list add list="netmap_ip" address=100.64.0.2
/ip firewall address-list add list="netmap_ip" address=100.64.0.3
/ip firewall nat add action=masquerade chain=srcnat src-address-list=!netmap_ip out-interface-list=WAN
/ip firewall nat add chain=srcnat src-address=100.64.0.2 action=netmap to-addresses=1.1.1.2
/ip firewall nat add chain=dstnat dst-address=1.1.1.2 action=netmap to-addresses=100.64.0.2
/ip firewall nat add chain=srcnat src-address=100.64.0.3 action=netmap to-addresses=1.1.1.3
/ip firewall nat add chain=dstnat dst-address=1.1.1.3 action=netmap to-addresses=100.64.0.3
В первом случае: - клиенту нужно просто прописать свой белый ip адрес с шлюзом 1.1.1.1, а во втором свой серый адрес с шлюзом 100.64.0.1.
1
John1216
6 / 6 / 0
Регистрация: 08.10.2018
Сообщений: 64
09.10.2019, 17:46  [ТС] 3
Спасибо за помощь!
Не совсем понимаю, почему network x.x.x.2-3
Если представить это в виду "реальных" IP, то правильно мыслю? Или прям нужно использовать 1.1.1.1 ?
Есть сеть 78.100.1.0/24
Из неё мои адреса 1.53-1.55 ; GW провайдера - 1.254
Хочу отдать 1.54 и 1.55 на 7 и 8 порты соответственно.
Делаю:
/ip address
add address=78.100.1.54 interface=ether7 network=78.100.1.0
add address=78.100.1.55 interface=ether8 network=78.100.1.0
/ip firewall address-list add list="white_ip" address=78.100.1.54
/ip firewall address-list add list="white_ip" address=78.100.1.55
/ip firewall nat add action=masquerade chain=srcnat src-address-list=!white_ip out-interface-list=WAN
Поправьте пожалуйста, если не так понял.
Спасибо!
0
NoNaMe
Модератор
Эксперт по компьютерным сетям
1002 / 411 / 76
Регистрация: 10.06.2009
Сообщений: 1,826
Завершенные тесты: 1
09.10.2019, 18:15 4
John1216, было взято как пример, в конкретных случаях адреса могут располагаться вообще в разных классах сетей.
1
John1216
6 / 6 / 0
Регистрация: 08.10.2018
Сообщений: 64
09.10.2019, 18:19  [ТС] 5
Спасибо!
Такая логика верна?
/ip address
add address=78.100.1.54 interface=ether7 network=78.100.1.0
add address=78.100.1.55 interface=ether8 network=78.100.1.0
/ip firewall address-list add list="white_ip" address=78.100.1.54
/ip firewall address-list add list="white_ip" address=78.100.1.55
/ip firewall nat add action=masquerade chain=srcnat src-address-list=!white_ip out-interface-list=WAN
0
NoNaMe
Модератор
Эксперт по компьютерным сетям
1002 / 411 / 76
Регистрация: 10.06.2009
Сообщений: 1,826
Завершенные тесты: 1
09.10.2019, 18:57 6
John1216, нет не верно.
add address=78.100.1.1 interface=ether7 network=78.100.1.54
Где 78.100.1.1 адрес через который будут маршрутизироваться 78.100.1.54 и 78.100.1.55
вариант с бриджем удобнее, вы не теряете адрес на маршрутизацию, и можете его то-же выдать клиентам.
0
09.10.2019, 18:57
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.10.2019, 18:57

В урне содержится 6 черных и белых шаров, к ним добавляют 3 белых шаров
В урне содержится 6 черных и белых шаров, к ним добавляют 3 белых шаров. После этого из урны...

В урне содержится 6 черных и белых шаров, к ним добавляют 3 белых шаров
1) В урне содержится 6 черных и белых шаров, к ним добавляют 3 белых шаров. После этого из урны...

В первой урне 6 белых и 4 черных шара, во второй 3 белых и 2 черных
В первой урне 6 белых и 4 черных шара, во второй 3 белых и 2 черных. Из первой урны наудачу...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.