Форум программистов, компьютерный форум, киберфорум
Наши страницы
Mikrotik
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
bytemyass
0 / 0 / 0
Регистрация: 22.12.2012
Сообщений: 22
1

Планировщик в микроте

08.11.2019, 13:31. Просмотров 904. Ответов 12

Добрый день!
Задался таким вопросом, есть в шедулере задачка, которая отсылает мне в телегу состояние (up/down) каналов. Скрипт работает, все хорошо, хочется чтобы оповещения в телеграме не настигли меня ночью во время сна, мут на канале в телеге не предлагайте)
Подскажите как сделать так, чтобы скрипт переставал работать в 9 вечера, вижу там старт тайм, а вот время работы с 8 утра до 9 вечера выставить нет возможности, может кто знает решение?
Спасибо!
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.11.2019, 13:31
Ответы с готовыми решениями:

Еще один пользователь на микроте
Ребят, ситуация следующая, есть микрот rb3011uias и на нем почему то 2 учетные записи, одна моя...

Планировщик
Добрый день! Создала форму Планировщика на основе документа, но элементы планировщика почему то не...

Планировщик C#
Нужно сделать планировщик на C#. То есть такую программу, позволяющую запланировать включение той...

Планировщик
Доброго времени суток. Не могу написать программу которая через квант времени сначала выполняла 1...

Планировщик в AD
Доброго времени суток, уважаемые участники форума. Руководство поставило задачу "бэкапить" рабочие...

12
insect_87
Эксперт по компьютерным сетям
4948 / 4008 / 836
Регистрация: 25.12.2012
Сообщений: 16,970
08.11.2019, 15:17 2
В самом скрипте время отсылки ограничить может?
1
romsan
Эксперт по компьютерным сетям
2442 / 1379 / 295
Регистрация: 17.10.2015
Сообщений: 6,067
08.11.2019, 19:06 3
Написать еще два задания в шедуллере:
1) Enable sheduler1 start time=08-00 interval=24-00
2) Disable sheduler1 start time=21-00 interval=24-00
1
insect_87
Эксперт по компьютерным сетям
4948 / 4008 / 836
Регистрация: 25.12.2012
Сообщений: 16,970
08.11.2019, 19:19 4
romsan, и будет выполняться скрипт первого шедулера с интервалом в 24 ч, стартовав с 8 утра, по сути скрипт запускается каждый день в 8 утра
Или я чтнп?
1
08.11.2019, 19:19
romsan
Эксперт по компьютерным сетям
2442 / 1379 / 295
Регистрация: 17.10.2015
Сообщений: 6,067
08.11.2019, 19:52 5
Цитата Сообщение от insect_87 Посмотреть сообщение
по сути скрипт запускается каждый день в 8 утра
не скрипт, а нужное правило шедулера будет переходить в enable в 8 утра, и в disable в 21-00

ТС как писал: есть правило которое выполняется (возможно там отдельный скрипт, а в шеделере его выполнение), я не знаю. Но само правило другими двумя правилами вкл/выкл. И делов то. Только обязательно нужно следить за часами - собъется время, собъется период вкл/выкл.
1
insect_87
Эксперт по компьютерным сетям
4948 / 4008 / 836
Регистрация: 25.12.2012
Сообщений: 16,970
08.11.2019, 20:22 6
Или второй скрипт накатать и запустить по второму шедулеру круглосуточно.
Второй скрипт сверяет время, если время >= 8-00 и первый шедулер не активен, то активирует первый шедулер
Если время >= 21-00 и первый шедулер активен, то деактивирует его


не скрипт, а нужное правило шедулера будет переходить в enable в 8 утра, и в disable в 21-00
romsan, ну а где ты это все настроишь?
ТС в шедулере запускает скрипт с каким-то интервалом проверки состояния чего-то. Интервал указывается в шедулере. При смене состояния в телегу отправляется уведомление.
Задача - не присылать уведомление с 21-00 до 8-00.
Я пока вижу 2 способа - не отсылать сообщения в телегу с 21 до 8 - реализуется в самом скрипте
Выключать сам шедулер с помощью второго скрипта, который следит за временем. При этом второй скрипт работает всегда и в отдельном шедулере


По второму шедулеру - включать первый шедулер придется чуть раньше восьми (время >=7-50), если старт в первом шедулере 8-00, -а интервал для второго шедулера - менее 10 мин
1
romsan
Эксперт по компьютерным сетям
2442 / 1379 / 295
Регистрация: 17.10.2015
Сообщений: 6,067
08.11.2019, 21:17 7
Лучший ответ Сообщение было отмечено insect_87 как решение

Решение

Цитата Сообщение от insect_87 Посмотреть сообщение
в шедулере запускает скрипт с каким-то интервалом проверки состояния чего-то. Интервал указывается в шедулере. При смене состояния в телегу отправляется уведомление.
да, всё верно.
Цитата Сообщение от insect_87 Посмотреть сообщение
Задача - не присылать уведомление с 21-00 до 8-00.
предположим рабочее правило в шедулере за №2:
тогда создаем правило 3 со start time=21-00 interval=24-00
Код
/system scheduler set 2 disabled=yes
и правило 4 со start time=8-00 interval=24-00
Код
/system scheduler set 2 enable=yes
2
insect_87
Эксперт по компьютерным сетям
4948 / 4008 / 836
Регистрация: 25.12.2012
Сообщений: 16,970
08.11.2019, 21:45 8
Ну да, тоже верно. Ток тогда шедулер 4 надо стартануть раньше старта в шедулере 2
1
romsan
Эксперт по компьютерным сетям
2442 / 1379 / 295
Регистрация: 17.10.2015
Сообщений: 6,067
08.11.2019, 21:53 9
Цитата Сообщение от insect_87 Посмотреть сообщение
шедулер 4 надо стартануть раньше старта в шедулере 2
зачем? Что это даст? Требуемое правило отработает свое не 8-10, а в 8-00 (если интервал 10 мин) ? Ну и какая выгода в этих 10 минутах?
Шедулер 2 начнет свою работу с момента активации... т.е. в 8-00 и сразу же выполнит свою заданную проверку.
1
insect_87
Эксперт по компьютерным сетям
4948 / 4008 / 836
Регистрация: 25.12.2012
Сообщений: 16,970
08.11.2019, 22:01 10
И то верно. В шедулере 2 интервал вероятно небольшой. Главное sntp/ntp клиента натравить
1
romsan
Эксперт по компьютерным сетям
2442 / 1379 / 295
Регистрация: 17.10.2015
Сообщений: 6,067
08.11.2019, 22:13 11

Не по теме:

Убедил таки!


1
bytemyass
0 / 0 / 0
Регистрация: 22.12.2012
Сообщений: 22
09.11.2019, 05:28  [ТС] 12
Спасибо большое ребят за ответы, сейчас создам ещё 2 шедулера)
P.S: Сегодня ночью заспамил меня микрот)
0
romsan
Эксперт по компьютерным сетям
2442 / 1379 / 295
Регистрация: 17.10.2015
Сообщений: 6,067
09.11.2019, 09:48 13
Цитата Сообщение от bytemyass Посмотреть сообщение
егодня ночью заспамил меня микрот)
а что за правило то хоть?
0
09.11.2019, 09:48
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.11.2019, 09:48

Планировщик
У нас есть: - Домен - Сервер: w2k3 sp2 В планировщике устанавливаются задачи (bat), которые...

Планировщик и ресурсы
Здравствуйте. Есть форма на ней Embedded Scheduler. Хотелось бы что бы он отображал ресурсы...

Планировщик заданий
Как заставить работать планировщик каждый день раз в 9 часов?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.