Форум программистов, компьютерный форум, киберфорум
Наши страницы
MS Office Excel
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.87/15: Рейтинг темы: голосов - 15, средняя оценка - 4.87
kav0221
111 / 105 / 29
Регистрация: 29.03.2012
Сообщений: 237
1

Размножение формулы по строкам и изменение значений по столбцам

12.11.2013, 19:11. Просмотров 2884. Ответов 5
Метки нет (Все метки)

Собственно вопрос в названии. Необходимо сделать следующее:
Формула в ячейке D2:
=СУММ(N$2:N$35)

Я хочу, чтобы в ячейке D3 было следующее:
=СУММ(O$2:O$35)

и так далее....

Подскажите пожалуйста как это сделать
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.11.2013, 19:11
Ответы с готовыми решениями:

Подсчет уникальных значений по столбцам и строкам
Добрый день. Имеется затруднение: есть таблица, в ней столбец с массивом имён и рядом столбец с...

Формула Excel. Выборка значений по строкам и столбцам
Помогите научить ексель понимать, Как суммировать значения в одном столбце при выполнении условия в...

Размножение формулы с изменением одного значения
Здравствуйте. Имею формулу =СЧЁТЕСЛИ(N2:N1320;N2). При её простом протягивании она меняется...

Сумма значений по столбцам и строкам
Есть база данных на Mysql и приложение c# winforms ( скрин ниже ). Каким образом можно найти сумму...

Изменение значений в бд из таблицы по нескольким строкам
Добрый день товарищи! не соображу, имеется бд, есть форма php в ней выгружается по поиску данные из...

5
Czeslav
745 / 417 / 129
Регистрация: 30.03.2013
Сообщений: 848
12.11.2013, 21:17 2
Просто протяните Вашу формулу вправо.
0
Czeslav
745 / 417 / 129
Регистрация: 30.03.2013
Сообщений: 848
12.11.2013, 21:32 3
Как вариант попробуйте скопировать со специальной вставкой.
У меня для четырёх ячеек получилось.
1
Вложения
Тип файла: xlsx Book1.xlsx (8.7 Кб, 12 просмотров)
Pelena
2457 / 1246 / 213
Регистрация: 25.10.2010
Сообщений: 2,000
12.11.2013, 21:38 4
Как вариант
Код
=СУММ(СМЕЩ($N$2;;СТРОКА()-2;34))
Если диапазонов не очень много, можно ещё так
Код
=СУММ(ВЫБОР(СТРОКА()-1;$N$2:$N$10;$O$2:$O$10;$P$2:$P$10))
2
Fairuza
5218 / 2647 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
12.11.2013, 21:51 5
У меня так получилось
Код
=СУММ(СМЕЩ(N$2:N$35;;СТРОКА()-2))
1
kav0221
111 / 105 / 29
Регистрация: 29.03.2012
Сообщений: 237
12.11.2013, 22:07  [ТС] 6
спасибо, помогло=)
0
12.11.2013, 22:07
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.11.2013, 22:07

Массив: Условия ввода: по столбцам, Условия вывода: по строкам в виде таблицы. Написать исходную матрицу и вывод массива по строкам.
Есть массив B размерностью 5x5, тип данных real, Условия ввода: по столбцам, Условия вывода: по...

Упорядочить матрицу по строкам и столбцам
есть массив , нужно его отсортировать по рядкам и столбцам , то есть одна кнопка для сортировки по...

Матрица, доступ к строкам и столбцам
Как можно сделать доступ к строкам и столбцам матрицы одновременно? На данный момент для этого я...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru